]> git.pld-linux.org Git - packages/flux.git/blob - flux.spec
- removed stripping executables, it's done by rpm automation
[packages/flux.git] / flux.spec
1 Summary:        Flux is a survival-through-structure library
2 Name:           flux
3 Version:        0.4.1
4 Release:        2
5 Group:          Libraries
6 Group(fr):      Librairies
7 Group(pl):      Biblioteki
8 License:        GPL
9 Source0:        ftp://ftp.styx.net/projects/flux/%{name}-%{version}.tar.gz
10 Patch0:         %{name}-gethostbyname_is_in_libc_aka_no_libnsl.patch
11 BuildRequires:  autoconf
12 URL:            http://projects.simplemente.net/flux/
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Flux is a survival-through-structure library, whose goal is to reduce
17 the complexity of C programming. To this end, it supplies high-level
18 functions for manipulating data and communication with specialized
19 handles, masking typically tedious programming tasks. Common
20 instruction blocks are wrapped in higher-level calls with intuitive
21 names. In short: Do it once, do it right, then forget about it.
22
23 Abstracting things this way involves speed compromises. In Flux, these
24 should be minimal, and sometimes, when superiour algorithms are easily
25 accessible, efficiency is actually gained.
26
27 Another important goal is bridging gaps between typical tasks - like
28 parsing, storage, retrieval, buffering and transfer, data structures -
29 like generic tree structures, generic network structures, XML and
30 presentation formats, and protocols - like FluxComm, Unix protocols
31 and IRC. (Note: IRC protocols are hairy and ill-defined. Unification
32 and masking is particularly useful here).
33
34 %description -l pl
35 Flux jest bibliotek± typu "", której celem jest redukcja z³o¿ono¶ci
36 programowania w C. W tym celu zaprojektowano funkcje wysokiego poziomu
37 s³u¿±ce manipulacji danymi i komunikacji z wyspecjalizowanymi
38 uchwytami, ukrywaj±c nu¿±ce zazwyczaj zadania programistyczne.
39 Popularne bloki instrukcji s± zawiniête w wywo³aniach wy¿szego poziomu
40 o intuicyjnych nazwach. Mówi±c krótko: Zrób to raz, zrób to dobrze i
41 zapomnij o tym. Takie wyabstrahowywanie wymaga wielu kompromisów. We
42 Fluksie powinny byæ one ograniczone do minimum, czasem za¶, kiedy
43 ³atwo jest u¿yæ lepszych algorytmów, zyskuje siê na wydajno¶ci. Inn±
44 wa¿n± rzecz± jest stworzenie pomostu miêdzy typowymi zadaniami
45 (parsowanie, przechowywanie, wydobywanie, buforowanie i transfer),
46 strukturami danych (generyczne struktury drzew, generyczne struktury
47 sieci XML i formaty prezentacyjne) a protoko³ami (FluxComm, protoko³y
48 uniksowe i IRC. Uwaga: protoko³y ircowe s± niezgrabne i ¼le
49 zdefiniowane. Szczególnie w tym wypadku unifikacja i maskowanie
50 ukazuj± swoja warto¶æ).
51
52 %package devel
53 Summary:        Header files and development documentation for flux
54 Summary(pl):    Pliki nag³ówkowe i dokumentacja do flux
55 Group:          Development/Libraries
56 Group(fr):      Development/Librairies
57 Group(pl):      Programowanie/Biblioteki
58 Requires:       %{name} = %{version}
59
60 %description devel
61 Header files and development documentation for flux.
62
63 %description -l pl devel
64 Pliki nag³ówkowe i dokumentacja do biblioteki flux.
65
66 %package static
67 Summary:        Static flux libraries
68 Summary(pl):    Biblioteki statyczne flux
69 Group:          Development/Libraries
70 Group(fr):      Development/Librairies
71 Group(pl):      Programowanie/Biblioteki
72 Requires:       %{name}-devel = %{version}
73
74 %description static
75 Static flux libraries.
76
77 %description -l pl static
78 Biblioteki statyczne flux.
79
80 %prep
81 %setup -q
82
83 %build
84 autoconf
85 %configure
86 echo n | make
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install DESTDIR=$RPM_BUILD_ROOT
92
93 gzip -9nf AUTHORS README NEWS TODO 
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_libdir}/lib*.so.*.*
104
105 %files devel
106 %defattr(644,root,root,755)
107 %doc *.gz doc/*
108 %attr(755,root,root) %{_libdir}/lib*.so
109 %attr(755,root,root) %{_libdir}/lib*.la
110 %{_includedir}/*
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/lib*.a
This page took 0.076916 seconds and 4 git commands to generate.