]> git.pld-linux.org Git - packages/flux.git/blob - flux.spec
- "f" and some "g" letters of small fixes inpired by kloczek
[packages/flux.git] / flux.spec
1 Summary:        Flux is a survival-through-structure library
2 Summary(pl):    Flux - biblioteka struktur danych i operacji na nich
3 Name:           flux
4 Version:        0.4.1
5 Release:        5
6 License:        GPL
7 Group:          Libraries
8 Source0:        ftp://ftp.styx.net/projects/flux/%{name}-%{version}.tar.gz
9 # Source0-md5:  959cf209acfed3af40baf6a3bcd9c26b
10 Patch0:         %{name}-gethostbyname_is_in_libc_aka_no_libnsl.patch
11 Patch1:         %{name}-acinclude_fix.patch
12 Patch2:         %{name}-am15.patch
13 Patch3:         %{name}-AC_C_BIGENDIAN.patch
14 URL:            http://projects.simplemente.net/flux/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libtool
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Flux is a survival-through-structure library, whose goal is to reduce
22 the complexity of C programming. To this end, it supplies high-level
23 functions for manipulating data and communication with specialized
24 handles, masking typically tedious programming tasks. Common
25 instruction blocks are wrapped in higher-level calls with intuitive
26 names. In short: Do it once, do it right, then forget about it.
27
28 Abstracting things this way involves speed compromises. In Flux, these
29 should be minimal, and sometimes, when superiour algorithms are easily
30 accessible, efficiency is actually gained.
31
32 Another important goal is bridging gaps between typical tasks - like
33 parsing, storage, retrieval, buffering and transfer, data structures -
34 like generic tree structures, generic network structures, XML and
35 presentation formats, and protocols - like FluxComm, Unix protocols
36 and IRC. (Note: IRC protocols are hairy and ill-defined. Unification
37 and masking is particularly useful here).
38
39 %description -l pl
40 Flux jest bibliotek± typu "survival-through-structure", której celem
41 jest redukcja z³o¿ono¶ci programowania w C. W tym celu zaprojektowano
42 funkcje wysokiego poziomu s³u¿±ce manipulacji danymi i komunikacji z
43 wyspecjalizowanymi uchwytami, ukrywaj±c nu¿±ce zazwyczaj zadania
44 programistyczne. Popularne bloki instrukcji s± zawiniête w wywo³aniach
45 wy¿szego poziomu o intuicyjnych nazwach. Mówi±c krótko: Zrób to raz,
46 zrób to dobrze i zapomnij o tym. Takie wyabstrahowywanie wymaga wielu
47 kompromisów. We Fluksie powinny byæ one ograniczone do minimum, czasem
48 za¶, kiedy ³atwo jest u¿yæ lepszych algorytmów, zyskuje siê na
49 wydajno¶ci. Inn± wa¿n± rzecz± jest stworzenie pomostu miêdzy typowymi
50 zadaniami (parsowanie, przechowywanie, wydobywanie, buforowanie i
51 transfer), strukturami danych (generyczne struktury drzew, generyczne
52 struktury sieci XML i formaty prezentacyjne) a protoko³ami (FluxComm,
53 protoko³y uniksowe i IRC. Uwaga: protoko³y ircowe s± niezgrabne i ¼le
54 zdefiniowane. Szczególnie w tym wypadku unifikacja i maskowanie
55 ukazuj± swoja warto¶æ).
56
57 %package devel
58 Summary:        Header files and development documentation for flux
59 Summary(pl):    Pliki nag³ówkowe i dokumentacja do flux
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}
62
63 %description devel
64 Header files and development documentation for flux.
65
66 %description devel -l pl
67 Pliki nag³ówkowe i dokumentacja do biblioteki flux.
68
69 %package static
70 Summary:        Static flux libraries
71 Summary(pl):    Biblioteki statyczne flux
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}
74
75 %description static
76 Static flux libraries.
77
78 %description static -l pl
79 Biblioteki statyczne flux.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85 %patch2 -p1
86 %patch3 -p1
87
88 %build
89 rm -f missing
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__automake}
94 %configure
95 echo n | %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/lib*.so.*.*
112
113 %files devel
114 %defattr(644,root,root,755)
115 %doc AUTHORS README NEWS TODO doc/*
116 %attr(755,root,root) %{_libdir}/lib*.so
117 %{_libdir}/lib*.la
118 %{_includedir}/*
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/lib*.a
This page took 0.087222 seconds and 3 git commands to generate.