]> git.pld-linux.org Git - packages/flux.git/blob - flux.spec
- adapterized.
[packages/flux.git] / flux.spec
1 Summary:        Flux is a survival-through-structure library
2 Summary(pl):    Flux - biblioteka struktur danych i operacji na nich
3 Name:           flux
4 Version:        0.4.1
5 Release:        3
6 License:        GPL
7 Group:          Libraries
8 Source0:        ftp://ftp.styx.net/projects/flux/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-gethostbyname_is_in_libc_aka_no_libnsl.patch
10 Patch1:         %{name}-acinclude_fix.patch
11 Patch2:         %{name}-am15.patch
12 Patch3:         %{name}-AC_C_BIGENDIAN.patch
13 URL:            http://projects.simplemente.net/flux/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Flux is a survival-through-structure library, whose goal is to reduce
21 the complexity of C programming. To this end, it supplies high-level
22 functions for manipulating data and communication with specialized
23 handles, masking typically tedious programming tasks. Common
24 instruction blocks are wrapped in higher-level calls with intuitive
25 names. In short: Do it once, do it right, then forget about it.
26
27 Abstracting things this way involves speed compromises. In Flux, these
28 should be minimal, and sometimes, when superiour algorithms are easily
29 accessible, efficiency is actually gained.
30
31 Another important goal is bridging gaps between typical tasks - like
32 parsing, storage, retrieval, buffering and transfer, data structures -
33 like generic tree structures, generic network structures, XML and
34 presentation formats, and protocols - like FluxComm, Unix protocols
35 and IRC. (Note: IRC protocols are hairy and ill-defined. Unification
36 and masking is particularly useful here).
37
38 %description -l pl
39 Flux jest bibliotek± typu "survival-through-structure", której celem
40 jest redukcja z³o¿ono¶ci programowania w C. W tym celu zaprojektowano
41 funkcje wysokiego poziomu s³u¿±ce manipulacji danymi i komunikacji z
42 wyspecjalizowanymi uchwytami, ukrywaj±c nu¿±ce zazwyczaj zadania
43 programistyczne. Popularne bloki instrukcji s± zawiniête w wywo³aniach
44 wy¿szego poziomu o intuicyjnych nazwach. Mówi±c krótko: Zrób to raz,
45 zrób to dobrze i zapomnij o tym. Takie wyabstrahowywanie wymaga wielu
46 kompromisów. We Fluksie powinny byæ one ograniczone do minimum, czasem
47 za¶, kiedy ³atwo jest u¿yæ lepszych algorytmów, zyskuje siê na
48 wydajno¶ci. Inn± wa¿n± rzecz± jest stworzenie pomostu miêdzy typowymi
49 zadaniami (parsowanie, przechowywanie, wydobywanie, buforowanie i
50 transfer), strukturami danych (generyczne struktury drzew, generyczne
51 struktury sieci XML i formaty prezentacyjne) a protoko³ami (FluxComm,
52 protoko³y uniksowe i IRC. Uwaga: protoko³y ircowe s± niezgrabne i ¼le
53 zdefiniowane. Szczególnie w tym wypadku unifikacja i maskowanie
54 ukazuj± swoja warto¶æ).
55
56 %package devel
57 Summary:        Header files and development documentation for flux
58 Summary(pl):    Pliki nag³ówkowe i dokumentacja do flux
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}
61
62 %description devel
63 Header files and development documentation for flux.
64
65 %description devel -l pl
66 Pliki nag³ówkowe i dokumentacja do biblioteki flux.
67
68 %package static
69 Summary:        Static flux libraries
70 Summary(pl):    Biblioteki statyczne flux
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}
73
74 %description static
75 Static flux libraries.
76
77 %description static -l pl
78 Biblioteki statyczne flux.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85 %patch3 -p1
86
87 %build
88 rm -f missing
89 libtoolize --copy --force
90 aclocal
91 autoconf
92 automake -a -c
93 %configure
94 echo n | %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install DESTDIR=$RPM_BUILD_ROOT
100
101 gzip -9nf AUTHORS README NEWS TODO
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/lib*.so.*.*
112
113 %files devel
114 %defattr(644,root,root,755)
115 %doc *.gz doc/*
116 %attr(755,root,root) %{_libdir}/lib*.so
117 %attr(755,root,root) %{_libdir}/lib*.la
118 %{_includedir}/*
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/lib*.a
This page took 0.068287 seconds and 3 git commands to generate.