]> git.pld-linux.org Git - packages/flux.git/blob - flux.spec
46922a3905dedc8268da6e042dea7fea4154e2a2
[packages/flux.git] / flux.spec
1 Summary:        Flux is a survival-through-structure library
2 Summary(pl):    Flux - biblioteka struktur danych i operacji na nich
3 Name:           flux
4 Version:        0.4.1
5 Release:        6
6 License:        GPL
7 Group:          Libraries
8 Source0:        ftp://ftp.copyleft.no/projects/fluxlib/%{name}-%{version}.tar.gz
9 # Source0-md5:  959cf209acfed3af40baf6a3bcd9c26b
10 Patch0:         %{name}-gethostbyname_is_in_libc_aka_no_libnsl.patch
11 Patch1:         %{name}-acinclude_fix.patch
12 Patch2:         %{name}-am15.patch
13 Patch3:         %{name}-AC_C_BIGENDIAN.patch
14 Patch4:         %{name}-gcc33.patch
15 Patch5:         %{name}-ltfix.patch
16 Patch6:         %{name}-errno.patch
17 URL:            http://www.fluxlib.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  libtool
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Flux is a survival-through-structure library, whose goal is to reduce
25 the complexity of C programming. To this end, it supplies high-level
26 functions for manipulating data and communication with specialized
27 handles, masking typically tedious programming tasks. Common
28 instruction blocks are wrapped in higher-level calls with intuitive
29 names. In short: Do it once, do it right, then forget about it.
30
31 Abstracting things this way involves speed compromises. In Flux, these
32 should be minimal, and sometimes, when superiour algorithms are easily
33 accessible, efficiency is actually gained.
34
35 Another important goal is bridging gaps between typical tasks - like
36 parsing, storage, retrieval, buffering and transfer, data structures -
37 like generic tree structures, generic network structures, XML and
38 presentation formats, and protocols - like FluxComm, Unix protocols
39 and IRC. (Note: IRC protocols are hairy and ill-defined. Unification
40 and masking is particularly useful here).
41
42 %description -l pl
43 Flux jest bibliotek± typu "survival-through-structure", której celem
44 jest redukcja z³o¿ono¶ci programowania w C. W tym celu zaprojektowano
45 funkcje wysokiego poziomu s³u¿±ce manipulacji danymi i komunikacji z
46 wyspecjalizowanymi uchwytami, ukrywaj±c nu¿±ce zazwyczaj zadania
47 programistyczne. Popularne bloki instrukcji s± zawiniête w wywo³aniach
48 wy¿szego poziomu o intuicyjnych nazwach. Mówi±c krótko: Zrób to raz,
49 zrób to dobrze i zapomnij o tym. Takie wyabstrahowywanie wymaga wielu
50 kompromisów. We Fluksie powinny byæ one ograniczone do minimum, czasem
51 za¶, kiedy ³atwo jest u¿yæ lepszych algorytmów, zyskuje siê na
52 wydajno¶ci. Inn± wa¿n± rzecz± jest stworzenie pomostu miêdzy typowymi
53 zadaniami (parsowanie, przechowywanie, wydobywanie, buforowanie i
54 transfer), strukturami danych (generyczne struktury drzew, generyczne
55 struktury sieci XML i formaty prezentacyjne) a protoko³ami (FluxComm,
56 protoko³y uniksowe i IRC. Uwaga: protoko³y ircowe s± niezgrabne i ¼le
57 zdefiniowane. Szczególnie w tym wypadku unifikacja i maskowanie
58 ukazuj± swoja warto¶æ).
59
60 %package devel
61 Summary:        Header files and development documentation for flux
62 Summary(pl):    Pliki nag³ówkowe i dokumentacja do flux
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65
66 %description devel
67 Header files and development documentation for flux.
68
69 %description devel -l pl
70 Pliki nag³ówkowe i dokumentacja do biblioteki flux.
71
72 %package static
73 Summary:        Static flux libraries
74 Summary(pl):    Biblioteki statyczne flux
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static flux libraries.
80
81 %description static -l pl
82 Biblioteki statyczne flux.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89 %patch3 -p1
90 %patch4 -p1
91 %patch5 -p1
92 %patch6 -p1
93
94 %build
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoconf}
98 %{__automake}
99 %configure
100 echo n | %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/lib*.so.*.*
117
118 %files devel
119 %defattr(644,root,root,755)
120 %doc AUTHORS README NEWS TODO doc/*
121 %attr(755,root,root) %{_libdir}/lib*.so
122 %{_libdir}/lib*.la
123 %{_includedir}/*
124
125 %files static
126 %defattr(644,root,root,755)
127 %{_libdir}/lib*.a
This page took 0.072455 seconds and 2 git commands to generate.