]> git.pld-linux.org Git - packages/fluidsynth.git/commitdiff
- added lash bcond, note GPL license if built with ladcca/lash or readline
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 18 Dec 2011 15:54:58 +0000 (15:54 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added midishare patch and bcond (off by default as midishare is unfinished in PLD)

Changed files:
    fluidsynth-midishare.patch -> 1.1
    fluidsynth.spec -> 1.46

fluidsynth-midishare.patch [new file with mode: 0644]
fluidsynth.spec

diff --git a/fluidsynth-midishare.patch b/fluidsynth-midishare.patch
new file mode 100644 (file)
index 0000000..aa090db
--- /dev/null
@@ -0,0 +1,31 @@
+--- fluidsynth-1.1.5/src/Makefile.am.orig      2011-09-04 09:38:58.000000000 +0200
++++ fluidsynth-1.1.5/src/Makefile.am   2011-12-18 16:12:19.962675709 +0100
+@@ -40,6 +40,9 @@ if OSS_SUPPORT
+ fluid_oss = drivers/fluid_oss.c
+ endif
++if MIDISHARE_SUPPORT
++fluid_midishare = drivers/fluid_midishare.c
++endif
+ # if LASH_SUPPORT || LADCCA_SUPPORT (Makefile supports OR?)
+ if LASH_SUPPORT
+@@ -90,6 +93,7 @@ libfluidsynth_la_SOURCES = \
+       $(fluid_jack) \
+       $(fluid_ladspa) \
+       $(fluid_lash) \
++      $(fluid_midishare) \
+       $(fluid_oss) \
+       $(fluid_portaudio) \
+       $(fluid_pulse) \
+--- fluidsynth-1.1.5/acinclude.m4.orig 2011-09-04 09:38:58.000000000 +0200
++++ fluidsynth-1.1.5/acinclude.m4      2011-12-18 16:10:42.556005782 +0100
+@@ -32,6 +32,8 @@ AC_DEFUN([AC_MIDISHARE],
+          AC_MSG_WARN([ *** Could not find MidiShare.h, disabling MidiShare driver])
+      fi       dnl  midishare.h header test
+    fi dnl  enable_midishare != no?
++
++   AM_CONDITIONAL([MIDISHARE_SUPPORT], [test $MIDISHARE_SUPPORT = 1])
+ ])
+ AC_DEFUN([AC_OSS_AUDIO],
index 91c384d754b1f0d9aeaf41329758e48d4688ad0d..56ec49b5f98f10ecacfa1d5c19ebe2ac964c9c77 100644 (file)
@@ -1,7 +1,9 @@
 #
 # Conditional build:
-%bcond_with    ladcca          # enable ladcca sesion management support (deprecated)
-%bcond_without readline        # build with readline lib line editing
+%bcond_with    ladcca          # ladcca sesion management support (deprecated) (GPL)
+%bcond_without lash            # LASH support (GPL)
+%bcond_with    midishare       # MidiShare support
+%bcond_without readline        # readline line editing (GPL)
 %bcond_with    sse             # use the SSE instructions of Pentium3+ or Athlon XP
 %bcond_without static_libs     # don't build static library
 #
@@ -14,10 +16,15 @@ Summary(pl.UTF-8):  FluidSynth - programowy syntezator działający w czasie rzec
 Name:          fluidsynth
 Version:       1.1.5
 Release:       1
+%if %{with ladcca} || %{with lash} || %{with readline}
+License:       GPL v2+ (enforced by ladcca/lash/readline), LGPL v2+ (fluidsynth itself)
+%else
 License:       LGPL v2+
+%endif
 Group:         Applications/Sound
 Source0:       http://downloads.sourceforge.net/fluidsynth/%{name}-%{version}.tar.bz2
 # Source0-md5: 835b98b0ddedbb9cc24b53d66cf900c3
+Patch0:                %{name}-midishare.patch
 URL:           http://www.fluidsynth.org/
 BuildRequires: alsa-lib-devel >= 0.9.1
 BuildRequires: autoconf >= 2.52
@@ -29,9 +36,10 @@ BuildRequires:       jack-audio-connection-kit-devel
 %{?with_ladcca:BuildRequires:  ladcca-devel < 0.4.0}
 %{?with_ladcca:BuildRequires:  ladcca-devel >= 0.3.1}
 BuildRequires: ladspa-devel
-BuildRequires: lash-devel >= 0.3
+%{?with_lash:BuildRequires:    lash-devel >= 0.3}
 BuildRequires: libsndfile-devel >= 1.0.18
 BuildRequires: libtool
+%{?with_midishare:BuildRequires:       midishare-devel}
 BuildRequires: pkgconfig
 BuildRequires: portaudio-devel >= 19
 BuildRequires: pulseaudio-devel >= 0.9.8
@@ -60,8 +68,9 @@ Requires:     alsa-lib-devel >= 0.9.1
 Requires:      dbus-devel >= 1.0.0
 Requires:      glib2-devel >= 1:2.6.5
 Requires:      jack-audio-connection-kit-devel
-Requires:      lash-devel >= 0.3
+%{?with_lash:Requires: lash-devel >= 0.3}
 Requires:      libsndfile-devel >= 1.0.18
+%{?with_midishare:Requires:    midishare-devel}
 Requires:      portaudio-devel >= 19
 Requires:      pulseaudio-devel >= 0.9.8
 %{?with_readline:Requires:     readline-devel}
@@ -88,6 +97,7 @@ Ten pakiet zawiera bibliotekę statyczną FluidSynth.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__libtoolize}
@@ -98,6 +108,8 @@ Ten pakiet zawiera bibliotekę statyczną FluidSynth.
 
 %configure \
        %{!?with_ladcca:--disable-ladcca} \
+       %{!?with_lash:--disable-lash} \
+       %{!?with_midishare:--disable-midishare} \
        %{!?with_static_libs:--disable-static} \
        %{?with_sse:--enable-SSE} \
        --enable-jack-support \
@@ -109,7 +121,6 @@ Ten pakiet zawiera bibliotekę statyczną FluidSynth.
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
This page took 0.116964 seconds and 4 git commands to generate.