]> git.pld-linux.org Git - packages/fluidsynth.git/blobdiff - fluidsynth.spec
- lt/ac/am; added -build.patch; BR: autoconf, libtool
[packages/fluidsynth.git] / fluidsynth.spec
index b5c06c9fb40072fb50f1755b04564ce4a9c73117..b85a93c87f331c964a37620852bf417ca0b2a065 100644 (file)
@@ -1,19 +1,34 @@
 #
 # Conditional build:
-# _with_sse    - use the SSE instructions of Pentium3+ or Athlon XP
+%bcond_with    ladcca          # enable ladcca sesion managment support
+%bcond_with    sse             # use the SSE instructions of Pentium3+ or Athlon XP
+%bcond_without static_libs     # don't build static library
 #
-Summary:       FluidSynth is a software, real-time synthesizer
-Summary(pl):   FluidSynth to programowy syntezator dzia³aj±cy w czasie rzeczywistym
+%ifarch pentium3 pentium4 %{x8664}
+%define                with_sse        1
+%endif
+#
+Summary:       FluidSynth - a software, real-time synthesizer
+Summary(pl.UTF-8):     FluidSynth - programowy syntezator działający w czasie rzeczywistym
 Name:          fluidsynth
-Version:       1.0.2
+Version:       1.0.8
 Release:       1
-License:       GPL
+License:       LGPL
 Group:         Applications/Sound
-Source0:       http://savannah.nongnu.org/download/fluid/stable.pkg/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 9765e1601ba0fc546f5bf2e0d966784b
+Source0:       http://savannah.nongnu.org/download/fluid/%{name}-%{version}.tar.gz
+# Source0-md5: e2abfd2e69fd8b28d965df968d7d44ee
+Patch0:                %{name}-build.patch
 URL:           http://www.fluidsynth.org/
 BuildRequires: alsa-lib-devel >= 0.9.0
+BuildRequires: autoconf >= 2.52
+BuildRequires: automake
 BuildRequires: jack-audio-connection-kit-devel
+%{?with_ladcca:BuildRequires:  ladcca-devel < 0.4.0}
+%{?with_ladcca:BuildRequires:  ladcca-devel >= 0.3.1}
+BuildRequires: ladspa-devel
+BuildRequires: libtool
+BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.213
 Requires:      alsa-lib
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -21,46 +36,57 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Fluid Synth is a software, real-time synthesizer based on the
 Soundfont 2 specifications.
 
-%description -l pl
-Fluid Synth to programowy, dzia³aj±cy w czasie rzeczywistym syntezator
+%description -l pl.UTF-8
+Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
 oparty na specyfikacji Soundfont 2.
 
 %package devel
 Summary:       Development files for the FluidSynth
-Summary(pl):   Pliki nag³ówkowe dla FluidSynth
+Summary(pl.UTF-8):     Pliki nagłówkowe dla FluidSynth
 Group:         Development/Libraries
-Requires:       %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
 This package contains the header files necessary to develop
 applications using FluidSynth.
 
-%description devel -l pl
-Pakiet tem zawiera pliki nag³ówkowe potrzebne do tworzenia i
-kompilacji aplikacji korzystaj±cych z bibliotek FluidSynth.
+%description devel -l pl.UTF-8
+Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
+kompilacji aplikacji korzystających z bibliotek FluidSynth.
 
 %package static
-Summary:        Static FluidSynth library
-Summary(pl):    Statyczna wersje biblioteki FluidSynth
-Group:          Development/Libraries
-Requires:       %{name}-devel = %{version}
+Summary:       Static FluidSynth library
+Summary(pl.UTF-8):     Statyczna wersje biblioteki FluidSynth
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 This package contains static version of the FluidSynth library.
 
-%description static -l pl
-Ten pakiet zawiera bibliotekê statyczn± FluidSynth.
+%description static -l pl.UTF-8
+Ten pakiet zawiera bibliotekę statyczną FluidSynth.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+
 %configure \
-       --enable-ladspa \
-       --enable-midishare \
-       --enable-jack-support \
+       %{!?with_ladcca:--disable-ladcca} \
+       %{!?with_static_libs:--disable-static} \
+       %{?with_sse:--enable-SSE} \
        --enable-coreaudio \
-       %{?_with_sse:--enable-SSE}
+       --enable-jack-support \
+       --enable-ladspa \
+       --enable-profiling \
+       --without-readline
+
 %{__make}
 
 %install
@@ -79,18 +105,21 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc ChangeLog README
-%{_mandir}/man1/*
-%attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/lib%{name}.so.*.*.*
+%attr(755,root,root) %{_bindir}/fluidsynth
+%attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.1
+%{_mandir}/man1/fluidsynth.1*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib%{name}.so
-%attr(755,root,root) %{_libdir}/lib%{name}.la
-%{_includedir}/%{name}.h
+%attr(755,root,root) %{_libdir}/libfluidsynth.so
+%{_libdir}/libfluidsynth.la
+%{_includedir}/fluidsynth.h
 %{_includedir}/%{name}
-%{_libdir}/pkgconfig/fluidsynth.pc
+%{_pkgconfigdir}/fluidsynth.pc
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib%{name}.a
+%{_libdir}/libfluidsynth.a
+%endif
This page took 0.066282 seconds and 4 git commands to generate.