]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
- updated to 2.3.4
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_with     ladcca          # ladcca sesion management support (deprecated) (GPL)
4 %bcond_without  lash            # LASH support (GPL)
5 %bcond_with     midishare       # MidiShare support
6 %bcond_without  readline        # readline line editing (GPL)
7 %bcond_with     sse             # use the SSE instructions of Pentium3+ or Athlon XP
8 %bcond_without  static_libs     # don't build static library
9 #
10 %ifarch pentium3 pentium4 %{x8664}
11 %define         with_sse        1
12 %endif
13 #
14 Summary:        FluidSynth - a software, real-time synthesizer
15 Summary(pl.UTF-8):      FluidSynth - programowy syntezator działający w czasie rzeczywistym
16 Name:           fluidsynth
17 Version:        1.1.6
18 Release:        2
19 %if %{with ladcca} || %{with lash} || %{with readline}
20 License:        GPL v2+ (enforced by ladcca/lash/readline), LGPL v2+ (fluidsynth itself)
21 %else
22 License:        LGPL v2+
23 %endif
24 Group:          Applications/Sound
25 Source0:        http://downloads.sourceforge.net/fluidsynth/%{name}-%{version}.tar.bz2
26 # Source0-md5:  f6e696690e989098f70641364fdffad7
27 Patch0:         %{name}-midishare.patch
28 URL:            http://www.fluidsynth.org/
29 BuildRequires:  alsa-lib-devel >= 0.9.1
30 BuildRequires:  autoconf >= 2.52
31 BuildRequires:  automake
32 BuildRequires:  dbus-devel >= 1.0.0
33 BuildRequires:  gettext-tools
34 BuildRequires:  glib2-devel >= 1:2.6.5
35 BuildRequires:  jack-audio-connection-kit-devel
36 %{?with_ladcca:BuildRequires:   ladcca-devel < 0.4.0}
37 %{?with_ladcca:BuildRequires:   ladcca-devel >= 0.3.1}
38 BuildRequires:  ladspa-devel
39 %{?with_lash:BuildRequires:     lash-devel >= 0.3}
40 BuildRequires:  libsndfile-devel >= 1.0.18
41 BuildRequires:  libtool
42 %{?with_midishare:BuildRequires:        midishare-devel}
43 BuildRequires:  pkgconfig
44 BuildRequires:  portaudio-devel >= 19
45 BuildRequires:  pulseaudio-devel >= 0.9.8
46 %{?with_readline:BuildRequires: readline-devel}
47 BuildRequires:  rpmbuild(macros) >= 1.213
48 Requires:       alsa-lib >= 0.9.1
49 Requires:       glib2 >= 1:2.6.5
50 Requires:       libsndfile >= 1.0.18
51 Suggests:       soundfont-fluid
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 Fluid Synth is a software, real-time synthesizer based on the
56 Soundfont 2 specifications.
57
58 %description -l pl.UTF-8
59 Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
60 oparty na specyfikacji Soundfont 2.
61
62 %package devel
63 Summary:        Development files for the FluidSynth
64 Summary(pl.UTF-8):      Pliki nagłówkowe dla FluidSynth
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       alsa-lib-devel >= 0.9.1
68 Requires:       dbus-devel >= 1.0.0
69 Requires:       glib2-devel >= 1:2.6.5
70 Requires:       jack-audio-connection-kit-devel
71 %{?with_lash:Requires:  lash-devel >= 0.3}
72 Requires:       libsndfile-devel >= 1.0.18
73 %{?with_midishare:Requires:     midishare-devel}
74 Requires:       portaudio-devel >= 19
75 Requires:       pulseaudio-devel >= 0.9.8
76 %{?with_readline:Requires:      readline-devel}
77
78 %description devel
79 This package contains the header files necessary to develop
80 applications using FluidSynth.
81
82 %description devel -l pl.UTF-8
83 Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
84 kompilacji aplikacji korzystających z bibliotek FluidSynth.
85
86 %package static
87 Summary:        Static FluidSynth library
88 Summary(pl.UTF-8):      Statyczna wersje biblioteki FluidSynth
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91
92 %description static
93 This package contains static version of the FluidSynth library.
94
95 %description static -l pl.UTF-8
96 Ten pakiet zawiera bibliotekę statyczną FluidSynth.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101
102 %build
103 %{__libtoolize}
104 %{__aclocal}
105 %{__autoconf}
106 %{__autoheader}
107 %{__automake}
108
109 %configure \
110         %{!?with_ladcca:--disable-ladcca} \
111         %{!?with_lash:--disable-lash} \
112         %{!?with_midishare:--disable-midishare} \
113         %{!?with_static_libs:--disable-static} \
114         %{?with_sse:--enable-SSE} \
115         --enable-jack-support \
116         --enable-ladspa \
117         --enable-profiling \
118         %{!?with_readline:--without-readline}
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfluidsynth.la
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc ChangeLog README
139 %attr(755,root,root) %{_bindir}/fluidsynth
140 %attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.1
142 %{_mandir}/man1/fluidsynth.1*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/libfluidsynth.so
147 %{_includedir}/fluidsynth.h
148 %{_includedir}/%{name}
149 %{_pkgconfigdir}/fluidsynth.pc
150
151 %if %{with static_libs}
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/libfluidsynth.a
155 %endif
This page took 0.054202 seconds and 3 git commands to generate.