]> git.pld-linux.org Git - packages/fluidsynth.git/blame - fluidsynth.spec
- updated to 2.1.6
[packages/fluidsynth.git] / fluidsynth.spec
CommitLineData
f6e767e3 1# TODO: OBOE support, BR: pkgconfig(oboe-1.0)
5fadb22d 2#
3# Conditional build:
e389d9b2
JB
4%bcond_without lash # LASH support (GPL)
5%bcond_with midishare # MidiShare support
2566f65e 6%bcond_without portaudio # portaudio support
e389d9b2 7%bcond_without readline # readline line editing (GPL)
c26a125b 8%bcond_without systemd # systemd notify support
13cb656b 9#
a02834be 10Summary: FluidSynth - a software, real-time synthesizer
c832e2f0 11Summary(pl.UTF-8): FluidSynth - programowy syntezator działający w czasie rzeczywistym
43d51d96 12Name: fluidsynth
f6e767e3 13Version: 2.1.6
c26a125b 14Release: 1
e2b99d1e
JB
15%if %{with lash} || %{with readline}
16License: GPL v2+ (enforced by lash/readline), LGPL v2+ (fluidsynth itself)
e389d9b2 17%else
c0296b5f 18License: LGPL v2+
e389d9b2 19%endif
43d51d96 20Group: Applications/Sound
c2d1ce44
JB
21#Source0Download: https://github.com/FluidSynth/fluidsynth/releases
22Source0: https://github.com/FluidSynth/fluidsynth/archive/v%{version}/%{name}-%{version}.tar.gz
f6e767e3 23# Source0-md5: 4e5111b59ba4b91c549f9eb088da0a52
43d51d96 24URL: http://www.fluidsynth.org/
f6e767e3 25BuildRequires: SDL2-devel >= 2
c0296b5f 26BuildRequires: alsa-lib-devel >= 0.9.1
2566f65e 27BuildRequires: cmake >= 3.1.0
c0296b5f 28BuildRequires: dbus-devel >= 1.0.0
2a60fc6b 29BuildRequires: gettext-tools
c0296b5f 30BuildRequires: glib2-devel >= 1:2.6.5
43d51d96 31BuildRequires: jack-audio-connection-kit-devel
f9c8cc03 32BuildRequires: ladspa-devel
e389d9b2 33%{?with_lash:BuildRequires: lash-devel >= 0.3}
e2b99d1e
JB
34# OpenMP 4.0
35BuildRequires: libgomp-devel >= 6:4.9
c26a125b 36BuildRequires: libinstpatch >= 1.1.0
e690dbbd 37BuildRequires: libsndfile-devel >= 1.0.18
e389d9b2 38%{?with_midishare:BuildRequires: midishare-devel}
4737413f 39BuildRequires: pkgconfig
2566f65e 40%{?with_portaudio:BuildRequires: portaudio-devel >= 19}
e690dbbd 41BuildRequires: pulseaudio-devel >= 0.9.8
ecf407a5 42%{?with_readline:BuildRequires: readline-devel}
7e677f47 43BuildRequires: rpmbuild(macros) >= 1.213
c26a125b 44%{?with_systemd:BuildRequires: systemd-devel >= 1:209}
c0296b5f
JB
45Requires: alsa-lib >= 0.9.1
46Requires: glib2 >= 1:2.6.5
47Requires: libsndfile >= 1.0.18
cbc84b11 48Suggests: soundfont-fluid
43d51d96 49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
52Fluid Synth is a software, real-time synthesizer based on the
53Soundfont 2 specifications.
54
b01c0090
JR
55%description -l pl.UTF-8
56Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
51d3a7f0 57oparty na specyfikacji Soundfont 2.
43d51d96 58
59%package devel
60Summary: Development files for the FluidSynth
c832e2f0 61Summary(pl.UTF-8): Pliki nagłówkowe dla FluidSynth
43d51d96 62Group: Development/Libraries
e3ebd3aa 63Requires: %{name} = %{version}-%{release}
c0296b5f
JB
64Requires: alsa-lib-devel >= 0.9.1
65Requires: dbus-devel >= 1.0.0
66Requires: glib2-devel >= 1:2.6.5
e690dbbd 67Requires: jack-audio-connection-kit-devel
e389d9b2 68%{?with_lash:Requires: lash-devel >= 0.3}
e690dbbd 69Requires: libsndfile-devel >= 1.0.18
2566f65e 70%{?with_midishare:Requires: midishare-devel}
c18887e9 71%{?with_portaudio:Requires: portaudio-devel >= 19}
e690dbbd 72Requires: pulseaudio-devel >= 0.9.8
2566f65e 73%{?with_readline:Requires: readline-devel}
e2b99d1e 74Obsoletes: fluidsynth-devel < 2
43d51d96 75
76%description devel
77This package contains the header files necessary to develop
51d3a7f0 78applications using FluidSynth.
43d51d96 79
b01c0090
JR
80%description devel -l pl.UTF-8
81Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
82kompilacji aplikacji korzystających z bibliotek FluidSynth.
43d51d96 83
43d51d96 84%prep
0afc704e 85%setup -q
43d51d96 86
87%build
2566f65e
JK
88mkdir -p build
89cd build
e2b99d1e 90%cmake .. \
2566f65e
JK
91 -Denable-midishare=%{with midishare} \
92 -Denable-lash=%{with lash} \
93 -Denable-portaudio=%{with portaudio} \
c26a125b
JB
94 -Denable-readline=%{with readline} \
95 %{!?with_systemd:-Denable-systemd=OFF}
fde40a28 96
c2d1ce44
JB
97# define missing in autotools suite
98echo '#define DEFAULT_SOUNDFONT "%{_datadir}/soundfonts/default.sf2"' >> src/config.h
99
43d51d96 100%{__make}
101
102%install
103rm -rf $RPM_BUILD_ROOT
43d51d96 104
2566f65e 105cd build
9b5cb572
PG
106%{__make} install \
107 DESTDIR=$RPM_BUILD_ROOT
43d51d96 108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
51d3a7f0
JB
112%post -p /sbin/ldconfig
113%postun -p /sbin/ldconfig
114
43d51d96 115%files
116%defattr(644,root,root,755)
c26a125b 117%doc AUTHORS README.md THANKS TODO
9e796385
KK
118%attr(755,root,root) %{_bindir}/fluidsynth
119%attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
2566f65e 120%attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.2
9e796385 121%{_mandir}/man1/fluidsynth.1*
5fadb22d 122
123%files devel
43d51d96 124%defattr(644,root,root,755)
9e796385 125%attr(755,root,root) %{_libdir}/libfluidsynth.so
9e796385 126%{_includedir}/fluidsynth.h
ef862a88 127%{_includedir}/fluidsynth
fde40a28 128%{_pkgconfigdir}/fluidsynth.pc
This page took 0.064932 seconds and 4 git commands to generate.