]> git.pld-linux.org Git - packages/fltk2.git/commitdiff
- build fixed
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 10 Jul 2009 20:22:24 +0000 (20:22 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    fltk2-gcc43.patch -> 1.1
    fltk2-glibc2.10-scandir.patch -> 1.1
    fltk2.spec -> 1.11

fltk2-gcc43.patch [new file with mode: 0644]
fltk2-glibc2.10-scandir.patch [new file with mode: 0644]
fltk2.spec

diff --git a/fltk2-gcc43.patch b/fltk2-gcc43.patch
new file mode 100644 (file)
index 0000000..1165828
--- /dev/null
@@ -0,0 +1,20 @@
+--- fltk-2.0.x-r6671.orig/src/Image.cxx        2009-04-10 16:07:34.000000000 +0200
++++ fltk-2.0.x-r6671/src/Image.cxx     2009-04-10 16:03:22.000000000 +0200
+@@ -20,6 +20,7 @@
+ // Please report all bugs and problems to "fltk-bugs@fltk.org".
+ #include <config.h>
++#include <cstring>
+ #include <fltk/Image.h>
+ #include <fltk/Widget.h>
+ #include <fltk/events.h>
+--- fltk-2.0.x-r6671.orig/src/setcolor.cxx     2009-04-10 16:07:19.000000000 +0200
++++ fltk-2.0.x-r6671/src/setcolor.cxx  2009-04-10 16:08:27.000000000 +0200
+@@ -24,6 +24,7 @@
+ #include <fltk/Color.h>
+ #include <fltk/draw.h>
+ #include <config.h>
++#include <cstring>
+ #if defined(_WIN32) && USE_STOCK_BRUSH && _WIN32_WINNT<0x0500
+ # undef _WIN32_WINNT
+ # define _WIN32_WINNT 0x0500
diff --git a/fltk2-glibc2.10-scandir.patch b/fltk2-glibc2.10-scandir.patch
new file mode 100644 (file)
index 0000000..2026306
--- /dev/null
@@ -0,0 +1,11 @@
+--- src/filename_list.cxx      2009-06-17 09:47:57.000000000 +0200
++++ src/filename_list.cxx      2007-06-01 15:13:08.000000000 +0200
+@@ -63,7 +63,7 @@
+   // some Unix systems):
+   int n = scandir(d, list, 0, sort);
+ #elif defined(__linux) || defined (__FreeBSD__) || defined (__NetBSD__)
+-  int n = scandir(d, list, 0, (int(*)(const void*,const void*))sort);
++  int n = scandir(d, list, 0, (int(*)(const dirent **,const dirent **))sort);
+ #elif defined(__hpux) || defined(__CYGWIN__)
+   // HP-UX, Cygwin define the comparison function like this:
+   int n = scandir(d, list, 0, (int(*)(const dirent **, const dirent **))sort);
index ba98855d23b3d3fccfea099263304bea372fdb17..18eec2bb327c9b0fa37bffd5dc5416d130a630ec 100644 (file)
@@ -1,5 +1,5 @@
 %define                _name           fltk
-%define                _snap           r6671
+%define                _snap           r6793
 %define                _version        2.0
 # Conditional build:
 %bcond_with    cairo   # without cairo support
@@ -8,14 +8,16 @@ Summary:      Fast Light Tool Kit 2.x
 Summary(pl.UTF-8):     FLTK - "lekki" X11 toolkit wersja 2.x
 Summary(pt_BR.UTF-8):  Interface gráfica em C++ para X, OpenGL e Windows
 Name:          fltk2
-Version:       2.0.%{_snap}
-Release:       0.1
+Version:       2.0
+Release:       0.%{_snap}.1
 License:       LGPL with amendments (see COPYING)
 Group:         X11/Libraries
 Source0:       http://ftp.easysw.com/pub/fltk/snapshots/%{_name}-%{_version}.x-%{_snap}.tar.bz2
-# Source0-md5: 6bcef5fd51eb3bc4dd0702f3ae6da6ba
+# Source0-md5: 3e413b2063bdb3d1a6ad4832458d885d
 Patch0:                %{name}-rpath.patch
 Patch1:                %{name}-soname.patch
+Patch2:                %{name}-gcc43.patch
+Patch3:                %{name}-glibc2.10-scandir.patch
 URL:           http://www.fltk.org/
 BuildRequires: autoconf
 BuildRequires: Mesa-libGLU-devel
@@ -91,6 +93,8 @@ Bibliotecas estáticas para o FLTK2.
 %setup -q -n %{_name}-%{_version}.x-%{_snap}
 %patch0 -p0
 %patch1 -p0
+%patch2 -p1
+%patch3 -p0
 
 %build
 %{__sed} -i -e '/fltk2-config/s/^\t/\t$(DESTDIR)/' fluid/Makefile
This page took 0.113173 seconds and 4 git commands to generate.