]> git.pld-linux.org Git - packages/fltk2.git/blob - fltk2.spec
- bconds should be the very first thing, moved defines and includes after them
[packages/fltk2.git] / fltk2.spec
1 # TODO:
2 #       - tons of "Unresolved symbols found in: ..."
3 #
4 # Conditional build:
5 %bcond_with     cairo   # without cairo support
6
7 %define         _name           fltk
8 %define         _snap           r6970
9 %define         _version        2.0
10 Summary:        Fast Light Tool Kit 2.x
11 Summary(pl.UTF-8):      FLTK - "lekki" X11 toolkit wersja 2.x
12 Summary(pt_BR.UTF-8):   Interface gráfica em C++ para X, OpenGL e Windows
13 Name:           fltk2
14 Version:        2.0
15 Release:        0.%{_snap}.2
16 License:        LGPL with amendments (see COPYING)
17 Group:          X11/Libraries
18 Source0:        http://ftp.easysw.com/pub/fltk/snapshots/%{_name}-%{_version}.x-%{_snap}.tar.bz2
19 # Source0-md5:  f78976d0ba1a5c845e14f4df96d580a0
20 Patch0:         %{name}-rpath.patch
21 Patch1:         %{name}-soname.patch
22 Patch2:         %{name}-gcc43.patch
23 Patch3:         %{name}-libpng.patch
24 URL:            http://www.fltk.org/
25 BuildRequires:  Mesa-libGLU-devel
26 BuildRequires:  autoconf
27 # don't build with cairo support if you're planning to use fltk2 with
28 # dillo 2.x
29 %{?with_cairo:BuildRequires:    cairo-devel}
30 BuildRequires:  libjpeg-devel
31 BuildRequires:  libpng-devel
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  rpmbuild(macros) >= 1.315
34 BuildRequires:  xorg-lib-libX11-devel
35 BuildRequires:  xorg-lib-libXext-devel
36 BuildRequires:  xorg-lib-libXi-devel
37 BuildRequires:  xorg-lib-libXinerama-devel
38 BuildRequires:  zlib-devel
39 Obsoletes:      fltk
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd
44 C++ graphical user interface toolkit for X (UNIX(r)), OpenGL(r), and
45 Microsoft(r) Windows(r) NT 4.0, 95, or 98. It was originally developed
46 by Mr. Bill Spitzak and is currently maintained by a small group of
47 developers across the world with a central repository in the US. This
48 is a development version of incoming 2.x release.
49
50 %description -l pl.UTF-8
51 Fast Light Tool Kit ("FLTK", wymawiane "fultik"), jest rozprowadzanym
52 na licencji LGPL narzędziem do tworzenia graficznych interfejsów
53 użytkownika w C++ dla X (UNIX(r)), OpenGL(r), i Microsoft(r)
54 Windows(r) NT 4.0, 95, oraz 98. Jego pierwotnym autorem jest pan Bill
55 Spitzak; obecnie pakiet jest rozwijany przez niewielką grupę
56 deweloperów z różnych stron świata (centralne repozytorium znajduje
57 się w USA). To jest rozwojowa wersja FLTK nadchodzącej wersji 2.x.
58
59 %description -l pt_BR.UTF-8
60 A Fast Light Tool Kit ("FLTK", pronuncia-se "fulltick") é uma
61 ferramenta e interface gráfica feita em C++ para desenvolver
62 aplicativos para o X, OpenGL e Windows.
63
64 %package devel
65 Summary:        FLTK2 development files
66 Summary(pl.UTF-8):      Narzędzia programistyczne dla FLTK2
67 Summary(pt_BR.UTF-8):   Arquivos de inclusão para o FLTK2
68 Group:          X11/Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       libstdc++-devel
71 Obsoletes:      fltk-devel
72
73 %description devel
74 FLTK 2.x development files.
75
76 %description devel -l pl.UTF-8
77 Narzędzia programistyczne dla FLTK 2.x.
78
79 %description devel -l pt_BR.UTF-8
80 Arquivos de inclusão para o FLTK 2.x.
81
82 %package static
83 Summary:        FLTK2 static library
84 Summary(pl.UTF-8):      Biblioteka FLTK2 konsolidowana statycznie
85 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para o FLTK2
86 Group:          X11/Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88
89 %description static
90 FLTK2 static library.
91
92 %description static -l pl.UTF-8
93 Biblioteka FLTK2 konsolidowana statycznie.
94
95 %description static -l pt_BR.UTF-8
96 Bibliotecas estáticas para o FLTK2.
97
98 %prep
99 %setup -q -n %{_name}-%{_version}.x-%{_snap}
100 %patch0 -p0
101 %patch1 -p0
102 %patch2 -p1
103 %patch3 -p1
104
105 %build
106 %{__autoconf}
107 %configure \
108         --%{?with_cairo:en}%{!?with_cairo:dis}able-cairo \
109         --enable-shared \
110         --enable-threads \
111         --enable-xinerama \
112         --with-x \
113         --enable-xft \
114         --with-optim="%{rpmcxxflags}"
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 install -d $RPM_BUILD_ROOT%{_mandir}/man{1,3}
122
123 %{__make} install \
124         prefix=$RPM_BUILD_ROOT%{_prefix} \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 # install man by hand
128 %{__mv} documentation/fltk2-config.man $RPM_BUILD_ROOT%{_mandir}/man1/fltk2-config.1
129 %{__mv} documentation/fluid.man $RPM_BUILD_ROOT%{_mandir}/man1/fluid.1
130 %{__mv} documentation/fltk.man $RPM_BUILD_ROOT%{_mandir}/man3/fltk.3
131
132 # broken so linking, the idea stolen from
133 # https://bugzilla.redhat.com/show_bug.cgi?id=477683
134 ln -fs $(basename $RPM_BUILD_ROOT%{_libdir}/libfltk2.so.*.*) $RPM_BUILD_ROOT%{_libdir}/libfltk2.so
135 ln -fs $(basename $RPM_BUILD_ROOT%{_libdir}/libfltk2.so.*.*) $RPM_BUILD_ROOT%{_libdir}/libfltk2.so
136 ln -fs $(basename $RPM_BUILD_ROOT%{_libdir}/libfltk2_gl.so.*.*) $RPM_BUILD_ROOT%{_libdir}/libfltk2_gl.so
137 ln -fs $(basename $RPM_BUILD_ROOT%{_libdir}/libfltk2_glut.so.*.*) $RPM_BUILD_ROOT%{_libdir}/libfltk2_glut.so
138 ln -fs $(basename $RPM_BUILD_ROOT%{_libdir}/libfltk2_images.so.*.*) $RPM_BUILD_ROOT%{_libdir}/libfltk2_images.so
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %doc CHANGES COPYING CREDITS README
149 %attr(755,root,root) %{_libdir}/libfltk2.so.*.*
150 %attr(755,root,root) %{_libdir}/libfltk2_gl.so.*.*
151 %attr(755,root,root) %{_libdir}/libfltk2_glut.so.*.*
152 %attr(755,root,root) %{_libdir}/libfltk2_images.so.*.*
153
154 %files devel
155 %defattr(644,root,root,755)
156 %doc documentation/*.{html,gif,jpg}
157 %attr(755,root,root) %{_bindir}/fltk2-config
158 %attr(755,root,root) %{_bindir}/fluid2
159 %attr(755,root,root) %{_libdir}/libfltk2.so
160 %attr(755,root,root) %{_libdir}/libfltk2_gl.so
161 %attr(755,root,root) %{_libdir}/libfltk2_glut.so
162 %attr(755,root,root) %{_libdir}/libfltk2_images.so
163 %dir %{_includedir}/fltk
164 %dir %{_includedir}/fltk/compat
165 %dir %{_includedir}/fltk/compat/FL
166 %{_includedir}/fltk/*.[hr]
167 %{_includedir}/fltk/compat/FL/*.[hH]
168 %{_mandir}/man1/fltk2-config.1*
169 %{_mandir}/man1/fluid.1*
170 %{_mandir}/man3/fltk.3*
171
172 %files static
173 %defattr(644,root,root,755)
174 %{_libdir}/libfltk2.a
175 %{_libdir}/libfltk2_gl.a
176 %{_libdir}/libfltk2_glut.a
177 %{_libdir}/libfltk2_images.a
This page took 0.067093 seconds and 3 git commands to generate.