]> git.pld-linux.org Git - packages/fltk2.git/blame - fltk2.spec
- BR: Mesa-libGLU-devel.spec
[packages/fltk2.git] / fltk2.spec
CommitLineData
080a6f77 1%define _name fltk
2%define _snap r6671
3%define _version 2.0
8b9f0de0 4# Conditional build:
5%bcond_with cairo # without cairo support
6#
080a6f77 7Summary: Fast Light Tool Kit 2.x
8Summary(pl.UTF-8): FLTK - "lekki" X11 toolkit wersja 2.x
11cd401e 9Summary(pt_BR.UTF-8): Interface gráfica em C++ para X, OpenGL e Windows
080a6f77 10Name: fltk2
11Version: 2.0.%{_snap}
12Release: 1
13License: LGPL with amendments (see COPYING)
14Group: X11/Libraries
11cd401e 15Source0: http://ftp.easysw.com/pub/fltk/snapshots/%{_name}-%{_version}.x-%{_snap}.tar.bz2
080a6f77 16# Source0-md5: 6bcef5fd51eb3bc4dd0702f3ae6da6ba
17URL: http://www.fltk.org/
18BuildRequires: autoconf
8b9f0de0 19# don't build with cairo support if you're planning to use fltk2 with
20# dillo 2.x
d21c2632 21BuildRequires: Mesa-libGLU-devel
8b9f0de0 22%{?with_cairo:BuildRequires: cairo-devel}
080a6f77 23BuildRequires: libstdc++-devel
24BuildRequires: rpmbuild(macros) >= 1.315
25BuildRequires: xorg-lib-libX11-devel
26BuildRequires: xorg-lib-libXext-devel
27BuildRequires: xorg-lib-libXinerama-devel
28BuildRequires: xorg-util-makedepend
29Obsoletes: fltk
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
883114b6 31
080a6f77 32%description
33The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a LGPL'd
34C++ graphical user interface toolkit for X (UNIX(r)), OpenGL(r), and
35Microsoft(r) Windows(r) NT 4.0, 95, or 98. It was originally developed
36by Mr. Bill Spitzak and is currently maintained by a small group of
37developers across the world with a central repository in the US. This
38is a development version of incoming 2.x release.
39
40%description -l pl.UTF-8
41Fast Light Tool Kit ("FLTK", wymawiane "fultik"), jest rozprowadzanym
42na licencji LGPL narzędziem do tworzenia graficznych interfejsów
43użytkownika w C++ dla X (UNIX(r)), OpenGL(r), i Microsoft(r)
44Windows(r) NT 4.0, 95, oraz 98. Jego pierwotnym autorem jest pan Bill
45Spitzak; obecnie pakiet jest rozwijany przez niewielką grupę
46deweloperów z różnych stron świata (centralne repozytorium znajduje
47się w USA). To jest rozwojowa wersja FLTK nadchodzącej wersji 2.x.
48
49%description -l pt_BR.UTF-8
50A Fast Light Tool Kit ("FLTK", pronuncia-se "fulltick") é uma
51ferramenta e interface gráfica feita em C++ para desenvolver
52aplicativos para o X, OpenGL e Windows.
53
54%package devel
55Summary: FLTK2 development files
56Summary(pl.UTF-8): Narzędzia programistyczne dla FLTK2
57Summary(pt_BR.UTF-8): Arquivos de inclusão para o FLTK2
58Group: X11/Development/Libraries
59Requires: %{name} = %{version}-%{release}
60Requires: libstdc++-devel
61Obsoletes: fltk-devel
62
63%description devel
64FLTK 2.x development files.
65
66%description devel -l pl.UTF-8
67Narzędzia programistyczne dla FLTK 2.x.
68
69%description devel -l pt_BR.UTF-8
70Arquivos de inclusão para o FLTK 2.x.
71
72%package static
73Summary: FLTK2 static library
74Summary(pl.UTF-8): Biblioteka FLTK2 konsolidowana statycznie
75Summary(pt_BR.UTF-8): Bibliotecas estáticas para o FLTK2
76Group: X11/Development/Libraries
77Requires: %{name}-devel = %{version}-%{release}
78
79%description static
80FLTK2 static library.
81
82%description static -l pl.UTF-8
83Biblioteka FLTK2 konsolidowana statycznie.
84
85%description static -l pt_BR.UTF-8
86Bibliotecas estáticas para o FLTK2.
87
88%prep
89%setup -q -n %{_name}-%{_version}.x-%{_snap}
90
91%build
92%{__sed} -i -e '/fltk2-config/s/^\t/\t$(DESTDIR)/' fluid/Makefile
93%{__autoconf}
94%configure \
8b9f0de0 95 --%{?with_cairo:en}%{!?with_cairo:dis}able-cairo \
080a6f77 96 --enable-shared \
97 --enable-threads \
98 --enable-xinerama \
99 --with-x \
100 --enable-xft \
101 --with-optim="%{rpmcxxflags}"
102
103%{__make}
104
105%install
106rm -rf $RPM_BUILD_ROOT
11cd401e 107
080a6f77 108install -d $RPM_BUILD_ROOT%{_mandir}/man{1,3}
109
110%{__make} install \
111 prefix=$RPM_BUILD_ROOT%{_prefix} \
112 DESTDIR=$RPM_BUILD_ROOT
113
114# install man by hand
11cd401e 115%{__mv} documentation/fltk2-config.man $RPM_BUILD_ROOT%{_mandir}/man1/fltk2-config.1
080a6f77 116%{__mv} documentation/fluid.man $RPM_BUILD_ROOT%{_mandir}/man1/fluid.1
117%{__mv} documentation/fltk.man $RPM_BUILD_ROOT%{_mandir}/man3/fltk.3
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post -p /sbin/ldconfig
123%postun -p /sbin/ldconfig
124
125%files
126%defattr(644,root,root,755)
127%doc CHANGES COPYING CREDITS README
128%attr(755,root,root) %{_libdir}/libfltk2.so.*.*
129%attr(755,root,root) %{_libdir}/libfltk2_gl.so.*.*
130%attr(755,root,root) %{_libdir}/libfltk2_glut.so.*.*
131%attr(755,root,root) %{_libdir}/libfltk2_images.so.*.*
132
133%files devel
134%defattr(644,root,root,755)
135%doc documentation/*.{html,gif,jpg}
136%attr(755,root,root) %{_bindir}/fltk2-config
137%attr(755,root,root) %{_bindir}/fluid2
138%attr(755,root,root) %{_libdir}/libfltk2.so
139%attr(755,root,root) %{_libdir}/libfltk2_gl.so
140%attr(755,root,root) %{_libdir}/libfltk2_glut.so
141%attr(755,root,root) %{_libdir}/libfltk2_images.so
142%dir %{_includedir}/fltk
143%dir %{_includedir}/fltk/compat
144%dir %{_includedir}/fltk/compat/FL
145%{_includedir}/fltk/*.[hr]
146%{_includedir}/fltk/compat/FL/*.[hH]
147%{_mandir}/man1/fltk2-config.1*
148%{_mandir}/man1/fluid.1*
149%{_mandir}/man3/fltk.3*
150
151%files static
152%defattr(644,root,root,755)
153%{_libdir}/libfltk2.a
154%{_libdir}/libfltk2_gl.a
155%{_libdir}/libfltk2_glut.a
156%{_libdir}/libfltk2_images.a
This page took 0.214522 seconds and 4 git commands to generate.