]> git.pld-linux.org Git - packages/flowcanvas.git/commitdiff
- added graph patch from FreeBSD (switch from obsolete libgraph to libcgraph API) master auto/th/flowcanvas-0.7.1-2
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 9 Apr 2014 14:57:31 +0000 (16:57 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 9 Apr 2014 14:57:31 +0000 (16:57 +0200)
- release 2

flowcanvas-graph.patch [new file with mode: 0644]
flowcanvas.spec

diff --git a/flowcanvas-graph.patch b/flowcanvas-graph.patch
new file mode 100644 (file)
index 0000000..e34b107
--- /dev/null
@@ -0,0 +1,46 @@
+--- src/Canvas.cpp.orig        2011-01-10 00:19:58.000000000 +0100
++++ src/Canvas.cpp     2013-03-16 13:45:17.797462753 +0100
+@@ -1253,21 +1253,21 @@
+        */
+       GVC_t* gvc = gvContext();
+-      Agraph_t* G = agopen((char*)"g", AGDIGRAPH);
++      Agraph_t* G = agopen((char*)"g", Agdirected, NULL);
+       nodes.gvc = gvc;
+       nodes.G = G;
+       if (_direction == HORIZONTAL)
+-              agraphattr(G, (char*)"rankdir", (char*)"LR");
++              agattr(G, AGRAPH, (char*)"rankdir", (char*)"LR");
+       else
+-              agraphattr(G, (char*)"rankdir", (char*)"TD");
++              agattr(G, AGRAPH, (char*)"rankdir", (char*)"TD");
+       unsigned id = 0;
+       for (ItemList::const_iterator i = _items.begin(); i != _items.end(); ++i) {
+               std::ostringstream ss;
+               ss << "n" << id++;
+-              Agnode_t* node = agnode(G, strdup(ss.str().c_str()));
++              Agnode_t* node = agnode(G, strdup(ss.str().c_str()), true);
+               if (boost::dynamic_pointer_cast<Module>(*i)) {
+                       ss.str("");
+                       ss << (*i)->width() / 96.0;
+@@ -1310,7 +1310,7 @@
+               assert(src_node && dst_node);
+-              Agedge_t* edge = agedge(G, src_node, dst_node);
++              Agedge_t* edge = agedge(G, src_node, dst_node, NULL, true);
+               if (use_length_hints && c->length_hint() != 0) {
+                       std::ostringstream len_ss;
+@@ -1325,7 +1325,7 @@
+               if (partner) {
+                       GVNodes::iterator p = nodes.find(partner);
+                       if (p != nodes.end())
+-                              agedge(G, i->second, p->second);
++                              agedge(G, i->second, p->second, NULL, true);
+               }
+       }
index d754e065deb0aec3106a552b95d679ba5c86026c..021829dff220a5f199cb731bf624c1a0a8e87f3a 100644 (file)
@@ -2,20 +2,21 @@ Summary:      Interactive Gtkmm/Gnomecanvasmm widget for graph-based interfaces
 Summary(pl.UTF-8):     Interaktywny widget Gtkmm/Gnomecanvasmm do interfejsów opartych na rysunkach
 Name:          flowcanvas
 Version:       0.7.1
-Release:       1
+Release:       2
 License:       GPL v2+
 Group:         Libraries
 Source0:       http://download.drobilla.net/%{name}-%{version}.tar.bz2
 # Source0-md5: a4908f6385ce9fd2ce97c8caa823f053
+Patch0:                %{name}-graph.patch
 URL:           http://drobilla.net/software/flowcanvas/
 BuildRequires: boost-devel
-BuildRequires: graphviz-devel >= 2.8
+BuildRequires: graphviz-devel >= 2.30
 BuildRequires: gtkmm-devel >= 2.10.0
 BuildRequires: libgnomecanvasmm-devel >= 2.6.0
 BuildRequires: libstdc++-devel
 BuildRequires: pkgconfig
 BuildRequires: python
-Requires:      graphviz >= 2.8
+Requires:      graphviz >= 2.30
 Requires:      gtkmm >= 2.10.0
 Requires:      libgnomecanvasmm >= 2.6.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -36,7 +37,7 @@ Summary(pl.UTF-8):    Pliki nagłówkowe biblioteki flowcanvas
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      boost-devel
-Requires:      graphviz-devel >= 2.8
+Requires:      graphviz-devel >= 2.30
 Requires:      gtkmm-devel >= 2.10.0
 Requires:      libgnomecanvasmm-devel >= 2.6.0
 
@@ -48,6 +49,7 @@ Pliki nagłówkowe biblioteki flowcanvas.
 
 %prep
 %setup -q
+%patch0 -p0
 
 %build
 CXX="%{__cxx}" \
This page took 0.057967 seconds and 4 git commands to generate.