]> git.pld-linux.org Git - packages/flocker.git/blob - flocker.spec
- pl
[packages/flocker.git] / flocker.spec
1 Summary:        Easily manage Docker containers & their data
2 Name:           flocker
3 Version:        0.4.0
4 Release:        0.1
5 License:        Apache v2.0
6 Group:          Libraries/Python
7 Source0:        https://github.com/ClusterHQ/flocker/archive/%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  76aa991d8ea4cbf7ae6b3b81b9073a06
9 Patch0:         deps.patch
10 URL:            https://github.com/ClusterHQ/flocker
11 BuildRequires:  python-PyYAML >= 3.10
12 #BuildRequires: python-Twisted >= 15.0.0
13 #BuildRequires: python-characteristic >= 14.1.0
14 BuildRequires:  python-docker >= 0.7.1
15 #BuildRequires: python-eliot >= 0.6.0
16 BuildRequires:  python-ipaddr >= 2.1.11
17 BuildRequires:  python-jsonschema >= 2.4.0
18 BuildRequires:  python-klein >= 0.2.3
19 #BuildRequires: python-machinist >= 0.2.0
20 BuildRequires:  python-netifaces >= 0.8
21 BuildRequires:  python-psutil >= 2.1.2
22 BuildRequires:  python-pyrsistent >= 0.9.1
23 BuildRequires:  python-pytz
24 BuildRequires:  python-setuptools
25 BuildRequires:  python-setuptools >= 7.0
26 #BuildRequires: python-treq >= 0.2.1
27 #BuildRequires: python-zope.interface >= 4.0.5
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.710
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Flocker is a data volume manager and multi-host Docker cluster
35 management tool. With it you can control your data using the same
36 tools you use for your stateless applications by harnessing the power
37 of ZFS on Linux. This means that you can run your databases, queues
38 and key-value stores in Docker and move them around as easily as the
39 rest of your app.
40
41 %prep
42 %setup -q
43 %patch0 -p1
44
45 %build
46 %py_build
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 %py_install
51
52 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/flocker/volume/test
53
54 %py_postclean
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %attr(755,root,root) %{_bindir}/flocker
62 %attr(755,root,root) %{_bindir}/flocker-changestate
63 %attr(755,root,root) %{_bindir}/flocker-control
64 %attr(755,root,root) %{_bindir}/flocker-dataset-agent
65 %attr(755,root,root) %{_bindir}/flocker-deploy
66 %attr(755,root,root) %{_bindir}/flocker-reportstate
67 %attr(755,root,root) %{_bindir}/flocker-volume
68 %attr(755,root,root) %{_bindir}/flocker-zfs-agent
69 %{py_sitescriptdir}/Flocker-%{version}-py*.egg-info
70 %{py_sitescriptdir}/flocker
This page took 0.083392 seconds and 3 git commands to generate.