]> git.pld-linux.org Git - packages/flashrom.git/blob - flashrom.spec
update required meson version
[packages/flashrom.git] / flashrom.spec
1 #
2 # Conditional build:
3 %bcond_without  ftdi    # FTDI chips
4 #
5 Summary:        Tool Flashing your BIOS from the Unix/Linux command line
6 Summary(pl.UTF-8):      Narzędzie do aktualizacji BIOS-u z linii poleceń Uniksa/Linuksa
7 Name:           flashrom
8 Version:        0.9.9
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/System
12 Source0:        http://download.flashrom.org/releases/%{name}-%{version}.tar.bz2
13 # Source0-md5:  aab9c98925d9cfb5ffb28b67a6112530
14 URL:            http://www.flashrom.org/Flashrom
15 %{?with_ftdi:BuildRequires:     libftdi1-devel >= 1.0}
16 # libusb 0.1 still needed for PICKIT2_SPI dongle
17 BuildRequires:  libusb-compat-devel >= 0.1
18 BuildRequires:  libusb-devel >= 1.0
19 BuildRequires:  pciutils-devel
20 BuildRequires:  pkgconfig
21 BuildRequires:  zlib-devel
22 ExclusiveArch:  %{ix86} %{x8664} x32 mips ppc ppc64 sparc sparcv9 sparc64
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _sbindir                /sbin
26
27 %description
28 flashrom is a utility for identifying, reading, writing, verifying and
29 erasing flash chips. It's often used to flash BIOS / EFI / coreboot /
30 firmware images.
31  - Supports more than 160 flash chips, 75 chipsets, 100 mainboards, and
32    10 PCI devices which can be used as external programmers.
33  - Supports parallel, LPC, FWH and SPI flash interfaces and various
34    chip packages (DIP32, PLCC32, DIP8, SO8/SOIC8, TSOP32, TSOP40 and
35    more)
36  - No physical access needed, root access is sufficient.
37  - No bootable floppy disk, bootable CD-ROM or other media needed.
38  - No keyboard or monitor needed. Simply reflash remotely via SSH.
39  - No instant reboot needed. Reflash your chip in a running system,
40    verify it, be happy. The new firmware will be present next time you
41    boot.
42  - Crossflashing and hotflashing is possible as long as the flash chips
43    are electrically and logically compatible (same protocol). Great for
44    recovery.
45  - Scriptability. Reflash a whole pool of identical machines at the
46    same time from the command line. It is recommended to check flashrom
47    output and error codes.
48  - Speed. flashrom is often much faster than most vendor flash tools.
49  - Portability. Supports Linux, FreeBSD, DragonFly BSD, Solaris, Mac OS
50    X, and other Unix-like OSes.
51
52 %description -l pl.UTF-8
53 flashrom to narzędzie do identyfikacji, odczytu, zapisu, weryfikacji i
54 kasowania układów flash. Jest często używany do programowania obrazów
55 BIOS-u / EFI / coreboot / firmware'u.
56  - Obsługuje ponad 160 układów flash, 75 chipsetów, 100 płyt głównych i
57    10 urządzeń PCI, które mogą być wykorzystane jako zewnętrzne
58    programatory.
59  - Wspiera układy flash równoległe, LPC, SPI i FWH o różnych
60    obudowach/wyprowadzeniach (DIP32, PLCC32, DIP8, SO8/SOIC8, TSOP32,
61    TSOP40 i inne)
62  - Nie wymaga fizycznego dostępu, wystarczy dostęp do konta roota.
63  - Nie potrzebuje bootowalnej dyskietki, rozruchowego dysku CD-ROM lub
64    innych nośników.
65  - Nie jest wymagana klawiatura ani monitor. Wystarczy przeprogramować
66    zdalnie poprzez SSH.
67  - Nie ma potrzeby ponownego uruchamiania komputera. Wystarczy
68    przeprogramować układ w uruchomionym systemie, zweryfikować i być
69    szczęśliwym. Nowy firmware będzie dostępny przy następnym bootowaniu.
70  - Crossflashing i hotflashing są możliwe na tyle, na ile układy flash
71    są elektrycznie i logicznie kompatybilne (ten sam protokół). Jest to
72    świetna metoda do przywracania sprzętu ze źle zaprogramowanym
73    firmwarem/BIOS-em.
74  - Pozwala na tworzenie skryptów do wielokrotnego programowania.
75    Programowanie identycznych maszyn w tym samym czasie z wiersza
76    poleceń. Zaleca się sprawdzanie komunikatów programu flashrom i kodów
77    błędów.
78  - Szybkość. flashrom jest często znacznie szybszy niż większość
79    sprzedawanych narzędzi do flashowania.
80  - Wszechstronność. Obsługuje systemy Linux, FreeBSD, Dragonfly BSD,
81    Solaris, Mac OS X oraz inne systemy operacyjne oparte na Uniksie.
82
83 %prep
84 %setup -q
85
86 %build
87 %{__make} \
88         CC='%{__cc}' \
89         CFLAGS="%{rpmcflags}" \
90         LDFLAGS="%{rpmldflags}" \
91         %{!?with_ftdi:CONFIG_FT2232_SPI=no}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8}
96 install %{name} $RPM_BUILD_ROOT%{_sbindir}
97 install %{name}.8 $RPM_BUILD_ROOT%{_mandir}/man8
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files
103 %defattr(644,root,root,755)
104 %doc README
105 %attr(755,root,root) %{_sbindir}/flashrom
106 %{_mandir}/man8/flashrom.8*
This page took 0.090172 seconds and 3 git commands to generate.