]> git.pld-linux.org Git - packages/flam3.git/blame - flam3.spec
- drop more flags
[packages/flam3.git] / flam3.spec
CommitLineData
0c03dc22 1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
5Summary: Programs to generate and render cosmic recursive fractal flames
6Name: flam3
7Version: 3.0.1
8Release: 1
9License: GPL v3+
10Group: Applications/Multimedia
11Source0: http://flam3.googlecode.com/files/%{name}-%{version}.tar.gz
12# Source0-md5: 916e1cda65b4ce2c84b3b4edc7d9605a
13URL: http://www.flam3.com/
14BuildRequires: autoconf
15BuildRequires: automake
16BuildRequires: libjpeg-devel
17BuildRequires: libpng-devel
18BuildRequires: libtool
19BuildRequires: libxml2-devel
20BuildRequires: pkgconfig
21BuildRequires: sed >= 4.0
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Flam3, or Fractal Flames, are algorithmically generated images and
26animations. This is free software to render fractal flames as
27described on http://flam3.com. Flam3-animate makes animations, and
28flam3-render makes still images. Flam3-genome creates and manipulates
29genomes (parameter sets).
30
31%package devel
32Summary: C headers to generate and render cosmic recursive fractal flames
33Group: Development/Libraries
34Requires: %{name} = %{version}-%{release}
35
36%description devel
37Flam3, or Fractal Flames, are algorithmically generated images and
38animations. This is free software to render fractal flames as
39described on http://flam3.com. Flam3-animate makes animations, and
40flam3-render makes still images. Flam3-genome creates and manipulates
41genomes (parameter sets). This package contains a header file for C, a
42library, and a pkgconfig file.
43
44%package static
45Summary: Static flam3 library
46Summary(pl.UTF-8): Statyczna biblioteka flam3
47Group: Development/Libraries
48Requires: %{name}-devel = %{version}-%{release}
49
50%description static
51This package contains static version of flam3.
52
53%description static -l pl.UTF-8
54Ten pakiet zawiera statycznÄ… wersjÄ™ biblioteki flam3.
55
56%prep
57%setup -q -n %{name}-%{version}/src
58
8f1fd20e 59# drop redundant opt flags
60%{__sed} -i 's,-g -O3,,' Makefile.am
0c03dc22 61
62%build
63%{__libtoolize}
64%{__aclocal} -I m4
65%{__autoconf}
66%{__autoheader}
67%{__automake}
68%configure \
69 --enable-shared \
70 %{!?with_static_libs:--disable-static}
71%{__make}
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76%{__make} install \
77 DESTDIR=$RPM_BUILD_ROOT
78
79%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post -p /sbin/ldconfig
85%postun -p /sbin/ldconfig
86
87%files
88%defattr(644,root,root,755)
89%doc README.txt
90%attr(755,root,root) %{_bindir}/flam3-animate
91%attr(755,root,root) %{_bindir}/flam3-convert
92%attr(755,root,root) %{_bindir}/flam3-genome
93%attr(755,root,root) %{_bindir}/flam3-render
94%attr(755,root,root) %{_libdir}/libflam3.so.*.*.*
95%attr(755,root,root) %ghost %{_libdir}/libflam3.so.0
96%{_datadir}/flam3
97%{_mandir}/man1/flam3*.1*
98
99%files devel
100%defattr(644,root,root,755)
101%{_includedir}/*.h
102%{_libdir}/libflam3.so
103%{_pkgconfigdir}/flam3.pc
104
105%if %{with static_libs}
106%files static
107%defattr(644,root,root,755)
108%{_libdir}/libflam3.a
109%endif
This page took 0.069789 seconds and 4 git commands to generate.