]> git.pld-linux.org Git - packages/flac.git/commitdiff
- updated to 1.3.2 auto/th/flac-1.3.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 20 Jan 2017 21:08:14 +0000 (22:08 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 20 Jan 2017 21:08:14 +0000 (22:08 +0100)
- removed obsolete opt,x32 patches
- added sse2 bcond

flac-opt.patch [deleted file]
flac.spec
x32.patch [deleted file]

diff --git a/flac-opt.patch b/flac-opt.patch
deleted file mode 100644 (file)
index 73a7e68..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
---- flac-1.3.1/configure.ac.orig       2014-11-27 03:45:33.598155763 +0100
-+++ flac-1.3.1/configure.ac    2014-11-29 09:01:11.196400208 +0100
-@@ -348,12 +348,9 @@
- if test "x$debug" = xtrue; then
-       CPPFLAGS="-DDEBUG $CPPFLAGS"
--      CFLAGS=$(echo "$CFLAGS" | sed 's/-g//')
--      CFLAGS="-g $CFLAGS"
- else
-       CPPFLAGS="-DNDEBUG $CPPFLAGS"
--      CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//;s/-g//')
--      CFLAGS="-O3 -funroll-loops $CFLAGS"
-+      CFLAGS="$CFLAGS -O3 -funroll-loops"
- fi
- XIPH_GCC_VERSION
index 000140161726454b72c82f49871536ecc10f7ffe..4ffbad8a7d168477f7a41ffb21d56fd6ec52073d 100644 (file)
--- a/flac.spec
+++ b/flac.spec
@@ -2,18 +2,20 @@
 # Conditional build:
 %bcond_without static_libs     # don't build static library
 %bcond_without xmms            # don't build XMMS plugin
+%bcond_with    sse2            # SSE2 instructions
 
+%ifarch %{x8664} x32 pentium4
+%define        with_sse2       1
+%endif
 Summary:       Free Lossless Audio Codec
 Summary(pl.UTF-8):     Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
 Name:          flac
-Version:       1.3.1
-Release:       6
+Version:       1.3.2
+Release:       1
 License:       BSD (libFLAC/libFLAC++), GPL v2+ (programs and plugins)
 Group:         Libraries
 Source0:       http://downloads.xiph.org/releases/flac/%{name}-%{version}.tar.xz
-# Source0-md5: b9922c9a0378c88d3e901b234f852698
-Patch0:                %{name}-opt.patch
-Patch1:                x32.patch
+# Source0-md5: 454f1bfa3f93cc708098d7890d0499bd
 URL:           http://xiph.org/flac/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1:1.11
@@ -116,8 +118,6 @@ Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
 
 %{__rm} m4/ogg.m4
 
@@ -129,6 +129,7 @@ Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
 %{__automake}
 %configure \
        --disable-silent-rules \
+       %{!?with_sse2:--disable-sse} \
        %{?with_static_libs:--enable-static} \
        %{!?with_xmms:--disable-xmms-plugin}
 
diff --git a/x32.patch b/x32.patch
deleted file mode 100644 (file)
index c364c6b..0000000
--- a/x32.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- flac-1.3.1/configure.ac~   2014-12-25 12:11:41.000000000 +0000
-+++ flac-1.3.1/configure.ac    2014-12-25 12:28:28.561894846 +0000
-@@ -105,6 +105,14 @@
- asm_optimisation=no
- case "$host_cpu" in
-       x86_64)
-+              case "$host" in
-+                      *gnux32)
-+                              cpu_x86_64=true
-+                              AC_DEFINE(FLAC__CPU_X86_64)
-+                              AH_TEMPLATE(FLAC__CPU_X86_64, [define if building for x86_64])
-+                              asm_optimisation=$asm_opt
-+                              ;;
-+                      *)
-               if test $ac_cv_sizeof_voidp = 4 ; then
-                       # This must be a 32 bit user space running on 64 bit kernel so treat
-                       # this as ia32.
-@@ -118,6 +126,8 @@
-                       AH_TEMPLATE(FLAC__CPU_X86_64, [define if building for x86_64])
-                       fi
-               asm_optimisation=$asm_opt
-+                              ;;
-+              esac
-               ;;
-       i*86)
-               cpu_ia32=true
-@@ -150,6 +150,7 @@
-       *-*-cygwin|*mingw*) OBJ_FORMAT=win32 ;;
-       *-*-darwin*) OBJ_FORMAT=macho ;;
-       *emx*) OBJ_FORMAT=aout ;;
-+      *gnux32*) OBJ_FORMAT=elfx32 ;;
-       *) OBJ_FORMAT=elf ;;
- esac
- AC_SUBST(OBJ_FORMAT)
-@@ -370,6 +371,12 @@
-               CPPFLAGS="$CPPFLAGS -DFLAC__USE_VISIBILITY_ATTR"
-               CFLAGS="$CFLAGS -fvisibility=hidden"
-               CXXFLAGS="$CXXFLAGS -fvisibility=hidden"
-+              fi
-+
-+      if test "$GCC_MAJOR_VERSION" -ge 4 && test "$OBJ_FORMAT" = elfx32; then
-+              CPPFLAGS="$CPPFLAGS -DFLAC__USE_VISIBILITY_ATTR"
-+              CFLAGS="$CFLAGS -fvisibility=hidden"
-+              CXXFLAGS="$CXXFLAGS -fvisibility=hidden"
-               fi
-       if test "$GCC_MAJOR_VERSION" -ge 4 && test "$OBJ_FORMAT" = macho; then
---- flac-1.3.1/src/libFLAC/ia32/nasm.h~        2014-11-27 01:19:47.000000000 +0000
-+++ flac-1.3.1/src/libFLAC/ia32/nasm.h 2014-12-25 12:31:46.790820947 +0000
-@@ -50,6 +50,10 @@
-       %idefine code_section section .text align=16
-       %idefine data_section section .data align=32
-       %idefine bss_section  section .bss  align=32
-+%elifdef OBJ_FORMAT_elfx32
-+      %idefine code_section section .text align=16
-+      %idefine data_section section .data align=32
-+      %idefine bss_section  section .bss  align=32
- %else
-       %error unsupported object format!
- %endif
This page took 0.114028 seconds and 4 git commands to generate.