]> git.pld-linux.org Git - packages/flac.git/blobdiff - flac.spec
- rel 5; use system ogg.m4
[packages/flac.git] / flac.spec
index dac856f801fe80b961c5e3a5d109fed7ea5c8065..06815913475eb81aba16bd78dac434e7a490c324 100644 (file)
--- a/flac.spec
+++ b/flac.spec
@@ -1,22 +1,24 @@
-# maybe TODO: split (c++, ogg?)
 #
 # Conditional build:
-%bcond_without xmms    # don't build XMMS plugin
+%bcond_without static_libs     # don't build static library
+%bcond_without xmms            # don't build XMMS plugin
 #
 Summary:       Free Lossless Audio Codec
-Summary(pl):   Free Lossless Audio Codec - Wolnodostêpny bezstratny kodek audio
+Summary(pl.UTF-8):     Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
 Name:          flac
-Version:       1.1.2
-Release:       2
-License:       GPL/LGPL
+Version:       1.2.1
+Release:       5
+License:       BSD (libFLAC/libFLAC++), GPL (programs and plugins)
 Group:         Libraries
 Source0:       http://dl.sourceforge.net/flac/%{name}-%{version}.tar.gz
-# Source0-md5: 2bfc127cdda02834d0491ab531a20960
+# Source0-md5: 153c8b15a54da428d1f0fadc756c22c7
 Patch0:                %{name}-without_xmms.patch
-Patch1:                %{name}-read_only_relocs.patch
+Patch1:                %{name}-lt.patch
+Patch2:                %{name}-gcc44.patch
 URL:           http://flac.sourceforge.net/
 BuildRequires: autoconf
-BuildRequires: automake
+BuildRequires: automake >= 1:1.7
+# for AM_ICONV
 BuildRequires: gettext-devel
 BuildRequires: libogg-devel >= 2:1.0
 BuildRequires: libstdc++-devel
@@ -28,38 +30,80 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %description
 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
 
-%description -l pl
-FLAC jest bezstratnym kodekiem audio z otwartymi ¼ród³ami, rozwijanym
+%description -l pl.UTF-8
+FLAC jest bezstratnym kodekiem audio z otwartymi źródłami, rozwijanym
 przez Josha Coalsona.
 
 %package devel
 Summary:       FLAC - development files
-Summary(pl):   FLAC - pliki nag³ówkowe
+Summary(pl.UTF-8):     FLAC - pliki nagłówkowe
+License:       BSD
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      libogg-devel >= 2:1.0
+# for -c++ only
+#Requires:     libstdc++-devel
 
 %description devel
 The package contains the development header files for FLAC libraries.
 
-%description devel -l pl
-Ten pakiet zawiera pliki nag³ówkowe bibliotek FLAC.
+%description devel -l pl.UTF-8
+Ten pakiet zawiera pliki nagłówkowe bibliotek FLAC.
 
 %package static
 Summary:       FLAC - static libraries
-Summary(pl):   FLAC - biblioteki statyczne
+Summary(pl.UTF-8):     FLAC - biblioteki statyczne
+License:       BSD
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 The package contains FLAC static libraries.
 
-%description static -l pl
+%description static -l pl.UTF-8
 Ten pakiet zawiera biblioteki statyczne FLAC.
 
+%package c++
+Summary:       FLAC++ - C++ API for FLAC codec
+Summary(pl.UTF-8):     FLAC++ - API C++ do kodeka FLAC
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description c++
+FLAC++ - C++ API for FLAC codec.
+
+%description c++ -l pl.UTF-8
+FLAC++ - API C++ do kodeka FLAC.
+
+%package c++-devel
+Summary:       Header files for FLAC++ library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki FLAC++
+Group:         Development/Libraries
+Requires:      %{name}-c++ = %{version}-%{release}
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description c++-devel
+Header files for FLAC++ library.
+
+%description c++-devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki FLAC++.
+
+%package c++-static
+Summary:       Static FLAC++ library
+Summary(pl.UTF-8):     Statyczna biblioteka FLAC++
+Group:         Development/Libraries
+Requires:      %{name}-c++-devel = %{version}-%{release}
+
+%description c++-static
+Static FLAC++ library.
+
+%description c++-static -l pl.UTF-8
+Statyczna biblioteka FLAC++.
+
 %package -n xmms-input-flac
 Summary:       Free Lossless Audio Codec - XMMS plugin
-Summary(pl):   Wtyczka FLAC dla XMMS
-License:       GPL/LGPL
+Summary(pl.UTF-8):     Wtyczka FLAC dla XMMS
+License:       GPL v2+
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      xmms
@@ -67,20 +111,25 @@ Requires:  xmms
 %description -n xmms-input-flac
 FLAC input plugin for XMMS.
 
-%description -n xmms-input-flac -l pl
-Wtyczka dla XMMS umo¿liwiaj±ca odtwarzanie plików w formacie FLAC.
+%description -n xmms-input-flac -l pl.UTF-8
+Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
 
 %prep
 %setup -q
 %{!?with_xmms:%patch0 -p1}
 %patch1 -p1
+%patch2 -p1
+
+rm m4/ogg.m4
 
 %build
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
+%{__autoheader}
 %{__automake}
-%configure
+%configure \
+       %{!?with_static_libs:--disable-static}
 
 %{__make}
 
@@ -91,7 +140,7 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 
 # no makefiles in doc dirs
-rm -f doc/html/{Makefile*,images/Makefile*,ru/Makefile*}
+rm -f doc/html/{Makefile*,images/Makefile*,images/hw/Makefile*,ru/Makefile*}
 rm -f $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.la
 
 %clean
@@ -100,27 +149,55 @@ rm -rf $RPM_BUILD_ROOT
 %post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
+%post   c++ -p /sbin/ldconfig
+%postun c++ -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS README doc/html/{*.html,images}
+%doc AUTHORS COPYING.Xiph README doc/html/{*.html,images}
 %lang(ru) %doc doc/html/ru
-%attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
-%{_mandir}/man1/*
+%attr(755,root,root) %{_bindir}/flac
+%attr(755,root,root) %{_bindir}/metaflac
+%attr(755,root,root) %{_libdir}/libFLAC.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libFLAC.so.8
+%{_mandir}/man1/flac.1*
+%{_mandir}/man1/metaflac.1*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
-%{_includedir}/*
-%{_aclocaldir}/*
+%attr(755,root,root) %{_libdir}/libFLAC.so
+%{_libdir}/libFLAC.la
+%{_includedir}/FLAC
+%{_pkgconfigdir}/flac.pc
+%{_aclocaldir}/libFLAC.m4
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libFLAC.a
+%endif
+
+%files c++
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libFLAC++.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libFLAC++.so.6
+
+%files c++-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libFLAC++.so
+%{_libdir}/libFLAC++.la
+%{_includedir}/FLAC++
+%{_pkgconfigdir}/flac++.pc
+%{_aclocaldir}/libFLAC++.m4
+
+%if %{with static_libs}
+%files c++-static
+%defattr(644,root,root,755)
+%{_libdir}/libFLAC++.a
+%endif
 
 %if %{with xmms}
 %files -n xmms-input-flac
 %defattr(644,root,root,755)
-%attr(755,root,root) %{xmms_input_plugindir}/*.so
+%attr(755,root,root) %{xmms_input_plugindir}/libxmms-flac.so
 %endif
This page took 0.067797 seconds and 4 git commands to generate.