]> git.pld-linux.org Git - packages/flac.git/blob - flac.spec
Fix -Werror=format-security errors. rebased for current tree
[packages/flac.git] / flac.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  xmms            # don't build XMMS plugin
5
6 Summary:        Free Lossless Audio Codec
7 Summary(pl.UTF-8):      Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
8 Name:           flac
9 Version:        1.2.1
10 Release:        7
11 License:        BSD (libFLAC/libFLAC++), GPL (programs and plugins)
12 Group:          Libraries
13 Source0:        http://dl.sourceforge.net/flac/%{name}-%{version}.tar.gz
14 # Source0-md5:  153c8b15a54da428d1f0fadc756c22c7
15 Patch0:         %{name}-without_xmms.patch
16 Patch1:         %{name}-lt.patch
17 Patch2:         %{name}-gcc44.patch
18 Patch3:         crbug-111390.patch
19 Patch4:         deb-643377.patch
20 URL:            http://flac.sourceforge.net/
21 BuildRequires:  autoconf
22 BuildRequires:  automake >= 1:1.7
23 # for AM_ICONV
24 BuildRequires:  gettext-devel
25 BuildRequires:  libogg-devel >= 2:1.0
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool >= 2:1.4d-3
28 %{?with_xmms:BuildRequires:     rpmbuild(macros) >= 1.125}
29 %{?with_xmms:BuildRequires:     xmms-devel >= 0.9.5.1}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
34
35 %description -l pl.UTF-8
36 FLAC jest bezstratnym kodekiem audio z otwartymi źródłami, rozwijanym
37 przez Josha Coalsona.
38
39 %package devel
40 Summary:        FLAC - development files
41 Summary(pl.UTF-8):      FLAC - pliki nagłówkowe
42 License:        BSD
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       libogg-devel >= 2:1.0
46 # for -c++ only
47 #Requires:      libstdc++-devel
48
49 %description devel
50 The package contains the development header files for FLAC libraries.
51
52 %description devel -l pl.UTF-8
53 Ten pakiet zawiera pliki nagłówkowe bibliotek FLAC.
54
55 %package static
56 Summary:        FLAC - static libraries
57 Summary(pl.UTF-8):      FLAC - biblioteki statyczne
58 License:        BSD
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 The package contains FLAC static libraries.
64
65 %description static -l pl.UTF-8
66 Ten pakiet zawiera biblioteki statyczne FLAC.
67
68 %package c++
69 Summary:        FLAC++ - C++ API for FLAC codec
70 Summary(pl.UTF-8):      FLAC++ - API C++ do kodeka FLAC
71 Group:          Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description c++
75 FLAC++ - C++ API for FLAC codec.
76
77 %description c++ -l pl.UTF-8
78 FLAC++ - API C++ do kodeka FLAC.
79
80 %package c++-devel
81 Summary:        Header files for FLAC++ library
82 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FLAC++
83 Group:          Development/Libraries
84 Requires:       %{name}-c++ = %{version}-%{release}
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description c++-devel
88 Header files for FLAC++ library.
89
90 %description c++-devel -l pl.UTF-8
91 Pliki nagłówkowe biblioteki FLAC++.
92
93 %package c++-static
94 Summary:        Static FLAC++ library
95 Summary(pl.UTF-8):      Statyczna biblioteka FLAC++
96 Group:          Development/Libraries
97 Requires:       %{name}-c++-devel = %{version}-%{release}
98
99 %description c++-static
100 Static FLAC++ library.
101
102 %description c++-static -l pl.UTF-8
103 Statyczna biblioteka FLAC++.
104
105 %package -n xmms-input-flac
106 Summary:        Free Lossless Audio Codec - XMMS plugin
107 Summary(pl.UTF-8):      Wtyczka FLAC dla XMMS
108 License:        GPL v2+
109 Group:          Libraries
110 Requires:       %{name} = %{version}-%{release}
111 Requires:       xmms
112
113 %description -n xmms-input-flac
114 FLAC input plugin for XMMS.
115
116 %description -n xmms-input-flac -l pl.UTF-8
117 Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
118
119 %prep
120 %setup -q
121 %{!?with_xmms:%patch0 -p1}
122 %patch1 -p1
123 %patch2 -p1
124 %patch3 -p1
125 %patch4 -p1
126
127 %{__rm} m4/ogg.m4
128
129 %build
130 %{__libtoolize}
131 %{__aclocal} -I m4
132 %{__autoconf}
133 %{__autoheader}
134 %{__automake}
135 %configure \
136         %{!?with_static_libs:--disable-static}
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 # no makefiles in doc dirs
147 rm -f doc/html/{Makefile*,images/Makefile*,images/hw/Makefile*,ru/Makefile*}
148 rm -f $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.la
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %post   c++ -p /sbin/ldconfig
157 %postun c++ -p /sbin/ldconfig
158
159 %files
160 %defattr(644,root,root,755)
161 %doc AUTHORS COPYING.Xiph README doc/html/{*.html,images}
162 %lang(ru) %doc doc/html/ru
163 %attr(755,root,root) %{_bindir}/flac
164 %attr(755,root,root) %{_bindir}/metaflac
165 %attr(755,root,root) %{_libdir}/libFLAC.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libFLAC.so.8
167 %{_mandir}/man1/flac.1*
168 %{_mandir}/man1/metaflac.1*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libFLAC.so
173 %{_libdir}/libFLAC.la
174 %{_includedir}/FLAC
175 %{_pkgconfigdir}/flac.pc
176 %{_aclocaldir}/libFLAC.m4
177
178 %if %{with static_libs}
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/libFLAC.a
182 %endif
183
184 %files c++
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/libFLAC++.so.*.*.*
187 %attr(755,root,root) %ghost %{_libdir}/libFLAC++.so.6
188
189 %files c++-devel
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/libFLAC++.so
192 %{_libdir}/libFLAC++.la
193 %{_includedir}/FLAC++
194 %{_pkgconfigdir}/flac++.pc
195 %{_aclocaldir}/libFLAC++.m4
196
197 %if %{with static_libs}
198 %files c++-static
199 %defattr(644,root,root,755)
200 %{_libdir}/libFLAC++.a
201 %endif
202
203 %if %{with xmms}
204 %files -n xmms-input-flac
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{xmms_input_plugindir}/libxmms-flac.so
207 %endif
This page took 0.07974 seconds and 4 git commands to generate.