]> git.pld-linux.org Git - packages/flac.git/blob - flac.spec
- release 4
[packages/flac.git] / flac.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  xmms            # don't build XMMS plugin
5 #
6 Summary:        Free Lossless Audio Codec
7 Summary(pl.UTF-8):      Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
8 Name:           flac
9 Version:        1.2.1
10 Release:        4
11 License:        BSD (libFLAC/libFLAC++), GPL (programs and plugins)
12 Group:          Libraries
13 Source0:        http://dl.sourceforge.net/flac/%{name}-%{version}.tar.gz
14 # Source0-md5:  153c8b15a54da428d1f0fadc756c22c7
15 Patch0:         %{name}-without_xmms.patch
16 Patch1:         %{name}-lt.patch
17 Patch2:         %{name}-gcc44.patch
18 URL:            http://flac.sourceforge.net/
19 BuildRequires:  autoconf
20 BuildRequires:  automake >= 1:1.7
21 # for AM_ICONV
22 BuildRequires:  gettext-devel
23 BuildRequires:  libogg-devel >= 2:1.0
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool >= 2:1.4d-3
26 %{?with_xmms:BuildRequires:     rpmbuild(macros) >= 1.125}
27 %{?with_xmms:BuildRequires:     xmms-devel >= 0.9.5.1}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
32
33 %description -l pl.UTF-8
34 FLAC jest bezstratnym kodekiem audio z otwartymi źródłami, rozwijanym
35 przez Josha Coalsona.
36
37 %package devel
38 Summary:        FLAC - development files
39 Summary(pl.UTF-8):      FLAC - pliki nagłówkowe
40 License:        BSD
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       libogg-devel >= 2:1.0
44 # for -c++ only
45 #Requires:      libstdc++-devel
46
47 %description devel
48 The package contains the development header files for FLAC libraries.
49
50 %description devel -l pl.UTF-8
51 Ten pakiet zawiera pliki nagłówkowe bibliotek FLAC.
52
53 %package static
54 Summary:        FLAC - static libraries
55 Summary(pl.UTF-8):      FLAC - biblioteki statyczne
56 License:        BSD
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 The package contains FLAC static libraries.
62
63 %description static -l pl.UTF-8
64 Ten pakiet zawiera biblioteki statyczne FLAC.
65
66 %package c++
67 Summary:        FLAC++ - C++ API for FLAC codec
68 Summary(pl.UTF-8):      FLAC++ - API C++ do kodeka FLAC
69 Group:          Libraries
70 Requires:       %{name} = %{version}-%{release}
71
72 %description c++
73 FLAC++ - C++ API for FLAC codec.
74
75 %description c++ -l pl.UTF-8
76 FLAC++ - API C++ do kodeka FLAC.
77
78 %package c++-devel
79 Summary:        Header files for FLAC++ library
80 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FLAC++
81 Group:          Development/Libraries
82 Requires:       %{name}-c++ = %{version}-%{release}
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description c++-devel
86 Header files for FLAC++ library.
87
88 %description c++-devel -l pl.UTF-8
89 Pliki nagłówkowe biblioteki FLAC++.
90
91 %package c++-static
92 Summary:        Static FLAC++ library
93 Summary(pl.UTF-8):      Statyczna biblioteka FLAC++
94 Group:          Development/Libraries
95 Requires:       %{name}-c++-devel = %{version}-%{release}
96
97 %description c++-static
98 Static FLAC++ library.
99
100 %description c++-static -l pl.UTF-8
101 Statyczna biblioteka FLAC++.
102
103 %package -n xmms-input-flac
104 Summary:        Free Lossless Audio Codec - XMMS plugin
105 Summary(pl.UTF-8):      Wtyczka FLAC dla XMMS
106 License:        GPL v2+
107 Group:          Libraries
108 Requires:       %{name} = %{version}-%{release}
109 Requires:       xmms
110
111 %description -n xmms-input-flac
112 FLAC input plugin for XMMS.
113
114 %description -n xmms-input-flac -l pl.UTF-8
115 Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
116
117 %prep
118 %setup -q
119 %{!?with_xmms:%patch0 -p1}
120 %patch1 -p1
121 %patch2 -p1
122
123 %build
124 %{__libtoolize}
125 %{__aclocal} -I m4
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 %configure \
130         %{!?with_static_libs:--disable-static}
131
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 # no makefiles in doc dirs
141 rm -f doc/html/{Makefile*,images/Makefile*,images/hw/Makefile*,ru/Makefile*}
142 rm -f $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.la
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %post   c++ -p /sbin/ldconfig
151 %postun c++ -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc AUTHORS COPYING.Xiph README doc/html/{*.html,images}
156 %lang(ru) %doc doc/html/ru
157 %attr(755,root,root) %{_bindir}/flac
158 %attr(755,root,root) %{_bindir}/metaflac
159 %attr(755,root,root) %{_libdir}/libFLAC.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libFLAC.so.8
161 %{_mandir}/man1/flac.1*
162 %{_mandir}/man1/metaflac.1*
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libFLAC.so
167 %{_libdir}/libFLAC.la
168 %{_includedir}/FLAC
169 %{_pkgconfigdir}/flac.pc
170 %{_aclocaldir}/libFLAC.m4
171
172 %if %{with static_libs}
173 %files static
174 %defattr(644,root,root,755)
175 %{_libdir}/libFLAC.a
176 %endif
177
178 %files c++
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/libFLAC++.so.*.*.*
181 %attr(755,root,root) %ghost %{_libdir}/libFLAC++.so.6
182
183 %files c++-devel
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_libdir}/libFLAC++.so
186 %{_libdir}/libFLAC++.la
187 %{_includedir}/FLAC++
188 %{_pkgconfigdir}/flac++.pc
189 %{_aclocaldir}/libFLAC++.m4
190
191 %if %{with static_libs}
192 %files c++-static
193 %defattr(644,root,root,755)
194 %{_libdir}/libFLAC++.a
195 %endif
196
197 %if %{with xmms}
198 %files -n xmms-input-flac
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{xmms_input_plugindir}/libxmms-flac.so
201 %endif
This page took 0.091668 seconds and 4 git commands to generate.