]> git.pld-linux.org Git - packages/flac.git/blob - flac.spec
- converted to UTF-8
[packages/flac.git] / flac.spec
1 # TODO: separate c++
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # don't build static library
5 %bcond_without  xmms            # don't build XMMS plugin
6 #
7 Summary:        Free Lossless Audio Codec
8 Summary(pl.UTF-8):   Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
9 Name:           flac
10 Version:        1.1.3
11 Release:        1
12 License:        BSD (libFLAC/libFLAC++), GPL (programs and plugins)
13 Group:          Libraries
14 Source0:        http://dl.sourceforge.net/flac/%{name}-%{version}.tar.gz
15 # Source0-md5:  b084603948b60ee338e0c29978cc580c
16 Patch0:         %{name}-link.patch
17 Patch1:         %{name}-without_xmms.patch
18 URL:            http://flac.sourceforge.net/
19 BuildRequires:  autoconf
20 BuildRequires:  automake >= 1:1.7
21 # for AM_ICONV
22 BuildRequires:  gettext-devel
23 BuildRequires:  libogg-devel >= 2:1.0
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool >= 2:1.4d-3
26 %{?with_xmms:BuildRequires:     rpmbuild(macros) >= 1.125}
27 %{?with_xmms:BuildRequires:     xmms-devel >= 0.9.5.1}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
32
33 %description -l pl.UTF-8
34 FLAC jest bezstratnym kodekiem audio z otwartymi źródłami, rozwijanym
35 przez Josha Coalsona.
36
37 %package devel
38 Summary:        FLAC - development files
39 Summary(pl.UTF-8):   FLAC - pliki nagłówkowe
40 License:        BSD
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       libogg-devel >= 2:1.0
44 # for -c++ only
45 #Requires:      libstdc++-devel
46
47 %description devel
48 The package contains the development header files for FLAC libraries.
49
50 %description devel -l pl.UTF-8
51 Ten pakiet zawiera pliki nagłówkowe bibliotek FLAC.
52
53 %package static
54 Summary:        FLAC - static libraries
55 Summary(pl.UTF-8):   FLAC - biblioteki statyczne
56 License:        BSD
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 The package contains FLAC static libraries.
62
63 %description static -l pl.UTF-8
64 Ten pakiet zawiera biblioteki statyczne FLAC.
65
66 %package -n xmms-input-flac
67 Summary:        Free Lossless Audio Codec - XMMS plugin
68 Summary(pl.UTF-8):   Wtyczka FLAC dla XMMS
69 License:        GPL v2+
70 Group:          Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       xmms
73
74 %description -n xmms-input-flac
75 FLAC input plugin for XMMS.
76
77 %description -n xmms-input-flac -l pl.UTF-8
78 Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %{!?with_xmms:%patch1 -p1}
84
85 %build
86 %{__libtoolize}
87 %{__aclocal}
88 %{__autoconf}
89 %{__autoheader}
90 %{__automake}
91 %configure \
92         %{!?with_static_libs:--disable-static}
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 # no makefiles in doc dirs
103 rm -f doc/html/{Makefile*,images/Makefile*,ru/Makefile*}
104 rm -f $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.la
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS COPYING.Xiph README doc/html/{*.html,images}
115 %lang(ru) %doc doc/html/ru
116 %attr(755,root,root) %{_bindir}/flac
117 %attr(755,root,root) %{_bindir}/metaflac
118 %attr(755,root,root) %{_libdir}/libFLAC.so.*.*.*
119 %attr(755,root,root) %{_libdir}/libFLAC++.so.*.*.*
120 %{_mandir}/man1/flac.1*
121 %{_mandir}/man1/metaflac.1*
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libFLAC.so
126 %attr(755,root,root) %{_libdir}/libFLAC++.so
127 %{_libdir}/libFLAC.la
128 %{_libdir}/libFLAC++.la
129 %{_includedir}/FLAC
130 %{_includedir}/FLAC++
131 %{_aclocaldir}/libFLAC.m4
132 %{_aclocaldir}/libFLAC++.m4
133
134 %if %{with static_libs}
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/libFLAC.a
138 %{_libdir}/libFLAC++.a
139 %endif
140
141 %if %{with xmms}
142 %files -n xmms-input-flac
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{xmms_input_plugindir}/libxmms-flac.so
145 %endif
This page took 0.070949 seconds and 4 git commands to generate.