]> git.pld-linux.org Git - packages/flac.git/blob - flac.spec
fixes from chromium (rather minor one in md5.c)
[packages/flac.git] / flac.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  xmms            # don't build XMMS plugin
5
6 Summary:        Free Lossless Audio Codec
7 Summary(pl.UTF-8):      Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
8 Name:           flac
9 Version:        1.2.1
10 Release:        7
11 License:        BSD (libFLAC/libFLAC++), GPL (programs and plugins)
12 Group:          Libraries
13 Source0:        http://dl.sourceforge.net/flac/%{name}-%{version}.tar.gz
14 # Source0-md5:  153c8b15a54da428d1f0fadc756c22c7
15 Patch0:         %{name}-without_xmms.patch
16 Patch1:         %{name}-lt.patch
17 Patch2:         %{name}-gcc44.patch
18 Patch3:         crbug-111390.patch
19 URL:            http://flac.sourceforge.net/
20 BuildRequires:  autoconf
21 BuildRequires:  automake >= 1:1.7
22 # for AM_ICONV
23 BuildRequires:  gettext-devel
24 BuildRequires:  libogg-devel >= 2:1.0
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool >= 2:1.4d-3
27 %{?with_xmms:BuildRequires:     rpmbuild(macros) >= 1.125}
28 %{?with_xmms:BuildRequires:     xmms-devel >= 0.9.5.1}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
33
34 %description -l pl.UTF-8
35 FLAC jest bezstratnym kodekiem audio z otwartymi źródłami, rozwijanym
36 przez Josha Coalsona.
37
38 %package devel
39 Summary:        FLAC - development files
40 Summary(pl.UTF-8):      FLAC - pliki nagłówkowe
41 License:        BSD
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       libogg-devel >= 2:1.0
45 # for -c++ only
46 #Requires:      libstdc++-devel
47
48 %description devel
49 The package contains the development header files for FLAC libraries.
50
51 %description devel -l pl.UTF-8
52 Ten pakiet zawiera pliki nagłówkowe bibliotek FLAC.
53
54 %package static
55 Summary:        FLAC - static libraries
56 Summary(pl.UTF-8):      FLAC - biblioteki statyczne
57 License:        BSD
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 The package contains FLAC static libraries.
63
64 %description static -l pl.UTF-8
65 Ten pakiet zawiera biblioteki statyczne FLAC.
66
67 %package c++
68 Summary:        FLAC++ - C++ API for FLAC codec
69 Summary(pl.UTF-8):      FLAC++ - API C++ do kodeka FLAC
70 Group:          Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description c++
74 FLAC++ - C++ API for FLAC codec.
75
76 %description c++ -l pl.UTF-8
77 FLAC++ - API C++ do kodeka FLAC.
78
79 %package c++-devel
80 Summary:        Header files for FLAC++ library
81 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FLAC++
82 Group:          Development/Libraries
83 Requires:       %{name}-c++ = %{version}-%{release}
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description c++-devel
87 Header files for FLAC++ library.
88
89 %description c++-devel -l pl.UTF-8
90 Pliki nagłówkowe biblioteki FLAC++.
91
92 %package c++-static
93 Summary:        Static FLAC++ library
94 Summary(pl.UTF-8):      Statyczna biblioteka FLAC++
95 Group:          Development/Libraries
96 Requires:       %{name}-c++-devel = %{version}-%{release}
97
98 %description c++-static
99 Static FLAC++ library.
100
101 %description c++-static -l pl.UTF-8
102 Statyczna biblioteka FLAC++.
103
104 %package -n xmms-input-flac
105 Summary:        Free Lossless Audio Codec - XMMS plugin
106 Summary(pl.UTF-8):      Wtyczka FLAC dla XMMS
107 License:        GPL v2+
108 Group:          Libraries
109 Requires:       %{name} = %{version}-%{release}
110 Requires:       xmms
111
112 %description -n xmms-input-flac
113 FLAC input plugin for XMMS.
114
115 %description -n xmms-input-flac -l pl.UTF-8
116 Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
117
118 %prep
119 %setup -q
120 %{!?with_xmms:%patch0 -p1}
121 %patch1 -p1
122 %patch2 -p1
123 %patch3 -p1
124
125 %{__rm} m4/ogg.m4
126
127 %build
128 %{__libtoolize}
129 %{__aclocal} -I m4
130 %{__autoconf}
131 %{__autoheader}
132 %{__automake}
133 %configure \
134         %{!?with_static_libs:--disable-static}
135
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 # no makefiles in doc dirs
145 rm -f doc/html/{Makefile*,images/Makefile*,images/hw/Makefile*,ru/Makefile*}
146 rm -f $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.la
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %post   c++ -p /sbin/ldconfig
155 %postun c++ -p /sbin/ldconfig
156
157 %files
158 %defattr(644,root,root,755)
159 %doc AUTHORS COPYING.Xiph README doc/html/{*.html,images}
160 %lang(ru) %doc doc/html/ru
161 %attr(755,root,root) %{_bindir}/flac
162 %attr(755,root,root) %{_bindir}/metaflac
163 %attr(755,root,root) %{_libdir}/libFLAC.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libFLAC.so.8
165 %{_mandir}/man1/flac.1*
166 %{_mandir}/man1/metaflac.1*
167
168 %files devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libFLAC.so
171 %{_libdir}/libFLAC.la
172 %{_includedir}/FLAC
173 %{_pkgconfigdir}/flac.pc
174 %{_aclocaldir}/libFLAC.m4
175
176 %if %{with static_libs}
177 %files static
178 %defattr(644,root,root,755)
179 %{_libdir}/libFLAC.a
180 %endif
181
182 %files c++
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libFLAC++.so.*.*.*
185 %attr(755,root,root) %ghost %{_libdir}/libFLAC++.so.6
186
187 %files c++-devel
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/libFLAC++.so
190 %{_libdir}/libFLAC++.la
191 %{_includedir}/FLAC++
192 %{_pkgconfigdir}/flac++.pc
193 %{_aclocaldir}/libFLAC++.m4
194
195 %if %{with static_libs}
196 %files c++-static
197 %defattr(644,root,root,755)
198 %{_libdir}/libFLAC++.a
199 %endif
200
201 %if %{with xmms}
202 %files -n xmms-input-flac
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{xmms_input_plugindir}/libxmms-flac.so
205 %endif
This page took 0.053282 seconds and 4 git commands to generate.