]> git.pld-linux.org Git - packages/flac.git/blob - flac.spec
- patch for xmms
[packages/flac.git] / flac.spec
1 # maybe TODO: split (c++, ogg?)
2 #
3 # Conditional build:
4 %bcond_without  xmms    # don't build XMMS plugin
5 #
6 Summary:        Free Lossless Audio Codec
7 Summary(pl):    Free Lossless Audio Codec - Wolnodostêpny bezstratny kodek audio
8 Name:           flac
9 Version:        1.1.2
10 Release:        3
11 License:        GPL/LGPL
12 Group:          Libraries
13 Source0:        http://dl.sourceforge.net/flac/%{name}-%{version}.tar.gz
14 # Source0-md5:  2bfc127cdda02834d0491ab531a20960
15 Patch0:         %{name}-without_xmms.patch
16 Patch1:         %{name}-read_only_relocs.patch
17 Patch2:         %{name}-plugin_xmms.patch
18 URL:            http://flac.sourceforge.net/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  gettext-devel
22 BuildRequires:  libogg-devel >= 2:1.0
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtool >= 2:1.4d-3
25 %{?with_xmms:BuildRequires:     rpmbuild(macros) >= 1.125}
26 %{?with_xmms:BuildRequires:     xmms-devel >= 0.9.5.1}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
31
32 %description -l pl
33 FLAC jest bezstratnym kodekiem audio z otwartymi ¼ród³ami, rozwijanym
34 przez Josha Coalsona.
35
36 %package devel
37 Summary:        FLAC - development files
38 Summary(pl):    FLAC - pliki nag³ówkowe
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 The package contains the development header files for FLAC libraries.
44
45 %description devel -l pl
46 Ten pakiet zawiera pliki nag³ówkowe bibliotek FLAC.
47
48 %package static
49 Summary:        FLAC - static libraries
50 Summary(pl):    FLAC - biblioteki statyczne
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 The package contains FLAC static libraries.
56
57 %description static -l pl
58 Ten pakiet zawiera biblioteki statyczne FLAC.
59
60 %package -n xmms-input-flac
61 Summary:        Free Lossless Audio Codec - XMMS plugin
62 Summary(pl):    Wtyczka FLAC dla XMMS
63 License:        GPL/LGPL
64 Group:          Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       xmms
67
68 %description -n xmms-input-flac
69 FLAC input plugin for XMMS.
70
71 %description -n xmms-input-flac -l pl
72 Wtyczka dla XMMS umo¿liwiaj±ca odtwarzanie plików w formacie FLAC.
73
74 %prep
75 %setup -q
76 %{!?with_xmms:%patch0 -p1}
77 %patch1 -p1
78 %patch2 -p1
79 %build
80 %{__libtoolize}
81 %{__aclocal}
82 %{__autoconf}
83 %{__automake}
84 %configure
85
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 # no makefiles in doc dirs
95 rm -f doc/html/{Makefile*,images/Makefile*,ru/Makefile*}
96 rm -f $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.la
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc AUTHORS README doc/html/{*.html,images}
107 %lang(ru) %doc doc/html/ru
108 %attr(755,root,root) %{_bindir}/*
109 %attr(755,root,root) %{_libdir}/lib*.so.*.*
110 %{_mandir}/man1/*
111
112 %files devel
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_libdir}/lib*.so
115 %{_libdir}/lib*.la
116 %{_includedir}/*
117 %{_aclocaldir}/*
118
119 %files static
120 %defattr(644,root,root,755)
121 %{_libdir}/lib*.a
122
123 %if %{with xmms}
124 %files -n xmms-input-flac
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{xmms_input_plugindir}/*.so
127 %endif
This page took 0.042927 seconds and 4 git commands to generate.