]> git.pld-linux.org Git - packages/flac.git/blob - flac.spec
dfb6eefadb5d3219080cab7e325a24e15a7fb1a1
[packages/flac.git] / flac.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  xmms            # don't build XMMS plugin
5
6 Summary:        Free Lossless Audio Codec
7 Summary(pl.UTF-8):      Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
8 Name:           flac
9 Version:        1.3.1
10 Release:        1
11 License:        BSD (libFLAC/libFLAC++), GPL v2+ (programs and plugins)
12 Group:          Libraries
13 Source0:        http://downloads.xiph.org/releases/flac/%{name}-%{version}.tar.xz
14 # Source0-md5:  b9922c9a0378c88d3e901b234f852698
15 URL:            http://xiph.org/flac/
16 BuildRequires:  autoconf >= 2.60
17 BuildRequires:  automake >= 1:1.11
18 # for AM_ICONV
19 BuildRequires:  gettext-devel
20 BuildRequires:  libogg-devel >= 2:1.0
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:2
23 %{?with_xmms:BuildRequires:     rpmbuild(macros) >= 1.125}
24 BuildRequires:  tar >= 1:1.22
25 %{?with_xmms:BuildRequires:     xmms-devel >= 0.9.5.1}
26 BuildRequires:  xz
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
31
32 %description -l pl.UTF-8
33 FLAC jest bezstratnym kodekiem audio z otwartymi źródłami, rozwijanym
34 przez Josha Coalsona.
35
36 %package devel
37 Summary:        FLAC - development files
38 Summary(pl.UTF-8):      FLAC - pliki nagłówkowe
39 License:        BSD
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       libogg-devel >= 2:1.0
43 # for -c++ only
44 #Requires:      libstdc++-devel
45
46 %description devel
47 The package contains the development header files for FLAC libraries.
48
49 %description devel -l pl.UTF-8
50 Ten pakiet zawiera pliki nagłówkowe bibliotek FLAC.
51
52 %package static
53 Summary:        FLAC - static libraries
54 Summary(pl.UTF-8):      FLAC - biblioteki statyczne
55 License:        BSD
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 The package contains FLAC static libraries.
61
62 %description static -l pl.UTF-8
63 Ten pakiet zawiera biblioteki statyczne FLAC.
64
65 %package c++
66 Summary:        FLAC++ - C++ API for FLAC codec
67 Summary(pl.UTF-8):      FLAC++ - API C++ do kodeka FLAC
68 Group:          Libraries
69 Requires:       %{name} = %{version}-%{release}
70
71 %description c++
72 FLAC++ - C++ API for FLAC codec.
73
74 %description c++ -l pl.UTF-8
75 FLAC++ - API C++ do kodeka FLAC.
76
77 %package c++-devel
78 Summary:        Header files for FLAC++ library
79 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FLAC++
80 Group:          Development/Libraries
81 Requires:       %{name}-c++ = %{version}-%{release}
82 Requires:       %{name}-devel = %{version}-%{release}
83
84 %description c++-devel
85 Header files for FLAC++ library.
86
87 %description c++-devel -l pl.UTF-8
88 Pliki nagłówkowe biblioteki FLAC++.
89
90 %package c++-static
91 Summary:        Static FLAC++ library
92 Summary(pl.UTF-8):      Statyczna biblioteka FLAC++
93 Group:          Development/Libraries
94 Requires:       %{name}-c++-devel = %{version}-%{release}
95
96 %description c++-static
97 Static FLAC++ library.
98
99 %description c++-static -l pl.UTF-8
100 Statyczna biblioteka FLAC++.
101
102 %package -n xmms-input-flac
103 Summary:        Free Lossless Audio Codec - XMMS plugin
104 Summary(pl.UTF-8):      Wtyczka FLAC dla XMMS
105 License:        GPL v2+
106 Group:          Libraries
107 Requires:       %{name} = %{version}-%{release}
108 Requires:       xmms >= 0.9.5.1
109
110 %description -n xmms-input-flac
111 FLAC input plugin for XMMS.
112
113 %description -n xmms-input-flac -l pl.UTF-8
114 Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
115
116 %prep
117 %setup -q
118
119 %{__rm} m4/ogg.m4
120
121 %build
122 %{__libtoolize}
123 %{__aclocal} -I m4
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure \
128         --disable-silent-rules \
129         %{?with_static_libs:--enable-static} \
130         %{!?with_xmms:--disable-xmms-plugin}
131
132 %{__make}
133
134 rm -rf doc-html
135 cp -a doc/html doc-html
136 # no makefiles in doc dirs
137 find doc-html -name 'Makefile*' | xargs %{__rm}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
145
146 %{__rm} $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.la
147 %if %{with static_libs}
148 %{__rm} $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.a
149 %endif
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post   -p /sbin/ldconfig
155 %postun -p /sbin/ldconfig
156
157 %post   c++ -p /sbin/ldconfig
158 %postun c++ -p /sbin/ldconfig
159
160 %files
161 %defattr(644,root,root,755)
162 %doc AUTHORS COPYING.Xiph README
163 %attr(755,root,root) %{_bindir}/flac
164 %attr(755,root,root) %{_bindir}/metaflac
165 %attr(755,root,root) %{_libdir}/libFLAC.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libFLAC.so.8
167 %{_mandir}/man1/flac.1*
168 %{_mandir}/man1/metaflac.1*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %doc doc-html/{*.html,images}
173 %attr(755,root,root) %{_libdir}/libFLAC.so
174 %{_libdir}/libFLAC.la
175 %{_includedir}/FLAC
176 %{_pkgconfigdir}/flac.pc
177 %{_aclocaldir}/libFLAC.m4
178
179 %if %{with static_libs}
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/libFLAC.a
183 %endif
184
185 %files c++
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/libFLAC++.so.*.*.*
188 %attr(755,root,root) %ghost %{_libdir}/libFLAC++.so.6
189
190 %files c++-devel
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_libdir}/libFLAC++.so
193 %{_libdir}/libFLAC++.la
194 %{_includedir}/FLAC++
195 %{_pkgconfigdir}/flac++.pc
196 %{_aclocaldir}/libFLAC++.m4
197
198 %if %{with static_libs}
199 %files c++-static
200 %defattr(644,root,root,755)
201 %{_libdir}/libFLAC++.a
202 %endif
203
204 %if %{with xmms}
205 %files -n xmms-input-flac
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{xmms_input_plugindir}/libxmms-flac.so
208 %endif
This page took 0.042396 seconds and 2 git commands to generate.