]> git.pld-linux.org Git - packages/flac.git/blob - flac.spec
a9f9ac66bbadf21cdc8cfe1e64e9668611afb7d5
[packages/flac.git] / flac.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  xmms            # don't build XMMS plugin
5
6 Summary:        Free Lossless Audio Codec
7 Summary(pl.UTF-8):      Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
8 Name:           flac
9 Version:        1.3.1
10 Release:        3
11 License:        BSD (libFLAC/libFLAC++), GPL v2+ (programs and plugins)
12 Group:          Libraries
13 Source0:        http://downloads.xiph.org/releases/flac/%{name}-%{version}.tar.xz
14 # Source0-md5:  b9922c9a0378c88d3e901b234f852698
15 Patch0:         %{name}-opt.patch
16 URL:            http://xiph.org/flac/
17 BuildRequires:  autoconf >= 2.60
18 BuildRequires:  automake >= 1:1.11
19 # for AM_ICONV
20 BuildRequires:  gettext-devel
21 BuildRequires:  libogg-devel >= 2:1.0
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool >= 2:2
24 %{?with_xmms:BuildRequires:     rpmbuild(macros) >= 1.125}
25 BuildRequires:  tar >= 1:1.22
26 %{?with_xmms:BuildRequires:     xmms-devel >= 0.9.5.1}
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
32
33 %description -l pl.UTF-8
34 FLAC jest bezstratnym kodekiem audio z otwartymi źródłami, rozwijanym
35 przez Josha Coalsona.
36
37 %package devel
38 Summary:        FLAC - development files
39 Summary(pl.UTF-8):      FLAC - pliki nagłówkowe
40 License:        BSD
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       libogg-devel >= 2:1.0
44
45 %description devel
46 The package contains the development header files for FLAC libraries.
47
48 %description devel -l pl.UTF-8
49 Ten pakiet zawiera pliki nagłówkowe bibliotek FLAC.
50
51 %package static
52 Summary:        FLAC - static libraries
53 Summary(pl.UTF-8):      FLAC - biblioteki statyczne
54 License:        BSD
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 The package contains FLAC static libraries.
60
61 %description static -l pl.UTF-8
62 Ten pakiet zawiera biblioteki statyczne FLAC.
63
64 %package c++
65 Summary:        FLAC++ - C++ API for FLAC codec
66 Summary(pl.UTF-8):      FLAC++ - API C++ do kodeka FLAC
67 Group:          Libraries
68 Requires:       %{name} = %{version}-%{release}
69
70 %description c++
71 FLAC++ - C++ API for FLAC codec.
72
73 %description c++ -l pl.UTF-8
74 FLAC++ - API C++ do kodeka FLAC.
75
76 %package c++-devel
77 Summary:        Header files for FLAC++ library
78 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FLAC++
79 Group:          Development/Libraries
80 Requires:       %{name}-c++ = %{version}-%{release}
81 Requires:       %{name}-devel = %{version}-%{release}
82 Requires:       libstdc++-devel
83
84 %description c++-devel
85 Header files for FLAC++ library.
86
87 %description c++-devel -l pl.UTF-8
88 Pliki nagłówkowe biblioteki FLAC++.
89
90 %package c++-static
91 Summary:        Static FLAC++ library
92 Summary(pl.UTF-8):      Statyczna biblioteka FLAC++
93 Group:          Development/Libraries
94 Requires:       %{name}-c++-devel = %{version}-%{release}
95
96 %description c++-static
97 Static FLAC++ library.
98
99 %description c++-static -l pl.UTF-8
100 Statyczna biblioteka FLAC++.
101
102 %package -n xmms-input-flac
103 Summary:        Free Lossless Audio Codec - XMMS plugin
104 Summary(pl.UTF-8):      Wtyczka FLAC dla XMMS
105 License:        GPL v2+
106 Group:          Libraries
107 Requires:       %{name} = %{version}-%{release}
108 Requires:       xmms >= 0.9.5.1
109
110 %description -n xmms-input-flac
111 FLAC input plugin for XMMS.
112
113 %description -n xmms-input-flac -l pl.UTF-8
114 Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
115
116 %prep
117 %setup -q
118 %patch0 -p1
119
120 %{__rm} m4/ogg.m4
121
122 %build
123 %{__libtoolize}
124 %{__aclocal} -I m4
125 %{__autoconf}
126 %{__autoheader}
127 %{__automake}
128 %configure \
129         --disable-silent-rules \
130         %{?with_static_libs:--enable-static} \
131         %{!?with_xmms:--disable-xmms-plugin}
132
133 %{__make}
134
135 rm -rf doc-html
136 cp -a doc/html doc-html
137 # no makefiles in doc dirs
138 find doc-html -name 'Makefile*' | xargs %{__rm}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
146
147 %{__rm} $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.la
148 %if %{with static_libs}
149 %{__rm} $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.a
150 %endif
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post   -p /sbin/ldconfig
156 %postun -p /sbin/ldconfig
157
158 %post   c++ -p /sbin/ldconfig
159 %postun c++ -p /sbin/ldconfig
160
161 %files
162 %defattr(644,root,root,755)
163 %doc AUTHORS COPYING.Xiph README
164 %attr(755,root,root) %{_bindir}/flac
165 %attr(755,root,root) %{_bindir}/metaflac
166 %attr(755,root,root) %{_libdir}/libFLAC.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libFLAC.so.8
168 %{_mandir}/man1/flac.1*
169 %{_mandir}/man1/metaflac.1*
170
171 %files devel
172 %defattr(644,root,root,755)
173 %doc doc-html/{*.html,images}
174 %attr(755,root,root) %{_libdir}/libFLAC.so
175 %{_libdir}/libFLAC.la
176 %{_includedir}/FLAC
177 %{_pkgconfigdir}/flac.pc
178 %{_aclocaldir}/libFLAC.m4
179
180 %if %{with static_libs}
181 %files static
182 %defattr(644,root,root,755)
183 %{_libdir}/libFLAC.a
184 %endif
185
186 %files c++
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/libFLAC++.so.*.*.*
189 %attr(755,root,root) %ghost %{_libdir}/libFLAC++.so.6
190
191 %files c++-devel
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/libFLAC++.so
194 %{_libdir}/libFLAC++.la
195 %{_includedir}/FLAC++
196 %{_pkgconfigdir}/flac++.pc
197 %{_aclocaldir}/libFLAC++.m4
198
199 %if %{with static_libs}
200 %files c++-static
201 %defattr(644,root,root,755)
202 %{_libdir}/libFLAC++.a
203 %endif
204
205 %if %{with xmms}
206 %files -n xmms-input-flac
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{xmms_input_plugindir}/libxmms-flac.so
209 %endif
This page took 0.039327 seconds and 2 git commands to generate.