]> git.pld-linux.org Git - packages/flac.git/blob - flac.spec
4b66a87004fb2f3cbdd8353a4d64508bd90f8e3e
[packages/flac.git] / flac.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  xmms            # don't build XMMS plugin
5 #
6 Summary:        Free Lossless Audio Codec
7 Summary(pl.UTF-8):      Free Lossless Audio Codec - Wolnodostępny bezstratny kodek audio
8 Name:           flac
9 Version:        1.2.1
10 Release:        1
11 License:        BSD (libFLAC/libFLAC++), GPL (programs and plugins)
12 Group:          Libraries
13 Source0:        http://dl.sourceforge.net/flac/%{name}-%{version}.tar.gz
14 # Source0-md5:  153c8b15a54da428d1f0fadc756c22c7
15 Patch0:         %{name}-without_xmms.patch
16 URL:            http://flac.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  automake >= 1:1.7
19 # for AM_ICONV
20 BuildRequires:  gettext-devel
21 BuildRequires:  libogg-devel >= 2:1.0
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool >= 2:1.4d-3
24 %{?with_xmms:BuildRequires:     rpmbuild(macros) >= 1.125}
25 %{?with_xmms:BuildRequires:     xmms-devel >= 0.9.5.1}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 FLAC is an Open Source lossless audio codec developed by Josh Coalson.
30
31 %description -l pl.UTF-8
32 FLAC jest bezstratnym kodekiem audio z otwartymi źródłami, rozwijanym
33 przez Josha Coalsona.
34
35 %package devel
36 Summary:        FLAC - development files
37 Summary(pl.UTF-8):      FLAC - pliki nagłówkowe
38 License:        BSD
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       libogg-devel >= 2:1.0
42 # for -c++ only
43 #Requires:      libstdc++-devel
44
45 %description devel
46 The package contains the development header files for FLAC libraries.
47
48 %description devel -l pl.UTF-8
49 Ten pakiet zawiera pliki nagłówkowe bibliotek FLAC.
50
51 %package static
52 Summary:        FLAC - static libraries
53 Summary(pl.UTF-8):      FLAC - biblioteki statyczne
54 License:        BSD
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 The package contains FLAC static libraries.
60
61 %description static -l pl.UTF-8
62 Ten pakiet zawiera biblioteki statyczne FLAC.
63
64 %package c++
65 Summary:        FLAC++ - C++ API for FLAC codec
66 Summary(pl.UTF-8):      FLAC++ - API C++ do kodeka FLAC
67 Group:          Libraries
68 Requires:       %{name} = %{version}-%{release}
69
70 %description c++
71 FLAC++ - C++ API for FLAC codec.
72
73 %description c++ -l pl.UTF-8
74 FLAC++ - API C++ do kodeka FLAC.
75
76 %package c++-devel
77 Summary:        Header files for FLAC++ library
78 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FLAC++
79 Group:          Development/Libraries
80 Requires:       %{name}-c++ = %{version}-%{release}
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description c++-devel
84 Header files for FLAC++ library.
85
86 %description c++-devel -l pl.UTF-8
87 Pliki nagłówkowe biblioteki FLAC++.
88
89 %package c++-static
90 Summary:        Static FLAC++ library
91 Summary(pl.UTF-8):      Statyczna biblioteka FLAC++
92 Group:          Development/Libraries
93 Requires:       %{name}-c++-devel = %{version}-%{release}
94
95 %description c++-static
96 Static FLAC++ library.
97
98 %description c++-static -l pl.UTF-8
99 Statyczna biblioteka FLAC++.
100
101 %package -n xmms-input-flac
102 Summary:        Free Lossless Audio Codec - XMMS plugin
103 Summary(pl.UTF-8):      Wtyczka FLAC dla XMMS
104 License:        GPL v2+
105 Group:          Libraries
106 Requires:       %{name} = %{version}-%{release}
107 Requires:       xmms
108
109 %description -n xmms-input-flac
110 FLAC input plugin for XMMS.
111
112 %description -n xmms-input-flac -l pl.UTF-8
113 Wtyczka dla XMMS umożliwiająca odtwarzanie plików w formacie FLAC.
114
115 %prep
116 %setup -q
117 %{!?with_xmms:%patch0 -p1}
118
119 %build
120 %{__libtoolize}
121 %{__aclocal}
122 %{__autoconf}
123 %{__autoheader}
124 %{__automake}
125 %configure \
126         %{!?with_static_libs:--disable-static}
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 # no makefiles in doc dirs
137 rm -f doc/html/{Makefile*,images/Makefile*,ru/Makefile*}
138 rm -f $RPM_BUILD_ROOT%{xmms_input_plugindir}/*.la
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %post   c++ -p /sbin/ldconfig
147 %postun c++ -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc AUTHORS COPYING.Xiph README doc/html/{*.html,images}
152 %lang(ru) %doc doc/html/ru
153 %attr(755,root,root) %{_bindir}/flac
154 %attr(755,root,root) %{_bindir}/metaflac
155 %attr(755,root,root) %{_libdir}/libFLAC.so.*.*.*
156 %{_mandir}/man1/flac.1*
157 %{_mandir}/man1/metaflac.1*
158
159 %files devel
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libFLAC.so
162 %{_libdir}/libFLAC.la
163 %{_includedir}/FLAC
164 %{_pkgconfigdir}/flac.pc
165 %{_aclocaldir}/libFLAC.m4
166
167 %if %{with static_libs}
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/libFLAC.a
171 %endif
172
173 %files c++
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/libFLAC++.so.*.*.*
176
177 %files c++-devel
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/libFLAC++.so
180 %{_libdir}/libFLAC++.la
181 %{_includedir}/FLAC++
182 %{_pkgconfigdir}/flac++.pc
183 %{_aclocaldir}/libFLAC++.m4
184
185 %if %{with static_libs}
186 %files c++-static
187 %defattr(644,root,root,755)
188 %{_libdir}/libFLAC++.a
189 %endif
190
191 %if %{with xmms}
192 %files -n xmms-input-flac
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{xmms_input_plugindir}/libxmms-flac.so
195 %endif
This page took 0.03143 seconds and 2 git commands to generate.