]> git.pld-linux.org Git - packages/firewall-init.git/blob - firewall-init.spec
- standarized line with BuildRoot field:
[packages/firewall-init.git] / firewall-init.spec
1 Summary:   Firewall SysV-init style start-up script
2 Name:      firewall-init
3 Version:   1.2
4 Release:   6
5 Copyright: BSD
6 Group:     Networking/Admin
7 Source:    ftp://ftp.redhat.com/pub/home/bandregg/%{name}-%{version}.tar.gz
8 Patch0:    firewall-init.patch
9 Patch1:    firewall-chkconfig.patch
10 Prereq:    /sbin/chkconfig
11 Requires:  ipfwadm
12 Buildarch: noarch
13 BuildRoot:      /tmp/%{name}-%{version}-root
14
15 %description
16 Firewall-init is meant to provide an easy to use interface to start and
17 stopping the kernel IP packet filters and accounting through ipfwadm(8).
18
19 %prep
20 %setup -q
21 %patch0 -p1
22 %patch1 -p1
23
24 %install
25 rm -rf $RPM_BUILD_ROOT
26 install -d $RPM_BUILD_ROOT/etc/{sysconfig/firewall-rules,rc.d/{init,rc{0,1,2,3,4,5,6}}.d}
27 install firewall $RPM_BUILD_ROOT/etc/sysconfig/
28 for i in input output forward; do
29         echo '#<policy> <proto> <s_addr/s_mask> <s_port> <d_addr/d_mask> <d_port> <options>' > \
30                 $RPM_BUILD_ROOT/etc/sysconfig/firewall-rules/${i}
31 done
32 echo '#<direction> <proto> <s_addr/s_mask> <s_port> <d_addr/d_mask> <d_port> <options>' > \
33         $RPM_BUILD_ROOT/etc/sysconfig/firewall-rules/account
34 install firewall.init $RPM_BUILD_ROOT/etc/rc.d/init.d/firewall
35
36 %post
37 /sbin/chkconfig --add firewall
38
39 %postun
40 if [ $1 = 0 ]; then
41    /sbin/chkconfig --del firewall
42 fi
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc README input.example
50 %attr(600,root,root) %verify(not size mtime md5) %config(noreplace) /etc/sysconfig/firewall
51 %attr(600,root,root) %verify(not size mtime md5) %config(noreplace) /etc/sysconfig/firewall-rules/*
52 %attr(700,root,root) %dir /etc/sysconfig/firewall-rules
53 %attr(700,root,root) /etc/rc.d/init.d/firewall
54
55 %changelog
56 * Thu Oct 29 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
57   [1.2-6]
58 - added support for chconfig (firewall-chconfig.patch and %post{un}
59   sections).
60
61 * Wed Jul 15 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
62   [1.2-5]
63 - added status and extstatus functionality to init script.
64
65 * Thu Jul  9 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
66   [1.2-4]
67 - added -q %setup parameter,
68 - added using %%{name}, %%{version} macros in Buildroot and Source,
69 - spec file rewritten for using Buildroot,
70 - added %clean section,
71 - removed Packager field from spec (if you want recompile package and
72   redistribute this package later put this in your private .rpmrc). 
73 - replaced "mkdir -p" with "install -d" in %install,
74 - added %defattr and %attr macros in %files (allows building package from
75   non-root account),
76 - changed permission for config files with firewall rules to 700,
77 - added %verify(not size mtime md5) for config files with firewall rules,
78 - added Summary field,
79 - changed build architecture to noarch,
80 - added restart and probe10min functionality to init script (probe10min 
81   helps on experiments with new FW rules),
82 - added noreplace parameter for %config for config files with firewall
83   rules.
84
85 * Mon Aug 18 1997 Bryan C. Andregg <bandregg@redhat.com>
86   [1.2-3]
87 Fixed error handling typo.
88 Removed handling of the 'any' case in favor of 'any/0'
89 Added masquerading notes in README.
90 Added empty config files.
91
92 * Sun Aug 17 1997 Bryan C. Andregg <bandregg@redhat.com>
93 Major bug fixes.
94 Added 'Requires' field.
95 Changes S9 to S09 in the rc.d runlevel dirs.
96 Fixed spelling errors.
97 Changed %config to %dir for /etc/sysconfig/firewall-rules.
98
99 * Wed Aug 13 1997 Bryan C. Andregg <bandregg@redhat.com>
100 Fixed numerous spelling errors.
101 Added stderr redirection to > /dev/null and logging of errors to syslogd.
102 Fixed bugs in /etc/rc.d/init.d/firewall
103 Changed version to 1.1.
104 Added support for ANY|any keyword in addrs,masks and ports.
105 Added accounting rule set.
106 Fixed xxx.xxx.xxx.xxx netmask format bug.
107 Cleaned up firewall.init.
108
109 * Tue Aug 12 1997 Bryan C. Andregg <bandregg@redhat.com>
110 Included README.
111 Moved /etc/sysconfig/firewall-ruels/input to %doc/input.example.
112 Initial build.
This page took 0.063355 seconds and 4 git commands to generate.