]> git.pld-linux.org Git - packages/firewall-init.git/blob - firewall-init.spec
- added line on top spec file with cvs tags ($Revision:$ and $Date:$).
[packages/firewall-init.git] / firewall-init.spec
1 Summary:        Firewall SysV-init style start-up script
2 Name:           firewall-init
3 Version:        2.0
4 Release:        1
5 Copyright:      BSD
6 Group:          Networking/Admin
7 Source:         ftp://hunter.mimuw.edu.pl/pub/users/baggins/%{name}-%{version}.tar.gz
8 Prereq:         /sbin/chkconfig
9 Requires:       ipchains
10 Buildarch:      noarch
11 Buildroot:      /tmp/%{name}-%{version}-root
12
13 %description
14 Firewall-init is meant to provide an easy to use interface to start and
15 stopping the kernel IP packet filters and accounting through ipchains(8).
16
17 %prep
18 %setup -q
19
20 %install
21 rm -rf $RPM_BUILD_ROOT
22
23 install -d $RPM_BUILD_ROOT/etc/{sysconfig/firewall-rules,rc.d/init.d}
24
25 install firewall.init $RPM_BUILD_ROOT/etc/rc.d/init.d/firewall
26 install firewall $RPM_BUILD_ROOT/etc/sysconfig/
27
28 for i in input output forward; do
29         echo '#<policy> <proto> <s_addr/s_mask> <s_port> <d_addr/d_mask> <d_port> <interface> <options>' > \
30                 $RPM_BUILD_ROOT/etc/sysconfig/firewall-rules/${i}
31 done
32
33 %post
34 /sbin/chkconfig --add firewall
35
36 %postun
37 if [ $1 = 0 ]; then
38    /sbin/chkconfig --del firewall
39 fi
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644, root, root, 755)
46 %doc README input.example
47 %attr(600, root, root) %verify(not size mtime md5) %config(noreplace) /etc/sysconfig/firewall
48 %attr(600, root, root) %verify(not size mtime md5) %config(noreplace) /etc/sysconfig/firewall-rules/*
49 %attr(700, root, root) %dir /etc/sysconfig/firewall-rules
50 %attr(700, root, root) /etc/rc.d/init.d/firewall
51
52 %changelog
53 * Tue Jul 06 1999 Jan Rêkorajski <baggins@pld.org.pl>
54   [2.0-1]
55 - converted to ipchains
56 - new source URL
57
58 * Thu Oct 29 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
59   [1.2-6]
60 - added support for chconfig (firewall-chconfig.patch and %post{un}
61   sections).
62
63 * Wed Jul 15 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
64   [1.2-5]
65 - added status and extstatus functionality to init script.
66
67 * Thu Jul  9 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
68   [1.2-4]
69 - added -q %setup parameter,
70 - added using %%{name}, %%{version} macros in Buildroot and Source,
71 - spec file rewritten for using Buildroot,
72 - added %clean section,
73 - removed Packager field from spec (if you want recompile package and
74   redistribute this package later put this in your private .rpmrc). 
75 - replaced "mkdir -p" with "install -d" in %install,
76 - added %defattr and %attr macros in %files (allows building package from
77   non-root account),
78 - changed permission for config files with firewall rules to 700,
79 - added %verify(not size mtime md5) for config files with firewall rules,
80 - added Summary field,
81 - changed build architecture to noarch,
82 - added restart and probe10min functionality to init script (probe10min 
83   helps on experiments with new FW rules),
84 - added noreplace parameter for %config for config files with firewall
85   rules.
86
87 * Mon Aug 18 1997 Bryan C. Andregg <bandregg@redhat.com>
88   [1.2-3]
89 Fixed error handling typo.
90 Removed handling of the 'any' case in favor of 'any/0'
91 Added masquerading notes in README.
92 Added empty config files.
93
94 * Sun Aug 17 1997 Bryan C. Andregg <bandregg@redhat.com>
95 Major bug fixes.
96 Added 'Requires' field.
97 Changes S9 to S09 in the rc.d runlevel dirs.
98 Fixed spelling errors.
99 Changed %config to %dir for /etc/sysconfig/firewall-rules.
100
101 * Wed Aug 13 1997 Bryan C. Andregg <bandregg@redhat.com>
102 Fixed numerous spelling errors.
103 Added stderr redirection to > /dev/null and logging of errors to syslogd.
104 Fixed bugs in /etc/rc.d/init.d/firewall
105 Changed version to 1.1.
106 Added support for ANY|any keyword in addrs,masks and ports.
107 Added accounting rule set.
108 Fixed xxx.xxx.xxx.xxx netmask format bug.
109 Cleaned up firewall.init.
110
111 * Tue Aug 12 1997 Bryan C. Andregg <bandregg@redhat.com>
112 Included README.
113 Moved /etc/sysconfig/firewall-ruels/input to %doc/input.example.
114 Initial build.
This page took 0.084577 seconds and 3 git commands to generate.