]> git.pld-linux.org Git - packages/firefox52-esr.git/blame - firefox52-esr.spec
- release 3 (by relup.sh)
[packages/firefox52-esr.git] / firefox52-esr.spec
CommitLineData
a4803e5e
AO
1# TODO:
2# - consider --enable-libproxy
3#
4# Conditional build:
5%bcond_with tests # enable tests (whatever they check)
6%bcond_without gtk3 # GTK+ 3.x instead of 2.x
7%bcond_without kerberos # disable krb5 support
8%bcond_without official # official Firefox branding
899c120f 9%bcond_with pgo # PGO-enabled build (requires working $DISPLAY == :100)
62aba55b 10%bcond_without gold # use default linker instead of gold
a4803e5e
AO
11# - disabled shared_js - https://bugzilla.mozilla.org/show_bug.cgi?id=1039964
12%bcond_with shared_js # shared libmozjs library [broken]
13%bcond_with system_icu # build with system ICU (disabled due to crashes with system icu 58.2)
3a4708da 14%bcond_without clang # build using Clang/LLVM
a4803e5e
AO
15
16# On updating version, grab CVE links from:
17# https://www.mozilla.org/security/known-vulnerabilities/firefox.html
18# Release Notes:
19# https://developer.mozilla.org/en-US/Firefox/Releases
20
21# The actual sqlite version (see RHBZ#480989):
22%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
23
24%define _basename firefox
25%define nspr_ver 4.13.1
bd3afde6 26%define nss_ver 3.28.6
a4803e5e
AO
27
28Summary: Firefox web browser
29Summary(hu.UTF-8): Firefox web böngésző
30Summary(pl.UTF-8): Firefox - przeglądarka WWW
31Name: firefox52-esr
f83e28e9 32Version: 52.9.0
3d134b89 33Release: 3
a4803e5e
AO
34License: MPL v2.0
35Group: X11/Applications/Networking
36Source0: http://releases.mozilla.org/pub/mozilla.org/firefox/releases/%{version}esr/source/firefox-%{version}esr.source.tar.xz
f83e28e9 37# Source0-md5: b8c2f3619c684818be9a513f8aa1dbfd
a4803e5e
AO
38Source3: %{_basename}.desktop
39Source4: %{_basename}.sh
40Source5: vendor.js
41Source6: vendor-ac.js
42Patch0: idl-parser.patch
43Patch1: xulrunner-new-libxul.patch
44Patch2: xulrunner-paths.patch
17c40eb2 45Patch3: ffmpeg4.patch
a4803e5e
AO
46Patch4: %{_basename}-prefs.patch
47Patch5: %{_basename}-pld-bookmarks.patch
48Patch6: %{_basename}-no-subshell.patch
49Patch7: %{_basename}-middle_click_paste.patch
50Patch8: %{_basename}-system-virtualenv.patch
51Patch9: %{_basename}-Disable-Firefox-Health-Report.patch
52Patch10: freetype.patch
04c32508 53Patch11: xulrunner-pc.patch
a4803e5e
AO
54URL: https://www.mozilla.org/firefox/
55BuildRequires: OpenGL-devel
56BuildRequires: alsa-lib-devel
a4803e5e 57BuildRequires: autoconf2_13
363b8f84 58BuildRequires: automake
ef44d358 59%{?with_gold:BuildRequires: binutils >= 3:2.20.51.0.7}
a4803e5e
AO
60BuildRequires: bzip2-devel
61BuildRequires: cairo-devel >= 1.10.2-5
3a4708da 62%{?with_clang:BuildRequires: clang}
a4803e5e
AO
63BuildRequires: dbus-glib-devel >= 0.60
64BuildRequires: fontconfig-devel >= 1:2.7.0
65BuildRequires: freetype-devel >= 1:2.1.8
3a4708da 66%{!?with_clang:BuildRequires: gcc-c++ >= 6:4.4}
a4803e5e
AO
67BuildRequires: glib2-devel >= 1:2.22
68BuildRequires: gstreamer-devel >= 1.0
69BuildRequires: gstreamer-plugins-base-devel >= 1.0
70%{!?with_gtk3:BuildRequires: gtk+2-devel >= 2:2.18.0}
71%{?with_gtk3:BuildRequires: gtk+3-devel >= 3.4.0}
72%{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
73BuildRequires: hunspell-devel >= 1.2.3
74BuildRequires: libIDL-devel >= 0.8.0
75# DECnet (dnprogs.spec), not dummy net (libdnet.spec)
76#BuildRequires: libdnet-devel
77BuildRequires: libevent-devel >= 1.4.7
78# standalone libffi 3.0.9 or gcc's from 4.5(?)+
79BuildRequires: libffi-devel >= 6:3.0.9
80%{?with_system_icu:BuildRequires: libicu-devel >= 58.1}
81# requires libjpeg-turbo implementing at least libjpeg 6b API
82BuildRequires: libjpeg-devel >= 6b
83BuildRequires: libjpeg-turbo-devel
84BuildRequires: libpng(APNG)-devel >= 0.10
85BuildRequires: libpng-devel >= 2:1.6.25
86BuildRequires: libstdc++-devel >= 6:4.4
87BuildRequires: libvpx-devel >= 1.5.0
88BuildRequires: nspr-devel >= 1:%{nspr_ver}
89BuildRequires: nss-devel >= 1:%{nss_ver}
90BuildRequires: pango-devel >= 1:1.22.0
a4803e5e 91BuildRequires: perl-modules >= 5.004
363b8f84 92BuildRequires: pixman-devel >= 0.19.2
a4803e5e 93BuildRequires: pkgconfig
a4803e5e
AO
94BuildRequires: pulseaudio-devel
95BuildRequires: python-modules >= 1:2.5
96%{?with_pgo:BuildRequires: python-modules-sqlite}
97BuildRequires: python-simplejson
98BuildRequires: python-virtualenv >= 15
99BuildRequires: readline-devel
100BuildRequires: rpm >= 4.4.9-56
101BuildRequires: rpmbuild(macros) >= 1.601
102BuildRequires: sed >= 4.0
103BuildRequires: sqlite3-devel >= 3.17.0
104BuildRequires: startup-notification-devel >= 0.8
105BuildRequires: xorg-lib-libX11-devel
106BuildRequires: xorg-lib-libXScrnSaver-devel
107BuildRequires: xorg-lib-libXcomposite-devel
108BuildRequires: xorg-lib-libXdamage-devel
109BuildRequires: xorg-lib-libXext-devel
110BuildRequires: xorg-lib-libXfixes-devel
111BuildRequires: xorg-lib-libXinerama-devel
112BuildRequires: xorg-lib-libXt-devel
113%{?with_pgo:BuildRequires: xorg-xserver-Xvfb}
114%ifarch %{x8664}
115BuildRequires: yasm >= 1.0.1
116%endif
117BuildRequires: zip
118BuildRequires: zlib-devel >= 1.2.3
119BuildConflicts: %{name}-devel < %{version}
120Requires(post): mktemp >= 1.5-18
121Requires: browser-plugins >= 2.0
122Requires: desktop-file-utils
123Requires: hicolor-icon-theme
124Requires: myspell-common
04c32508 125Requires: %{name}-libs = %{version}-%{release}
a4803e5e
AO
126Provides: wwwbrowser
127Obsoletes: iceweasel
128Obsoletes: mozilla-firebird
129Obsoletes: mozilla-firefox
130Obsoletes: mozilla-firefox-lang-en < 2.0.0.8-3
a4803e5e
AO
131Obsoletes: xulrunner
132Obsoletes: xulrunner-gnome
133Conflicts: firefox-lang-resources < %{version}
134BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
135
136%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
137
33c3f774
JP
138%if %{with clang}
139%define filterout -fvar-tracking-assignments
140%else
141%define filterout -Werror=format-security
142%endif
143
a4803e5e
AO
144# don't satisfy other packages
145%define _noautoprovfiles %{_libdir}/%{name}
146
147# and as we don't provide them, don't require either
ed1a48e8 148%define _noautoreq liblgpllibs.so libmozavcodec.so libmozavutil.so libmozgtk.so libmozjs.so libmozsandbox.so libxul.so
a4803e5e
AO
149
150%description
151Firefox is an open-source web browser, designed for standards
152compliance, performance and portability.
153
154%description -l hu.UTF-8
155Firefox egy nyílt forrású webböngésző, hatékonyságra és
156hordozhatóságra tervezve.
157
158%description -l pl.UTF-8
159Firefox jest przeglądarką WWW rozpowszechnianą zgodnie z ideami
160ruchu otwartego oprogramowania oraz tworzoną z myślą o zgodności ze
161standardami, wydajnością i przenośnością.
162
04c32508
JB
163%package libs
164Summary: Firefox shared libraries
165Summary(pl.UTF-8): Biblioteki współdzielone Firefoksa
166Group: X11/Libraries
167Requires: cairo >= 1.10.2-5
168Requires: dbus-glib >= 0.60
169Requires: fontconfig-libs >= 1:2.7.0
170Requires: glib2 >= 1:2.22
171%{!?with_gtk3:Requires: gtk+2 >= 2:2.18.0}
172%{?with_gtk3:Requires: gtk+3 >= 3.4.0}
173Requires: libjpeg-turbo
174Requires: libpng >= 2:1.6.25
175Requires: libpng(APNG) >= 0.10
176Requires: libvpx >= 1.5.0
177Requires: nspr >= 1:%{nspr_ver}
178Requires: nss >= 1:%{nss_ver}
179Requires: pango >= 1:1.22.0
180Requires: sqlite3 >= %{sqlite_build_version}
181Requires: startup-notification >= 0.8
182Provides: xulrunner-libs = 2:%{version}-%{release}
183Obsoletes: firefox-libs
184Obsoletes: iceweasel-libs
185Obsoletes: mozilla-firefox-libs
186Obsoletes: xulrunner-libs < 2:%{version}
60b88a47 187Conflicts: firefox52-esr < 52.9.0-2
04c32508
JB
188
189%description libs
190XULRunner shared libraries.
191
192%description libs -l pl.UTF-8
193Biblioteki współdzielone XULRunnera.
194
195%package devel
196Summary: Headers for developing programs that will use Firefox
197Summary(pl.UTF-8): Pliki nagłówkowe do tworzenia programów używających Firefoksa
198Group: X11/Development/Libraries
199Requires: %{name}-libs = %{version}-%{release}
200Requires: nspr-devel >= 1:%{nspr_ver}
201Requires: nss-devel >= 1:%{nss_ver}
202Requires: python-ply
203Provides: xulrunner-devel = 2:%{version}-%{release}
204Obsoletes: firefox-devel
205Obsoletes: iceweasel-devel
206Obsoletes: mozilla-devel
207Obsoletes: mozilla-firefox-devel
208Obsoletes: seamonkey-devel
209Obsoletes: xulrunner-devel
210
211%description devel
212Firefox development package.
213
214%description devel -l pl.UTF-8
215Pakiet programistyczny Firefoksa.
216
a4803e5e
AO
217%prep
218%setup -q -n %{_basename}-%{version}esr
219
220# avoid using included headers (-I. is before HUNSPELL_CFLAGS)
221%{__rm} extensions/spellcheck/hunspell/src/{*.hxx,hunspell.h}
222# hunspell needed for factory including mozHunspell.h
223echo 'LOCAL_INCLUDES += $(MOZ_HUNSPELL_CFLAGS)' >> extensions/spellcheck/src/Makefile.in
224
225%patch0 -p2
226%patch1 -p1
227%patch2 -p2
17c40eb2 228%patch3 -p1
a4803e5e
AO
229%patch4 -p1
230%patch5 -p1
231%patch6 -p2
232%patch7 -p1
233%patch8 -p2
234%patch9 -p1
235%patch10 -p2
04c32508 236%patch11 -p1
a4803e5e
AO
237
238%{__sed} -i -e '1s,/usr/bin/env python,%{__python},' xpcom/typelib/xpt/tools/xpt.py xpcom/idl-parser/xpidl/xpidl.py
239
240%if %{with pgo}
241%{__sed} -i -e 's@__BROWSER_PATH__@"../../dist/bin/firefox-bin"@' build/automation.py.in
242%endif
243
244%build
245cp -p %{_datadir}/automake/config.* build/autoconf
246
247cat << 'EOF' > .mozconfig
248. $topsrcdir/browser/config/mozconfig
249
3a4708da
JP
250%if %{with clang}
251export CC="clang"
252export CXX="clang++"
253%else
254export CC="%{__cc}"
255export CXX="%{__cxx}"
256%endif
257
a4803e5e
AO
258mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
259
260# Options for 'configure' (same as command-line options).
261ac_add_options --host=%{_target_platform}
262ac_add_options --prefix=%{_prefix}
263%if %{?debug:1}0
264ac_add_options --disable-optimize
265ac_add_options --enable-debug
266ac_add_options --enable-debug-modules
267ac_add_options --enable-debugger-info-modules
268ac_add_options --enable-crash-on-assert
269%else
270ac_add_options --disable-debug
540e18db 271ac_add_options --enable-optimize="%{rpmcflags}"
a4803e5e
AO
272%endif
273ac_add_options --disable-strip
274ac_add_options --disable-install-strip
275%if %{with tests}
276ac_add_options --enable-tests
277ac_add_options --enable-mochitest
278%else
279%if %{with pgo}
280ac_add_options --enable-tests
281%else
282ac_add_options --disable-tests
283%endif
284%endif
285ac_add_options --disable-crashreporter
286ac_add_options --disable-gconf
287ac_add_options --disable-gnomeui
288ac_add_options --disable-necko-wifi
289ac_add_options --disable-updater
290ac_add_options --enable-alsa
291ac_add_options --enable-chrome-format=omni
292ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
293ac_add_options --enable-extensions=default
ef44d358 294%{?with_gold:ac_add_options --enable-gold}
a4803e5e
AO
295ac_add_options --enable-gio
296ac_add_options --enable-readline
297ac_add_options --enable-safe-browsing
298%{?with_shared_js:ac_add_options --enable-shared-js}
299ac_add_options --enable-startup-notification
300ac_add_options --enable-system-cairo
301ac_add_options --enable-system-ffi
302ac_add_options --enable-system-hunspell
303ac_add_options --enable-system-sqlite
304ac_add_options --enable-url-classifier
305%{?with_official:ac_add_options --enable-official-branding}
306ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
307ac_add_options --with-distribution-id=org.pld-linux
308ac_add_options --with-pthreads
309ac_add_options --with-system-bz2
310ac_add_options --with%{!?with_system_icu:out}-system-icu
311ac_add_options --with-system-jpeg
312ac_add_options --with-system-libevent
313ac_add_options --with-system-libvpx
314ac_add_options --with-system-nspr
315ac_add_options --with-system-nss
316ac_add_options --with-system-png
317ac_add_options --with-system-zlib
318ac_add_options --with-x
319EOF
320
321%if %{with pgo}
322D=$(( RANDOM % (200 - 100 + 1 ) + 5 ))
323/usr/bin/Xvfb :${D} &
324XVFB_PID=$!
325[ -n "$XVFB_PID" ] || exit 1
326export DISPLAY=:${D}
327%{__make} -j1 -f client.mk profiledbuild \
328 AUTOCONF=/usr/bin/autoconf2_13 \
329 DESTDIR=obj-%{_target_cpu}/dist \
330 MOZ_MAKE_FLAGS="%{_smp_mflags}"
331kill $XVFB_PID
332%else
333%{__make} -j1 -f client.mk build \
334 AUTOCONF=/usr/bin/autoconf2_13 \
335 MOZ_MAKE_FLAGS="%{_smp_mflags}"
336%endif
337
338%install
339rm -rf $RPM_BUILD_ROOT
340install -d \
341 $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
342 $RPM_BUILD_ROOT%{_desktopdir} \
343 $RPM_BUILD_ROOT%{_datadir}/%{name}/browser \
344 $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/plugins \
04c32508 345 $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/sdk/{lib,bin} \
a4803e5e 346 $RPM_BUILD_ROOT%{_includedir}/%{name} \
04c32508 347 $RPM_BUILD_ROOT%{_datadir}/idl/%{name} \
a4803e5e
AO
348 $RPM_BUILD_ROOT%{_pkgconfigdir}
349
350%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/browser/plugins
351
352cd obj-%{_target_cpu}
04c32508 353%{__make} -C browser/installer stage-package libxul.pc libxul-embedding.pc mozilla-js.pc mozilla-plugin.pc \
a4803e5e 354 DESTDIR=$RPM_BUILD_ROOT \
04c32508 355 INSTALL_SDK=1 \
6ab32e1e
JB
356 PKG_SKIP_STRIP=1 \
357 idldir=%{_datadir}/idl/%{name} \
358 includedir=%{_includedir}/%{name} \
359 installdir=%{_libdir}/%{name} \
360 sdkdir=%{_libdir}/%{name}-devel
a4803e5e 361
04c32508 362cp -aL browser/installer/*.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
a4803e5e 363cp -aL dist/firefox/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
04c32508
JB
364cp -aL dist/idl/* $RPM_BUILD_ROOT%{_datadir}/idl/%{name}
365cp -aL dist/include/* $RPM_BUILD_ROOT%{_includedir}/%{name}
366cp -aL dist/include/xpcom-config.h $RPM_BUILD_ROOT%{_libdir}/%{name}-devel
367cp -aL dist/sdk/lib/* $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/sdk/lib
368cp -aL dist/sdk/bin/* $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/sdk/bin
369find $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/sdk -name "*.pyc" | xargs rm -f
370
371ln -s %{_libdir}/%{name} $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/bin
372ln -s %{_includedir}/%{name} $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/include
373ln -s %{_datadir}/idl/%{name} $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/idl
374ln -s %{_libdir}/%{name}-devel/sdk/lib $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/lib
375
376# replace copies with symlinks
377%{?with_shared_js:ln -sf %{_libdir}/%{name}/libmozjs.so $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/sdk/lib/libmozjs.so}
378ln -sf %{_libdir}/%{name}/libxul.so $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/sdk/lib/libxul.so
379# temp fix for https://bugzilla.mozilla.org/show_bug.cgi?id=63955
380chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/sdk/bin/xpt.py
a4803e5e
AO
381
382# move arch independant ones to datadir
ed1a48e8
JB
383%{__mv} $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/chrome
384%{__mv} $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/extensions
385%{__mv} $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/icons
386%{__mv} $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/defaults
387%{__mv} $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/defaults/{pref,preferences}
a4803e5e
AO
388
389ln -s ../../../share/%{name}/browser/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/chrome
390ln -s ../../../share/%{name}/browser/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/defaults
391ln -s ../../../share/%{name}/browser/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/extensions
392ln -s ../../../share/%{name}/browser/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/icons
393
394%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
395ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
396
397sed 's,@LIBDIR@,%{_libdir},;s,@NAME@,%{name},' %{SOURCE4} > $RPM_BUILD_ROOT%{_bindir}/%{name}
398chmod 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
399
400# install icons and desktop file
401for i in 16 32 48 %{?with_official:22 24 256}; do
402 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
403 cp -a ../browser/branding/%{!?with_official:un}official/default${i}.png \
404 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/%{name}.png
405done
406
407cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
408
409# install our settings
410%if "%{pld_release}" == "ac"
411cp -a %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/defaults/preferences/vendor.js
412%else
413cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/defaults/preferences/vendor.js
414%endif
415
416cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
417#!/bin/sh
418umask 022
419rm -f %{_libdir}/%{name}/browser/components/{compreg,xpti}.dat
420
421# it attempts to touch files in $HOME/.mozilla
422# beware if you run this with sudo!!!
423export HOME=$(mktemp -d)
424# also TMPDIR could be pointing to sudo user's homedir
425unset TMPDIR TMP || :
426
427%{_libdir}/%{name}/firefox -register
428
429rm -rf $HOME
430EOF
431chmod 755 $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
432
433%clean
434rm -rf $RPM_BUILD_ROOT
435
436%post
437%{_sbindir}/%{name}-chrome+xpcom-generate
438%update_browser_plugins
439%update_icon_cache hicolor
440%update_desktop_database
441
442%postun
443if [ "$1" = 0 ]; then
444 %update_browser_plugins
445 %update_icon_cache hicolor
446fi
447
448%files
449%defattr(644,root,root,755)
450%attr(755,root,root) %{_bindir}/%{name}
451%attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
452
453%{_desktopdir}/%{name}.desktop
454%{_iconsdir}/hicolor/*/apps/%{name}.png
455
456# browser plugins v2
457%{_browserpluginsconfdir}/browsers.d/%{name}.*
458%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
459
460%dir %{_libdir}/%{name}/browser
461%dir %{_libdir}/%{name}/browser/plugins
462%dir %{_libdir}/%{name}/browser/features
463
464%dir %{_datadir}/%{name}
465%dir %{_datadir}/%{name}/browser
466%dir %{_datadir}/%{name}/browser/extensions
467%{_datadir}/%{name}/browser/chrome
468%{_datadir}/%{name}/browser/defaults
469%{_datadir}/%{name}/browser/icons
470
471# symlinks
472%{_libdir}/%{name}/browser/extensions
473%{_libdir}/%{name}/browser/chrome
474%{_libdir}/%{name}/browser/icons
475%{_libdir}/%{name}/browser/defaults
476
477%attr(755,root,root) %{_libdir}/%{name}/firefox
478%attr(755,root,root) %{_libdir}/%{name}/firefox-bin
479%attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
480%{_libdir}/%{name}/application.ini
481%{_libdir}/%{name}/chrome.manifest
482%{_libdir}/%{name}/browser/blocklist.xml
483%{_libdir}/%{name}/browser/chrome.manifest
484# the signature of the default theme
485%{_datadir}/%{name}/browser/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
486%{_libdir}/%{name}/browser/omni.ja
487
488%{_libdir}/%{name}/browser/features/aushelper@mozilla.org.xpi
489%{_libdir}/%{name}/browser/features/e10srollout@mozilla.org.xpi
490%{_libdir}/%{name}/browser/features/firefox@getpocket.com.xpi
491%{_libdir}/%{name}/browser/features/webcompat@mozilla.org.xpi
492
493%attr(755,root,root) %{_libdir}/%{name}/plugin-container
494%{_libdir}/%{name}/dictionaries
495
496%dir %{_libdir}/%{name}/fonts
497%{_libdir}/%{name}/fonts/EmojiOneMozilla.ttf
498
499%dir %{_libdir}/%{name}/gmp-clearkey
500%dir %{_libdir}/%{name}/gmp-clearkey/0.1
501%{_libdir}/%{name}/gmp-clearkey/0.1/clearkey.info
502%attr(755,root,root) %{_libdir}/%{name}/gmp-clearkey/0.1/libclearkey.so
503%{!?with_system_icu:%{_libdir}/%{name}//icudt58l.dat}
504
04c32508
JB
505%files libs
506%defattr(644,root,root,755)
a4803e5e
AO
507%dir %{_libdir}/%{name}
508%{_libdir}/%{name}/platform.ini
509%{?with_shared_js:%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so}
510%attr(755,root,root) %{_libdir}/%{name}/liblgpllibs.so
511%attr(755,root,root) %{_libdir}/%{name}/libxul.so
512%attr(755,root,root) %{_libdir}/%{name}/libmozavcodec.so
513%attr(755,root,root) %{_libdir}/%{name}/libmozavutil.so
514%attr(755,root,root) %{_libdir}/%{name}/libmozsandbox.so
515%{_libdir}/%{name}/dependentlibs.list
516%{_libdir}/%{name}/omni.ja
517%if %{with gtk3}
518%dir %{_libdir}/%{name}/gtk2
519%attr(755,root,root) %{_libdir}/%{name}/gtk2/libmozgtk.so
520%attr(755,root,root) %{_libdir}/%{name}/libmozgtk.so
521%endif
04c32508
JB
522
523%files devel
524%defattr(644,root,root,755)
525%{_includedir}/%{name}
526%{_datadir}/idl/%{name}
527%dir %{_libdir}/%{name}-devel
528%{_libdir}/%{name}-devel/bin
529%{_libdir}/%{name}-devel/idl
530%{_libdir}/%{name}-devel/lib
531%{_libdir}/%{name}-devel/include
532%{_libdir}/%{name}-devel/*.h
533%dir %{_libdir}/%{name}-devel/sdk
534%{_libdir}/%{name}-devel/sdk/lib
535%dir %{_libdir}/%{name}-devel/sdk/bin
536%attr(755,root,root) %{_libdir}/%{name}-devel/sdk/bin/header.py
537%attr(755,root,root) %{_libdir}/%{name}-devel/sdk/bin/run-mozilla.sh
538%attr(755,root,root) %{_libdir}/%{name}-devel/sdk/bin/typelib.py
539%attr(755,root,root) %{_libdir}/%{name}-devel/sdk/bin/xpcshell
540%attr(755,root,root) %{_libdir}/%{name}-devel/sdk/bin/xpidl.py
541%{_libdir}/%{name}-devel/sdk/bin/xpidllex.py
542%{_libdir}/%{name}-devel/sdk/bin/xpidlyacc.py
543%attr(755,root,root) %{_libdir}/%{name}-devel/sdk/bin/xpt.py
544%{_libdir}/%{name}-devel/sdk/bin/ply
545
546%{_pkgconfigdir}/libxul.pc
547%{_pkgconfigdir}/libxul-embedding.pc
548%{_pkgconfigdir}/mozilla-js.pc
549%{_pkgconfigdir}/mozilla-plugin.pc
This page took 0.100778 seconds and 4 git commands to generate.