]> git.pld-linux.org Git - packages/firefox.git/commitdiff
upstream patch to fix build with wayland 1.20; rel 2 auto/th/firefox-95.0.1-2
authorJan Palus <atler@pld-linux.org>
Sat, 18 Dec 2021 10:18:48 +0000 (11:18 +0100)
committerJan Palus <atler@pld-linux.org>
Sat, 18 Dec 2021 10:18:48 +0000 (11:18 +0100)
firefox.spec
wayland-1.20.patch [new file with mode: 0644]

index 465b3b08e5af6b4dfe1f80f7f5fbd6ddaeeab04e..39c590baf402ad73d4f914843b64b106edace6cd 100644 (file)
@@ -51,7 +51,7 @@ Summary(hu.UTF-8):    Firefox web böngésző
 Summary(pl.UTF-8):     Firefox - przeglądarka WWW
 Name:          firefox
 Version:       95.0.1
-Release:       1
+Release:       2
 License:       MPL v2.0
 Group:         X11/Applications/Networking
 Source0:       https://releases.mozilla.org/pub/firefox/releases/%{version}/source/firefox-%{version}.source.tar.xz
@@ -256,6 +256,7 @@ Source196:  https://releases.mozilla.org/pub/firefox/releases/%{version}/linux-i6
 # Source196-md5:       f95b9d914fe1872d6270c79fc47cfc80
 Source197:     https://releases.mozilla.org/pub/firefox/releases/%{version}/linux-i686/xpi/zh-TW.xpi
 # Source197-md5:       6b56a60a7cb22c1be1f7e8448b928cb7
+Patch0:                wayland-1.20.patch
 Patch4:                %{name}-prefs.patch
 Patch5:                %{name}-pld-bookmarks.patch
 Patch6:                %{name}-no-subshell.patch
@@ -2109,6 +2110,7 @@ unpack() {
 %define __unzip unpack
 %setup -q %(seq -f '-a %g' 100 197 | xargs)
 
+%patch0 -p1
 %patch4 -p1
 %patch5 -p1
 %patch6 -p2
diff --git a/wayland-1.20.patch b/wayland-1.20.patch
new file mode 100644 (file)
index 0000000..610c335
--- /dev/null
@@ -0,0 +1,32 @@
+
+# HG changeset patch
+# User Kevin Daudt <kdaudt@alpinelinux.org>
+# Date 1639316328 0
+# Node ID f7e2cf808d303d04b1b92dc825621b2fdba5559b
+# Parent  ce23c0066bacde4cef8dac8e5e8e42df6cac4bff
+Bug 1745560 - Add missing stub for wl_proxy_marshal_flags, r=stransky
+
+Firefox fails to build against wayland 1.20 because this symbol is missing
+
+Differential Revision: https://phabricator.services.mozilla.com/D133583
+
+diff --git a/widget/gtk/mozwayland/mozwayland.c b/widget/gtk/mozwayland/mozwayland.c
+--- a/widget/gtk/mozwayland/mozwayland.c
++++ b/widget/gtk/mozwayland/mozwayland.c
+@@ -195,8 +195,15 @@ MOZ_EXPORT void wl_list_insert(struct wl
+ MOZ_EXPORT void wl_list_remove(struct wl_list* elm) {}
+ MOZ_EXPORT int wl_list_length(const struct wl_list* list) { return -1; }
+ MOZ_EXPORT int wl_list_empty(const struct wl_list* list) { return -1; }
+ MOZ_EXPORT void wl_list_insert_list(struct wl_list* list,
+                                     struct wl_list* other) {}
++
++MOZ_EXPORT struct wl_proxy* wl_proxy_marshal_flags(
++    struct wl_proxy* proxy, uint32_t opcode,
++    const struct wl_interface* interface, uint32_t version, uint32_t flags,
++    ...) {
++  return NULL;
++}
+
This page took 0.377664 seconds and 4 git commands to generate.