]> git.pld-linux.org Git - packages/firefox.git/commitdiff
patch to fix font rendering with skia backend and ft 2.8.1; rel 3 auto/th/firefox-55.0.3-3
authorJan Palus <atler@pld-linux.org>
Sun, 17 Sep 2017 22:53:50 +0000 (00:53 +0200)
committerJan Palus <atler@pld-linux.org>
Sun, 17 Sep 2017 22:57:10 +0000 (00:57 +0200)
see https://bugzilla.mozilla.org/show_bug.cgi?id=1393467

clip-ft-glyph.patch [new file with mode: 0644]
firefox.spec

diff --git a/clip-ft-glyph.patch b/clip-ft-glyph.patch
new file mode 100644 (file)
index 0000000..4ca7035
--- /dev/null
@@ -0,0 +1,162 @@
+# HG changeset patch
+# User Lee Salzman <lsalzman@mozilla.com>
+# Date 1504120456 14400
+#      Wed Aug 30 15:14:16 2017 -0400
+# Node ID 708d52f954b6d7ca2497fcb5b5084c6483300e89
+# Parent  33224536ce20d942576cd4b9ffb350d6dce397bc
+clip FreeType glyph bitmap to mask in Skia
+
+MozReview-Commit-ID: 9NqLj9SkHFo
+
+diff --git a/gfx/skia/skia/src/ports/SkFontHost_FreeType_common.cpp b/gfx/skia/skia/src/ports/SkFontHost_FreeType_common.cpp
+--- a/gfx/skia/skia/src/ports/SkFontHost_FreeType_common.cpp
++++ b/gfx/skia/skia/src/ports/SkFontHost_FreeType_common.cpp
+@@ -390,65 +390,131 @@ void SkScalerContext_FreeType_Base::gene
+     const SkMatrix& bitmapTransform)
+ {
+     const bool doBGR = SkToBool(fRec.fFlags & SkScalerContext::kLCD_BGROrder_Flag);
+     const bool doVert = SkToBool(fRec.fFlags & SkScalerContext::kLCD_Vertical_Flag);
+     switch ( face->glyph->format ) {
+         case FT_GLYPH_FORMAT_OUTLINE: {
+             FT_Outline* outline = &face->glyph->outline;
+-            FT_BBox     bbox;
+-            FT_Bitmap   target;
+             int dx = 0, dy = 0;
+             if (fRec.fFlags & SkScalerContext::kSubpixelPositioning_Flag) {
+                 dx = SkFixedToFDot6(glyph.getSubXFixed());
+                 dy = SkFixedToFDot6(glyph.getSubYFixed());
+                 // negate dy since freetype-y-goes-up and skia-y-goes-down
+                 dy = -dy;
+             }
+-            FT_Outline_Get_CBox(outline, &bbox);
+-            /*
+-                what we really want to do for subpixel is
+-                    offset(dx, dy)
+-                    compute_bounds
+-                    offset(bbox & !63)
+-                but that is two calls to offset, so we do the following, which
+-                achieves the same thing with only one offset call.
+-            */
+-            FT_Outline_Translate(outline, dx - ((bbox.xMin + dx) & ~63),
+-                                          dy - ((bbox.yMin + dy) & ~63));
++
++            memset(glyph.fImage, 0, glyph.rowBytes() * glyph.fHeight);
+             if (SkMask::kLCD16_Format == glyph.fMaskFormat) {
++                FT_Outline_Translate(outline, dx, dy);
+                 FT_Error err = FT_Render_Glyph(face->glyph, doVert ? FT_RENDER_MODE_LCD_V :
+                                                                      FT_RENDER_MODE_LCD);
+                 if (err) {
+                     SK_TRACEFTR(err, "Could not render glyph.");
+-                    sk_bzero(glyph.fImage, glyph.computeImageSize());
+                     return;
+                 }
++
+                 SkMask mask;
+                 glyph.toMask(&mask);
++#ifdef SK_SHOW_TEXT_BLIT_COVERAGE
++                memset(mask.fImage, 0x80, mask.fBounds.height() * mask.fRowBytes);
++#endif
++                FT_GlyphSlotRec& ftGlyph = *face->glyph;
++
++                if (!SkIRect::Intersects(mask.fBounds,
++                                         SkIRect::MakeXYWH( ftGlyph.bitmap_left,
++                                                           -ftGlyph.bitmap_top,
++                                                            ftGlyph.bitmap.width,
++                                                            ftGlyph.bitmap.rows)))
++                {
++                    return;
++                }
++
++                // If the FT_Bitmap extent is larger, discard bits of the bitmap outside the mask.
++                // If the SkMask extent is larger, shrink mask to fit bitmap (clearing discarded).
++                unsigned char* origBuffer = ftGlyph.bitmap.buffer;
++                // First align the top left (origin).
++                if (-ftGlyph.bitmap_top < mask.fBounds.fTop) {
++                    int32_t topDiff = mask.fBounds.fTop - (-ftGlyph.bitmap_top);
++                    ftGlyph.bitmap.buffer += ftGlyph.bitmap.pitch * topDiff;
++                    ftGlyph.bitmap.rows -= topDiff;
++                    ftGlyph.bitmap_top = -mask.fBounds.fTop;
++                }
++                if (ftGlyph.bitmap_left < mask.fBounds.fLeft) {
++                    int32_t leftDiff = mask.fBounds.fLeft - ftGlyph.bitmap_left;
++                    ftGlyph.bitmap.buffer += leftDiff;
++                    ftGlyph.bitmap.width -= leftDiff;
++                    ftGlyph.bitmap_left = mask.fBounds.fLeft;
++                }
++                if (mask.fBounds.fTop < -ftGlyph.bitmap_top) {
++                    mask.fImage += mask.fRowBytes * (-ftGlyph.bitmap_top - mask.fBounds.fTop);
++                    mask.fBounds.fTop = -ftGlyph.bitmap_top;
++                }
++                if (mask.fBounds.fLeft < ftGlyph.bitmap_left) {
++                    mask.fImage += sizeof(uint16_t) * (ftGlyph.bitmap_left - mask.fBounds.fLeft);
++                    mask.fBounds.fLeft = ftGlyph.bitmap_left;
++                }
++                // Origins aligned, clean up the width and height.
++                int ftVertScale = (doVert ? 3 : 1);
++                int ftHoriScale = (doVert ? 1 : 3);
++                if (mask.fBounds.height() * ftVertScale < SkToInt(ftGlyph.bitmap.rows)) {
++                    ftGlyph.bitmap.rows = mask.fBounds.height() * ftVertScale;
++                }
++                if (mask.fBounds.width() * ftHoriScale < SkToInt(ftGlyph.bitmap.width)) {
++                    ftGlyph.bitmap.width = mask.fBounds.width() * ftHoriScale;
++                }
++                if (SkToInt(ftGlyph.bitmap.rows) < mask.fBounds.height() * ftVertScale) {
++                    mask.fBounds.fBottom = mask.fBounds.fTop + ftGlyph.bitmap.rows / ftVertScale;
++                }
++                if (SkToInt(ftGlyph.bitmap.width) < mask.fBounds.width() * ftHoriScale) {
++                    mask.fBounds.fRight = mask.fBounds.fLeft + ftGlyph.bitmap.width / ftHoriScale;
++                }
+                 if (fPreBlend.isApplicable()) {
+-                    copyFT2LCD16<true>(face->glyph->bitmap, mask, doBGR,
++                    copyFT2LCD16<true>(ftGlyph.bitmap, mask, doBGR,
+                                        fPreBlend.fR, fPreBlend.fG, fPreBlend.fB);
+                 } else {
+-                    copyFT2LCD16<false>(face->glyph->bitmap, mask, doBGR,
++                    copyFT2LCD16<false>(ftGlyph.bitmap, mask, doBGR,
+                                         fPreBlend.fR, fPreBlend.fG, fPreBlend.fB);
+                 }
++                // Restore the buffer pointer so FreeType can properly free it.
++                ftGlyph.bitmap.buffer = origBuffer;
+             } else {
++                FT_BBox     bbox;
++                FT_Bitmap   target;
++                FT_Outline_Get_CBox(outline, &bbox);
++                /*
++                    what we really want to do for subpixel is
++                        offset(dx, dy)
++                        compute_bounds
++                        offset(bbox & !63)
++                    but that is two calls to offset, so we do the following, which
++                    achieves the same thing with only one offset call.
++                */
++                FT_Outline_Translate(outline, dx - ((bbox.xMin + dx) & ~63),
++                                              dy - ((bbox.yMin + dy) & ~63));
++
+                 target.width = glyph.fWidth;
+                 target.rows = glyph.fHeight;
+                 target.pitch = glyph.rowBytes();
+                 target.buffer = reinterpret_cast<uint8_t*>(glyph.fImage);
+                 target.pixel_mode = compute_pixel_mode( (SkMask::Format)fRec.fMaskFormat);
+                 target.num_grays = 256;
+-                memset(glyph.fImage, 0, glyph.rowBytes() * glyph.fHeight);
+                 FT_Outline_Get_Bitmap(face->glyph->library, outline, &target);
++#ifdef SK_SHOW_TEXT_BLIT_COVERAGE
++                for (int y = 0; y < glyph.fHeight; ++y) {
++                    for (int x = 0; x < glyph.fWidth; ++x) {
++                        uint8_t& a = ((uint8_t*)glyph.fImage)[(glyph.rowBytes() * y) + x];
++                        a = SkTMax<uint8_t>(a, 0x20);
++                    }
++                }
++#endif
+             }
+         } break;
+         case FT_GLYPH_FORMAT_BITMAP: {
+             FT_Pixel_Mode pixel_mode = static_cast<FT_Pixel_Mode>(face->glyph->bitmap.pixel_mode);
+             SkMask::Format maskFormat = static_cast<SkMask::Format>(glyph.fMaskFormat);
+             // Assume that the other formats do not exist.
index 51013410e7fa0926ebbda790180532ac32e8823f..7d5af1e98883ca1683b6cc49e5029d9312390cfb 100644 (file)
@@ -37,7 +37,7 @@ Summary(hu.UTF-8):    Firefox web böngésző
 Summary(pl.UTF-8):     Firefox - przeglądarka WWW
 Name:          firefox
 Version:       55.0.3
-Release:       2
+Release:       3
 License:       MPL v2.0
 Group:         X11/Applications/Networking
 Source0:       http://releases.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.xz
@@ -243,6 +243,7 @@ Patch7:             %{name}-middle_click_paste.patch
 Patch8:                %{name}-system-virtualenv.patch
 Patch9:                %{name}-Disable-Firefox-Health-Report.patch
 Patch10:       freetype.patch
+Patch11:       clip-ft-glyph.patch
 URL:           https://www.mozilla.org/firefox/
 BuildRequires: OpenGL-devel
 BuildRequires: alsa-lib-devel
@@ -2019,6 +2020,7 @@ echo 'LOCAL_INCLUDES += $(MOZ_HUNSPELL_CFLAGS)' >> extensions/spellcheck/src/Mak
 %patch8 -p2
 %patch9 -p1
 %patch10 -p2
+%patch11 -p1
 
 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' xpcom/typelib/xpt/tools/xpt.py xpcom/idl-parser/xpidl/xpidl.py
 
This page took 0.05847 seconds and 4 git commands to generate.