]> git.pld-linux.org Git - packages/firefox.git/commitdiff
- added clang bcond (works for me)
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 19 Aug 2017 08:22:35 +0000 (10:22 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 19 Aug 2017 08:22:35 +0000 (10:22 +0200)
firefox.spec

index df6ea8226058ef7db0472e9991f2b173ac43ae46..62c991bc3622fb35a18d43c9c0ad8d6dbf8380fe 100644 (file)
@@ -10,6 +10,7 @@
 # - disabled shared_js - https://bugzilla.mozilla.org/show_bug.cgi?id=1039964
 %bcond_with    shared_js       # shared libmozjs library [broken]
 %bcond_without system_icu      # build without system ICU
+%bcond_with    clang           # build using Clang/LLVM
 
 # On updating version, grab CVE links from:
 # https://www.mozilla.org/security/known-vulnerabilities/firefox.html
@@ -213,8 +214,13 @@ cp -p %{_datadir}/automake/config.* build/autoconf
 cat << 'EOF' > .mozconfig
 . $topsrcdir/browser/config/mozconfig
 
+%if %{with clang}
+export CC="clang"
+export CXX="clang++"
+%else
 export CC="%{__cc}"
 export CXX="%{__cxx}"
+%endif
 export CFLAGS="%{rpmcflags} -D_FILE_OFFSET_BITS=64"
 export CXXFLAGS="%{rpmcxxflags} -D_FILE_OFFSET_BITS=64"
 
This page took 0.073744 seconds and 4 git commands to generate.