]> git.pld-linux.org Git - packages/firefox.git/commitdiff
- up to 25.0.1
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 29 Nov 2013 17:41:04 +0000 (18:41 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 29 Nov 2013 17:41:04 +0000 (18:41 +0100)
mozilla-firefox-941837.patch [new file with mode: 0644]
mozilla-firefox.spec

diff --git a/mozilla-firefox-941837.patch b/mozilla-firefox-941837.patch
new file mode 100644 (file)
index 0000000..8e85cf6
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/js/src/gc/Memory.cpp.orig        2013-11-13 01:13:53.000000000 +0100
++++ a/js/src/gc/Memory.cpp     2013-11-28 05:03:31.160133711 +0100
+@@ -63,7 +63,7 @@
+         p = VirtualAlloc(NULL, size * 2, MEM_RESERVE, PAGE_READWRITE);
+         if (!p)
+             return NULL;
+-        void *chunkStart = (void *)(uintptr_t(p) + (alignment - (uintptr_t(p) % alignment)));
++        void *chunkStart = (void *)AlignBytes(uintptr_t(p), alignment);
+         UnmapPages(rt, p, size * 2);
+         p = VirtualAlloc(chunkStart, size, MEM_COMMIT | MEM_RESERVE, PAGE_READWRITE);
+@@ -335,7 +335,7 @@
+     uintptr_t offset = uintptr_t(region) % alignment;
+     JS_ASSERT(offset < reqSize - size);
+-    void *front = (void *)(uintptr_t(region) + (alignment - offset));
++    void *front = (void *)AlignBytes(uintptr_t(region), alignment);
+     void *end = (void *)(uintptr_t(front) + size);
+     if (front != region)
+         JS_ALWAYS_TRUE(0 == munmap(region, alignment - offset));
index b5f2661fe03762df6daa3f6d817fe9f296b9dd0e..3d30abf2c3c2ddd1af8f8725a959958edff11ffe 100644 (file)
 Summary:       Firefox Community Edition web browser
 Summary(pl.UTF-8):     Firefox Community Edition - przeglÄ…darka WWW
 Name:          mozilla-firefox
-Version:       25.0
+Version:       25.0.1
 Release:       1
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         X11/Applications/Networking
 Source0:       http://releases.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.bz2
-# Source0-md5: 90ac047e83079a9046192c732e195329
+# Source0-md5: b5b57d3ea937a339e0ed7ebea604b430
 Source3:       %{name}.desktop
 Source4:       %{name}.sh
 Source5:       vendor.js
 Source6:       vendor-ac.js
 Patch0:                %{name}-branding.patch
+Patch1:                %{name}-941837.patch
 Patch7:                %{name}-prefs.patch
 Patch9:                %{name}-no-subshell.patch
 Patch11:       %{name}-middle_click_paste.patch
@@ -139,6 +140,7 @@ mv -f mozilla-release mozilla
 cd mozilla
 
 %patch0 -p1
+%patch1 -p1
 %patch7 -p1
 %patch9 -p2
 %patch11 -p2
This page took 0.471603 seconds and 4 git commands to generate.