]> git.pld-linux.org Git - packages/firefox.git/blobdiff - mozilla-firefox.spec
- up to 38.0.1
[packages/firefox.git] / mozilla-firefox.spec
index 46eab72b7ca02826f36cd6225130ad75601a83df..f58ee9503d70dffa98e86fcdbec1d8491b671a4d 100644 (file)
 %bcond_with    gtk3            # GTK+ 3.x instead of 2.x
 %bcond_without kerberos        # disable krb5 support
 %bcond_with    xulrunner       # system xulrunner [no longer supported]
-# - disabled shared_js - https://bugzilla.mozilla.org/show_bug.cgi?id=1039964
-%bcond_with    shared_js       # shared libmozjs library [broken]
+%bcond_with    shared_js       # shared libmozjs library
 
 %if %{without xulrunner}
 # The actual sqlite version (see RHBZ#480989):
 %define                sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
 %endif
 
-%define                nspr_ver        4.10.6
-%define                nss_ver         3.17.1
+%define                nspr_ver        4.10.8
+%define                nss_ver         3.18.1
 
 Summary:       Firefox Community Edition web browser
 Summary(pl.UTF-8):     Firefox Community Edition - przeglÄ…darka WWW
 Name:          mozilla-firefox
-Version:       33.0.2
+Version:       38.0.1
 Release:       1
 License:       MPL v2.0
 Group:         X11/Applications/Networking
 Source0:       http://releases.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.bz2
-# Source0-md5: 385ad037451f141b68515c73cad01704
+# Source0-md5: 3c496e4ec072327b1ef2b820f15dff26
 Source3:       %{name}.desktop
 Source4:       %{name}.sh
 Source5:       vendor.js
@@ -50,15 +49,16 @@ BuildRequires:      cairo-devel >= 1.10.2-5
 BuildRequires: dbus-glib-devel >= 0.60
 BuildRequires: freetype-devel >= 1:2.1.8
 BuildRequires: gcc-c++ >= 6:4.4
-BuildRequires: glib2-devel >= 1:2.20
+BuildRequires: glib2-devel >= 1:2.22
 BuildRequires: gstreamer-devel >= 1.0
 BuildRequires: gstreamer-plugins-base-devel >= 1.0
-%{!?with_gtk3:BuildRequires:   gtk+2-devel >= 2:2.14}
-%{?with_gtk3:BuildRequires:    gtk+3-devel >= 3.0.0}
+%{!?with_gtk3:BuildRequires:   gtk+2-devel >= 2:2.18.0}
+%{?with_gtk3:BuildRequires:    gtk+3-devel >= 3.4.0}
 %{?with_kerberos:BuildRequires:        heimdal-devel >= 0.7.1}
 BuildRequires: hunspell-devel >= 1.2.3
 BuildRequires: libIDL-devel >= 0.8.0
-BuildRequires: libdnet-devel
+# DECnet (dnprogs.spec), not dummy net (libdnet.spec)
+#BuildRequires:        libdnet-devel
 BuildRequires: libevent-devel >= 1.4.7
 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
 BuildRequires: libffi-devel >= 6:3.0.9
@@ -67,7 +67,7 @@ BuildRequires:        libicu-devel >= 50.1
 BuildRequires: libjpeg-devel >= 6b
 BuildRequires: libjpeg-turbo-devel
 BuildRequires: libpng(APNG)-devel >= 0.10
-BuildRequires: libpng-devel >= 2:1.6.10
+BuildRequires: libpng-devel >= 2:1.6.16
 BuildRequires: libstdc++-devel >= 6:4.4
 BuildRequires: libvpx-devel >= 1.3.0
 BuildRequires: nspr-devel >= 1:%{nspr_ver}
@@ -79,11 +79,12 @@ BuildRequires:      pkgconfig
 BuildRequires: pkgconfig(libffi) >= 3.0.9
 BuildRequires: pulseaudio-devel
 BuildRequires: python-modules >= 1:2.5
+BuildRequires: python-simplejson
 BuildRequires: python-virtualenv >= 1.9.1-4
 BuildRequires: readline-devel
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.601
-BuildRequires: sqlite3-devel >= 3.8.5
+BuildRequires: sqlite3-devel >= 3.8.9
 BuildRequires: startup-notification-devel >= 0.8
 BuildRequires: xorg-lib-libXScrnSaver-devel
 BuildRequires: xorg-lib-libXext-devel
@@ -95,19 +96,19 @@ BuildRequires:      xulrunner-devel >= 2:%{version}
 BuildRequires: zip
 BuildRequires: zlib-devel >= 1.2.3
 Requires(post):        mktemp >= 1.5-18
+Requires:      browser-plugins >= 2.0
 Requires:      desktop-file-utils
 Requires:      hicolor-icon-theme
 %if %{with xulrunner}
 %requires_eq_to        xulrunner xulrunner-devel
 %else
-Requires:      browser-plugins >= 2.0
 Requires:      cairo >= 1.10.2-5
 Requires:      dbus-glib >= 0.60
-Requires:      glib2 >= 1:2.20
-%{!?with_gtk3:Requires:        gtk+2 >= 2:2.14}
-%{?with_gtk3:Requires: gtk+3 >= 3.0.0}
+Requires:      glib2 >= 1:2.22
+%{!?with_gtk3:Requires:        gtk+2 >= 2:2.18.0}
+%{?with_gtk3:Requires: gtk+3 >= 3.4.0}
 Requires:      libjpeg-turbo
-Requires:      libpng >= 2:1.6.10
+Requires:      libpng >= 2:1.6.16
 Requires:      libpng(APNG) >= 0.10
 Requires:      libvpx >= 1.3.0
 Requires:      myspell-common
@@ -130,7 +131,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _noautoprovfiles        %{_libdir}/mozilla-firefox
 %if %{without xulrunner}
 # and as we don't provide them, don't require either
-%define                _noautoreq      libmozalloc.so libmozjs.so libxpcom.so libxul.so
+%define                _noautoreq      libmozalloc.so libmozjs.so libxul.so
 %endif
 
 %description
@@ -151,7 +152,7 @@ cd mozilla
 %patch7 -p1
 %patch9 -p2
 %patch11 -p2
-%patch12 -p2
+%patch12 -p1
 %patch13 -p2
 %patch15 -p1
 
@@ -242,6 +243,7 @@ ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
 %endif
 ac_add_options --with-pthreads
 ac_add_options --with-system-bz2
+ac_add_options --with-system-icu
 ac_add_options --with-system-jpeg
 ac_add_options --with-system-libevent
 ac_add_options --with-system-libvpx
@@ -250,7 +252,6 @@ ac_add_options --with-system-nss
 ac_add_options --with-system-ply
 ac_add_options --with-system-png
 ac_add_options --with-system-zlib
-ac_add_options --with-system-icu
 ac_add_options --with-x
 EOF
 
@@ -439,9 +440,13 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
 %{?with_shared_js:%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so}
 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
-%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
 %{_libdir}/%{name}/dictionaries
 %{_libdir}/%{name}/chrome.manifest
 %{_libdir}/%{name}/omni.ja
+
+%dir %{_libdir}/%{name}/gmp-clearkey
+%dir %{_libdir}/%{name}/gmp-clearkey/0.1
+%{_libdir}/%{name}/gmp-clearkey/0.1/clearkey.info
+%attr(755,root,root) %{_libdir}/%{name}/gmp-clearkey/0.1/libclearkey.so
 %endif
This page took 0.044339 seconds and 4 git commands to generate.