]> git.pld-linux.org Git - packages/firefox.git/blobdiff - mozilla-firefox.spec
- updated to 10.0.2
[packages/firefox.git] / mozilla-firefox.spec
index 2b6af4bbe573a1593f238ecca3b0446b75d68611..c5a00c217778a3d8a31bd9b1db435a06d7577b9c 100644 (file)
+# NOTE: PLD distributes iceweasel instead
+#
 # TODO:
-# - handle locales differently (runtime, since it's possible to do)
-# - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
-#   for hints how to make locales
-# - make it more pld-like (bookmarks, default page etc..)
+# - (12:22:58)  patrys:  can you also move _libdir/mozilla-firefox to just _libdir/firefox?
+#   (12:23:25)  patrys:  it's not like we ship official firefox
+# - fix wrapper script to allow playing with profiles (must not use -remote)
 #
 # Conditional build:
 %bcond_with    tests           # enable tests (whatever they check)
 %bcond_without gnomeui         # disable gnomeui support
-%bcond_without gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
-%bcond_without gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
-#
+%bcond_without gnome           # synonym for gnomeui (gconf, libnotify and gio are still enabled)
+%bcond_without kerberos        # disable krb5 support
+%bcond_without xulrunner       # system xulrunner
+
 %if %{without gnome}
 %undefine      with_gnomeui
-%undefine      with_gnomevfs
 %endif
-%define                firefox_ver     2.0.0.14
-#
+
+%if %{without xulrunner}
+# The actual sqlite version (see RHBZ#480989):
+%define                sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
+%endif
+
 Summary:       Firefox Community Edition web browser
 Summary(pl.UTF-8):     Firefox Community Edition - przeglądarka WWW
 Name:          mozilla-firefox
-Version:       %{firefox_ver}
-Release:       2
+Version:       10.0.2
+Release:       1
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         X11/Applications/Networking
-Source0:       ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
-# Source0-md5: 9e9c13ba7b81f93f2fa10c6f256ee31e
+Source0:       http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.bz2
+# Source0-md5: 5ce038d591964f72c534fa33b75a62f5
 Source1:       %{name}.desktop
 Source2:       %{name}.sh
-Patch0:                mozilla-install.patch
-Patch1:                %{name}-lib_path.patch
-Patch2:                %{name}-fonts.patch
-Patch3:                %{name}-agent.patch
-Patch4:                %{name}-myspell.patch
-Patch5:                %{name}-pango-cursor-position.patch
-Patch6:                %{name}-pango-ligatures.patch
-Patch7:                %{name}-pango-cursor-position-more.patch
-Patch8:                %{name}-pango-justified-range.patch
-Patch9:                %{name}-pango-printing.patch
-Patch10:       %{name}-pango-underline.patch
-Patch11:       %{name}-xft-randewidth.patch
-# if ac rebuild is needed...
-#PatchX:               %{name}-ac.patch
+Patch0:                %{name}-install.patch
+Patch1:                %{name}-gcc3.patch
+Patch2:                %{name}-agent.patch
+Patch3:                %{name}-agent-ac.patch
+Patch4:                %{name}-ti-agent.patch
+Patch5:                %{name}-branding.patch
+Patch6:                %{name}-prefs.patch
+Patch7:                %{name}-nss_cflags.patch
+Patch8:                %{name}-no-subshell.patch
 URL:           http://www.mozilla.org/projects/firefox/
-%{?with_gnomevfs:BuildRequires:        GConf2-devel >= 1.2.1}
+BuildRequires: GConf2-devel >= 1.2.1
+BuildRequires: OpenGL-devel
+BuildRequires: alsa-lib-devel
 BuildRequires: automake
-BuildRequires: cairo-devel >= 1.0.0
-%{?with_gnomevfs:BuildRequires:        gnome-vfs2-devel >= 2.0}
-BuildRequires: gtk+2-devel >= 1:2.0.0
-BuildRequires: krb5-devel
+BuildRequires: bzip2-devel
+BuildRequires: cairo-devel >= 1.10.2-5
+BuildRequires: dbus-glib-devel >= 0.60
+BuildRequires: glib2-devel >= 1:2.18
+BuildRequires: gtk+2-devel >= 2:2.14
+%{?with_kerberos:BuildRequires:        heimdal-devel >= 0.7.1}
+BuildRequires: hunspell-devel
 BuildRequires: libIDL-devel >= 0.8.0
-%{?with_gnomevfs:BuildRequires:        libgnome-devel >= 2.0}
+BuildRequires: libdnet-devel
+BuildRequires: libevent-devel >= 1.4.7
 %{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
+BuildRequires: libiw-devel
 BuildRequires: libjpeg-devel >= 6b
-BuildRequires: libpng-devel >= 1.2.7
+BuildRequires: libnotify-devel >= 0.4
+BuildRequires: libpng(APNG)-devel >= 0.10
+BuildRequires: libpng-devel >= 1.4.1
 BuildRequires: libstdc++-devel
-BuildRequires: myspell-devel
-BuildRequires: nspr-devel >= 1:4.6.3
-BuildRequires: nss-devel >= 1:3.11.3-3
-BuildRequires: pango-devel >= 1:1.6.0
+BuildRequires: libvpx-devel >= 1.0.0
+BuildRequires: nspr-devel >= 1:4.8.9
+BuildRequires: nss-devel >= 1:3.13.1
+BuildRequires: pango-devel >= 1:1.14.0
 BuildRequires: perl-modules >= 5.004
 BuildRequires: pkgconfig
-BuildRequires: rpmbuild(macros) >= 1.356
+BuildRequires: pkgconfig(libffi) >= 3.0.9
+BuildRequires: python-modules
+BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpmbuild(macros) >= 1.601
+BuildRequires: sqlite3-devel >= 3.7.7.1
+BuildRequires: startup-notification-devel >= 0.8
+BuildRequires: xorg-lib-libXScrnSaver-devel
 BuildRequires: xorg-lib-libXext-devel
-BuildRequires: xorg-lib-libXft-devel >= 2.1
 BuildRequires: xorg-lib-libXinerama-devel
-BuildRequires: xorg-lib-libXp-devel
 BuildRequires: xorg-lib-libXt-devel
+%if %{with xulrunner}
+BuildRequires: xulrunner-devel >= 2:%{version}
+%endif
 BuildRequires: zip
 BuildRequires: zlib-devel >= 1.2.3
 Requires(post):        mktemp >= 1.5-18
+%if %{with xulrunner}
+%requires_eq_to        xulrunner xulrunner-devel
+%else
 Requires:      browser-plugins >= 2.0
-Requires:      nspr >= 1:4.6.3
-Requires:      nss >= 1:3.11.3
+Requires:      cairo >= 1.10.2-5
+Requires:      dbus-glib >= 0.60
+Requires:      glib2 >= 1:2.18
+Requires:      gtk+2 >= 2:2.14
+Requires:      libpng >= 1.4.1
+Requires:      libpng(APNG) >= 0.10
+Requires:      myspell-common
+Requires:      nspr >= 1:4.8.9
+Requires:      nss >= 1:3.13.1
+Requires:      pango >= 1:1.14.0
+Requires:      sqlite3 >= %{sqlite_build_version}
+Requires:      startup-notification >= 0.8
+%endif
 Provides:      wwwbrowser
 Obsoletes:     mozilla-firebird
 Obsoletes:     mozilla-firefox-lang-en < 2.0.0.8-3
 Obsoletes:     mozilla-firefox-libs
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# firefox/thunderbird/seamonkey provide their own versions
-%define                _noautoreqdep           libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so
-%define                _noautoprovfiles        %{_libdir}/%{name}/components
-# we don't want these to satisfy xulrunner-devel
-%define                _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
+# don't satisfy other packages (don't use %{name} here)
+%define                _noautoprovfiles        %{_libdir}/mozilla-firefox
 # and as we don't provide them, don't require either
-%define                _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
+%define                _noautoreq      libmozjs.so libxpcom.so libxul.so %{!?with_xulrunner:libmozalloc.so}
 
+%if "%{cc_version}" >= "3.4"
 %define                specflags       -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
+%else
+%define                specflags       -fno-strict-aliasing
+%endif
 
 %description
 Firefox Community Edition is an open-source web browser, designed for
@@ -99,32 +130,47 @@ o zgodności ze standardami, wydajnością i przenośnością.
 
 %prep
 %setup -qc
+mv -f mozilla-release mozilla
 cd mozilla
+
+# libvpx fix
+grep -q VPX_CODEC_USE_INPUT_PARTITION configure.in && sed -i 's#VPX_CODEC_USE_INPUT_PARTITION#VPX_CODEC_USE_INPUT_FRAGMENTS#' configure || exit 1
+
 %patch0 -p1
-%patch1 -p1
+
+%if "%{cc_version}" < "3.4"
+%patch1 -p2
+%endif
+
+%if "%{pld_release}" == "th"
 %patch2 -p1
+%endif
+
+%if "%{pld_release}" == "ac"
 %patch3 -p1
+%endif
+
+%if "%{pld_release}" == "ti"
 %patch4 -p1
+%endif
+
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
-%patch8 -p1
-%patch9 -p0
-%patch10 -p1
-%patch11 -p1
+%patch8 -p2
+
+# config/rules.mk is patched by us and js/src/config/rules.mk
+# is supposed to be exact copy
+cp -a config/rules.mk js/src/config/rules.mk
 
 %build
 cd mozilla
-
 cp -f %{_datadir}/automake/config.* build/autoconf
-cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
-cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
 
-cat << 'EOF' > .mozconfig
-. $topsrcdir/browser/config/mozconfig
+cat << EOF > .mozconfig
+. \$topsrcdir/browser/config/mozconfig
 
 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
-ac_cv_visibility_pragma=no
 
 # Options for 'configure' (same as command-line options).
 ac_add_options --prefix=%{_prefix}
@@ -150,8 +196,10 @@ ac_add_options --enable-crash-on-assert
 ac_add_options --disable-debug
 ac_add_options --disable-debug-modules
 ac_add_options --disable-logging
-ac_add_options --enable-optimize="%{rpmcflags}"
+ac_add_options --enable-optimize="%{rpmcflags} -Os"
 %endif
+ac_add_options --disable-strip
+ac_add_options --disable-strip-libs
 %if %{with tests}
 ac_add_options --enable-tests
 %else
@@ -162,22 +210,29 @@ ac_add_options --enable-gnomeui
 %else
 ac_add_options --disable-gnomeui
 %endif
-%if %{with gnomevfs}
-ac_add_options --enable-gnomevfs
-%else
 ac_add_options --disable-gnomevfs
-%endif
-ac_add_options --disable-freetype2
+ac_add_options --disable-crashreporter
 ac_add_options --disable-installer
 ac_add_options --disable-javaxpcom
 ac_add_options --disable-updater
-ac_add_options --enable-default-toolkit=gtk2
-ac_add_options --enable-svg
+ac_add_options --enable-gio
+ac_add_options --enable-libxul
+ac_add_options --enable-pango
+ac_add_options --enable-shared-js
+ac_add_options --enable-startup-notification
 ac_add_options --enable-system-cairo
-ac_add_options --enable-system-myspell
-ac_add_options --enable-xft
+ac_add_options --enable-system-hunspell
+ac_add_options --enable-system-sqlite
 ac_add_options --with-distribution-id=org.pld-linux
+%if %{with xulrunner}
+ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
+%endif
+ac_add_options --with-pthreads
+ac_add_options --with-system-bz2
+ac_add_options --with-system-ffi
 ac_add_options --with-system-jpeg
+ac_add_options --with-system-libevent
+ac_add_options --with-system-libvpx
 ac_add_options --with-system-nspr
 ac_add_options --with-system-nss
 ac_add_options --with-system-png
@@ -185,7 +240,8 @@ ac_add_options --with-system-zlib
 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
 EOF
 
-%{__make} -j1 -f client.mk build \
+%{__make} -f client.mk build \
+       STRIP="/bin/true" \
        CC="%{__cc}" \
        CXX="%{__cxx}"
 
@@ -199,51 +255,61 @@ install -d \
 
 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
 
-%{__make} -C obj-%{_target_cpu}/xpinstall/packager stage-package \
+%{__make} -C obj-%{_target_cpu}/browser/installer stage-package \
        DESTDIR=$RPM_BUILD_ROOT \
-       MOZ_PKG_APPDIR=%{_libdir}/%{name} \
+       MOZ_PKG_DIR=%{_libdir}/%{name} \
        PKG_SKIP_STRIP=1
 
+install -d \
+       $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
+
+%if %{with xulrunner}
+# >= 5.0 seems to require this
+ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
+%endif
+
 # move arch independant ones to datadir
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
+mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
+%if %{without xulrunner}
+mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
+mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
+%endif
+
 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
-ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
+ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
-ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
-ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
+%if %{without xulrunner}
+ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
+ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
+%endif
 
-rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
+%if %{without xulrunner}
+%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
+%endif
 
 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
+chmod 755 $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
 ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
 
-install browser/base/branding/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
+cp -a browser/branding/unofficial/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
+cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
-
-# header/development files
-rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpidl
-rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_dump
-rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_link
-
-# files created by regxpcom and firefox -register
+# files created by firefox -register
 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
 
-# what's this? it's content is invalid anyway.
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
+%if %{with xulrunner}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/run-mozilla.sh
+%endif
 
 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
 #!/bin/sh
@@ -256,11 +322,11 @@ export HOME=$(mktemp -d)
 # also TMPDIR could be pointing to sudo user's homedir
 unset TMPDIR TMP || :
 
-LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
 %{_libdir}/%{name}/firefox -register
 
 rm -rf $HOME
 EOF
+chmod 755 $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -269,7 +335,7 @@ rm -rf $RPM_BUILD_ROOT
 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
        mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
 fi
-for d in chrome defaults extensions greprefs icons init.d res searchplugins; do
+for d in chrome defaults extensions greprefs.js icons res searchplugins; do
        if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
                install -d %{_datadir}/%{name}
                mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
@@ -297,283 +363,149 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
 
 %dir %{_libdir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}/*.so
+%if %{without xulrunner}
+%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
+%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
+%attr(755,root,root) %{_libdir}/%{name}/libxul.so
+%endif
+%{_libdir}/%{name}/blocklist.xml
+
+%if %{with crashreporter}
+%{_libdir}/%{name}/crashreporter
+%{_libdir}/%{name}/crashreporter-override.ini
+%{_libdir}/%{name}/crashreporter.ini
+%{_libdir}/%{name}/Throbber-small.gif
+%endif
+
+# config?
+%{_libdir}/%{name}/application.ini
+%{_libdir}/%{name}/chrome.manifest
 
 %dir %{_libdir}/%{name}/components
-%attr(755,root,root) %{_libdir}/%{name}/components/libaccessibility.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libappcomps.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libauth.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libautoconfig.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libcaps.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libchrome.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libcommandlines.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libcomposer.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libcookie.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libdocshell.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libeditor.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libembedcomponents.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libfileview.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libgfx_gtk.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libgfxps.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libgklayout.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libgkplugin.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libhtmlpars.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libi18n.so
-%{?with_gnomeui:%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so}
-%attr(755,root,root) %{_libdir}/%{name}/components/libimglib2.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libjar50.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libjsd.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libmork.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libmozfind.so
-%{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so}
-%attr(755,root,root) %{_libdir}/%{name}/components/libmyspell.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libnecko2.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libnecko.so
-%{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so}
-%attr(755,root,root) %{_libdir}/%{name}/components/libnsappshell.so
-%attr(755,root,root) %{_libdir}/%{name}/components/liboji.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libpermissions.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libpipboot.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libpipnss.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libpippki.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libpref.so
-%attr(755,root,root) %{_libdir}/%{name}/components/librdf.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libremoteservice.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libsearchservice.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libspellchecker.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libstoragecomps.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libsystem-pref.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libtoolkitcomps.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libtransformiix.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libtxmgr.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libuconv.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libucvmath.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libuniversalchardet.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libwebbrwsr.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libwebsrvcs.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libwidget_gtk2.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libxmlextras.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libxpcom_compat_c.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libxpconnect.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libxpinstall.so
-%{_libdir}/%{name}/components/accessibility-atk.xpt
-%{_libdir}/%{name}/components/accessibility.xpt
-%{_libdir}/%{name}/components/alerts.xpt
-%{_libdir}/%{name}/components/appshell.xpt
-%{_libdir}/%{name}/components/appstartup.xpt
-%{_libdir}/%{name}/components/autocomplete.xpt
-%{_libdir}/%{name}/components/autoconfig.xpt
-%{_libdir}/%{name}/components/bookmarks.xpt
-%{_libdir}/%{name}/components/browsercompsbase.xpt
-%{_libdir}/%{name}/components/browser-feeds.xpt
-%{_libdir}/%{name}/components/browsersearch.xpt
-%{_libdir}/%{name}/components/caps.xpt
-%{_libdir}/%{name}/components/chardet.xpt
-%{_libdir}/%{name}/components/chrome.xpt
-%{_libdir}/%{name}/components/commandhandler.xpt
-%{_libdir}/%{name}/components/commandlines.xpt
-%{_libdir}/%{name}/components/composer.xpt
-%{_libdir}/%{name}/components/content_base.xpt
-%{_libdir}/%{name}/components/content_htmldoc.xpt
-%{_libdir}/%{name}/components/content_html.xpt
-%{_libdir}/%{name}/components/content_xmldoc.xpt
-%{_libdir}/%{name}/components/content_xslt.xpt
-%{_libdir}/%{name}/components/content_xtf.xpt
-%{_libdir}/%{name}/components/cookie.xpt
-%{_libdir}/%{name}/components/directory.xpt
-%{_libdir}/%{name}/components/docshell.xpt
-%{_libdir}/%{name}/components/dom_base.xpt
-%{_libdir}/%{name}/components/dom_canvas.xpt
-%{_libdir}/%{name}/components/dom_core.xpt
-%{_libdir}/%{name}/components/dom_css.xpt
-%{_libdir}/%{name}/components/dom_events.xpt
-%{_libdir}/%{name}/components/dom_html.xpt
-%{_libdir}/%{name}/components/dom_loadsave.xpt
-%{_libdir}/%{name}/components/dom_range.xpt
-%{_libdir}/%{name}/components/dom_sidebar.xpt
-%{_libdir}/%{name}/components/dom_storage.xpt
-%{_libdir}/%{name}/components/dom_stylesheets.xpt
-%{_libdir}/%{name}/components/dom_svg.xpt
-%{_libdir}/%{name}/components/dom_traversal.xpt
-%{_libdir}/%{name}/components/dom_views.xpt
-%{_libdir}/%{name}/components/dom_xbl.xpt
-%{_libdir}/%{name}/components/dom_xpath.xpt
-%{_libdir}/%{name}/components/dom.xpt
-%{_libdir}/%{name}/components/dom_xul.xpt
-%{_libdir}/%{name}/components/downloads.xpt
-%{_libdir}/%{name}/components/editor.xpt
-%{_libdir}/%{name}/components/embed_base.xpt
-%{_libdir}/%{name}/components/extensions.xpt
-%{_libdir}/%{name}/components/exthandler.xpt
-%{_libdir}/%{name}/components/fastfind.xpt
+
 %{_libdir}/%{name}/components/FeedConverter.js
-%{_libdir}/%{name}/components/FeedProcessor.js
-%{_libdir}/%{name}/components/feeds.xpt
 %{_libdir}/%{name}/components/FeedWriter.js
-%{_libdir}/%{name}/components/filepicker.xpt
-%{_libdir}/%{name}/components/find.xpt
-%{_libdir}/%{name}/components/gfx.xpt
-%{_libdir}/%{name}/components/gksvgrenderer.xpt
-%{_libdir}/%{name}/components/history.xpt
-%{_libdir}/%{name}/components/htmlparser.xpt
-%{?with_gnomeui:%{_libdir}/%{name}/components/imgicon.xpt}
-%{_libdir}/%{name}/components/imglib2.xpt
-%{_libdir}/%{name}/components/inspector.xpt
-%{_libdir}/%{name}/components/intl.xpt
-%{_libdir}/%{name}/components/jar.xpt
-%{_libdir}/%{name}/components/jsconsole-clhandler.js
-%{_libdir}/%{name}/components/jsconsole.xpt
-%{_libdir}/%{name}/components/jsdservice.xpt
-%{_libdir}/%{name}/components/layout_base.xpt
-%{_libdir}/%{name}/components/layout_printing.xpt
-%{_libdir}/%{name}/components/layout_xul_tree.xpt
-%{_libdir}/%{name}/components/layout_xul.xpt
-%{_libdir}/%{name}/components/locale.xpt
-%{_libdir}/%{name}/components/lwbrk.xpt
-%{_libdir}/%{name}/components/microsummaries.xpt
-%{_libdir}/%{name}/components/migration.xpt
-%{_libdir}/%{name}/components/mimetype.xpt
-%{_libdir}/%{name}/components/mozbrwsr.xpt
-%{_libdir}/%{name}/components/mozfind.xpt
-%{_libdir}/%{name}/components/mozgnome.xpt
-%{_libdir}/%{name}/components/necko_about.xpt
-%{_libdir}/%{name}/components/necko_cache.xpt
-%{_libdir}/%{name}/components/necko_cookie.xpt
-%{_libdir}/%{name}/components/necko_data.xpt
-%{_libdir}/%{name}/components/necko_dns.xpt
-%{_libdir}/%{name}/components/necko_file.xpt
-%{_libdir}/%{name}/components/necko_ftp.xpt
-%{_libdir}/%{name}/components/necko_http.xpt
-%{_libdir}/%{name}/components/necko_res.xpt
-%{_libdir}/%{name}/components/necko_socket.xpt
-%{_libdir}/%{name}/components/necko_strconv.xpt
-%{_libdir}/%{name}/components/necko_viewsource.xpt
-%{_libdir}/%{name}/components/necko.xpt
-%{_libdir}/%{name}/components/nsBookmarkTransactionManager.js
+%{_libdir}/%{name}/components/PlacesProtocolHandler.js
+%{_libdir}/%{name}/components/Weave.js
+%{_libdir}/%{name}/components/WebContentConverter.js
+%{_libdir}/%{name}/components/browser.xpt
+%{_libdir}/%{name}/components/fuelApplication.js
 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
 %{_libdir}/%{name}/components/nsBrowserGlue.js
-%{_libdir}/%{name}/components/nsCloseAllWindows.js
+%{_libdir}/%{name}/components/nsPrivateBrowsingService.js
+%{_libdir}/%{name}/components/nsSafebrowsingApplication.js
+%{_libdir}/%{name}/components/nsSessionStartup.js
+%{_libdir}/%{name}/components/nsSessionStore.js
+%{_libdir}/%{name}/components/nsSetDefaultBrowser.js
+%{_libdir}/%{name}/components/nsSidebar.js
+
+%{_libdir}/%{name}/components/components.manifest
+%{_libdir}/%{name}/components/interfaces.manifest
+
+%if %{without xulrunner}
+%{_libdir}/%{name}/platform.ini
+%{_libdir}/%{name}/components/ConsoleAPI.js
+%{_libdir}/%{name}/components/FeedProcessor.js
+%{_libdir}/%{name}/components/GPSDGeolocationProvider.js
+%{_libdir}/%{name}/components/NetworkGeolocationProvider.js
+%{_libdir}/%{name}/components/PlacesCategoriesStarter.js
+%{_libdir}/%{name}/components/TelemetryPing.js
+%{_libdir}/%{name}/components/addonManager.js
+%{_libdir}/%{name}/components/amContentHandler.js
+%{_libdir}/%{name}/components/amWebInstallListener.js
+%{_libdir}/%{name}/components/contentAreaDropListener.js
+%{_libdir}/%{name}/components/contentSecurityPolicy.js
+%{_libdir}/%{name}/components/crypto-SDR.js
+%{_libdir}/%{name}/components/jsconsole-clhandler.js
+%{_libdir}/%{name}/components/nsBadCertHandler.js
+%{_libdir}/%{name}/components/nsBlocklistService.js
+%{_libdir}/%{name}/components/nsContentDispatchChooser.js
+%{_libdir}/%{name}/components/nsContentPrefService.js
 %{_libdir}/%{name}/components/nsDefaultCLH.js
-%{_libdir}/%{name}/components/nsDictionary.js
-%{_libdir}/%{name}/components/nsExtensionManager.js
+%{_libdir}/%{name}/components/nsDownloadManagerUI.js
 %{_libdir}/%{name}/components/nsFilePicker.js
+%{_libdir}/%{name}/components/nsFormAutoComplete.js
+%{_libdir}/%{name}/components/nsFormHistory.js
+%{_libdir}/%{name}/components/nsHandlerService.js
 %{_libdir}/%{name}/components/nsHelperAppDlg.js
-%{_libdir}/%{name}/components/nsInterfaceInfoToIDL.js
-%{_libdir}/%{name}/components/nsKillAll.js
-%{_libdir}/%{name}/components/nsMicrosummaryService.js
-%{_libdir}/%{name}/components/nsProgressDialog.js
+%{_libdir}/%{name}/components/nsINIProcessor.js
+%{_libdir}/%{name}/components/nsInputListAutoComplete.js
+%{_libdir}/%{name}/components/nsLivemarkService.js
+%{_libdir}/%{name}/components/nsLoginInfo.js
+%{_libdir}/%{name}/components/nsLoginManager.js
+%{_libdir}/%{name}/components/nsLoginManagerPrompter.js
+%{_libdir}/%{name}/components/nsPlacesAutoComplete.js
+%{_libdir}/%{name}/components/nsPlacesExpiration.js
+%{_libdir}/%{name}/components/nsPrompter.js
 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
-%{_libdir}/%{name}/components/nsResetPref.js
-%{_libdir}/%{name}/components/nsSafebrowsingApplication.js
 %{_libdir}/%{name}/components/nsSearchService.js
 %{_libdir}/%{name}/components/nsSearchSuggestions.js
-%{_libdir}/%{name}/components/nsSessionStartup.js
-%{_libdir}/%{name}/components/nsSessionStore.js
-%{_libdir}/%{name}/components/nsSetDefaultBrowser.js
-%{_libdir}/%{name}/components/nsSidebar.js
-%{_libdir}/%{name}/components/nsUpdateService.js
+%{_libdir}/%{name}/components/nsTaggingService.js
+%{_libdir}/%{name}/components/nsTryToClose.js
+%{_libdir}/%{name}/components/nsURLFormatter.js
+%{_libdir}/%{name}/components/nsUpdateTimerManager.js
+%{_libdir}/%{name}/components/nsUrlClassifierHashCompleter.js
 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
-%{_libdir}/%{name}/components/nsUrlClassifierTable.js
-%{_libdir}/%{name}/components/nsURLFormatter.js
-%{_libdir}/%{name}/components/nsXmlRpcClient.js
-%{_libdir}/%{name}/components/oji.xpt
-%{_libdir}/%{name}/components/passwordmgr.xpt
-%{_libdir}/%{name}/components/pipboot.xpt
-%{_libdir}/%{name}/components/pipnss.xpt
-%{_libdir}/%{name}/components/pippki.xpt
-%{_libdir}/%{name}/components/plugin.xpt
-%{_libdir}/%{name}/components/prefetch.xpt
-%{_libdir}/%{name}/components/pref.xpt
-%{_libdir}/%{name}/components/profile.xpt
-%{_libdir}/%{name}/components/progressDlg.xpt
-%{_libdir}/%{name}/components/proxyObjInst.xpt
-%{_libdir}/%{name}/components/rdf.xpt
-%{_libdir}/%{name}/components/safebrowsing.xpt
-%{_libdir}/%{name}/components/satchel.xpt
-%{_libdir}/%{name}/components/saxparser.xpt
-%{_libdir}/%{name}/components/search.xpt
-%{_libdir}/%{name}/components/sessionstore.xpt
-%{_libdir}/%{name}/components/shellservice.xpt
-%{_libdir}/%{name}/components/shistory.xpt
-%{_libdir}/%{name}/components/spellchecker.xpt
-%{_libdir}/%{name}/components/storage.xpt
-%{_libdir}/%{name}/components/toolkitprofile.xpt
-%{_libdir}/%{name}/components/toolkitremote.xpt
-%{_libdir}/%{name}/components/txmgr.xpt
-%{_libdir}/%{name}/components/txtsvc.xpt
-%{_libdir}/%{name}/components/uconv.xpt
-%{_libdir}/%{name}/components/unicharutil.xpt
-%{_libdir}/%{name}/components/update.xpt
-%{_libdir}/%{name}/components/uriloader.xpt
-%{_libdir}/%{name}/components/url-classifier.xpt
-%{_libdir}/%{name}/components/urlformatter.xpt
-%{_libdir}/%{name}/components/webBrowser_core.xpt
-%{_libdir}/%{name}/components/webbrowserpersist.xpt
-%{_libdir}/%{name}/components/WebContentConverter.js
-%{_libdir}/%{name}/components/webshell_idls.xpt
-%{_libdir}/%{name}/components/websrvcs.xpt
-%{_libdir}/%{name}/components/widget.xpt
-%{_libdir}/%{name}/components/windowds.xpt
-%{_libdir}/%{name}/components/windowwatcher.xpt
-%{_libdir}/%{name}/components/xml-rpc.xpt
-%{_libdir}/%{name}/components/xpcom_base.xpt
-%{_libdir}/%{name}/components/xpcom_components.xpt
-%{_libdir}/%{name}/components/xpcom_ds.xpt
-%{_libdir}/%{name}/components/xpcom_io.xpt
-%{_libdir}/%{name}/components/xpcom_obsolete.xpt
-%{_libdir}/%{name}/components/xpcom_threads.xpt
-%{_libdir}/%{name}/components/xpcom_xpti.xpt
-%{_libdir}/%{name}/components/xpconnect.xpt
-%{_libdir}/%{name}/components/xpinstall.xpt
-%{_libdir}/%{name}/components/xulapp.xpt
-%{_libdir}/%{name}/components/xuldoc.xpt
-%{_libdir}/%{name}/components/xultmpl.xpt
+%{_libdir}/%{name}/components/nsWebHandlerApp.js
+%{_libdir}/%{name}/components/storage-Legacy.js
+%{_libdir}/%{name}/components/storage-mozStorage.js
+%{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
+%endif
+
+%attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
+%if %{without xulrunner}
+%attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
+%endif
+
+%if %{without xulrunner}
+%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
+%endif
+
+%attr(755,root,root) %{_libdir}/%{name}/firefox
 %dir %{_libdir}/%{name}/plugins
-%attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
-%attr(755,root,root) %{_libdir}/%{name}/*.sh
-%attr(755,root,root) %{_libdir}/%{name}/m*
-%attr(755,root,root) %{_libdir}/%{name}/f*
-%attr(755,root,root) %{_libdir}/%{name}/regxpcom
-%attr(755,root,root) %{_libdir}/%{name}/xpcshell
-%attr(755,root,root) %{_libdir}/%{name}/xpicleanup
+%if %{without xulrunner}
+%attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
+%attr(755,root,root) %{_libdir}/%{name}/firefox-bin
+%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
+%attr(755,root,root) %{_libdir}/%{name}/plugin-container
+%endif
+
 %{_pixmapsdir}/mozilla-firefox.png
 %{_desktopdir}/mozilla-firefox.desktop
 
 # symlinks
 %{_libdir}/%{name}/chrome
 %{_libdir}/%{name}/defaults
-%{_libdir}/%{name}/dictionaries
 %{_libdir}/%{name}/extensions
-%{_libdir}/%{name}/greprefs
 %{_libdir}/%{name}/icons
-%{_libdir}/%{name}/init.d
-%{_libdir}/%{name}/res
+%{_libdir}/%{name}/modules
 %{_libdir}/%{name}/searchplugins
-
-# browserconfig
-%{_libdir}/%{name}/browserconfig.properties
-
-%{_libdir}/%{name}/LICENSE
-%{_libdir}/%{name}/README.txt
+%if %{with xulrunner}
+%{_libdir}/%{name}/xulrunner
+%else
+%{_libdir}/%{name}/dictionaries
+%{_libdir}/%{name}/greprefs.js
+%{_libdir}/%{name}/res
+%endif
 
 %dir %{_datadir}/%{name}
 %{_datadir}/%{name}/chrome
 %{_datadir}/%{name}/defaults
-%{_datadir}/%{name}/greprefs
 %{_datadir}/%{name}/icons
-%{_datadir}/%{name}/init.d
-%{_datadir}/%{name}/res
+%{_datadir}/%{name}/modules
 %{_datadir}/%{name}/searchplugins
+%if %{without xulrunner}
+%{_datadir}/%{name}/greprefs.js
+%{_datadir}/%{name}/res
+%endif
 
 %dir %{_datadir}/%{name}/extensions
 # -dom-inspector subpackage?
-%{_datadir}/%{name}/extensions/inspector@mozilla.org
+#%{_datadir}/%{name}/extensions/inspector@mozilla.org
 # the signature of the default theme
 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
 
-# files created by regxpcom and firefox -register
+# files created by firefox -register
 %ghost %{_libdir}/%{name}/components/compreg.dat
 %ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.24073 seconds and 4 git commands to generate.