]> git.pld-linux.org Git - packages/firefox.git/blobdiff - mozilla-firefox.spec
- rel 5
[packages/firefox.git] / mozilla-firefox.spec
index ebf85fa1cb1826d16ee21fa9501701e3da732e63..a6e2294aa21103132726f312b339c2320eae62ca 100644 (file)
@@ -5,24 +5,30 @@
 # - make it more pld-like (bookmarks, default page etc..)
 #
 # Conditional build:
-%bcond_with    tests   # enable tests (whatever they check)
-%bcond_without gnome   # disable all GNOME components (gnomevfs, gnome, gnomeui)
-%bcond_with    tidy    # enable htmlvalidator extension (tidy)
+%bcond_with    tests           # enable tests (whatever they check)
+%bcond_without gnomeui         # disable gnomeui support
+%bcond_without gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
+%bcond_without gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
+%bcond_without tidy            # htmlvalidator extension (tidy)
 #
-%define                _tidy_ver               0.839
-%define                _firefox_ver    2.0.0.4
+%if %{without gnome}
+%undefine      with_gnomeui
+%undefine      with_gnomevfs
+%endif
+%define                tidy_ver        0.8.4.1
+%define                firefox_ver     2.0.0.6
 #
 Summary:       Firefox Community Edition web browser
 Summary(pl.UTF-8):     Firefox Community Edition - przeglądarka WWW
 Name:          mozilla-firefox
-Version:       2.0.0.4
-Release:       1
-License:       MPL/LGPL
+Version:       %{firefox_ver}
+Release:       5
+License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         X11/Applications/Networking
 Source0:       ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
-# Source0-md5: 99c14794976b2532addfcd2d836c6bb2
+# Source0-md5: 16fb252fb7b0371894f7101b88fd9076
 Source1:       http://users.skynet.be/mgueury/mozilla/tidy_08x_source.zip
-# Source1-md5: ad63736e9d57de3e6c69696319b34b3b
+# Source1-md5: 2cab81118267fc87c9ebbfa6fb44b113
 Source2:       %{name}.desktop
 Source3:       %{name}.sh
 Patch0:                mozilla-install.patch
@@ -30,27 +36,27 @@ Patch1:             %{name}-lib_path.patch
 Patch2:                %{name}-addon-tidy.patch
 Patch3:                %{name}-nopangoxft.patch
 Patch5:                %{name}-fonts.patch
-Patch69:       %{name}-agent.patch
+Patch6:                %{name}-agent.patch
 Patch7:                %{name}-myspell.patch
 # if ac rebuild is needed...
 #PatchX:               %{name}-ac.patch
 URL:           http://www.mozilla.org/projects/firefox/
-%{?with_gnome:BuildRequires:   GConf2-devel >= 1.2.1}
+%{?with_gnomevfs:BuildRequires:        GConf2-devel >= 1.2.1}
 BuildRequires: automake
 BuildRequires: cairo-devel >= 1.0.0
-%{?with_gnome:BuildRequires:   gnome-vfs2-devel >= 2.0}
+%{?with_gnomevfs:BuildRequires:        gnome-vfs2-devel >= 2.0}
 BuildRequires: gtk+2-devel >= 1:2.0.0
 BuildRequires: krb5-devel
 BuildRequires: libIDL-devel >= 0.8.0
-%{?with_gnome:BuildRequires:   libgnome-devel >= 2.0}
-%{?with_gnome:BuildRequires:   libgnomeui-devel >= 2.2.0}
+%{?with_gnomevfs:BuildRequires:        libgnome-devel >= 2.0}
+%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
 BuildRequires: libjpeg-devel >= 6b
 BuildRequires: libpng-devel >= 1.2.7
 BuildRequires: libstdc++-devel
 BuildRequires: myspell-devel
 BuildRequires: nspr-devel >= 1:4.6.3
 BuildRequires: nss-devel >= 1:3.11.3-3
-%{?with_tidy:BuildRequires:    opensp-devel}
+%{?with_tidy:BuildRequires:    opensp-devel >= 2:1.5.2-4}
 BuildRequires: pango-devel >= 1:1.6.0
 BuildRequires: perl-modules >= 5.004
 BuildRequires: pkgconfig
@@ -103,12 +109,32 @@ Firefox Community Edition shared libraries.
 %description libs -l pl.UTF-8
 Biblioteki współdzielone przeglądarki Firefox Community Edition.
 
+%package addon-tidy
+Summary:       HTML Validator for Firefox
+Summary(pl.UTF-8):     Narzędzie do sprawdzania poprawności HTML-a dla Firefoksa
+Version:       %{tidy_ver}
+License:       GPL
+Group:         X11/Applications/Networking
+URL:           http://users.skynet.be/mgueury/mozilla/
+Requires:      %{name} = %{firefox_ver}-%{release}
+
+%description addon-tidy
+HTML Validator is a Mozilla extension that adds HTML validation inside
+Firefox. The number of errors of a HTML page is seen on the form of an
+icon in the status bar when browsing.
+
+%description addon-tidy -l pl.UTF-8
+HTML Validator to rozszerzenie Mozilli dodające sprawdzanie
+poprawności HTML-a w Firefoksie. Liczbę błędów na przeglądanej stronie
+HTML można zobaczyć w postaci ikony na pasku stanu.
+
 %package lang-en
 Summary:       English resources for Firefox Community Edition
 Summary(pl.UTF-8):     Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition
+Version:       %{firefox_ver}
 Group:         X11/Applications/Networking
-Requires:      %{name} = %{version}-%{release}
-Provides:      %{name}-lang-resources = %{version}-%{release}
+Requires:      %{name} = %{firefox_ver}-%{release}
+Provides:      %{name}-lang-resources = %{firefox_ver}-%{release}
 
 %description lang-en
 English resources for Firefox Community Edition.
@@ -129,8 +155,8 @@ cd mozilla
 %{?with_tidy:%patch2 -p1}
 %patch3 -p1
 %patch5 -p1
+%patch6 -p1
 %patch7 -p1
-%patch69 -p1
 
 # use system
 #rm -rf mozilla/nsprpub mozilla/security/nss
@@ -177,13 +203,16 @@ ac_add_options --enable-tests
 %else
 ac_add_options --disable-tests
 %endif
-%if %{with gnome}
-ac_add_options --enable-gnomevfs
+%if %{with gnomeui}
 ac_add_options --enable-gnomeui
 %else
-ac_add_options --disable-gnomevfs
 ac_add_options --disable-gnomeui
 %endif
+%if %{with gnomevfs}
+ac_add_options --enable-gnomevfs
+%else
+ac_add_options --disable-gnomevfs
+%endif
 ac_add_options --disable-freetype2
 ac_add_options --disable-installer
 ac_add_options --disable-javaxpcom
@@ -261,6 +290,7 @@ touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
 
 # what's this? it's content is invalid anyway.
 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
 
 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
 #!/bin/sh
@@ -335,17 +365,17 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/components/libgkplugin.so
 %attr(755,root,root) %{_libdir}/%{name}/components/libhtmlpars.so
 %attr(755,root,root) %{_libdir}/%{name}/components/libi18n.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so
+%{?with_gnomeui:%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so}
 %attr(755,root,root) %{_libdir}/%{name}/components/libimglib2.so
 %attr(755,root,root) %{_libdir}/%{name}/components/libjar50.so
 %attr(755,root,root) %{_libdir}/%{name}/components/libjsd.so
 %attr(755,root,root) %{_libdir}/%{name}/components/libmork.so
 %attr(755,root,root) %{_libdir}/%{name}/components/libmozfind.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
+%{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so}
 %attr(755,root,root) %{_libdir}/%{name}/components/libmyspell.so
 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko2.so
 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko.so
-%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so
+%{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so}
 %attr(755,root,root) %{_libdir}/%{name}/components/libnsappshell.so
 %attr(755,root,root) %{_libdir}/%{name}/components/liboji.so
 %attr(755,root,root) %{_libdir}/%{name}/components/libpermissions.so
@@ -432,7 +462,7 @@ fi
 %{_libdir}/%{name}/components/gksvgrenderer.xpt
 %{_libdir}/%{name}/components/history.xpt
 %{_libdir}/%{name}/components/htmlparser.xpt
-%{_libdir}/%{name}/components/imgicon.xpt
+%{?with_gnomeui:%{_libdir}/%{name}/components/imgicon.xpt}
 %{_libdir}/%{name}/components/imglib2.xpt
 %{_libdir}/%{name}/components/inspector.xpt
 %{_libdir}/%{name}/components/intl.xpt
@@ -601,3 +631,10 @@ fi
 %defattr(644,root,root,755)
 %{_datadir}/%{name}/chrome/en-US.jar
 %{_datadir}/%{name}/chrome/en-US.manifest
+
+%if %{with tidy}
+%files addon-tidy
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/components/libnstidy.so
+%{_libdir}/%{name}/components/nstidy.xpt
+%endif
This page took 0.054543 seconds and 4 git commands to generate.