]> git.pld-linux.org Git - packages/firefox.git/blobdiff - mozilla-firefox.spec
- switch to heimdal kerberos
[packages/firefox.git] / mozilla-firefox.spec
index 37c69dc83a758550b7b81c4c6c63f8a4359701c1..54ceaf54f7fbbcd1baa1e50cd695a8fceba769fe 100644 (file)
+#
 # TODO:
 # - handle locales differently (runtime, since it's possible to do)
 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
 #   for hints how to make locales
-# - make it more pld-like (bookmarks, default page etc..)
-# - add dictionaries outside of mozilla
+# - (12:22:58)  patrys:  can you also move _libdir/mozilla-firefox to just _libdir/firefox?
+#   (12:23:25)  patrys:  it's not like we ship official firefox
+# - fix wrapper script to allow playing with profiles (must not use -remote)
 #
 # Conditional build:
-%bcond_with    tests   # enable tests (whatever they check)
-%bcond_without gnome   # disable all GNOME components (gnomevfs, gnome, gnomeui)
-#
+%bcond_with    tests           # enable tests (whatever they check)
+%bcond_without gnomeui         # disable gnomeui support
+%bcond_without gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
+%bcond_without gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
+%bcond_without kerberos        # disable krb5 support
+%bcond_with    xulrunner       # build with system xulrunner
+
+%if %{without gnome}
+%undefine      with_gnomeui
+%undefine      with_gnomevfs
+%endif
+
 Summary:       Firefox Community Edition web browser
 Summary(pl.UTF-8):     Firefox Community Edition - przeglądarka WWW
 Name:          mozilla-firefox
-Version:       2.0.0.1
-Release:       3.1
-License:       MPL/LGPL
+Version:       3.0.10
+Release:       1
+License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         X11/Applications/Networking
 Source0:       ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
-# Source0-md5: 7a1fc804ed735c5b7e9b1498bac8b5db
+# Source0-md5: 1012e835a5c130d18479bccdee240640
 Source1:       %{name}.desktop
 Source2:       %{name}.sh
-Patch0:                mozilla-install.patch
-Patch1:                %{name}-lib_path.patch
-Patch3:                %{name}-nopangoxft.patch
-Patch5:                %{name}-fonts.patch
-# if ac rebuild is needed...
-#PatchX:               %{name}-ac.patch
+Patch0:                %{name}-install.patch
+Patch1:                %{name}-gcc3.patch
+Patch2:                %{name}-agent.patch
+Patch3:                %{name}-agent-ac.patch
+Patch4:                %{name}-ti-agent.patch
+Patch5:                %{name}-branding.patch
+Patch6:                %{name}-prefs.patch
+Patch7:                %{name}-nss_cflags.patch
 URL:           http://www.mozilla.org/projects/firefox/
-%{?with_gnome:BuildRequires:   GConf2-devel >= 1.2.1}
+%{?with_gnomevfs:BuildRequires:        GConf2-devel >= 1.2.1}
 BuildRequires: automake
-BuildRequires: cairo-devel >= 1.0.0
-%{?with_gnome:BuildRequires:   gnome-vfs2-devel >= 2.0}
-BuildRequires: gtk+2-devel >= 1:2.0.0
-BuildRequires: heimdal-devel >= 0.7.1
+BuildRequires: cairo-devel >= 1.6.0
+BuildRequires: dbus-glib-devel >= 0.60
+BuildRequires: glib2-devel
+%{?with_gnomevfs:BuildRequires:        gnome-vfs2-devel >= 2.0}
+BuildRequires: gtk+2-devel >= 2:2.10
+%{?with_kerberos:BuildRequires:        heimdal-devel >= 0.7.1}
 BuildRequires: libIDL-devel >= 0.8.0
-%{?with_gnome:BuildRequires:   libgnome-devel >= 2.0}
-%{?with_gnome:BuildRequires:   libgnomeui-devel >= 2.2.0}
+%{?with_gnomevfs:BuildRequires:        libgnome-devel >= 2.0}
+%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
 BuildRequires: libjpeg-devel >= 6b
+BuildRequires: libpng(APNG)-devel >= 0.10
 BuildRequires: libpng-devel >= 1.2.7
 BuildRequires: libstdc++-devel
-BuildRequires: nspr-devel >= 1:4.6.3
-BuildRequires: nss-devel >= 1:3.11.3-3
-BuildRequires: pango-devel >= 1:1.6.0
+BuildRequires: nspr-devel >= 1:4.7
+BuildRequires: nss-devel >= 1:3.12-2
+BuildRequires: pango-devel >= 1:1.10.0
 BuildRequires: perl-modules >= 5.004
 BuildRequires: pkgconfig
-BuildRequires: rpmbuild(macros) >= 1.356
+BuildRequires: python-modules
+BuildRequires: sqlite3-devel >= 3.5.9
+BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpmbuild(macros) >= 1.453
+BuildRequires: startup-notification-devel
+%if "%{pld_release}" == "ac"
+BuildRequires: XFree86-devel
+%else
 BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXft-devel >= 2.1
 BuildRequires: xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXp-devel
 BuildRequires: xorg-lib-libXt-devel
+%endif
+%if %{with xulrunner}
+BuildRequires: xulrunner-devel >= 1.9-2
+%endif
 BuildRequires: zip
 BuildRequires: zlib-devel >= 1.2.3
 Requires(post):        mktemp >= 1.5-18
-Requires:      %{name}-lang-resources = %{version}
-Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
+%if %{without xulrunner}
 Requires:      browser-plugins >= 2.0
-Requires:      nspr >= 1:4.6.3
-Requires:      nss >= 1:3.11.3
+%endif
+Requires:      cairo >= 1.6.0
+Requires:      gtk+2 >= 2:2.10
+Requires:      libpng(APNG) >= 0.10
+Requires:      nspr >= 1:4.7
+Requires:      nss >= 1:3.12-2
+Requires:      pango >= 1:1.10.0
+Requires:      sqlite3 >= 3.5.9
+%if %{with xulrunner}
+%requires_eq_to        xulrunner xulrunner-devel
+%endif
 Provides:      wwwbrowser
 Obsoletes:     mozilla-firebird
+Obsoletes:     mozilla-firefox-lang-en < 2.0.0.8-3
+Obsoletes:     mozilla-firefox-libs
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# mozilla and firefox provide their own versions
-%define                _noautoreqdep           libgkgfx.so libgtkembedmoz.so libgtkxtbin.so libjsj.so libmozjs.so libxpcom.so libxpcom_compat.so libxpcom_core.so
-%define                _noautoprovfiles        %{_libdir}/%{name}/components
+# don't satisfy other packages (don't use %{name} here)
+%define                _noautoprovfiles        %{_libdir}/mozilla-firefox
+# and as we don't provide them, don't require either
+%define                _noautoreq      libmozjs.so libxpcom.so libxul.so libjemalloc.so
 
-%define                specflags       -fno-strict-aliasing -fno-tree-vrp
+%if "%{cc_version}" >= "3.4"
+%define                specflags       -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
+%else
+%define                specflags       -fno-strict-aliasing
+%endif
 
 %description
 Firefox Community Edition is an open-source web browser, designed for
 standards compliance, performance and portability.
 
 %description -l pl.UTF-8
-Firefox Community Edition jest open sourcową przeglądarką sieci WWW,
-stworzoną z myślą o zgodności ze standardami, wydajnością i
-przenośnością.
-
-%package libs
-Summary:       Firefox Community Edition shared libraries
-Summary(pl.UTF-8):     Biblioteki współdzielone przeglądarki Firefox Community Edition
-Group:         Libraries
-Conflicts:     mozilla-firefox < 2.0-1.4
-
-%description libs
-Firefox Community Edition shared libraries.
-
-%description libs -l pl.UTF-8
-Biblioteki współdzielone przeglądarki Firefox Community Edition.
-
-%package lang-en
-Summary:       English resources for Firefox Community Edition
-Summary(pl.UTF-8):     Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition
-Group:         X11/Applications/Networking
-Requires:      %{name} = %{version}-%{release}
-Provides:      %{name}-lang-resources = %{version}-%{release}
-
-%description lang-en
-English resources for Firefox Community Edition.
-
-%description lang-en -l pl.UTF-8
-Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition.
+Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
+zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
+o zgodności ze standardami, wydajnością i przenośnością.
 
 %prep
-%setup -qc
+%setup -qc -n %{name}-%{version}
 cd mozilla
 %patch0 -p1
-%patch1 -p1
+
+%if "%{cc_version}" < "3.4"
+%patch1 -p2
+%endif
+
+%if "%{pld_release}" == "th"
+%patch2 -p1
+%endif
+
+%if "%{pld_release}" == "ac"
 %patch3 -p1
-%patch5 -p1
+%endif
 
-sed -i 's/\(-lgss\)\(\W\)/\1disable\2/' configure
+%if "%{pld_release}" == "ti"
+%patch4 -p1
+%endif
 
-# use system
-#rm -rf mozilla/nsprpub mozilla/security/nss
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
 
 %build
 cd mozilla
-export CFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
-export CXXFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
-
 cp -f %{_datadir}/automake/config.* build/autoconf
 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
-cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
 
 cat << 'EOF' > .mozconfig
 . $topsrcdir/browser/config/mozconfig
 
+mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
+
 # Options for 'configure' (same as command-line options).
 ac_add_options --prefix=%{_prefix}
 ac_add_options --exec-prefix=%{_exec_prefix}
@@ -149,40 +176,52 @@ ac_add_options --enable-debugger-info-modules
 ac_add_options --enable-crash-on-assert
 %else
 ac_add_options --disable-debug
+ac_add_options --disable-debug-modules
 ac_add_options --disable-logging
-ac_add_options --enable-optimize="%{rpmcflags}"
+ac_add_options --enable-optimize="%{rpmcflags} -Os"
 %endif
 %if %{with tests}
 ac_add_options --enable-tests
 %else
 ac_add_options --disable-tests
 %endif
-%if %{with gnome}
-ac_add_options --enable-gnomevfs
+%if %{with gnomeui}
 ac_add_options --enable-gnomeui
 %else
-ac_add_options --disable-gnomevfs
 ac_add_options --disable-gnomeui
 %endif
-ac_add_options --disable-freetype2
+%if %{with gnomevfs}
+ac_add_options --enable-gnomevfs
+%else
+ac_add_options --disable-gnomevfs
+%endif
+ac_add_options --disable-crashreporter
 ac_add_options --disable-installer
 ac_add_options --disable-javaxpcom
 ac_add_options --disable-updater
-ac_add_options --enable-default-toolkit=gtk2
+ac_add_options --disable-strip
+ac_add_options --disable-xprint
+ac_add_options --enable-startup-notification
 ac_add_options --enable-svg
 ac_add_options --enable-system-cairo
-ac_add_options --enable-xft
+ac_add_options --enable-system-sqlite
+ac_add_options --enable-libxul
+ac_add_options --enable-xinerama
 ac_add_options --with-distribution-id=org.pld-linux
+%if %{with xulrunner}
+ac_add_options --with-libxul-sdk=%{_libdir}/xulrunner-sdk
+%endif
+ac_add_options --with-pthreads
+ac_add_options --with-system-jpeg
 ac_add_options --with-system-nspr
 ac_add_options --with-system-nss
-ac_add_options --with-system-zlib
-ac_add_options --with-system-jpeg
 ac_add_options --with-system-png
+ac_add_options --with-system-zlib
 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
-ac_cv_visibility_pragma=no
 EOF
 
 %{__make} -j1 -f client.mk build \
+       STRIP="/bin/true" \
        CC="%{__cc}" \
        CXX="%{__cxx}"
 
@@ -194,9 +233,11 @@ install -d \
        $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
        $RPM_BUILD_ROOT%{_datadir}/%{name}
 
+%if %{without xulrunner}
 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
+%endif
 
-%{__make} -C xpinstall/packager stage-package \
+%{__make} -C obj-%{_target_cpu}/browser/installer stage-package \
        DESTDIR=$RPM_BUILD_ROOT \
        MOZ_PKG_APPDIR=%{_libdir}/%{name} \
        PKG_SKIP_STRIP=1
@@ -204,34 +245,36 @@ install -d \
 # move arch independant ones to datadir
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries $RPM_BUILD_ROOT%{_datadir}/%{name}/dictionaries
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
+mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
+%if %{without xulrunner}
+mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
+mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
+%endif
 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
-ln -s ../../share/%{name}/dictionaries $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
-ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
+ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
-ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
-ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
+%if %{without xulrunner}
+ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
+ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
+%endif
+
+%if %{without xulrunner}
+rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
+ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
+%endif
 
 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
 ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
 
 install browser/base/branding/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
-
-# header/development files
-rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpidl
-rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_dump
-rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_link
+install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
 
 # files created by regxpcom and firefox -register
 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
@@ -239,6 +282,7 @@ touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
 
 # what's this? it's content is invalid anyway.
 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
 
 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
 #!/bin/sh
@@ -251,7 +295,7 @@ export HOME=$(mktemp -d)
 # also TMPDIR could be pointing to sudo user's homedir
 unset TMPDIR TMP || :
 
-LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
+#LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
 %{_libdir}/%{name}/firefox -register
 
 rm -rf $HOME
@@ -260,8 +304,11 @@ EOF
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%pre
-for d in chrome defaults dictionaries extensions greprefs icons init.d res searchplugins; do
+%pretrans
+if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
+       mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
+fi
+for d in chrome defaults extensions greprefs icons res searchplugins; do
        if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
                install -d %{_datadir}/%{name}
                mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
@@ -271,12 +318,16 @@ exit 0
 
 %post
 %{_sbindir}/%{name}-chrome+xpcom-generate
+%if %{without xulrunner}
 %update_browser_plugins
+%endif
 
 %postun
+%if %{without xulrunner}
 if [ "$1" = 0 ]; then
        %update_browser_plugins
 fi
+%endif
 
 %files
 %defattr(644,root,root,755)
@@ -284,71 +335,144 @@ fi
 %attr(755,root,root) %{_bindir}/firefox
 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
 
+%if %{without xulrunner}
 # browser plugins v2
 %{_browserpluginsconfdir}/browsers.d/%{name}.*
 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
+%endif
+
+%dir %{_libdir}/%{name}
+%attr(755,root,root) %{_libdir}/%{name}/libjemalloc.so
+%if %{without xulrunner}
+%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
+%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
+%attr(755,root,root) %{_libdir}/%{name}/libxul.so
+%endif
+%{_libdir}/%{name}/blocklist.xml
+
+%if %{with crashreporter}
+%{_libdir}/%{name}/crashreporter
+%{_libdir}/%{name}/crashreporter-override.ini
+%{_libdir}/%{name}/crashreporter.ini
+%{_libdir}/%{name}/Throbber-small.gif
+%endif
+
+# config?
+%{_libdir}/%{name}/.autoreg
+%{_libdir}/%{name}/application.ini
 
 %dir %{_libdir}/%{name}/components
-%attr(755,root,root) %{_libdir}/%{name}/components/*.so
-%{_libdir}/%{name}/components/*.js
-%{_libdir}/%{name}/components/*.xpt
+
+%{_libdir}/%{name}/components/aboutRights.js
+%{_libdir}/%{name}/components/aboutRobots.js
+%{_libdir}/%{name}/components/FeedConverter.js
+%{_libdir}/%{name}/components/FeedWriter.js
+%{_libdir}/%{name}/components/WebContentConverter.js
+%{_libdir}/%{name}/components/browser.xpt
+%{_libdir}/%{name}/components/fuelApplication.js
+%{_libdir}/%{name}/components/nsBrowserContentHandler.js
+%{_libdir}/%{name}/components/nsBrowserGlue.js
+%{_libdir}/%{name}/components/nsMicrosummaryService.js
+%{_libdir}/%{name}/components/nsPlacesTransactionsService.js
+%{_libdir}/%{name}/components/nsSafebrowsingApplication.js
+%{_libdir}/%{name}/components/nsSearchService.js
+%{_libdir}/%{name}/components/nsSearchSuggestions.js
+%{_libdir}/%{name}/components/nsSessionStartup.js
+%{_libdir}/%{name}/components/nsSessionStore.js
+%{_libdir}/%{name}/components/nsSetDefaultBrowser.js
+%{_libdir}/%{name}/components/nsSidebar.js
+%if %{without xulrunner}
+%{_libdir}/%{name}/platform.ini
+%{_libdir}/%{name}/components/FeedProcessor.js
+%{_libdir}/%{name}/components/jsconsole-clhandler.js
+%{_libdir}/%{name}/components/nsAddonRepository.js
+%{_libdir}/%{name}/components/nsBadCertHandler.js
+%{_libdir}/%{name}/components/nsBlocklistService.js
+%{_libdir}/%{name}/components/nsContentDispatchChooser.js
+%{_libdir}/%{name}/components/nsContentPrefService.js
+%{_libdir}/%{name}/components/nsDefaultCLH.js
+%{_libdir}/%{name}/components/nsDownloadManagerUI.js
+%{_libdir}/%{name}/components/nsExtensionManager.js
+%{_libdir}/%{name}/components/nsFilePicker.js
+%{_libdir}/%{name}/components/nsHandlerService.js
+%{_libdir}/%{name}/components/nsHelperAppDlg.js
+%{_libdir}/%{name}/components/nsLivemarkService.js
+%{_libdir}/%{name}/components/nsLoginInfo.js
+%{_libdir}/%{name}/components/nsLoginManager.js
+%{_libdir}/%{name}/components/nsLoginManagerPrompter.js
+%{_libdir}/%{name}/components/nsProxyAutoConfig.js
+%{_libdir}/%{name}/components/nsTaggingService.js
+%{_libdir}/%{name}/components/nsTryToClose.js
+%{_libdir}/%{name}/components/nsURLFormatter.js
+%{_libdir}/%{name}/components/nsUpdateService.js
+%{_libdir}/%{name}/components/nsUrlClassifierLib.js
+%{_libdir}/%{name}/components/nsUrlClassifierListManager.js
+%{_libdir}/%{name}/components/nsWebHandlerApp.js
+%{_libdir}/%{name}/components/pluginGlue.js
+%{_libdir}/%{name}/components/storage-Legacy.js
+%{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
+%endif
+
+%attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
+%attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
+%if %{without xulrunner}
+%attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
+%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so
+%endif
+
+%if %{with gnomevfs}
+%if %{without xulrunner}
+%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
+%endif
+%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so
+%endif
+
+%attr(755,root,root) %{_libdir}/%{name}/*.sh
+%attr(755,root,root) %{_libdir}/%{name}/firefox
+%if %{without xulrunner}
+%attr(755,root,root) %{_libdir}/%{name}/firefox-bin
 %dir %{_libdir}/%{name}/plugins
 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
-%attr(755,root,root) %{_libdir}/%{name}/*.sh
-%attr(755,root,root) %{_libdir}/%{name}/m*
-%attr(755,root,root) %{_libdir}/%{name}/f*
-%attr(755,root,root) %{_libdir}/%{name}/regxpcom
-%attr(755,root,root) %{_libdir}/%{name}/xpcshell
-%attr(755,root,root) %{_libdir}/%{name}/xpicleanup
+%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
+%endif
 %{_pixmapsdir}/mozilla-firefox.png
 %{_desktopdir}/mozilla-firefox.desktop
 
 # symlinks
 %{_libdir}/%{name}/chrome
 %{_libdir}/%{name}/defaults
-%{_libdir}/%{name}/dictionaries
 %{_libdir}/%{name}/extensions
-%{_libdir}/%{name}/greprefs
 %{_libdir}/%{name}/icons
-%{_libdir}/%{name}/init.d
-%{_libdir}/%{name}/res
+%{_libdir}/%{name}/modules
 %{_libdir}/%{name}/searchplugins
+%if %{without xulrunner}
+%{_libdir}/%{name}/dictionaries
+%{_libdir}/%{name}/greprefs
+%{_libdir}/%{name}/res
+%endif
 
 # browserconfig
 %{_libdir}/%{name}/browserconfig.properties
 
-%{_libdir}/%{name}/LICENSE
 %{_libdir}/%{name}/README.txt
 
 %dir %{_datadir}/%{name}
 %{_datadir}/%{name}/chrome
 %{_datadir}/%{name}/defaults
-%{_datadir}/%{name}/dictionaries
-%{_datadir}/%{name}/greprefs
 %{_datadir}/%{name}/icons
-%{_datadir}/%{name}/init.d
-%{_datadir}/%{name}/res
+%{_datadir}/%{name}/modules
 %{_datadir}/%{name}/searchplugins
+%if %{without xulrunner}
+%{_datadir}/%{name}/greprefs
+%{_datadir}/%{name}/res
+%endif
 
 %dir %{_datadir}/%{name}/extensions
 # -dom-inspector subpackage?
-%{_datadir}/%{name}/extensions/inspector@mozilla.org
+#%{_datadir}/%{name}/extensions/inspector@mozilla.org
 # the signature of the default theme
 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
 
 # files created by regxpcom and firefox -register
 %ghost %{_libdir}/%{name}/components/compreg.dat
 %ghost %{_libdir}/%{name}/components/xpti.dat
-
-%files libs
-%defattr(644,root,root,755)
-%dir %{_libdir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}/*.so
-
-%files lang-en
-%defattr(644,root,root,755)
-%{_datadir}/%{name}/chrome/en-US.jar
-%{_datadir}/%{name}/chrome/en-US.manifest
-# probably should share these with all mozilla apps
-%{_datadir}/%{name}/dictionaries/en-US.aff
-%{_datadir}/%{name}/dictionaries/en-US.dic
This page took 0.077671 seconds and 4 git commands to generate.