]> git.pld-linux.org Git - packages/firefox.git/blobdiff - mozilla-firefox.spec
- if you want to use compiler specific options, don't use them unconditionally
[packages/firefox.git] / mozilla-firefox.spec
index 081eebe53bf9c6c168263a7f63e271c7c882177f..33baa97f6b321db981b2d3124b61e1c02ea76de3 100644 (file)
@@ -1,9 +1,15 @@
 #
 # TODO:
+# - with new gcc version (it is possible that)
+#   - -fvisibility=hiddenn and ac_cv_visibility_pragma=no can be removed
+# - with new firefox version (it is possible that)
+#   - -fno-strict-aliasing can be removed (needs to be tested carefuly,
+#      not to be fixed soon, imho)
 # - handle locales differently (runtime, since it's possible to do)
 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
 #   for hints how to make locales and other stuff like extensions working
 # - rpm upgrade is broken. First you need uninstall Firefox 1.0.x.
+#
 # Conditional build:
 %bcond_with    tests   # enable tests (whatever they check)
 %bcond_without gnome   # disable all GNOME components (gnomevfs, gnome, gnomeui)
@@ -12,7 +18,7 @@ Summary:      Mozilla Firefox web browser
 Summary(pl):   Mozilla Firefox - przeglĀ±darka WWW
 Name:          mozilla-firefox
 Version:       1.5.0.1
-Release:       1
+Release:       2
 License:       MPL/LGPL
 Group:         X11/Applications/Networking
 Source0:       ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
@@ -24,6 +30,8 @@ Patch1:               %{name}-lib_path.patch
 Patch2:                %{name}-nss-system-nspr.patch
 Patch3:                %{name}-nopangoxft.patch
 Patch4:                %{name}-name.patch
+Patch5:                %{name}-dumpstack.patch
+Patch6:                %{name}-pango-typo.patch
 # UPDATE or DROP?
 #PatchX:       %{name}-searchplugins.patch
 URL:           http://www.mozilla.org/projects/firefox/
@@ -48,9 +56,6 @@ BuildRequires:        zip
 Requires:      %{name}-lang-resources = %{version}
 Requires:      nspr >= 1:4.6.1
 Requires:      nss >= 3.10.2
-# for /etc/ld.so.conf.d
-Requires:      glibc >= 6:2.3.5-7.6
-Requires(post,postun): /sbin/ldconfig
 Provides:      wwwbrowser
 Obsoletes:     mozilla-firebird
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -104,6 +109,8 @@ Angloj
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p0
+%patch6 -p0
 
 sed -i 's/\(-lgss\)\(\W\)/\1disable\2/' configure
 
@@ -183,7 +190,7 @@ ac_add_options --with-system-zlib
 EOF
 
 %{__make} -j1 -f client.mk build \
-       CC="%{__cc}" \
+       CC="%{__cc} -fno-strict-aliasing" \
        CXX="%{__cxx}"
 
 %install
@@ -199,7 +206,7 @@ install -d \
        MOZILLA_BIN="\$(DIST)/bin/firefox-bin" \
        EXCLUDE_NSPR_LIBS=1
 
-install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
+sed 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
 
 tar -xvz -C $RPM_BUILD_ROOT%{_libdir} -f dist/mozilla-firefox-*linux*.tar.gz
 
@@ -209,9 +216,6 @@ install other-licenses/branding/firefox/content/icon64.png $RPM_BUILD_ROOT%{_pix
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
 
-#grep locale $RPM_BUILD_ROOT%{_firefoxdir}/chrome/installed-chrome.txt > $RPM_BUILD_ROOT%{_firefoxdir}/chrome/%{name}-en-US-installed-chrome.txt
-#grep -v locale $RPM_BUILD_ROOT%{_firefoxdir}/chrome/installed-chrome.txt > $RPM_BUILD_ROOT%{_firefoxdir}/chrome/%{name}-misc-installed-chrome.txt
-
 rm -rf US classic comm embed-sample en-{US,mac,unix,win} modern pipnss pippki
 rm -f en-win.jar en-mac.jar embed-sample.jar modern.jar
 
@@ -249,8 +253,6 @@ sed -i -e '/Cflags:/{/{includedir}\/dom/!s,$, -I${includedir}/dom,}' \
 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/firefox-chrome+xpcom-generate
 #!/bin/sh
 umask 022
-#There is no such files (*-installed-chrome.txt). IMO obsolete.
-#cat %{_firefoxdir}/chrome/*-installed-chrome.txt > %{_firefoxdir}/chrome/installed-chrome.txt
 rm -f %{_firefoxdir}/chrome/{chrome.rdf,overlayinfo/*/*/*.rdf}
 rm -f %{_firefoxdir}/components/{compreg,xpti}.dat
 MOZILLA_FIVE_HOME=%{_firefoxdir}
@@ -273,7 +275,6 @@ EOF
 rm -rf $RPM_BUILD_ROOT
 
 %post
-/sbin/ldconfig
 %{_sbindir}/firefox-chrome+xpcom-generate
 %banner %{name} -e <<EOF
 ###################################################################
@@ -286,7 +287,6 @@ rm -rf $RPM_BUILD_ROOT
 EOF
 
 %postun
-/sbin/ldconfig
 if [ "$1" != "0" ]; then
        %{_sbindir}/firefox-chrome+xpcom-generate
 fi
@@ -299,14 +299,6 @@ if [ "$1" == "0" ]; then
        rm -rf %{_firefoxdir}/extensions
 fi
 
-#%post lang-en
-#umask 022
-#cat %{_firefoxdir}/chrome/*-installed-chrome.txt >%{_firefoxdir}/chrome/installed-chrome.txt
-
-#%postun lang-en
-#umask 022
-#cat %{_firefoxdir}/chrome/*-installed-chrome.txt >%{_firefoxdir}/chrome/installed-chrome.txt
-
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/mozilla*
@@ -341,7 +333,6 @@ fi
 #%{_firefoxdir}/chrome/content-packs.jar
 # -dom-inspector subpackage?
 #%{_firefoxdir}/chrome/inspector.jar
-#%{_firefoxdir}/chrome/mozilla-firefox-misc-installed-chrome.txt
 %dir %{_firefoxdir}/chrome/icons
 %{_firefoxdir}/chrome/icons/default
 
@@ -358,4 +349,3 @@ fi
 %defattr(644,root,root,755)
 %{_firefoxdir}/chrome/en-US.jar
 %{_firefoxdir}/chrome/en-US.manifest
-#%{_firefoxdir}/chrome/mozilla-firefox-en-US-installed-chrome.txt
This page took 0.045098 seconds and 4 git commands to generate.