]> git.pld-linux.org Git - packages/firefox.git/blobdiff - mozilla-firefox.spec
- play with official firefox build method
[packages/firefox.git] / mozilla-firefox.spec
index b84ecfff8c059fcb3e270290154aab9bab58979c..0a0eb7ea8f75646c9ee92638c549a8e1093259ba 100644 (file)
@@ -3,20 +3,32 @@
 # - handle locales differently (runtime, since it's possible to do)
 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
 #   for hints how to make locales and other stuff like extensions working
+# - unpackaged files check
+#   /usr/lib/mozilla-firefox/LICENSE
+#   /usr/lib/mozilla-firefox/README.txt
+#   /usr/lib/mozilla-firefox/browserconfig.properties
+#   /usr/lib/mozilla-firefox/chrome/chatzilla.jar
+#   /usr/lib/mozilla-firefox/chrome/chromelist.txt
+#   /usr/lib/mozilla-firefox/chrome/content-packs.jar
+#   /usr/lib/mozilla-firefox/chrome/embed-sample.jar
+#   /usr/lib/mozilla-firefox/chrome/installed-chrome.txt
+#   /usr/lib/mozilla-firefox/components/myspell/en-US.aff
+#   /usr/lib/mozilla-firefox/components/myspell/en-US.dic
+#   /usr/lib/mozilla-firefox/init.d/README
 #
 # Conditional build:
 %bcond_with    tests   # enable tests (whatever they check)
-%bcond_with    ft218   # compile with freetype >= 2.1.8
+%bcond_without ft218   # compile with freetype < 2.1.8
 #
 Summary:       Mozilla Firefox web browser
 Summary(pl):   Mozilla Firefox - przegl±darka WWW
 Name:          mozilla-firefox
-Version:       1.0.4
-Release:       6
+Version:       1.0.7
+Release:       0.1
 License:       MPL/LGPL
 Group:         X11/Applications/Networking
 Source0:       http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
-# Source0-md5: 0f5d0586750fde79ba98ecf3ee4425a7
+# Source0-md5: 5704a8c36de84b408e069afb0c5bc1df
 Source1:       %{name}.desktop
 Source2:       %{name}.sh
 Patch0:                %{name}-alpha-gcc3.patch
@@ -25,6 +37,7 @@ Patch2:               %{name}-nss.patch
 Patch3:                %{name}-lib_path.patch
 Patch4:                %{name}-freetype.patch
 Patch5:                %{name}-searchplugins.patch
+Patch6:                %{name}-gcc-bugs.patch
 URL:           http://www.mozilla.org/projects/firefox/
 BuildRequires: automake
 %if %{with ft218}
@@ -35,6 +48,7 @@ BuildRequires:        freetype-devel < 1:2.1.8
 BuildConflicts:        freetype-devel = 2.1.8
 %endif
 BuildRequires: gtk+2-devel >= 1:2.0.0
+BuildRequires: heimdal-devel >= 0.7
 BuildRequires: libIDL-devel >= 0.8.0
 BuildRequires: libjpeg-devel >= 6b
 BuildRequires: libpng-devel >= 1.2.0
@@ -45,7 +59,6 @@ BuildRequires:        pango-devel >= 1:1.1.0
 BuildRequires: perl-modules
 BuildRequires: pkgconfig
 BuildRequires: zip
-BuildRequires:  heimdal-devel >= 0.7
 Requires:      %{name}-lang-resources = %{version}
 %if %{with ft218}
 Requires:      freetype >= 1:2.1.3
@@ -101,70 +114,84 @@ English resources for Mozilla-firefox
 Anglojêzyczne zasoby dla Mozilla-FireFox
 
 %prep
-%setup -q -n mozilla
+%setup -q -c
+cd mozilla
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %{?with_ft218:%patch4 -p1}
 %patch5 -p0
+%patch6 -p0
 sed -i 's/\(-lgss\)\(\W\)/\1disable\2/' configure
 
 %build
-export CFLAGS="%{rpmcflags}"
-export CXXFLAGS="%{rpmcflags}"
-export MOZ_PHOENIX="1"
-export BUILD_OFFICIAL="1"
-export MOZILLA_OFFICIAL="1"
+cd mozilla
+rm -f .mozconfig
+export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
+export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
 
 cp -f %{_datadir}/automake/config.* build/autoconf
 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
-%configure2_13 \
+
+LIBIDL_CONFIG="%{_bindir}/libIDL-config-2"; export LIBIDL_CONFIG
+
+echo << EOF > .mozconfig
+. $topsrcdir/browser/config/mozconfig
+
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+mk_add_options BUILD_OFFICIAL=1
+mk_add_options MOZILLA_OFFICIAL=1
+
+ac_add_options --enable-optimize="%{rpmcflags}"
 %if %{?debug:1}0
-       --enable-debug \
-       --enable-debug-modules \
+ac_add_options --disable-debug
+ac_add_options --disable-debug-modules
 %else
-       --disable-debug \
-       --disable-debug-modules \
+ac_add_options --enable-debug
+ac_add_options --enable-debug-modules
 %endif
-       --disable-composer \
-       --disable-dtd-debug \
-       --disable-installer \
-       --disable-jsd \
-       --disable-ldap \
-       --disable-mailnews \
 %if %{with tests}
-       --enable-tests \
+ac_add_options --enable-tests
 %else
-       --disable-tests \
+ac_add_options --disable-tests
 %endif
-       --disable-xprint \
-       --enable-crypto \
-       --enable-freetype2 \
-       --enable-mathml \
-       --enable-optimize="%{rpmcflags}" \
-       --enable-plaintext-editor-only \
-       --enable-reorder \
-       --enable-strip \
-       --enable-strip-libs \
-       --enable-xinerama \
-       --enable-xft \
-       --enable-default-toolkit="gtk2" \
-       --with-pthreads \
-       --with-system-nspr \
-       --with-system-jpeg \
-       --with-system-png \
-       --with-system-zlib \
-       --enable-single-profile \
-       --disable-profilesharing \
-       --enable-extensions=cookie,xml-rpc,xmlextras,pref,transformiix,universalchardet,webservices,inspector,gnomevfs,negotiateauth
-       
+ac_add_options --disable-composer
+ac_add_options --disable-dtd-debug
+ac_add_options --disable-installer
+ac_add_options --disable-jsd
+ac_add_options --disable-ldap
+ac_add_options --disable-mailnews
+ac_add_options --disable-xprint
+ac_add_options --disable-profilesharing
+ac_add_options --enable-xpctools
+ac_add_options --enable-native-uconv
+ac_add_options --enable-crypto
+ac_add_options --enable-freetype2
+ac_add_options --enable-mathml
+ac_add_options --enable-reorder
+ac_add_options --enable-strip
+ac_add_options --enable-strip-libs
+ac_add_options --enable-xinerama
+ac_add_options --enable-xft
+ac_add_options --enable-default-toolkit=gtk2
+ac_add_options --with-pthreads
+ac_add_options --with-system-nspr
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-png
+ac_add_options --with-system-zlib
+ac_add_options --enable-single-profile
+EOF
 
-%{__make}
+%{__make} -f client.mk build \
+       CC="%{__cc}" \
+       CXX="%{__cxx}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
+cd mozilla
 install -d \
        $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
        $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
This page took 0.088834 seconds and 4 git commands to generate.