]> git.pld-linux.org Git - packages/firefox.git/blobdiff - mozilla-firefox-install.patch
- up to 19.0, further sync with iceweasel
[packages/firefox.git] / mozilla-firefox-install.patch
index 8625747b95d784282baf051954931d29cfc4c258..22a3807dc0441a9fd909e00f7ad9cda1050997a9 100644 (file)
@@ -1,11 +1,11 @@
 --- mozilla/browser/app/Makefile.in    2008-06-22 22:54:03.000000000 +0200
 +++ mozilla/browser/app/Makefile.in    2008-06-23 10:34:59.000000000 +0200
 @@ -397,7 +397,7 @@
-       rsync -a $(DIST)/bin/ $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/$(APPFILES)
-       $(RM) $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/$(APPFILES)/mangle $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/$(APPFILES)/shlibsign
+       sed -e "s/%MAC_APP_NAME%/$(MAC_APP_NAME)/" $(srcdir)/macbuild/Contents/Resources/English.lproj/InfoPlist.strings.in | iconv -f UTF-8 -t UTF-16 > $(dist_dest)/Contents/Resources/$(AB).lproj/InfoPlist.strings
+       rsync -a $(DIST)/bin/ $(dist_dest)/Contents/$(APPFILES)
  ifdef LIBXUL_SDK
--      cp $(LIBXUL_DIST)/bin/$(XR_STUB_NAME) $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/MacOS/firefox
-+      cp $(LIBXUL_DIST)/bin/$(XR_STUB_NAME) $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/MacOS/$(MOZ_APP_NAME)
+-      cp $(LIBXUL_DIST)/bin/$(XR_STUB_NAME) $(dist_dest)/Contents/MacOS/firefox
++      cp $(LIBXUL_DIST)/bin/$(XR_STUB_NAME) $(dist_dest)/Contents/MacOS/$(MOZ_APP_NAME)
  else
        rm -f $(DIST)/$(APP_NAME).app/Contents/MacOS/$(PROGRAM)
        rsync -aL $(PROGRAM) $(DIST)/$(APP_NAME).app/Contents/MacOS
  endif
  
 @@ -433,7 +433,7 @@
-       rsync -a --copy-unsafe-links $(LIBXUL_DIST)/XUL.framework $(DIST)/$(APP_NAME).app/Contents/Frameworks
+       rsync -a --copy-unsafe-links $(LIBXUL_DIST)/XUL.framework $(dist_dest)/Contents/Frameworks
  else
        $(NSINSTALL) -D $(DIST)/bin/xulrunner
 -      (cd $(LIBXUL_SDK)/bin && tar $(TAR_CREATE_FLAGS) - .) | (cd $(DIST)/bin/xulrunner && tar -xf -)
 +      cp -rfRp $(LIBXUL_SDK)/bin $(DIST)/bin/xulrunner
- endif # cocoa
- endif # SKIP_COPY_XULRUNNER
- endif # LIBXUL_SDK
+ endif #} cocoa
+ endif #} SKIP_COPY_XULRUNNER
+ endif #} LIBXUL_SDK
 --- mozilla/toolkit/mozapps/installer/packager.mk.orig 2011-03-19 00:34:12.000000000 +0100
 +++ mozilla/toolkit/mozapps/installer/packager.mk      2011-03-22 23:53:43.877485659 +0100
-@@ -708,30 +708,30 @@
+@@ -708,41 +708,41 @@
  endif
  
- stage-package: $(MOZ_PKG_MANIFEST) $(MOZ_PKG_REMOVALS_GEN) elfhack
--      @rm -rf $(DIST)/$(MOZ_PKG_DIR) $(DIST)/$(PKG_PATH)$(PKG_BASENAME).tar $(DIST)/$(PKG_PATH)$(PKG_BASENAME).dmg $@ $(EXCLUDE_LIST)
-+      @rm -rf $(DESTDIR)/$(MOZ_PKG_DIR) $(DIST)/$(PKG_PATH)$(PKG_BASENAME).tar $(DIST)/$(PKG_PATH)$(PKG_BASENAME).dmg $@ $(EXCLUDE_LIST)
+ stage-package: $(MOZ_PKG_MANIFEST) $(MOZ_PKG_REMOVALS_GEN)
+-      @rm -rf $(DIST)/$(PKG_PATH)$(PKG_BASENAME).tar $(DIST)/$(PKG_PATH)$(PKG_BASENAME).dmg $@ $(EXCLUDE_LIST)
++      @rm -rf $(DIST)/$(PKG_PATH)$(PKG_BASENAME).tar $(DIST)/$(PKG_PATH)$(PKG_BASENAME).dmg $@ $(EXCLUDE_LIST)
+ ifndef MOZ_FAST_PACKAGE
+-      @rm -rf $(DIST)/$(MOZ_PKG_DIR)
++      @rm -rf $(DESTDIR)/$(MOZ_PKG_DIR)
+ endif
  # NOTE: this must be a tar now that dist links into the tree so that we
  # do not strip the binaries actually in the tree.
        @echo "Creating package directory..."
--      @mkdir $(DIST)/$(MOZ_PKG_DIR)
-+      @mkdir -p $(DESTDIR)/$(MOZ_PKG_DIR)
+-      if ! test -d $(DIST)/$(MOZ_PKG_DIR) ; then \
+-              mkdir $(DIST)/$(MOZ_PKG_DIR); \
++      if ! test -d $(DESTDIR)/$(MOZ_PKG_DIR) ; then \
++              mkdir -p $(DESTDIR)/$(MOZ_PKG_DIR); \
+       fi
  ifndef UNIVERSAL_BINARY
  # If UNIVERSAL_BINARY, the package will be made from an already-prepared
  # STAGEPATH
  ifdef MOZ_PKG_MANIFEST
+ ifndef MOZ_FAST_PACKAGE
        $(RM) -rf $(DIST)/xpt $(DIST)/manifests
+ endif
        $(call PACKAGER_COPY, "$(call core_abspath,$(DIST))",\
 -        "$(call core_abspath,$(DIST)/$(MOZ_PKG_DIR))", \
 +        "$(call core_abspath,$(DESTDIR)/$(MOZ_PKG_DIR))", \
 -        $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome/localized.manifest \
 +        $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome/localized.manifest \
          $(patsubst %,$(DIST)/manifests/%/chrome,$(MOZ_LOCALIZED_PKG_LIST))
+ ifdef MOZ_WEBAPP_RUNTIME
+-      mv $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/webapprt/chrome/$(AB_CD).manifest $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/webapprt/chrome/localized.manifest
+-      sed 's/$(AB_CD)/localized/' $(DIST)/bin/webapprt/chrome.manifest > $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/webapprt/chrome.manifest
++      mv $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/webapprt/chrome/$(AB_CD).manifest $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/webapprt/chrome/localized.manifest
++      sed 's/$(AB_CD)/localized/' $(DIST)/bin/webapprt/chrome.manifest > $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/webapprt/chrome.manifest
+ endif
 -      printf "manifest components/interfaces.manifest\nmanifest components/components.manifest\nmanifest chrome/nonlocalized.manifest\nmanifest chrome/localized.manifest\n" > $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome.manifest
 +      printf "manifest components/interfaces.manifest\nmanifest components/components.manifest\nmanifest chrome/nonlocalized.manifest\nmanifest chrome/localized.manifest\n" > $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome.manifest
  else # !MOZ_PKG_MANIFEST
- ifeq ($(MOZ_PKG_FORMAT),DMG)
+ ifeq ($(MOZ_WIDGET_TOOLKIT),cocoa)
  ifndef STAGE_SDK
 @@ -741,10 +741,10 @@
        @$(NSINSTALL) -D $(DIST)/xpt
        cd $(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)$(_BINPATH) && $(PACK_OMNIJAR)
  endif
        $(NSINSTALL) -D $(DESTDIR)$(installdir)
--      (cd $(DIST)/$(MOZ_PKG_DIR) && tar $(TAR_CREATE_FLAGS) - .) | \
-+      (cd $(DESTDIR)/$(MOZ_PKG_DIR) && tar $(TAR_CREATE_FLAGS) - .) | \
+-      (cd $(DIST)/$(MOZ_PKG_DIR) && tar --exclude=precomplete $(TAR_CREATE_FLAGS) - .) | \
++      (cd $(DESTDIR)/$(MOZ_PKG_DIR) && tar --exclude=precomplete $(TAR_CREATE_FLAGS) - .) | \
          (cd $(DESTDIR)$(installdir) && tar -xf -)
        $(NSINSTALL) -D $(DESTDIR)$(bindir)
        $(RM) -f $(DESTDIR)$(bindir)/$(MOZ_APP_NAME)
This page took 0.041313 seconds and 4 git commands to generate.