]> git.pld-linux.org Git - packages/firefox.git/blobdiff - firefox.spec
- typo
[packages/firefox.git] / firefox.spec
index df6ea8226058ef7db0472e9991f2b173ac43ae46..b73f666bef4d006b677a9bbe98879e3f6055ba66 100644 (file)
@@ -10,6 +10,7 @@
 # - disabled shared_js - https://bugzilla.mozilla.org/show_bug.cgi?id=1039964
 %bcond_with    shared_js       # shared libmozjs library [broken]
 %bcond_without system_icu      # build without system ICU
+%bcond_with    clang           # build using Clang/LLVM
 
 # On updating version, grab CVE links from:
 # https://www.mozilla.org/security/known-vulnerabilities/firefox.html
@@ -150,6 +151,10 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
 
+%if %{with clang}
+%define                filterout               -fvar-tracking-assignments
+%endif
+
 # don't satisfy other packages
 %define                _noautoprovfiles        %{_libdir}/%{name}
 
@@ -213,8 +218,13 @@ cp -p %{_datadir}/automake/config.* build/autoconf
 cat << 'EOF' > .mozconfig
 . $topsrcdir/browser/config/mozconfig
 
+%if %{with clang}
+export CC="clang"
+export CXX="clang++"
+%else
 export CC="%{__cc}"
 export CXX="%{__cxx}"
+%endif
 export CFLAGS="%{rpmcflags} -D_FILE_OFFSET_BITS=64"
 export CXXFLAGS="%{rpmcxxflags} -D_FILE_OFFSET_BITS=64"
 
This page took 0.574961 seconds and 4 git commands to generate.