]> git.pld-linux.org Git - packages/firefox.git/blobdiff - firefox.spec
- added clang bcond (works for me)
[packages/firefox.git] / firefox.spec
index 8eabb54a59cf63a9e85768acee8f21512c2cd0d5..62c991bc3622fb35a18d43c9c0ad8d6dbf8380fe 100644 (file)
@@ -10,6 +10,7 @@
 # - disabled shared_js - https://bugzilla.mozilla.org/show_bug.cgi?id=1039964
 %bcond_with    shared_js       # shared libmozjs library [broken]
 %bcond_without system_icu      # build without system ICU
+%bcond_with    clang           # build using Clang/LLVM
 
 # On updating version, grab CVE links from:
 # https://www.mozilla.org/security/known-vulnerabilities/firefox.html
@@ -26,12 +27,12 @@ Summary:    Firefox web browser
 Summary(hu.UTF-8):     Firefox web böngésző
 Summary(pl.UTF-8):     Firefox - przeglądarka WWW
 Name:          firefox
-Version:       55.0.1
+Version:       55.0.2
 Release:       1
 License:       MPL v2.0
 Group:         X11/Applications/Networking
 Source0:       http://releases.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.xz
-# Source0-md5: 53debc4c7edfaf84b42f040872771d9d
+# Source0-md5: d1e65708db51034d2ad090b4bfba7f1c
 Source3:       %{name}.desktop
 Source4:       %{name}.sh
 Source5:       vendor.js
@@ -213,6 +214,13 @@ cp -p %{_datadir}/automake/config.* build/autoconf
 cat << 'EOF' > .mozconfig
 . $topsrcdir/browser/config/mozconfig
 
+%if %{with clang}
+export CC="clang"
+export CXX="clang++"
+%else
+export CC="%{__cc}"
+export CXX="%{__cxx}"
+%endif
 export CFLAGS="%{rpmcflags} -D_FILE_OFFSET_BITS=64"
 export CXXFLAGS="%{rpmcxxflags} -D_FILE_OFFSET_BITS=64"
 
This page took 0.351864 seconds and 4 git commands to generate.