]> git.pld-linux.org Git - packages/firefox.git/blobdiff - firefox.spec
define parallel jobs number also for clang (all cores by default)
[packages/firefox.git] / firefox.spec
index cd1229964e0d88b6c26f0bd96979b93c510088f8..b1ffa6c66f1a7c5c425381af079eda58531123dd 100644 (file)
@@ -2127,12 +2127,14 @@ EOF
 %if ! %{with clang}
 # On x86_64 architectures, Mozilla can build up to 4 jobs at once in parallel,
 # however builds tend to fail on other arches when building in parallel.
-RPM_BUILD_NR_THREADS=1
+MOZ_PARALLEL_BUILD=1
 %ifarch %{x8664}
-jobs=$(echo %{_smp_mflags} | cut -dj -f2)
-[ -n "$jobs" -a "$jobs" -gt 4 ] && RPM_BUILD_NR_THREADS=4 || RPM_BUILD_NR_THREADS="$jobs"
+jobs="%{__jobs}"
+[ -n "$jobs" -a "$jobs" -gt 4 ] && MOZ_PARALLEL_BUILD=4 || MOZ_PARALLEL_BUILD="$jobs"
 %endif
-export MOZ_MAKE_FLAGS="-j${RPM_BUILD_NR_THREADS}"
+export MOZ_PARALLEL_BUILD
+%else
+%{?__jobs:export MOZ_PARALLEL_BUILD="%__jobs"}
 %endif
 
 export MOZ_SERVICES_SYNC="1"
This page took 0.028567 seconds and 4 git commands to generate.