]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- moved lang-en subpackage after addon-tidy to workaround rpm determining
[packages/firefox.git] / mozilla-firefox.spec
1 # TODO:
2 # - handle locales differently (runtime, since it's possible to do)
3 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
4 #   for hints how to make locales
5 # - make it more pld-like (bookmarks, default page etc..)
6 #
7 # Conditional build:
8 %bcond_with     tests   # enable tests (whatever they check)
9 %bcond_without  gnome   # disable all GNOME components (gnomevfs, gnome, gnomeui)
10 %bcond_with     tidy    # enable htmlvalidator extension (tidy)
11 #
12 %define         tidy_ver        0.8.4.0
13 %define         firefox_ver     2.0.0.5
14 #
15 Summary:        Firefox Community Edition web browser
16 Summary(pl.UTF-8):      Firefox Community Edition - przeglądarka WWW
17 Name:           mozilla-firefox
18 Version:        2.0.0.5
19 Release:        1
20 License:        MPL/LGPL
21 Group:          X11/Applications/Networking
22 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
23 # Source0-md5:  5a6ca3e4ac3ebc335d473cd3f682a916
24 Source1:        http://users.skynet.be/mgueury/mozilla/tidy_08x_source.zip
25 # Source1-md5:  cd5d54c47f08286605eaaa308536d4ab
26 Source2:        %{name}.desktop
27 Source3:        %{name}.sh
28 Patch0:         mozilla-install.patch
29 Patch1:         %{name}-lib_path.patch
30 Patch2:         %{name}-addon-tidy.patch
31 Patch3:         %{name}-nopangoxft.patch
32 Patch5:         %{name}-fonts.patch
33 Patch6:         %{name}-agent.patch
34 Patch7:         %{name}-myspell.patch
35 # if ac rebuild is needed...
36 #PatchX:                %{name}-ac.patch
37 URL:            http://www.mozilla.org/projects/firefox/
38 %{?with_gnome:BuildRequires:    GConf2-devel >= 1.2.1}
39 BuildRequires:  automake
40 BuildRequires:  cairo-devel >= 1.0.0
41 %{?with_gnome:BuildRequires:    gnome-vfs2-devel >= 2.0}
42 BuildRequires:  gtk+2-devel >= 1:2.0.0
43 BuildRequires:  krb5-devel
44 BuildRequires:  libIDL-devel >= 0.8.0
45 %{?with_gnome:BuildRequires:    libgnome-devel >= 2.0}
46 %{?with_gnome:BuildRequires:    libgnomeui-devel >= 2.2.0}
47 BuildRequires:  libjpeg-devel >= 6b
48 BuildRequires:  libpng-devel >= 1.2.7
49 BuildRequires:  libstdc++-devel
50 BuildRequires:  myspell-devel
51 BuildRequires:  nspr-devel >= 1:4.6.3
52 BuildRequires:  nss-devel >= 1:3.11.3-3
53 %{?with_tidy:BuildRequires:     opensp-devel >= 2:1.5.2-4}
54 BuildRequires:  pango-devel >= 1:1.6.0
55 BuildRequires:  perl-modules >= 5.004
56 BuildRequires:  pkgconfig
57 BuildRequires:  rpmbuild(macros) >= 1.356
58 BuildRequires:  xorg-lib-libXext-devel
59 BuildRequires:  xorg-lib-libXft-devel >= 2.1
60 BuildRequires:  xorg-lib-libXinerama-devel
61 BuildRequires:  xorg-lib-libXp-devel
62 BuildRequires:  xorg-lib-libXt-devel
63 BuildRequires:  zip
64 BuildRequires:  zlib-devel >= 1.2.3
65 Requires(post): mktemp >= 1.5-18
66 Requires:       %{name}-lang-resources = %{version}
67 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
68 Requires:       browser-plugins >= 2.0
69 Requires:       nspr >= 1:4.6.3
70 Requires:       nss >= 1:3.11.3
71 Provides:       wwwbrowser
72 Obsoletes:      mozilla-firebird
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 # firefox/thunderbird/seamonkey provide their own versions
76 %define         _noautoreqdep           libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so
77 %define         _noautoprovfiles        %{_libdir}/%{name}/components
78 # we don't want these to satisfy xulrunner-devel
79 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
80 # and as we don't provide them, don't require either
81 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
82
83 %define         specflags       -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
84
85 %description
86 Firefox Community Edition is an open-source web browser, designed for
87 standards compliance, performance and portability.
88
89 %description -l pl.UTF-8
90 Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
91 zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
92 o zgodności ze standardami, wydajnością i przenośnością.
93
94 %package libs
95 Summary:        Firefox Community Edition shared libraries
96 Summary(pl.UTF-8):      Biblioteki współdzielone przeglądarki Firefox Community Edition
97 Group:          Libraries
98 Conflicts:      mozilla-firefox < 2.0-1.4
99
100 %description libs
101 Firefox Community Edition shared libraries.
102
103 %description libs -l pl.UTF-8
104 Biblioteki współdzielone przeglądarki Firefox Community Edition.
105
106 %package addon-tidy
107 Summary:        HTML Validator for Firefox
108 Summary(pl.UTF-8):      Narzędzie do sprawdzania poprawności HTML-a dla Firefoksa
109 Version:        %{tidy_ver}
110 License:        GPL
111 Group:          X11/Applications/Networking
112 Requires:       %{name} = %{firefox_ver}-%{release}
113
114 %description addon-tidy
115 HTML Validator is a Mozilla extension that adds HTML validation inside
116 Firefox. The number of errors of a HTML page is seen on the form of an
117 icon in the status bar when browsing.
118
119 %description addon-tidy -l pl.UTF-8
120 HTML Validator to rozszerzenie Mozilli dodające sprawdzanie
121 poprawności HTML-a w Firefoksie. Liczbę błędów na przeglądanej stronie
122 HTML można zobaczyć w postaci ikony na pasku stanu.
123
124 %package lang-en
125 Summary:        English resources for Firefox Community Edition
126 Summary(pl.UTF-8):      Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition
127 Group:          X11/Applications/Networking
128 Requires:       %{name} = %{version}-%{release}
129 Provides:       %{name}-lang-resources = %{version}-%{release}
130
131 %description lang-en
132 English resources for Firefox Community Edition.
133
134 %description lang-en -l pl.UTF-8
135 Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition.
136
137 %prep
138 %setup -qc %{?with_tidy:-a1}
139 %if %{with tidy}
140 mv mozilla_tidy_source/mozilla/extensions/tidy mozilla/extensions/tidy
141 mv mozilla_tidy_source/tidy_extension .
142 rm -rf mozilla/extensions/tidy/opensp
143 %endif
144 cd mozilla
145 %patch0 -p1
146 %patch1 -p1
147 %{?with_tidy:%patch2 -p1}
148 %patch3 -p1
149 %patch5 -p1
150 %patch6 -p1
151 %patch7 -p1
152
153 # use system
154 #rm -rf mozilla/nsprpub mozilla/security/nss
155
156 %build
157 cd mozilla
158 export CFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
159 export CXXFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
160
161 cp -f %{_datadir}/automake/config.* build/autoconf
162 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
163 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
164
165 cat << 'EOF' > .mozconfig
166 . $topsrcdir/browser/config/mozconfig
167
168 # Options for 'configure' (same as command-line options).
169 ac_add_options --prefix=%{_prefix}
170 ac_add_options --exec-prefix=%{_exec_prefix}
171 ac_add_options --bindir=%{_bindir}
172 ac_add_options --sbindir=%{_sbindir}
173 ac_add_options --sysconfdir=%{_sysconfdir}
174 ac_add_options --datadir=%{_datadir}
175 ac_add_options --includedir=%{_includedir}
176 ac_add_options --libdir=%{_libdir}
177 ac_add_options --libexecdir=%{_libexecdir}
178 ac_add_options --localstatedir=%{_localstatedir}
179 ac_add_options --sharedstatedir=%{_sharedstatedir}
180 ac_add_options --mandir=%{_mandir}
181 ac_add_options --infodir=%{_infodir}
182 %if %{?debug:1}0
183 ac_add_options --disable-optimize
184 ac_add_options --enable-debug
185 ac_add_options --enable-debug-modules
186 ac_add_options --enable-debugger-info-modules
187 ac_add_options --enable-crash-on-assert
188 %else
189 ac_add_options --disable-debug
190 ac_add_options --disable-logging
191 ac_add_options --enable-optimize="%{rpmcflags}"
192 %endif
193 %if %{with tests}
194 ac_add_options --enable-tests
195 %else
196 ac_add_options --disable-tests
197 %endif
198 %if %{with gnome}
199 ac_add_options --enable-gnomevfs
200 ac_add_options --enable-gnomeui
201 %else
202 ac_add_options --disable-gnomevfs
203 ac_add_options --disable-gnomeui
204 %endif
205 ac_add_options --disable-freetype2
206 ac_add_options --disable-installer
207 ac_add_options --disable-javaxpcom
208 ac_add_options --disable-updater
209 ac_add_options --enable-default-toolkit=gtk2
210 ac_add_options --enable-svg
211 ac_add_options --enable-system-cairo
212 ac_add_options --enable-system-myspell
213 ac_add_options --enable-xft
214 ac_add_options --with-distribution-id=org.pld-linux
215 ac_add_options --with-system-nspr
216 ac_add_options --with-system-nss
217 ac_add_options --with-system-zlib
218 ac_add_options --with-system-jpeg
219 ac_add_options --with-system-png
220 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
221 ac_cv_visibility_pragma=no
222 EOF
223
224 %{__make} -j1 -f client.mk build \
225         CC="%{__cc}" \
226         CXX="%{__cxx}"
227
228 %install
229 rm -rf $RPM_BUILD_ROOT
230 cd mozilla
231 install -d \
232         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
233         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
234         $RPM_BUILD_ROOT%{_datadir}/%{name}
235
236 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
237
238 %{__make} -C xpinstall/packager stage-package \
239         DESTDIR=$RPM_BUILD_ROOT \
240         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
241         PKG_SKIP_STRIP=1
242
243 # move arch independant ones to datadir
244 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
245 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
246 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
247 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
248 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
249 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
250 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
251 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
252 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
253 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
254 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
255 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
256 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
257 ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
258 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
259 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
260
261 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
262 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
263
264 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
265 ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
266
267 install browser/base/branding/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
268
269 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
270
271 # header/development files
272 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpidl
273 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_dump
274 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_link
275
276 # files created by regxpcom and firefox -register
277 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
278 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
279
280 # what's this? it's content is invalid anyway.
281 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
282 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
283
284 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
285 #!/bin/sh
286 umask 022
287 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
288
289 # it attempts to touch files in $HOME/.mozilla
290 # beware if you run this with sudo!!!
291 export HOME=$(mktemp -d)
292 # also TMPDIR could be pointing to sudo user's homedir
293 unset TMPDIR TMP || :
294
295 LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
296 %{_libdir}/%{name}/firefox -register
297
298 rm -rf $HOME
299 EOF
300
301 %clean
302 rm -rf $RPM_BUILD_ROOT
303
304 %pretrans
305 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
306         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
307 fi
308 for d in chrome defaults extensions greprefs icons init.d res searchplugins; do
309         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
310                 install -d %{_datadir}/%{name}
311                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
312         fi
313 done
314 exit 0
315
316 %post
317 %{_sbindir}/%{name}-chrome+xpcom-generate
318 %update_browser_plugins
319
320 %postun
321 if [ "$1" = 0 ]; then
322         %update_browser_plugins
323 fi
324
325 %files
326 %defattr(644,root,root,755)
327 %attr(755,root,root) %{_bindir}/%{name}
328 %attr(755,root,root) %{_bindir}/firefox
329 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
330
331 # browser plugins v2
332 %{_browserpluginsconfdir}/browsers.d/%{name}.*
333 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
334
335 %dir %{_libdir}/%{name}/components
336 %attr(755,root,root) %{_libdir}/%{name}/components/libaccessibility.so
337 %attr(755,root,root) %{_libdir}/%{name}/components/libappcomps.so
338 %attr(755,root,root) %{_libdir}/%{name}/components/libauth.so
339 %attr(755,root,root) %{_libdir}/%{name}/components/libautoconfig.so
340 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
341 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
342 %attr(755,root,root) %{_libdir}/%{name}/components/libcaps.so
343 %attr(755,root,root) %{_libdir}/%{name}/components/libchrome.so
344 %attr(755,root,root) %{_libdir}/%{name}/components/libcommandlines.so
345 %attr(755,root,root) %{_libdir}/%{name}/components/libcomposer.so
346 %attr(755,root,root) %{_libdir}/%{name}/components/libcookie.so
347 %attr(755,root,root) %{_libdir}/%{name}/components/libdocshell.so
348 %attr(755,root,root) %{_libdir}/%{name}/components/libeditor.so
349 %attr(755,root,root) %{_libdir}/%{name}/components/libembedcomponents.so
350 %attr(755,root,root) %{_libdir}/%{name}/components/libfileview.so
351 %attr(755,root,root) %{_libdir}/%{name}/components/libgfx_gtk.so
352 %attr(755,root,root) %{_libdir}/%{name}/components/libgfxps.so
353 %attr(755,root,root) %{_libdir}/%{name}/components/libgklayout.so
354 %attr(755,root,root) %{_libdir}/%{name}/components/libgkplugin.so
355 %attr(755,root,root) %{_libdir}/%{name}/components/libhtmlpars.so
356 %attr(755,root,root) %{_libdir}/%{name}/components/libi18n.so
357 %attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so
358 %attr(755,root,root) %{_libdir}/%{name}/components/libimglib2.so
359 %attr(755,root,root) %{_libdir}/%{name}/components/libjar50.so
360 %attr(755,root,root) %{_libdir}/%{name}/components/libjsd.so
361 %attr(755,root,root) %{_libdir}/%{name}/components/libmork.so
362 %attr(755,root,root) %{_libdir}/%{name}/components/libmozfind.so
363 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
364 %attr(755,root,root) %{_libdir}/%{name}/components/libmyspell.so
365 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko2.so
366 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko.so
367 %attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so
368 %attr(755,root,root) %{_libdir}/%{name}/components/libnsappshell.so
369 %attr(755,root,root) %{_libdir}/%{name}/components/liboji.so
370 %attr(755,root,root) %{_libdir}/%{name}/components/libpermissions.so
371 %attr(755,root,root) %{_libdir}/%{name}/components/libpipboot.so
372 %attr(755,root,root) %{_libdir}/%{name}/components/libpipnss.so
373 %attr(755,root,root) %{_libdir}/%{name}/components/libpippki.so
374 %attr(755,root,root) %{_libdir}/%{name}/components/libpref.so
375 %attr(755,root,root) %{_libdir}/%{name}/components/librdf.so
376 %attr(755,root,root) %{_libdir}/%{name}/components/libremoteservice.so
377 %attr(755,root,root) %{_libdir}/%{name}/components/libsearchservice.so
378 %attr(755,root,root) %{_libdir}/%{name}/components/libspellchecker.so
379 %attr(755,root,root) %{_libdir}/%{name}/components/libstoragecomps.so
380 %attr(755,root,root) %{_libdir}/%{name}/components/libsystem-pref.so
381 %attr(755,root,root) %{_libdir}/%{name}/components/libtoolkitcomps.so
382 %attr(755,root,root) %{_libdir}/%{name}/components/libtransformiix.so
383 %attr(755,root,root) %{_libdir}/%{name}/components/libtxmgr.so
384 %attr(755,root,root) %{_libdir}/%{name}/components/libuconv.so
385 %attr(755,root,root) %{_libdir}/%{name}/components/libucvmath.so
386 %attr(755,root,root) %{_libdir}/%{name}/components/libuniversalchardet.so
387 %attr(755,root,root) %{_libdir}/%{name}/components/libwebbrwsr.so
388 %attr(755,root,root) %{_libdir}/%{name}/components/libwebsrvcs.so
389 %attr(755,root,root) %{_libdir}/%{name}/components/libwidget_gtk2.so
390 %attr(755,root,root) %{_libdir}/%{name}/components/libxmlextras.so
391 %attr(755,root,root) %{_libdir}/%{name}/components/libxpcom_compat_c.so
392 %attr(755,root,root) %{_libdir}/%{name}/components/libxpconnect.so
393 %attr(755,root,root) %{_libdir}/%{name}/components/libxpinstall.so
394 %{_libdir}/%{name}/components/accessibility-atk.xpt
395 %{_libdir}/%{name}/components/accessibility.xpt
396 %{_libdir}/%{name}/components/alerts.xpt
397 %{_libdir}/%{name}/components/appshell.xpt
398 %{_libdir}/%{name}/components/appstartup.xpt
399 %{_libdir}/%{name}/components/autocomplete.xpt
400 %{_libdir}/%{name}/components/autoconfig.xpt
401 %{_libdir}/%{name}/components/bookmarks.xpt
402 %{_libdir}/%{name}/components/browsercompsbase.xpt
403 %{_libdir}/%{name}/components/browser-feeds.xpt
404 %{_libdir}/%{name}/components/browsersearch.xpt
405 %{_libdir}/%{name}/components/caps.xpt
406 %{_libdir}/%{name}/components/chardet.xpt
407 %{_libdir}/%{name}/components/chrome.xpt
408 %{_libdir}/%{name}/components/commandhandler.xpt
409 %{_libdir}/%{name}/components/commandlines.xpt
410 %{_libdir}/%{name}/components/composer.xpt
411 %{_libdir}/%{name}/components/content_base.xpt
412 %{_libdir}/%{name}/components/content_htmldoc.xpt
413 %{_libdir}/%{name}/components/content_html.xpt
414 %{_libdir}/%{name}/components/content_xmldoc.xpt
415 %{_libdir}/%{name}/components/content_xslt.xpt
416 %{_libdir}/%{name}/components/content_xtf.xpt
417 %{_libdir}/%{name}/components/cookie.xpt
418 %{_libdir}/%{name}/components/directory.xpt
419 %{_libdir}/%{name}/components/docshell.xpt
420 %{_libdir}/%{name}/components/dom_base.xpt
421 %{_libdir}/%{name}/components/dom_canvas.xpt
422 %{_libdir}/%{name}/components/dom_core.xpt
423 %{_libdir}/%{name}/components/dom_css.xpt
424 %{_libdir}/%{name}/components/dom_events.xpt
425 %{_libdir}/%{name}/components/dom_html.xpt
426 %{_libdir}/%{name}/components/dom_loadsave.xpt
427 %{_libdir}/%{name}/components/dom_range.xpt
428 %{_libdir}/%{name}/components/dom_sidebar.xpt
429 %{_libdir}/%{name}/components/dom_storage.xpt
430 %{_libdir}/%{name}/components/dom_stylesheets.xpt
431 %{_libdir}/%{name}/components/dom_svg.xpt
432 %{_libdir}/%{name}/components/dom_traversal.xpt
433 %{_libdir}/%{name}/components/dom_views.xpt
434 %{_libdir}/%{name}/components/dom_xbl.xpt
435 %{_libdir}/%{name}/components/dom_xpath.xpt
436 %{_libdir}/%{name}/components/dom.xpt
437 %{_libdir}/%{name}/components/dom_xul.xpt
438 %{_libdir}/%{name}/components/downloads.xpt
439 %{_libdir}/%{name}/components/editor.xpt
440 %{_libdir}/%{name}/components/embed_base.xpt
441 %{_libdir}/%{name}/components/extensions.xpt
442 %{_libdir}/%{name}/components/exthandler.xpt
443 %{_libdir}/%{name}/components/fastfind.xpt
444 %{_libdir}/%{name}/components/FeedConverter.js
445 %{_libdir}/%{name}/components/FeedProcessor.js
446 %{_libdir}/%{name}/components/feeds.xpt
447 %{_libdir}/%{name}/components/FeedWriter.js
448 %{_libdir}/%{name}/components/filepicker.xpt
449 %{_libdir}/%{name}/components/find.xpt
450 %{_libdir}/%{name}/components/gfx.xpt
451 %{_libdir}/%{name}/components/gksvgrenderer.xpt
452 %{_libdir}/%{name}/components/history.xpt
453 %{_libdir}/%{name}/components/htmlparser.xpt
454 %{_libdir}/%{name}/components/imgicon.xpt
455 %{_libdir}/%{name}/components/imglib2.xpt
456 %{_libdir}/%{name}/components/inspector.xpt
457 %{_libdir}/%{name}/components/intl.xpt
458 %{_libdir}/%{name}/components/jar.xpt
459 %{_libdir}/%{name}/components/jsconsole-clhandler.js
460 %{_libdir}/%{name}/components/jsconsole.xpt
461 %{_libdir}/%{name}/components/jsdservice.xpt
462 %{_libdir}/%{name}/components/layout_base.xpt
463 %{_libdir}/%{name}/components/layout_printing.xpt
464 %{_libdir}/%{name}/components/layout_xul_tree.xpt
465 %{_libdir}/%{name}/components/layout_xul.xpt
466 %{_libdir}/%{name}/components/locale.xpt
467 %{_libdir}/%{name}/components/lwbrk.xpt
468 %{_libdir}/%{name}/components/microsummaries.xpt
469 %{_libdir}/%{name}/components/migration.xpt
470 %{_libdir}/%{name}/components/mimetype.xpt
471 %{_libdir}/%{name}/components/mozbrwsr.xpt
472 %{_libdir}/%{name}/components/mozfind.xpt
473 %{_libdir}/%{name}/components/mozgnome.xpt
474 %{_libdir}/%{name}/components/necko_about.xpt
475 %{_libdir}/%{name}/components/necko_cache.xpt
476 %{_libdir}/%{name}/components/necko_cookie.xpt
477 %{_libdir}/%{name}/components/necko_data.xpt
478 %{_libdir}/%{name}/components/necko_dns.xpt
479 %{_libdir}/%{name}/components/necko_file.xpt
480 %{_libdir}/%{name}/components/necko_ftp.xpt
481 %{_libdir}/%{name}/components/necko_http.xpt
482 %{_libdir}/%{name}/components/necko_res.xpt
483 %{_libdir}/%{name}/components/necko_socket.xpt
484 %{_libdir}/%{name}/components/necko_strconv.xpt
485 %{_libdir}/%{name}/components/necko_viewsource.xpt
486 %{_libdir}/%{name}/components/necko.xpt
487 %{_libdir}/%{name}/components/nsBookmarkTransactionManager.js
488 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
489 %{_libdir}/%{name}/components/nsBrowserGlue.js
490 %{_libdir}/%{name}/components/nsCloseAllWindows.js
491 %{_libdir}/%{name}/components/nsDefaultCLH.js
492 %{_libdir}/%{name}/components/nsDictionary.js
493 %{_libdir}/%{name}/components/nsExtensionManager.js
494 %{_libdir}/%{name}/components/nsFilePicker.js
495 %{_libdir}/%{name}/components/nsHelperAppDlg.js
496 %{_libdir}/%{name}/components/nsInterfaceInfoToIDL.js
497 %{_libdir}/%{name}/components/nsKillAll.js
498 %{_libdir}/%{name}/components/nsMicrosummaryService.js
499 %{_libdir}/%{name}/components/nsProgressDialog.js
500 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
501 %{_libdir}/%{name}/components/nsResetPref.js
502 %{_libdir}/%{name}/components/nsSafebrowsingApplication.js
503 %{_libdir}/%{name}/components/nsSearchService.js
504 %{_libdir}/%{name}/components/nsSearchSuggestions.js
505 %{_libdir}/%{name}/components/nsSessionStartup.js
506 %{_libdir}/%{name}/components/nsSessionStore.js
507 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
508 %{_libdir}/%{name}/components/nsSidebar.js
509 %{_libdir}/%{name}/components/nsUpdateService.js
510 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
511 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
512 %{_libdir}/%{name}/components/nsUrlClassifierTable.js
513 %{_libdir}/%{name}/components/nsURLFormatter.js
514 %{_libdir}/%{name}/components/nsXmlRpcClient.js
515 %{_libdir}/%{name}/components/oji.xpt
516 %{_libdir}/%{name}/components/passwordmgr.xpt
517 %{_libdir}/%{name}/components/pipboot.xpt
518 %{_libdir}/%{name}/components/pipnss.xpt
519 %{_libdir}/%{name}/components/pippki.xpt
520 %{_libdir}/%{name}/components/plugin.xpt
521 %{_libdir}/%{name}/components/prefetch.xpt
522 %{_libdir}/%{name}/components/pref.xpt
523 %{_libdir}/%{name}/components/profile.xpt
524 %{_libdir}/%{name}/components/progressDlg.xpt
525 %{_libdir}/%{name}/components/proxyObjInst.xpt
526 %{_libdir}/%{name}/components/rdf.xpt
527 %{_libdir}/%{name}/components/safebrowsing.xpt
528 %{_libdir}/%{name}/components/satchel.xpt
529 %{_libdir}/%{name}/components/saxparser.xpt
530 %{_libdir}/%{name}/components/search.xpt
531 %{_libdir}/%{name}/components/sessionstore.xpt
532 %{_libdir}/%{name}/components/shellservice.xpt
533 %{_libdir}/%{name}/components/shistory.xpt
534 %{_libdir}/%{name}/components/spellchecker.xpt
535 %{_libdir}/%{name}/components/storage.xpt
536 %{_libdir}/%{name}/components/toolkitprofile.xpt
537 %{_libdir}/%{name}/components/toolkitremote.xpt
538 %{_libdir}/%{name}/components/txmgr.xpt
539 %{_libdir}/%{name}/components/txtsvc.xpt
540 %{_libdir}/%{name}/components/uconv.xpt
541 %{_libdir}/%{name}/components/unicharutil.xpt
542 %{_libdir}/%{name}/components/update.xpt
543 %{_libdir}/%{name}/components/uriloader.xpt
544 %{_libdir}/%{name}/components/url-classifier.xpt
545 %{_libdir}/%{name}/components/urlformatter.xpt
546 %{_libdir}/%{name}/components/webBrowser_core.xpt
547 %{_libdir}/%{name}/components/webbrowserpersist.xpt
548 %{_libdir}/%{name}/components/WebContentConverter.js
549 %{_libdir}/%{name}/components/webshell_idls.xpt
550 %{_libdir}/%{name}/components/websrvcs.xpt
551 %{_libdir}/%{name}/components/widget.xpt
552 %{_libdir}/%{name}/components/windowds.xpt
553 %{_libdir}/%{name}/components/windowwatcher.xpt
554 %{_libdir}/%{name}/components/xml-rpc.xpt
555 %{_libdir}/%{name}/components/xpcom_base.xpt
556 %{_libdir}/%{name}/components/xpcom_components.xpt
557 %{_libdir}/%{name}/components/xpcom_ds.xpt
558 %{_libdir}/%{name}/components/xpcom_io.xpt
559 %{_libdir}/%{name}/components/xpcom_obsolete.xpt
560 %{_libdir}/%{name}/components/xpcom_threads.xpt
561 %{_libdir}/%{name}/components/xpcom_xpti.xpt
562 %{_libdir}/%{name}/components/xpconnect.xpt
563 %{_libdir}/%{name}/components/xpinstall.xpt
564 %{_libdir}/%{name}/components/xulapp.xpt
565 %{_libdir}/%{name}/components/xuldoc.xpt
566 %{_libdir}/%{name}/components/xultmpl.xpt
567 %dir %{_libdir}/%{name}/plugins
568 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
569 %attr(755,root,root) %{_libdir}/%{name}/*.sh
570 %attr(755,root,root) %{_libdir}/%{name}/m*
571 %attr(755,root,root) %{_libdir}/%{name}/f*
572 %attr(755,root,root) %{_libdir}/%{name}/regxpcom
573 %attr(755,root,root) %{_libdir}/%{name}/xpcshell
574 %attr(755,root,root) %{_libdir}/%{name}/xpicleanup
575 %{_pixmapsdir}/mozilla-firefox.png
576 %{_desktopdir}/mozilla-firefox.desktop
577
578 # symlinks
579 %{_libdir}/%{name}/chrome
580 %{_libdir}/%{name}/defaults
581 %{_libdir}/%{name}/dictionaries
582 %{_libdir}/%{name}/extensions
583 %{_libdir}/%{name}/greprefs
584 %{_libdir}/%{name}/icons
585 %{_libdir}/%{name}/init.d
586 %{_libdir}/%{name}/res
587 %{_libdir}/%{name}/searchplugins
588
589 # browserconfig
590 %{_libdir}/%{name}/browserconfig.properties
591
592 %{_libdir}/%{name}/LICENSE
593 %{_libdir}/%{name}/README.txt
594
595 %dir %{_datadir}/%{name}
596 %{_datadir}/%{name}/chrome
597 %{_datadir}/%{name}/defaults
598 %{_datadir}/%{name}/greprefs
599 %{_datadir}/%{name}/icons
600 %{_datadir}/%{name}/init.d
601 %{_datadir}/%{name}/res
602 %{_datadir}/%{name}/searchplugins
603
604 %dir %{_datadir}/%{name}/extensions
605 # -dom-inspector subpackage?
606 %{_datadir}/%{name}/extensions/inspector@mozilla.org
607 # the signature of the default theme
608 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
609
610 # files created by regxpcom and firefox -register
611 %ghost %{_libdir}/%{name}/components/compreg.dat
612 %ghost %{_libdir}/%{name}/components/xpti.dat
613
614 %files libs
615 %defattr(644,root,root,755)
616 %dir %{_libdir}/%{name}
617 %attr(755,root,root) %{_libdir}/%{name}/*.so
618
619 %files lang-en
620 %defattr(644,root,root,755)
621 %{_datadir}/%{name}/chrome/en-US.jar
622 %{_datadir}/%{name}/chrome/en-US.manifest
623
624 %if %{with tidy}
625 %files addon-tidy
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{_libdir}/%{name}/components/libnstidy.so
628 %attr(755,root,root) %{_libdir}/%{name}/components/libtodel.so
629 %{_libdir}/%{name}/components/nstidy.xpt
630 %endif
This page took 0.093333 seconds and 4 git commands to generate.