]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- up to 2.0.0.6
[packages/firefox.git] / mozilla-firefox.spec
1 # TODO:
2 # - handle locales differently (runtime, since it's possible to do)
3 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
4 #   for hints how to make locales
5 # - make it more pld-like (bookmarks, default page etc..)
6 #
7 # Conditional build:
8 %bcond_with     tests   # enable tests (whatever they check)
9 %bcond_without  gnome   # disable all GNOME components (gnomevfs, gnome, gnomeui)
10 %bcond_with     tidy    # enable htmlvalidator extension (tidy)
11 #
12 %define         tidy_ver        0.8.4.0
13 %define         firefox_ver     2.0.0.6
14 #
15 Summary:        Firefox Community Edition web browser
16 Summary(pl.UTF-8):      Firefox Community Edition - przeglądarka WWW
17 Name:           mozilla-firefox
18 Version:        %{firefox_ver}
19 Release:        1
20 License:        MPL/LGPL
21 Group:          X11/Applications/Networking
22 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
23 # Source0-md5:  16fb252fb7b0371894f7101b88fd9076
24 Source1:        http://users.skynet.be/mgueury/mozilla/tidy_08x_source.zip
25 # Source1-md5:  cd5d54c47f08286605eaaa308536d4ab
26 Source2:        %{name}.desktop
27 Source3:        %{name}.sh
28 Patch0:         mozilla-install.patch
29 Patch1:         %{name}-lib_path.patch
30 Patch2:         %{name}-addon-tidy.patch
31 Patch3:         %{name}-nopangoxft.patch
32 Patch5:         %{name}-fonts.patch
33 Patch6:         %{name}-agent.patch
34 Patch7:         %{name}-myspell.patch
35 # if ac rebuild is needed...
36 #PatchX:                %{name}-ac.patch
37 URL:            http://www.mozilla.org/projects/firefox/
38 %{?with_gnome:BuildRequires:    GConf2-devel >= 1.2.1}
39 BuildRequires:  automake
40 BuildRequires:  cairo-devel >= 1.0.0
41 %{?with_gnome:BuildRequires:    gnome-vfs2-devel >= 2.0}
42 BuildRequires:  gtk+2-devel >= 1:2.0.0
43 BuildRequires:  krb5-devel
44 BuildRequires:  libIDL-devel >= 0.8.0
45 %{?with_gnome:BuildRequires:    libgnome-devel >= 2.0}
46 %{?with_gnome:BuildRequires:    libgnomeui-devel >= 2.2.0}
47 BuildRequires:  libjpeg-devel >= 6b
48 BuildRequires:  libpng-devel >= 1.2.7
49 BuildRequires:  libstdc++-devel
50 BuildRequires:  myspell-devel
51 BuildRequires:  nspr-devel >= 1:4.6.3
52 BuildRequires:  nss-devel >= 1:3.11.3-3
53 %{?with_tidy:BuildRequires:     opensp-devel >= 2:1.5.2-4}
54 BuildRequires:  pango-devel >= 1:1.6.0
55 BuildRequires:  perl-modules >= 5.004
56 BuildRequires:  pkgconfig
57 BuildRequires:  rpmbuild(macros) >= 1.356
58 BuildRequires:  xorg-lib-libXext-devel
59 BuildRequires:  xorg-lib-libXft-devel >= 2.1
60 BuildRequires:  xorg-lib-libXinerama-devel
61 BuildRequires:  xorg-lib-libXp-devel
62 BuildRequires:  xorg-lib-libXt-devel
63 BuildRequires:  zip
64 BuildRequires:  zlib-devel >= 1.2.3
65 Requires(post): mktemp >= 1.5-18
66 Requires:       %{name}-lang-resources = %{version}
67 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
68 Requires:       browser-plugins >= 2.0
69 Requires:       nspr >= 1:4.6.3
70 Requires:       nss >= 1:3.11.3
71 Provides:       wwwbrowser
72 Obsoletes:      mozilla-firebird
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 # firefox/thunderbird/seamonkey provide their own versions
76 %define         _noautoreqdep           libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so
77 %define         _noautoprovfiles        %{_libdir}/%{name}/components
78 # we don't want these to satisfy xulrunner-devel
79 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
80 # and as we don't provide them, don't require either
81 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
82
83 %define         specflags       -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
84
85 %description
86 Firefox Community Edition is an open-source web browser, designed for
87 standards compliance, performance and portability.
88
89 %description -l pl.UTF-8
90 Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
91 zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
92 o zgodności ze standardami, wydajnością i przenośnością.
93
94 %package libs
95 Summary:        Firefox Community Edition shared libraries
96 Summary(pl.UTF-8):      Biblioteki współdzielone przeglądarki Firefox Community Edition
97 Group:          Libraries
98 Conflicts:      mozilla-firefox < 2.0-1.4
99
100 %description libs
101 Firefox Community Edition shared libraries.
102
103 %description libs -l pl.UTF-8
104 Biblioteki współdzielone przeglądarki Firefox Community Edition.
105
106 %package addon-tidy
107 Summary:        HTML Validator for Firefox
108 Summary(pl.UTF-8):      Narzędzie do sprawdzania poprawności HTML-a dla Firefoksa
109 Version:        %{tidy_ver}
110 License:        GPL
111 Group:          X11/Applications/Networking
112 Requires:       %{name} = %{firefox_ver}-%{release}
113
114 %description addon-tidy
115 HTML Validator is a Mozilla extension that adds HTML validation inside
116 Firefox. The number of errors of a HTML page is seen on the form of an
117 icon in the status bar when browsing.
118
119 %description addon-tidy -l pl.UTF-8
120 HTML Validator to rozszerzenie Mozilli dodające sprawdzanie
121 poprawności HTML-a w Firefoksie. Liczbę błędów na przeglądanej stronie
122 HTML można zobaczyć w postaci ikony na pasku stanu.
123
124 %package lang-en
125 Summary:        English resources for Firefox Community Edition
126 Summary(pl.UTF-8):      Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition
127 Version:        %{firefox_ver}
128 Group:          X11/Applications/Networking
129 Requires:       %{name} = %{firefox_ver}-%{release}
130 Provides:       %{name}-lang-resources = %{firefox_ver}-%{release}
131
132 %description lang-en
133 English resources for Firefox Community Edition.
134
135 %description lang-en -l pl.UTF-8
136 Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition.
137
138 %prep
139 %setup -qc %{?with_tidy:-a1}
140 %if %{with tidy}
141 mv mozilla_tidy_source/mozilla/extensions/tidy mozilla/extensions/tidy
142 mv mozilla_tidy_source/tidy_extension .
143 rm -rf mozilla/extensions/tidy/opensp
144 %endif
145 cd mozilla
146 %patch0 -p1
147 %patch1 -p1
148 %{?with_tidy:%patch2 -p1}
149 %patch3 -p1
150 %patch5 -p1
151 %patch6 -p1
152 %patch7 -p1
153
154 # use system
155 #rm -rf mozilla/nsprpub mozilla/security/nss
156
157 %build
158 cd mozilla
159 export CFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
160 export CXXFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
161
162 cp -f %{_datadir}/automake/config.* build/autoconf
163 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
164 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
165
166 cat << 'EOF' > .mozconfig
167 . $topsrcdir/browser/config/mozconfig
168
169 # Options for 'configure' (same as command-line options).
170 ac_add_options --prefix=%{_prefix}
171 ac_add_options --exec-prefix=%{_exec_prefix}
172 ac_add_options --bindir=%{_bindir}
173 ac_add_options --sbindir=%{_sbindir}
174 ac_add_options --sysconfdir=%{_sysconfdir}
175 ac_add_options --datadir=%{_datadir}
176 ac_add_options --includedir=%{_includedir}
177 ac_add_options --libdir=%{_libdir}
178 ac_add_options --libexecdir=%{_libexecdir}
179 ac_add_options --localstatedir=%{_localstatedir}
180 ac_add_options --sharedstatedir=%{_sharedstatedir}
181 ac_add_options --mandir=%{_mandir}
182 ac_add_options --infodir=%{_infodir}
183 %if %{?debug:1}0
184 ac_add_options --disable-optimize
185 ac_add_options --enable-debug
186 ac_add_options --enable-debug-modules
187 ac_add_options --enable-debugger-info-modules
188 ac_add_options --enable-crash-on-assert
189 %else
190 ac_add_options --disable-debug
191 ac_add_options --disable-logging
192 ac_add_options --enable-optimize="%{rpmcflags}"
193 %endif
194 %if %{with tests}
195 ac_add_options --enable-tests
196 %else
197 ac_add_options --disable-tests
198 %endif
199 %if %{with gnome}
200 ac_add_options --enable-gnomevfs
201 ac_add_options --enable-gnomeui
202 %else
203 ac_add_options --disable-gnomevfs
204 ac_add_options --disable-gnomeui
205 %endif
206 ac_add_options --disable-freetype2
207 ac_add_options --disable-installer
208 ac_add_options --disable-javaxpcom
209 ac_add_options --disable-updater
210 ac_add_options --enable-default-toolkit=gtk2
211 ac_add_options --enable-svg
212 ac_add_options --enable-system-cairo
213 ac_add_options --enable-system-myspell
214 ac_add_options --enable-xft
215 ac_add_options --with-distribution-id=org.pld-linux
216 ac_add_options --with-system-nspr
217 ac_add_options --with-system-nss
218 ac_add_options --with-system-zlib
219 ac_add_options --with-system-jpeg
220 ac_add_options --with-system-png
221 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
222 ac_cv_visibility_pragma=no
223 EOF
224
225 %{__make} -j1 -f client.mk build \
226         CC="%{__cc}" \
227         CXX="%{__cxx}"
228
229 %install
230 rm -rf $RPM_BUILD_ROOT
231 cd mozilla
232 install -d \
233         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
234         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
235         $RPM_BUILD_ROOT%{_datadir}/%{name}
236
237 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
238
239 %{__make} -C xpinstall/packager stage-package \
240         DESTDIR=$RPM_BUILD_ROOT \
241         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
242         PKG_SKIP_STRIP=1
243
244 # move arch independant ones to datadir
245 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
246 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
247 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
248 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
249 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
250 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
251 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
252 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
253 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
254 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
255 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
256 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
257 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
258 ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
259 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
260 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
261
262 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
263 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
264
265 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
266 ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
267
268 install browser/base/branding/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
269
270 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
271
272 # header/development files
273 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpidl
274 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_dump
275 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_link
276
277 # files created by regxpcom and firefox -register
278 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
279 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
280
281 # what's this? it's content is invalid anyway.
282 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
283 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
284
285 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
286 #!/bin/sh
287 umask 022
288 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
289
290 # it attempts to touch files in $HOME/.mozilla
291 # beware if you run this with sudo!!!
292 export HOME=$(mktemp -d)
293 # also TMPDIR could be pointing to sudo user's homedir
294 unset TMPDIR TMP || :
295
296 LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
297 %{_libdir}/%{name}/firefox -register
298
299 rm -rf $HOME
300 EOF
301
302 %clean
303 rm -rf $RPM_BUILD_ROOT
304
305 %pretrans
306 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
307         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
308 fi
309 for d in chrome defaults extensions greprefs icons init.d res searchplugins; do
310         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
311                 install -d %{_datadir}/%{name}
312                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
313         fi
314 done
315 exit 0
316
317 %post
318 %{_sbindir}/%{name}-chrome+xpcom-generate
319 %update_browser_plugins
320
321 %postun
322 if [ "$1" = 0 ]; then
323         %update_browser_plugins
324 fi
325
326 %files
327 %defattr(644,root,root,755)
328 %attr(755,root,root) %{_bindir}/%{name}
329 %attr(755,root,root) %{_bindir}/firefox
330 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
331
332 # browser plugins v2
333 %{_browserpluginsconfdir}/browsers.d/%{name}.*
334 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
335
336 %dir %{_libdir}/%{name}/components
337 %attr(755,root,root) %{_libdir}/%{name}/components/libaccessibility.so
338 %attr(755,root,root) %{_libdir}/%{name}/components/libappcomps.so
339 %attr(755,root,root) %{_libdir}/%{name}/components/libauth.so
340 %attr(755,root,root) %{_libdir}/%{name}/components/libautoconfig.so
341 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
342 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
343 %attr(755,root,root) %{_libdir}/%{name}/components/libcaps.so
344 %attr(755,root,root) %{_libdir}/%{name}/components/libchrome.so
345 %attr(755,root,root) %{_libdir}/%{name}/components/libcommandlines.so
346 %attr(755,root,root) %{_libdir}/%{name}/components/libcomposer.so
347 %attr(755,root,root) %{_libdir}/%{name}/components/libcookie.so
348 %attr(755,root,root) %{_libdir}/%{name}/components/libdocshell.so
349 %attr(755,root,root) %{_libdir}/%{name}/components/libeditor.so
350 %attr(755,root,root) %{_libdir}/%{name}/components/libembedcomponents.so
351 %attr(755,root,root) %{_libdir}/%{name}/components/libfileview.so
352 %attr(755,root,root) %{_libdir}/%{name}/components/libgfx_gtk.so
353 %attr(755,root,root) %{_libdir}/%{name}/components/libgfxps.so
354 %attr(755,root,root) %{_libdir}/%{name}/components/libgklayout.so
355 %attr(755,root,root) %{_libdir}/%{name}/components/libgkplugin.so
356 %attr(755,root,root) %{_libdir}/%{name}/components/libhtmlpars.so
357 %attr(755,root,root) %{_libdir}/%{name}/components/libi18n.so
358 %attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so
359 %attr(755,root,root) %{_libdir}/%{name}/components/libimglib2.so
360 %attr(755,root,root) %{_libdir}/%{name}/components/libjar50.so
361 %attr(755,root,root) %{_libdir}/%{name}/components/libjsd.so
362 %attr(755,root,root) %{_libdir}/%{name}/components/libmork.so
363 %attr(755,root,root) %{_libdir}/%{name}/components/libmozfind.so
364 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
365 %attr(755,root,root) %{_libdir}/%{name}/components/libmyspell.so
366 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko2.so
367 %attr(755,root,root) %{_libdir}/%{name}/components/libnecko.so
368 %attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so
369 %attr(755,root,root) %{_libdir}/%{name}/components/libnsappshell.so
370 %attr(755,root,root) %{_libdir}/%{name}/components/liboji.so
371 %attr(755,root,root) %{_libdir}/%{name}/components/libpermissions.so
372 %attr(755,root,root) %{_libdir}/%{name}/components/libpipboot.so
373 %attr(755,root,root) %{_libdir}/%{name}/components/libpipnss.so
374 %attr(755,root,root) %{_libdir}/%{name}/components/libpippki.so
375 %attr(755,root,root) %{_libdir}/%{name}/components/libpref.so
376 %attr(755,root,root) %{_libdir}/%{name}/components/librdf.so
377 %attr(755,root,root) %{_libdir}/%{name}/components/libremoteservice.so
378 %attr(755,root,root) %{_libdir}/%{name}/components/libsearchservice.so
379 %attr(755,root,root) %{_libdir}/%{name}/components/libspellchecker.so
380 %attr(755,root,root) %{_libdir}/%{name}/components/libstoragecomps.so
381 %attr(755,root,root) %{_libdir}/%{name}/components/libsystem-pref.so
382 %attr(755,root,root) %{_libdir}/%{name}/components/libtoolkitcomps.so
383 %attr(755,root,root) %{_libdir}/%{name}/components/libtransformiix.so
384 %attr(755,root,root) %{_libdir}/%{name}/components/libtxmgr.so
385 %attr(755,root,root) %{_libdir}/%{name}/components/libuconv.so
386 %attr(755,root,root) %{_libdir}/%{name}/components/libucvmath.so
387 %attr(755,root,root) %{_libdir}/%{name}/components/libuniversalchardet.so
388 %attr(755,root,root) %{_libdir}/%{name}/components/libwebbrwsr.so
389 %attr(755,root,root) %{_libdir}/%{name}/components/libwebsrvcs.so
390 %attr(755,root,root) %{_libdir}/%{name}/components/libwidget_gtk2.so
391 %attr(755,root,root) %{_libdir}/%{name}/components/libxmlextras.so
392 %attr(755,root,root) %{_libdir}/%{name}/components/libxpcom_compat_c.so
393 %attr(755,root,root) %{_libdir}/%{name}/components/libxpconnect.so
394 %attr(755,root,root) %{_libdir}/%{name}/components/libxpinstall.so
395 %{_libdir}/%{name}/components/accessibility-atk.xpt
396 %{_libdir}/%{name}/components/accessibility.xpt
397 %{_libdir}/%{name}/components/alerts.xpt
398 %{_libdir}/%{name}/components/appshell.xpt
399 %{_libdir}/%{name}/components/appstartup.xpt
400 %{_libdir}/%{name}/components/autocomplete.xpt
401 %{_libdir}/%{name}/components/autoconfig.xpt
402 %{_libdir}/%{name}/components/bookmarks.xpt
403 %{_libdir}/%{name}/components/browsercompsbase.xpt
404 %{_libdir}/%{name}/components/browser-feeds.xpt
405 %{_libdir}/%{name}/components/browsersearch.xpt
406 %{_libdir}/%{name}/components/caps.xpt
407 %{_libdir}/%{name}/components/chardet.xpt
408 %{_libdir}/%{name}/components/chrome.xpt
409 %{_libdir}/%{name}/components/commandhandler.xpt
410 %{_libdir}/%{name}/components/commandlines.xpt
411 %{_libdir}/%{name}/components/composer.xpt
412 %{_libdir}/%{name}/components/content_base.xpt
413 %{_libdir}/%{name}/components/content_htmldoc.xpt
414 %{_libdir}/%{name}/components/content_html.xpt
415 %{_libdir}/%{name}/components/content_xmldoc.xpt
416 %{_libdir}/%{name}/components/content_xslt.xpt
417 %{_libdir}/%{name}/components/content_xtf.xpt
418 %{_libdir}/%{name}/components/cookie.xpt
419 %{_libdir}/%{name}/components/directory.xpt
420 %{_libdir}/%{name}/components/docshell.xpt
421 %{_libdir}/%{name}/components/dom_base.xpt
422 %{_libdir}/%{name}/components/dom_canvas.xpt
423 %{_libdir}/%{name}/components/dom_core.xpt
424 %{_libdir}/%{name}/components/dom_css.xpt
425 %{_libdir}/%{name}/components/dom_events.xpt
426 %{_libdir}/%{name}/components/dom_html.xpt
427 %{_libdir}/%{name}/components/dom_loadsave.xpt
428 %{_libdir}/%{name}/components/dom_range.xpt
429 %{_libdir}/%{name}/components/dom_sidebar.xpt
430 %{_libdir}/%{name}/components/dom_storage.xpt
431 %{_libdir}/%{name}/components/dom_stylesheets.xpt
432 %{_libdir}/%{name}/components/dom_svg.xpt
433 %{_libdir}/%{name}/components/dom_traversal.xpt
434 %{_libdir}/%{name}/components/dom_views.xpt
435 %{_libdir}/%{name}/components/dom_xbl.xpt
436 %{_libdir}/%{name}/components/dom_xpath.xpt
437 %{_libdir}/%{name}/components/dom.xpt
438 %{_libdir}/%{name}/components/dom_xul.xpt
439 %{_libdir}/%{name}/components/downloads.xpt
440 %{_libdir}/%{name}/components/editor.xpt
441 %{_libdir}/%{name}/components/embed_base.xpt
442 %{_libdir}/%{name}/components/extensions.xpt
443 %{_libdir}/%{name}/components/exthandler.xpt
444 %{_libdir}/%{name}/components/fastfind.xpt
445 %{_libdir}/%{name}/components/FeedConverter.js
446 %{_libdir}/%{name}/components/FeedProcessor.js
447 %{_libdir}/%{name}/components/feeds.xpt
448 %{_libdir}/%{name}/components/FeedWriter.js
449 %{_libdir}/%{name}/components/filepicker.xpt
450 %{_libdir}/%{name}/components/find.xpt
451 %{_libdir}/%{name}/components/gfx.xpt
452 %{_libdir}/%{name}/components/gksvgrenderer.xpt
453 %{_libdir}/%{name}/components/history.xpt
454 %{_libdir}/%{name}/components/htmlparser.xpt
455 %{_libdir}/%{name}/components/imgicon.xpt
456 %{_libdir}/%{name}/components/imglib2.xpt
457 %{_libdir}/%{name}/components/inspector.xpt
458 %{_libdir}/%{name}/components/intl.xpt
459 %{_libdir}/%{name}/components/jar.xpt
460 %{_libdir}/%{name}/components/jsconsole-clhandler.js
461 %{_libdir}/%{name}/components/jsconsole.xpt
462 %{_libdir}/%{name}/components/jsdservice.xpt
463 %{_libdir}/%{name}/components/layout_base.xpt
464 %{_libdir}/%{name}/components/layout_printing.xpt
465 %{_libdir}/%{name}/components/layout_xul_tree.xpt
466 %{_libdir}/%{name}/components/layout_xul.xpt
467 %{_libdir}/%{name}/components/locale.xpt
468 %{_libdir}/%{name}/components/lwbrk.xpt
469 %{_libdir}/%{name}/components/microsummaries.xpt
470 %{_libdir}/%{name}/components/migration.xpt
471 %{_libdir}/%{name}/components/mimetype.xpt
472 %{_libdir}/%{name}/components/mozbrwsr.xpt
473 %{_libdir}/%{name}/components/mozfind.xpt
474 %{_libdir}/%{name}/components/mozgnome.xpt
475 %{_libdir}/%{name}/components/necko_about.xpt
476 %{_libdir}/%{name}/components/necko_cache.xpt
477 %{_libdir}/%{name}/components/necko_cookie.xpt
478 %{_libdir}/%{name}/components/necko_data.xpt
479 %{_libdir}/%{name}/components/necko_dns.xpt
480 %{_libdir}/%{name}/components/necko_file.xpt
481 %{_libdir}/%{name}/components/necko_ftp.xpt
482 %{_libdir}/%{name}/components/necko_http.xpt
483 %{_libdir}/%{name}/components/necko_res.xpt
484 %{_libdir}/%{name}/components/necko_socket.xpt
485 %{_libdir}/%{name}/components/necko_strconv.xpt
486 %{_libdir}/%{name}/components/necko_viewsource.xpt
487 %{_libdir}/%{name}/components/necko.xpt
488 %{_libdir}/%{name}/components/nsBookmarkTransactionManager.js
489 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
490 %{_libdir}/%{name}/components/nsBrowserGlue.js
491 %{_libdir}/%{name}/components/nsCloseAllWindows.js
492 %{_libdir}/%{name}/components/nsDefaultCLH.js
493 %{_libdir}/%{name}/components/nsDictionary.js
494 %{_libdir}/%{name}/components/nsExtensionManager.js
495 %{_libdir}/%{name}/components/nsFilePicker.js
496 %{_libdir}/%{name}/components/nsHelperAppDlg.js
497 %{_libdir}/%{name}/components/nsInterfaceInfoToIDL.js
498 %{_libdir}/%{name}/components/nsKillAll.js
499 %{_libdir}/%{name}/components/nsMicrosummaryService.js
500 %{_libdir}/%{name}/components/nsProgressDialog.js
501 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
502 %{_libdir}/%{name}/components/nsResetPref.js
503 %{_libdir}/%{name}/components/nsSafebrowsingApplication.js
504 %{_libdir}/%{name}/components/nsSearchService.js
505 %{_libdir}/%{name}/components/nsSearchSuggestions.js
506 %{_libdir}/%{name}/components/nsSessionStartup.js
507 %{_libdir}/%{name}/components/nsSessionStore.js
508 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
509 %{_libdir}/%{name}/components/nsSidebar.js
510 %{_libdir}/%{name}/components/nsUpdateService.js
511 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
512 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
513 %{_libdir}/%{name}/components/nsUrlClassifierTable.js
514 %{_libdir}/%{name}/components/nsURLFormatter.js
515 %{_libdir}/%{name}/components/nsXmlRpcClient.js
516 %{_libdir}/%{name}/components/oji.xpt
517 %{_libdir}/%{name}/components/passwordmgr.xpt
518 %{_libdir}/%{name}/components/pipboot.xpt
519 %{_libdir}/%{name}/components/pipnss.xpt
520 %{_libdir}/%{name}/components/pippki.xpt
521 %{_libdir}/%{name}/components/plugin.xpt
522 %{_libdir}/%{name}/components/prefetch.xpt
523 %{_libdir}/%{name}/components/pref.xpt
524 %{_libdir}/%{name}/components/profile.xpt
525 %{_libdir}/%{name}/components/progressDlg.xpt
526 %{_libdir}/%{name}/components/proxyObjInst.xpt
527 %{_libdir}/%{name}/components/rdf.xpt
528 %{_libdir}/%{name}/components/safebrowsing.xpt
529 %{_libdir}/%{name}/components/satchel.xpt
530 %{_libdir}/%{name}/components/saxparser.xpt
531 %{_libdir}/%{name}/components/search.xpt
532 %{_libdir}/%{name}/components/sessionstore.xpt
533 %{_libdir}/%{name}/components/shellservice.xpt
534 %{_libdir}/%{name}/components/shistory.xpt
535 %{_libdir}/%{name}/components/spellchecker.xpt
536 %{_libdir}/%{name}/components/storage.xpt
537 %{_libdir}/%{name}/components/toolkitprofile.xpt
538 %{_libdir}/%{name}/components/toolkitremote.xpt
539 %{_libdir}/%{name}/components/txmgr.xpt
540 %{_libdir}/%{name}/components/txtsvc.xpt
541 %{_libdir}/%{name}/components/uconv.xpt
542 %{_libdir}/%{name}/components/unicharutil.xpt
543 %{_libdir}/%{name}/components/update.xpt
544 %{_libdir}/%{name}/components/uriloader.xpt
545 %{_libdir}/%{name}/components/url-classifier.xpt
546 %{_libdir}/%{name}/components/urlformatter.xpt
547 %{_libdir}/%{name}/components/webBrowser_core.xpt
548 %{_libdir}/%{name}/components/webbrowserpersist.xpt
549 %{_libdir}/%{name}/components/WebContentConverter.js
550 %{_libdir}/%{name}/components/webshell_idls.xpt
551 %{_libdir}/%{name}/components/websrvcs.xpt
552 %{_libdir}/%{name}/components/widget.xpt
553 %{_libdir}/%{name}/components/windowds.xpt
554 %{_libdir}/%{name}/components/windowwatcher.xpt
555 %{_libdir}/%{name}/components/xml-rpc.xpt
556 %{_libdir}/%{name}/components/xpcom_base.xpt
557 %{_libdir}/%{name}/components/xpcom_components.xpt
558 %{_libdir}/%{name}/components/xpcom_ds.xpt
559 %{_libdir}/%{name}/components/xpcom_io.xpt
560 %{_libdir}/%{name}/components/xpcom_obsolete.xpt
561 %{_libdir}/%{name}/components/xpcom_threads.xpt
562 %{_libdir}/%{name}/components/xpcom_xpti.xpt
563 %{_libdir}/%{name}/components/xpconnect.xpt
564 %{_libdir}/%{name}/components/xpinstall.xpt
565 %{_libdir}/%{name}/components/xulapp.xpt
566 %{_libdir}/%{name}/components/xuldoc.xpt
567 %{_libdir}/%{name}/components/xultmpl.xpt
568 %dir %{_libdir}/%{name}/plugins
569 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
570 %attr(755,root,root) %{_libdir}/%{name}/*.sh
571 %attr(755,root,root) %{_libdir}/%{name}/m*
572 %attr(755,root,root) %{_libdir}/%{name}/f*
573 %attr(755,root,root) %{_libdir}/%{name}/regxpcom
574 %attr(755,root,root) %{_libdir}/%{name}/xpcshell
575 %attr(755,root,root) %{_libdir}/%{name}/xpicleanup
576 %{_pixmapsdir}/mozilla-firefox.png
577 %{_desktopdir}/mozilla-firefox.desktop
578
579 # symlinks
580 %{_libdir}/%{name}/chrome
581 %{_libdir}/%{name}/defaults
582 %{_libdir}/%{name}/dictionaries
583 %{_libdir}/%{name}/extensions
584 %{_libdir}/%{name}/greprefs
585 %{_libdir}/%{name}/icons
586 %{_libdir}/%{name}/init.d
587 %{_libdir}/%{name}/res
588 %{_libdir}/%{name}/searchplugins
589
590 # browserconfig
591 %{_libdir}/%{name}/browserconfig.properties
592
593 %{_libdir}/%{name}/LICENSE
594 %{_libdir}/%{name}/README.txt
595
596 %dir %{_datadir}/%{name}
597 %{_datadir}/%{name}/chrome
598 %{_datadir}/%{name}/defaults
599 %{_datadir}/%{name}/greprefs
600 %{_datadir}/%{name}/icons
601 %{_datadir}/%{name}/init.d
602 %{_datadir}/%{name}/res
603 %{_datadir}/%{name}/searchplugins
604
605 %dir %{_datadir}/%{name}/extensions
606 # -dom-inspector subpackage?
607 %{_datadir}/%{name}/extensions/inspector@mozilla.org
608 # the signature of the default theme
609 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
610
611 # files created by regxpcom and firefox -register
612 %ghost %{_libdir}/%{name}/components/compreg.dat
613 %ghost %{_libdir}/%{name}/components/xpti.dat
614
615 %files libs
616 %defattr(644,root,root,755)
617 %dir %{_libdir}/%{name}
618 %attr(755,root,root) %{_libdir}/%{name}/*.so
619
620 %files lang-en
621 %defattr(644,root,root,755)
622 %{_datadir}/%{name}/chrome/en-US.jar
623 %{_datadir}/%{name}/chrome/en-US.manifest
624
625 %if %{with tidy}
626 %files addon-tidy
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_libdir}/%{name}/components/libnstidy.so
629 %attr(755,root,root) %{_libdir}/%{name}/components/libtodel.so
630 %{_libdir}/%{name}/components/nstidy.xpt
631 %endif
This page took 0.140659 seconds and 4 git commands to generate.