]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- fix some drunken commit
[packages/firefox.git] / mozilla-firefox.spec
1 #
2 # TODO:
3 # - with new gcc version (it is possible that)
4 #   - -fvisibility=hiddenn and ac_cv_visibility_pragma=no can be removed
5 # - with new firefox version (it is possible that)
6 #   - -fno-strict-aliasing can be removed (needs to be tested carefuly,
7 #      not to be fixed soon, imho)
8 # - handle locales differently (runtime, since it's possible to do)
9 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
10 #   for hints how to make locales and other stuff like extensions working
11 # - rpm upgrade is broken. First you need uninstall Firefox 1.0.x.
12 #
13 # Conditional build:
14 %bcond_with     tests   # enable tests (whatever they check)
15 %bcond_without  gnome   # disable all GNOME components (gnomevfs, gnome, gnomeui)
16 #
17 Summary:        Mozilla Firefox web browser
18 Summary(pl):    Mozilla Firefox - przegl±darka WWW
19 Name:           mozilla-firefox
20 Version:        1.5.0.1
21 Release:        4
22 License:        MPL/LGPL
23 Group:          X11/Applications/Networking
24 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
25 # Source0-md5:  c76f02956645bc823241379e27f76bb5
26 Source1:        %{name}.desktop
27 Source2:        %{name}.sh
28 Patch0:         %{name}-nss.patch
29 Patch1:         %{name}-lib_path.patch
30 Patch2:         %{name}-nss-system-nspr.patch
31 Patch3:         %{name}-nopangoxft.patch
32 Patch4:         %{name}-name.patch
33 Patch5:         %{name}-dumpstack.patch
34 Patch6:         %{name}-pango-typo.patch
35 # UPDATE or DROP?
36 #PatchX:        %{name}-searchplugins.patch
37 URL:            http://www.mozilla.org/projects/firefox/
38 %{?with_gnome:BuildRequires:    GConf2-devel >= 1.2.1}
39 BuildRequires:  automake
40 BuildRequires:  cairo-devel >= 1.0.0
41 %{?with_gnome:BuildRequires:    gnome-vfs2-devel >= 2.0}
42 BuildRequires:  gtk+2-devel >= 1:2.0.0
43 BuildRequires:  heimdal-devel >= 0.7.1
44 BuildRequires:  libIDL-devel >= 0.8.0
45 %{?with_gnome:BuildRequires:    libgnome-devel >= 2.0}
46 %{?with_gnome:BuildRequires:    libgnomeui-devel >= 2.2.0}
47 BuildRequires:  libjpeg-devel >= 6b
48 BuildRequires:  libpng-devel >= 1.2.0
49 BuildRequires:  libstdc++-devel
50 BuildRequires:  nspr-devel >= 1:4.6.1
51 BuildRequires:  nss-devel >= 3.10.2
52 BuildRequires:  pango-devel >= 1:1.6.0
53 BuildRequires:  perl-modules >= 5.004
54 BuildRequires:  pkgconfig
55 BuildRequires:  zip
56 Requires:       %{name}-lang-resources = %{version}
57 Requires:       nspr >= 1:4.6.1
58 Requires:       nss >= 3.10.2
59 Provides:       wwwbrowser
60 Obsoletes:      mozilla-firebird
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %define         _firefoxdir     %{_libdir}/%{name}
64 # mozilla and firefox provide their own versions
65 %define         _noautoreqdep           libgkgfx.so libgtkembedmoz.so libgtkxtbin.so libjsj.so libmozjs.so libxpcom.so libxpcom_compat.so
66 %define         _noautoprovfiles        libplc4.so libplds4.so
67
68 %description
69 Mozilla Firefox is an open-source web browser, designed for standards
70 compliance, performance and portability.
71
72 %description -l pl
73 Mozilla Firefox jest open sourcow± przegl±dark± sieci WWW, stworzon± z
74 my¶l± o zgodno¶ci ze standardami, wydajno¶ci± i przeno¶no¶ci±.
75
76 %package devel
77 Summary:        Headers for developing programs that will use Mozilla Firefox
78 Summary(pl):    Mozilla Firefox - pliki nag³ówkowe
79 Group:          X11/Development/Libraries
80 Requires:       %{name} = %{epoch}:%{version}-%{release}
81 Requires:       nspr-devel >= 1:4.6.1
82 Obsoletes:      mozilla-devel
83
84 %description devel
85 Mozilla Firefox development package.
86
87 %description devel -l pl
88 Pliki nag³ówkowe przegl±darki Mozilla Firefox.
89
90 %package lang-en
91 Summary:        English resources for Mozilla Firefox
92 Summary(pl):    Anglojêzyczne zasoby dla przegl±darki Mozilla Firefox
93 Group:          X11/Applications/Networking
94 Requires(post,postun):  %{name} = %{version}-%{release}
95 Requires(post,postun):  textutils
96 Requires:       %{name} = %{version}-%{release}
97 Provides:       %{name}-lang-resources = %{version}-%{release}
98
99 %description lang-en
100 English resources for Mozilla Firefox.
101
102 %description lang-en -l pl
103 Anglojêzyczne zasoby dla przegl±darki Mozilla Firefox.
104
105 %prep
106 %setup -q -n mozilla
107 %patch0 -p1
108 %patch1 -p1
109 %patch2 -p1
110 %patch3 -p1
111 %patch4 -p1
112 %patch5 -p0
113 %patch6 -p0
114
115 sed -i 's/\(-lgss\)\(\W\)/\1disable\2/' configure
116
117 %build
118 rm -f .mozconfig
119 export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
120 export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
121
122 cp -f %{_datadir}/automake/config.* build/autoconf
123 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
124 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
125
126 LIBIDL_CONFIG="%{_bindir}/libIDL-config-2"; export LIBIDL_CONFIG
127
128 cat << EOF > .mozconfig
129 . \$topsrcdir/browser/config/mozconfig
130
131 export BUILD_OFFICIAL=1
132 export MOZILLA_OFFICIAL=1
133 mk_add_options BUILD_OFFICIAL=1
134 mk_add_options MOZILLA_OFFICIAL=1
135
136 ac_add_options --prefix=%{_prefix}
137 ac_add_options --exec-prefix=%{_exec_prefix}
138 ac_add_options --bindir=%{_bindir}
139 ac_add_options --sbindir=%{_sbindir}
140 ac_add_options --sysconfdir=%{_sysconfdir}
141 ac_add_options --datadir=%{_datadir}
142 ac_add_options --includedir=%{_includedir}
143 ac_add_options --libdir=%{_libdir}
144 ac_add_options --libexecdir=%{_libexecdir}
145 ac_add_options --localstatedir=%{_localstatedir}
146 ac_add_options --sharedstatedir=%{_sharedstatedir}
147 ac_add_options --mandir=%{_mandir}
148 ac_add_options --infodir=%{_infodir}
149 ac_add_options --enable-optimize="%{rpmcflags}"
150 %if %{?debug:1}0
151 ac_add_options --enable-debug
152 ac_add_options --enable-debug-modules
153 %else
154 ac_add_options --disable-debug
155 ac_add_options --disable-debug-modules
156 %endif
157 %if %{with tests}
158 ac_add_options --enable-tests
159 %else
160 ac_add_options --disable-tests
161 %endif
162 ac_add_options --disable-composer
163 ac_add_options --disable-dtd-debug
164 ac_add_options --disable-freetype2
165 ac_add_options --disable-installer
166 ac_add_options --disable-jsd
167 ac_add_options --disable-ldap
168 ac_add_options --disable-mailnews
169 ac_add_options --disable-profilesharing
170 ac_add_options --disable-xprint
171 ac_add_options --enable-canvas
172 ac_add_options --enable-crypto
173 ac_add_options --enable-default-toolkit=gtk2
174 ac_add_options --enable-mathml
175 ac_add_options --enable-pango
176 ac_add_options --enable-reorder
177 ac_add_options --enable-single-profile
178 ac_add_options --enable-strip
179 ac_add_options --enable-strip-libs
180 ac_add_options --enable-svg
181 ac_add_options --enable-system-cairo
182 ac_add_options --enable-xft
183 ac_add_options --enable-xinerama
184 ac_add_options --enable-xpctools
185 ac_add_options --with-pthreads
186 ac_add_options --with-system-jpeg
187 ac_add_options --with-system-nspr
188 ac_add_options --with-system-png
189 ac_add_options --with-system-zlib
190 EOF
191
192 %{__make} -j1 -f client.mk build \
193         CC="%{__cc} -fno-strict-aliasing" \
194         CXX="%{__cxx}"
195
196 %install
197 rm -rf $RPM_BUILD_ROOT
198 install -d \
199         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}{,extensions}} \
200         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
201         $RPM_BUILD_ROOT{%{_includedir}/%{name}/idl,%{_pkgconfigdir}}
202 # extensions dir is needed (it can be empty)
203
204 ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
205
206 %{__make} -C xpinstall/packager \
207         MOZ_PKG_APPNAME="mozilla-firefox" \
208         MOZILLA_BIN="\$(DIST)/bin/firefox-bin" \
209         EXCLUDE_NSPR_LIBS=1
210
211 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
212
213 tar -xvz -C $RPM_BUILD_ROOT%{_libdir} -f dist/mozilla-firefox-*linux*.tar.gz
214
215 install other-licenses/branding/firefox/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
216 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_firefoxdir}/defaults/profile/
217 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_firefoxdir}/defaults/profile/US/
218
219 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
220
221 rm -rf US classic comm embed-sample en-{US,mac,unix,win} modern pipnss pippki
222 rm -f en-win.jar en-mac.jar embed-sample.jar modern.jar
223
224 # header/developement files
225 cp -rfL dist/include/*  $RPM_BUILD_ROOT%{_includedir}/%{name}
226 cp -rfL dist/idl/*      $RPM_BUILD_ROOT%{_includedir}/%{name}/idl
227
228 install dist/bin/regxpcom $RPM_BUILD_ROOT%{_bindir}
229 install dist/bin/xpidl $RPM_BUILD_ROOT%{_bindir}
230 install dist/bin/xpt_dump $RPM_BUILD_ROOT%{_bindir}
231 install dist/bin/xpt_link $RPM_BUILD_ROOT%{_bindir}
232
233 ln -sf %{_includedir}/mozilla-firefox/necko/nsIURI.h \
234         $RPM_BUILD_ROOT%{_includedir}/mozilla-firefox/nsIURI.h
235
236 # CA certificates
237 ln -s %{_libdir}/libnssckbi.so $RPM_BUILD_ROOT%{_firefoxdir}/libnssckbi.so
238
239 # pkgconfig files
240 for f in build/unix/*.pc ; do
241         sed -e 's/firefox-%{version}/mozilla-firefox/' $f \
242             > $RPM_BUILD_ROOT%{_pkgconfigdir}/$(basename $f)
243 done
244
245 # already provided by standalone packages
246 rm -f $RPM_BUILD_ROOT%{_pkgconfigdir}/firefox-{nss,nspr}.pc
247
248 sed -i -e 's#firefox-nspr =.*#mozilla-nspr#g' -e 's#irefox-nss =.*#mozilla-nss#g' \
249         $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc
250
251 # includedir/dom CFLAGS
252 sed -i -e '/Cflags:/{/{includedir}\/dom/!s,$, -I${includedir}/dom,}' \
253         $RPM_BUILD_ROOT%{_pkgconfigdir}/firefox-plugin.pc
254
255 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/firefox-chrome+xpcom-generate
256 #!/bin/sh
257 umask 022
258 rm -f %{_firefoxdir}/chrome/{chrome.rdf,overlayinfo/*/*/*.rdf}
259 rm -f %{_firefoxdir}/components/{compreg,xpti}.dat
260 MOZILLA_FIVE_HOME=%{_firefoxdir}
261 export MOZILLA_FIVE_HOME
262
263 # PATH
264 PATH=%{_firefoxdir}:$PATH
265 export PATH
266
267 # added /usr/lib : don't load your local library
268 LD_LIBRARY_PATH=%{_firefoxdir}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}
269 export LD_LIBRARY_PATH
270
271 unset TMPDIR TMP || :
272 MOZILLA_FIVE_HOME=%{_firefoxdir} %{_firefoxdir}/regxpcom
273 MOZILLA_FIVE_HOME=%{_firefoxdir} %{_firefoxdir}/firefox -register
274 EOF
275
276 %clean
277 rm -rf $RPM_BUILD_ROOT
278
279 %post
280 %{_sbindir}/firefox-chrome+xpcom-generate
281 %banner %{name} -e <<EOF
282 ###################################################################
283 #                                                                 #
284 # NOTICE:                                                         #
285 # If you have problem with upgrade old mozilla-firefox 1.0.x, you #
286 # should remove it first.                                         #
287 #                                                                 #
288 ###################################################################
289 EOF
290
291 %postun
292 if [ "$1" != "0" ]; then
293         %{_sbindir}/firefox-chrome+xpcom-generate
294 fi
295
296 %preun
297 if [ "$1" == "0" ]; then
298         rm -rf %{_firefoxdir}/chrome/overlayinfo
299         rm -f  %{_firefoxdir}/chrome/*.rdf
300         rm -rf %{_firefoxdir}/components
301         rm -rf %{_firefoxdir}/extensions
302 fi
303
304 %files
305 %defattr(644,root,root,755)
306 %attr(755,root,root) %{_bindir}/mozilla*
307 %attr(755,root,root) %{_bindir}/firefox
308 %attr(755,root,root) %{_sbindir}/*
309 %dir %{_firefoxdir}
310 %{_firefoxdir}/res
311 %dir %{_firefoxdir}/components
312 %attr(755,root,root) %{_firefoxdir}/components/*.so
313 %{_firefoxdir}/components/*.js
314 %{_firefoxdir}/components/*.xpt
315 %{_firefoxdir}/plugins
316 %{_firefoxdir}/searchplugins
317 %{_firefoxdir}/icons
318 %{_firefoxdir}/defaults
319 %{_firefoxdir}/greprefs
320 %dir %{_firefoxdir}/extensions
321 %dir %{_firefoxdir}/init.d
322 %attr(755,root,root) %{_firefoxdir}/*.so
323 %attr(755,root,root) %{_firefoxdir}/*.sh
324 %attr(755,root,root) %{_firefoxdir}/m*
325 %attr(755,root,root) %{_firefoxdir}/f*
326 %attr(755,root,root) %{_firefoxdir}/reg*
327 %attr(755,root,root) %{_firefoxdir}/x*
328 %{_pixmapsdir}/*
329 %{_desktopdir}/*
330
331 %dir %{_firefoxdir}/chrome
332 %{_firefoxdir}/chrome/*.jar
333 %{_firefoxdir}/chrome/*.manifest
334 # -chat subpackage?
335 #%{_firefoxdir}/chrome/chatzilla.jar
336 #%{_firefoxdir}/chrome/content-packs.jar
337 %dir %{_firefoxdir}/chrome/icons
338 %{_firefoxdir}/chrome/icons/default
339
340 # -dom-inspector subpackage?
341 %dir %{_firefoxdir}/extensions/inspector@mozilla.org
342 %{_firefoxdir}/extensions/inspector@mozilla.org/*
343
344 %files devel
345 %defattr(644,root,root,755)
346 %attr(755,root,root) %{_bindir}/regxpcom
347 %attr(755,root,root) %{_bindir}/xpidl
348 %attr(755,root,root) %{_bindir}/xpt_dump
349 %attr(755,root,root) %{_bindir}/xpt_link
350 %{_includedir}/%{name}
351 %{_pkgconfigdir}/*
352
353 %files lang-en
354 %defattr(644,root,root,755)
355 %{_firefoxdir}/chrome/en-US.jar
356 %{_firefoxdir}/chrome/en-US.manifest
This page took 0.079676 seconds and 4 git commands to generate.