]> git.pld-linux.org Git - packages/firefox.git/blob - mozilla-firefox.spec
- back to mozilla-firefox 1.5.0.7 - Firefox 2.0 is in branch DEVEL
[packages/firefox.git] / mozilla-firefox.spec
1 #
2 # TODO:
3 # - with new gcc version (it is possible that)
4 #   - -fvisibility=hiddenn and ac_cv_visibility_pragma=no can be removed
5 # - with new firefox version (it is possible that)
6 #   - -fno-strict-aliasing can be removed (needs to be tested carefuly,
7 #      not to be fixed soon, imho)
8 # - handle locales differently (runtime, since it's possible to do)
9 # - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
10 #   for hints how to make locales and other stuff like extensions working
11 # - rpm upgrade is broken. First you need uninstall Firefox 1.0.x.
12 #
13 # Conditional build:
14 %bcond_with     tests   # enable tests (whatever they check)
15 %bcond_without  gnome   # disable all GNOME components (gnomevfs, gnome, gnomeui)
16 #
17 Summary:        Mozilla Firefox web browser
18 Summary(pl):    Mozilla Firefox - przegl±darka WWW
19 Name:           mozilla-firefox
20 Version:        1.5.0.7
21 Release:        1
22 License:        MPL/LGPL
23 Group:          X11/Applications/Networking
24 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
25 # Source0-md5:  518cbd99a3fe663237070013e5cdb1a4
26 Source1:        %{name}.desktop
27 Source2:        %{name}.sh
28 Patch0:         %{name}-nss.patch
29 Patch1:         %{name}-lib_path.patch
30 Patch2:         %{name}-nss-system-nspr.patch
31 Patch3:         %{name}-nopangoxft.patch
32 Patch4:         %{name}-name.patch
33 Patch5:         %{name}-fonts.patch
34 # UPDATE or DROP?
35 #PatchX:        %{name}-searchplugins.patch
36 URL:            http://www.mozilla.org/projects/firefox/
37 %{?with_gnome:BuildRequires:    GConf2-devel >= 1.2.1}
38 BuildRequires:  automake
39 BuildRequires:  cairo-devel >= 1.0.0
40 %{?with_gnome:BuildRequires:    gnome-vfs2-devel >= 2.0}
41 BuildRequires:  gtk+2-devel >= 1:2.0.0
42 BuildRequires:  heimdal-devel >= 0.7.1
43 BuildRequires:  libIDL-devel >= 0.8.0
44 %{?with_gnome:BuildRequires:    libgnome-devel >= 2.0}
45 %{?with_gnome:BuildRequires:    libgnomeui-devel >= 2.2.0}
46 BuildRequires:  libjpeg-devel >= 6b
47 BuildRequires:  libpng-devel >= 1.2.7
48 BuildRequires:  libstdc++-devel
49 BuildRequires:  nspr-devel >= 1:4.6.1-2
50 BuildRequires:  nss-devel >= 1:3.11.3
51 BuildRequires:  pango-devel >= 1:1.6.0
52 BuildRequires:  perl-modules >= 5.004
53 BuildRequires:  pkgconfig
54 BuildRequires:  xorg-lib-libXext-devel
55 BuildRequires:  xorg-lib-libXft-devel >= 2.1
56 BuildRequires:  xorg-lib-libXinerama-devel
57 BuildRequires:  xorg-lib-libXp-devel
58 BuildRequires:  xorg-lib-libXt-devel
59 BuildRequires:  zip
60 BuildRequires:  zlib-devel >= 1.2.3
61 Requires:       %{name}-lang-resources = %{version}
62 Requires:       nspr >= 1:4.6.1-2
63 Requires:       nss >= 1:3.11.3
64 Requires(post): mktemp >= 1.5-18
65 Provides:       wwwbrowser
66 Obsoletes:      mozilla-firebird
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %define         _firefoxdir     %{_libdir}/%{name}
70 # mozilla and firefox provide their own versions
71 %define         _noautoreqdep           libgkgfx.so libgtkembedmoz.so libgtkxtbin.so libjsj.so libmozjs.so libxpcom.so libxpcom_compat.so
72
73 %define         specflags       -fno-strict-aliasing
74
75 %description
76 Mozilla Firefox is an open-source web browser, designed for standards
77 compliance, performance and portability.
78
79 %description -l pl
80 Mozilla Firefox jest open sourcow± przegl±dark± sieci WWW, stworzon± z
81 my¶l± o zgodno¶ci ze standardami, wydajno¶ci± i przeno¶no¶ci±.
82
83 %package devel
84 Summary:        Headers for developing programs that will use Mozilla Firefox
85 Summary(pl):    Mozilla Firefox - pliki nag³ówkowe
86 Group:          X11/Development/Libraries
87 Requires:       %{name} = %{epoch}:%{version}-%{release}
88 Requires:       nspr-devel >= 1:4.6.1-2
89 Obsoletes:      mozilla-devel
90
91 %description devel
92 Mozilla Firefox development package.
93
94 %description devel -l pl
95 Pliki nag³ówkowe przegl±darki Mozilla Firefox.
96
97 %package lang-en
98 Summary:        English resources for Mozilla Firefox
99 Summary(pl):    Anglojêzyczne zasoby dla przegl±darki Mozilla Firefox
100 Group:          X11/Applications/Networking
101 Requires(post,postun):  %{name} = %{version}-%{release}
102 Requires(post,postun):  textutils
103 Requires:       %{name} = %{version}-%{release}
104 Provides:       %{name}-lang-resources = %{version}-%{release}
105
106 %description lang-en
107 English resources for Mozilla Firefox.
108
109 %description lang-en -l pl
110 Anglojêzyczne zasoby dla przegl±darki Mozilla Firefox.
111
112 %prep
113 %setup -qc
114 cd mozilla
115 %patch0 -p1
116 %patch1 -p1
117 %patch2 -p1
118 %patch3 -p1
119 %patch4 -p1
120 %patch5 -p1
121
122 sed -i 's/\(-lgss\)\(\W\)/\1disable\2/' configure
123
124 %build
125 cd mozilla
126 rm -f .mozconfig
127 export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
128 export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
129
130 cp -f %{_datadir}/automake/config.* build/autoconf
131 cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
132 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
133
134 LIBIDL_CONFIG="%{_bindir}/libIDL-config-2"; export LIBIDL_CONFIG
135
136 cat << 'EOF' > .mozconfig
137 . $topsrcdir/browser/config/mozconfig
138
139 export BUILD_OFFICIAL=1
140 export MOZILLA_OFFICIAL=1
141 mk_add_options BUILD_OFFICIAL=1
142 mk_add_options MOZILLA_OFFICIAL=1
143
144 ac_add_options --prefix=%{_prefix}
145 ac_add_options --exec-prefix=%{_exec_prefix}
146 ac_add_options --bindir=%{_bindir}
147 ac_add_options --sbindir=%{_sbindir}
148 ac_add_options --sysconfdir=%{_sysconfdir}
149 ac_add_options --datadir=%{_datadir}
150 ac_add_options --includedir=%{_includedir}
151 ac_add_options --libdir=%{_libdir}
152 ac_add_options --libexecdir=%{_libexecdir}
153 ac_add_options --localstatedir=%{_localstatedir}
154 ac_add_options --sharedstatedir=%{_sharedstatedir}
155 ac_add_options --mandir=%{_mandir}
156 ac_add_options --infodir=%{_infodir}
157 ac_add_options --enable-optimize="%{rpmcflags}"
158 %if %{?debug:1}0
159 ac_add_options --enable-debug
160 ac_add_options --enable-debug-modules
161 %else
162 ac_add_options --disable-debug
163 ac_add_options --disable-debug-modules
164 %endif
165 %if %{with tests}
166 ac_add_options --enable-tests
167 %else
168 ac_add_options --disable-tests
169 %endif
170 ac_add_options --disable-composer
171 ac_add_options --disable-dtd-debug
172 ac_add_options --disable-freetype2
173 ac_add_options --disable-installer
174 ac_add_options --disable-jsd
175 ac_add_options --disable-ldap
176 ac_add_options --disable-mailnews
177 ac_add_options --disable-profilesharing
178 ac_add_options --disable-xprint
179 ac_add_options --enable-canvas
180 ac_add_options --enable-crypto
181 ac_add_options --enable-default-toolkit=gtk2
182 ac_add_options --enable-mathml
183 ac_add_options --enable-pango
184 ac_add_options --enable-reorder
185 ac_add_options --enable-single-profile
186 ac_add_options --enable-strip
187 ac_add_options --enable-strip-libs
188 ac_add_options --enable-svg
189 ac_add_options --enable-system-cairo
190 ac_add_options --enable-xft
191 ac_add_options --enable-xinerama
192 ac_add_options --enable-xpctools
193 ac_add_options --with-pthreads
194 ac_add_options --with-system-jpeg
195 ac_add_options --with-system-nspr
196 ac_add_options --with-system-png
197 ac_add_options --with-system-zlib
198 ac_cv_visibility_pragma=no
199 EOF
200
201 %{__make} -j1 -f client.mk build \
202         CC="%{__cc}" \
203         CXX="%{__cxx}"
204
205 %install
206 rm -rf $RPM_BUILD_ROOT
207 cd mozilla
208 install -d \
209         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}{,extensions}} \
210         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
211         $RPM_BUILD_ROOT{%{_includedir}/%{name}/idl,%{_pkgconfigdir}}
212 # extensions dir is needed (it can be empty)
213
214 ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
215
216 %{__make} -C xpinstall/packager \
217         MOZ_PKG_APPNAME="mozilla-firefox" \
218         MOZILLA_BIN="\$(DIST)/bin/firefox-bin" \
219         EXCLUDE_NSPR_LIBS=1
220
221 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
222
223 tar -xvz -C $RPM_BUILD_ROOT%{_libdir} -f dist/mozilla-firefox-*linux*.tar.gz
224
225 install other-licenses/branding/firefox/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
226 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_firefoxdir}/defaults/profile/
227 #install -m0644 bookmarks.html $RPM_BUILD_ROOT%{_firefoxdir}/defaults/profile/US/
228
229 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
230
231 rm -rf US classic comm embed-sample en-{US,mac,unix,win} modern pipnss pippki
232 rm -f en-win.jar en-mac.jar embed-sample.jar modern.jar
233
234 # header/developement files
235 cp -rfL dist/include/*  $RPM_BUILD_ROOT%{_includedir}/%{name}
236 cp -rfL dist/idl/*      $RPM_BUILD_ROOT%{_includedir}/%{name}/idl
237
238 install dist/bin/regxpcom $RPM_BUILD_ROOT%{_bindir}
239 install dist/bin/xpidl $RPM_BUILD_ROOT%{_bindir}
240 install dist/bin/xpt_dump $RPM_BUILD_ROOT%{_bindir}
241 install dist/bin/xpt_link $RPM_BUILD_ROOT%{_bindir}
242
243 ln -sf %{_includedir}/mozilla-firefox/necko/nsIURI.h \
244         $RPM_BUILD_ROOT%{_includedir}/mozilla-firefox/nsIURI.h
245
246 # CA certificates
247 ln -s %{_libdir}/libnssckbi.so $RPM_BUILD_ROOT%{_firefoxdir}/libnssckbi.so
248
249 # pkgconfig files
250 for f in build/unix/*.pc ; do
251         sed -e 's/firefox-%{version}/mozilla-firefox/' $f \
252             > $RPM_BUILD_ROOT%{_pkgconfigdir}/$(basename $f)
253 done
254
255 # already provided by standalone packages
256 rm -f $RPM_BUILD_ROOT%{_pkgconfigdir}/firefox-{nss,nspr}.pc
257
258 sed -i -e 's#firefox-nspr =.*#mozilla-nspr#g' -e 's#irefox-nss =.*#mozilla-nss#g' \
259         $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc
260
261 # includedir/dom CFLAGS
262 sed -i -e '/Cflags:/{/{includedir}\/dom/!s,$, -I${includedir}/dom,}' \
263         $RPM_BUILD_ROOT%{_pkgconfigdir}/firefox-plugin.pc
264
265 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/firefox-chrome+xpcom-generate
266 #!/bin/sh
267 umask 022
268 rm -f %{_firefoxdir}/chrome/{chrome.rdf,overlayinfo/*/*/*.rdf}
269 rm -f %{_firefoxdir}/components/{compreg,xpti}.dat
270 MOZILLA_FIVE_HOME=%{_firefoxdir}
271 export MOZILLA_FIVE_HOME
272
273 # PATH
274 PATH=%{_firefoxdir}:$PATH
275 export PATH
276
277 # added /usr/lib : don't load your local library
278 LD_LIBRARY_PATH=%{_firefoxdir}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}
279 export LD_LIBRARY_PATH
280
281 unset TMPDIR TMP || :
282 export HOME=$(mktemp -d)
283 MOZILLA_FIVE_HOME=%{_firefoxdir} %{_firefoxdir}/regxpcom
284 MOZILLA_FIVE_HOME=%{_firefoxdir} %{_firefoxdir}/firefox -register
285 rm -rf $HOME
286 EOF
287
288 %clean
289 rm -rf $RPM_BUILD_ROOT
290
291 %post
292 %{_sbindir}/firefox-chrome+xpcom-generate
293
294 %postun
295 if [ "$1" = "0" ]; then
296         rm -rf %{_firefoxdir}/chrome/overlayinfo
297         rm -f  %{_firefoxdir}/chrome/*.rdf
298         rm -rf %{_firefoxdir}/components
299         rm -rf %{_firefoxdir}/extensions
300 fi
301
302 %triggerpostun -- %{name} < 1.5
303 %banner %{name} -e <<EOF
304 NOTICE:
305 If you have problem with upgrade from old mozilla-firefox 1.0.x,
306 you should remove it first and reinstall %{name}-%{version}
307 EOF
308
309 %files
310 %defattr(644,root,root,755)
311 %attr(755,root,root) %{_bindir}/mozilla*
312 %attr(755,root,root) %{_bindir}/firefox
313 %attr(755,root,root) %{_sbindir}/*
314 %dir %{_firefoxdir}
315 %{_firefoxdir}/res
316 %dir %{_firefoxdir}/components
317 %attr(755,root,root) %{_firefoxdir}/components/*.so
318 %{_firefoxdir}/components/*.js
319 %{_firefoxdir}/components/*.xpt
320 %dir %{_firefoxdir}/plugins
321 %attr(755,root,root) %{_firefoxdir}/plugins/*.so
322 %{_firefoxdir}/searchplugins
323 %{_firefoxdir}/icons
324 %{_firefoxdir}/defaults
325 %{_firefoxdir}/greprefs
326 %dir %{_firefoxdir}/extensions
327 %dir %{_firefoxdir}/init.d
328 %attr(755,root,root) %{_firefoxdir}/*.so
329 %attr(755,root,root) %{_firefoxdir}/*.sh
330 %attr(755,root,root) %{_firefoxdir}/m*
331 %attr(755,root,root) %{_firefoxdir}/f*
332 %attr(755,root,root) %{_firefoxdir}/reg*
333 %attr(755,root,root) %{_firefoxdir}/x*
334 %{_pixmapsdir}/*
335 %{_desktopdir}/*
336
337 %dir %{_firefoxdir}/chrome
338 %{_firefoxdir}/chrome/*.jar
339 %{_firefoxdir}/chrome/*.manifest
340 # -chat subpackage?
341 #%{_firefoxdir}/chrome/chatzilla.jar
342 #%{_firefoxdir}/chrome/content-packs.jar
343 %dir %{_firefoxdir}/chrome/icons
344 %{_firefoxdir}/chrome/icons/default
345
346 # -dom-inspector subpackage?
347 %dir %{_firefoxdir}/extensions/inspector@mozilla.org
348 %{_firefoxdir}/extensions/inspector@mozilla.org/*
349
350 %files devel
351 %defattr(644,root,root,755)
352 %attr(755,root,root) %{_bindir}/regxpcom
353 %attr(755,root,root) %{_bindir}/xpidl
354 %attr(755,root,root) %{_bindir}/xpt_dump
355 %attr(755,root,root) %{_bindir}/xpt_link
356 %{_includedir}/%{name}
357 %{_pkgconfigdir}/*
358
359 %files lang-en
360 %defattr(644,root,root,755)
361 %{_firefoxdir}/chrome/en-US.jar
362 %{_firefoxdir}/chrome/en-US.manifest
This page took 0.052825 seconds and 4 git commands to generate.