]> git.pld-linux.org Git - packages/firefox.git/blame_incremental - mozilla-firefox.spec
- updated to 3.6.15, fixes:
[packages/firefox.git] / mozilla-firefox.spec
... / ...
CommitLineData
1# NOTE: PLD distributes iceweasel instead
2#
3# TODO:
4# - handle locales differently (runtime, since it's possible to do)
5# - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
6# for hints how to make locales
7# - (12:22:58) patrys: can you also move _libdir/mozilla-firefox to just _libdir/firefox?
8# (12:23:25) patrys: it's not like we ship official firefox
9# - fix wrapper script to allow playing with profiles (must not use -remote)
10#
11# Conditional build:
12%bcond_with tests # enable tests (whatever they check)
13%bcond_without gnomeui # disable gnomeui support
14%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
15%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
16%bcond_without kerberos # disable krb5 support
17%bcond_without xulrunner # system xulrunner
18
19%if %{without gnome}
20%undefine with_gnomeui
21%undefine with_gnomevfs
22%endif
23
24# convert firefox release number to platform version: 3.6.x -> 1.9.2.x
25%define xulrunner_main 1.9.2
26%define xulrunner_ver %(v=%{version}; echo %{xulrunner_main}${v#3.6})
27
28%if %{without xulrunner}
29# The actual sqlite version (see RHBZ#480989):
30%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
31%endif
32
33Summary: Firefox Community Edition web browser
34Summary(pl.UTF-8): Firefox Community Edition - przeglądarka WWW
35Name: mozilla-firefox
36Version: 3.6.15
37Release: 1
38License: MPL 1.1 or GPL v2+ or LGPL v2.1+
39Group: X11/Applications/Networking
40Source0: http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.bz2
41# Source0-md5: fcf8042948d91f1f3d9c33599b79cf35
42Source1: %{name}.desktop
43Source2: %{name}.sh
44Patch0: %{name}-install.patch
45Patch1: %{name}-gcc3.patch
46Patch2: %{name}-agent.patch
47Patch3: %{name}-agent-ac.patch
48Patch4: %{name}-ti-agent.patch
49Patch5: %{name}-branding.patch
50Patch6: %{name}-prefs.patch
51Patch7: %{name}-nss_cflags.patch
52Patch8: %{name}-no-subshell.patch
53Patch9: %{name}-libpng.patch
54URL: http://www.mozilla.org/projects/firefox/
55%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
56BuildRequires: alsa-lib-devel
57BuildRequires: automake
58BuildRequires: bzip2-devel
59BuildRequires: cairo-devel >= 1.8.8
60BuildRequires: dbus-glib-devel >= 0.60
61%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
62BuildRequires: gtk+2-devel >= 2:2.10
63%{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
64BuildRequires: hunspell-devel
65BuildRequires: libIDL-devel >= 0.8.0
66BuildRequires: libdnet-devel
67%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
68%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
69BuildRequires: libiw-devel
70BuildRequires: libjpeg-devel >= 6b
71BuildRequires: libnotify-devel >= 0.4
72BuildRequires: libpng(APNG)-devel >= 0.10
73BuildRequires: libpng-devel >= 1.2.17
74BuildRequires: libstdc++-devel
75BuildRequires: nspr-devel >= 1:4.8.6
76BuildRequires: nss-devel >= 1:3.12.8
77BuildRequires: pango-devel >= 1:1.14.0
78BuildRequires: perl-modules >= 5.004
79BuildRequires: pkgconfig
80BuildRequires: python-modules
81BuildRequires: rpm >= 4.4.9-56
82BuildRequires: rpmbuild(macros) >= 1.453
83BuildRequires: sqlite3-devel >= 3.7.2
84BuildRequires: startup-notification-devel >= 0.8
85BuildRequires: xorg-lib-libXext-devel
86BuildRequires: xorg-lib-libXft-devel >= 2.1
87BuildRequires: xorg-lib-libXinerama-devel
88BuildRequires: xorg-lib-libXp-devel
89BuildRequires: xorg-lib-libXt-devel
90%if %{with xulrunner}
91BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
92%endif
93BuildRequires: zip
94BuildRequires: zlib-devel >= 1.2.3
95Requires(post): mktemp >= 1.5-18
96%if %{with xulrunner}
97%requires_eq_to xulrunner xulrunner-devel
98%else
99Requires: browser-plugins >= 2.0
100Requires: cairo >= 1.8.8
101Requires: dbus-glib >= 0.60
102Requires: gtk+2 >= 2:2.18
103Requires: libpng(APNG) >= 0.10
104Requires: myspell-common
105Requires: nspr >= 1:4.8.6
106Requires: nss >= 1:3.12.8
107Requires: pango >= 1:1.14.0
108Requires: sqlite3 >= %{sqlite_build_version}
109Requires: startup-notification >= 0.8
110%endif
111Provides: wwwbrowser
112Obsoletes: mozilla-firebird
113Obsoletes: mozilla-firefox-lang-en < 2.0.0.8-3
114Obsoletes: mozilla-firefox-libs
115BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
116
117# don't satisfy other packages (don't use %{name} here)
118%define _noautoprovfiles %{_libdir}/mozilla-firefox
119# and as we don't provide them, don't require either
120%define _noautoreq libmozjs.so libxpcom.so libxul.so libjemalloc.so
121
122%if "%{cc_version}" >= "3.4"
123%define specflags -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
124%else
125%define specflags -fno-strict-aliasing
126%endif
127
128%description
129Firefox Community Edition is an open-source web browser, designed for
130standards compliance, performance and portability.
131
132%description -l pl.UTF-8
133Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
134zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
135o zgodności ze standardami, wydajnością i przenośnością.
136
137%prep
138%setup -qc
139mv -f mozilla-%{xulrunner_main} mozilla
140cd mozilla
141
142%patch0 -p1
143
144%if "%{cc_version}" < "3.4"
145%patch1 -p2
146%endif
147
148%if "%{pld_release}" == "th"
149%patch2 -p1
150%endif
151
152%if "%{pld_release}" == "ac"
153%patch3 -p1
154%endif
155
156%if "%{pld_release}" == "ti"
157%patch4 -p1
158%endif
159
160%patch5 -p1
161%patch6 -p1
162%patch7 -p1
163%patch8 -p2
164%patch9 -p0
165
166%build
167cd mozilla
168cp -f %{_datadir}/automake/config.* build/autoconf
169
170cat << EOF > .mozconfig
171. \$topsrcdir/browser/config/mozconfig
172
173mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
174
175# Options for 'configure' (same as command-line options).
176ac_add_options --prefix=%{_prefix}
177ac_add_options --exec-prefix=%{_exec_prefix}
178ac_add_options --bindir=%{_bindir}
179ac_add_options --sbindir=%{_sbindir}
180ac_add_options --sysconfdir=%{_sysconfdir}
181ac_add_options --datadir=%{_datadir}
182ac_add_options --includedir=%{_includedir}
183ac_add_options --libdir=%{_libdir}
184ac_add_options --libexecdir=%{_libexecdir}
185ac_add_options --localstatedir=%{_localstatedir}
186ac_add_options --sharedstatedir=%{_sharedstatedir}
187ac_add_options --mandir=%{_mandir}
188ac_add_options --infodir=%{_infodir}
189%if %{?debug:1}0
190ac_add_options --disable-optimize
191ac_add_options --enable-debug
192ac_add_options --enable-debug-modules
193ac_add_options --enable-debugger-info-modules
194ac_add_options --enable-crash-on-assert
195%else
196ac_add_options --disable-debug
197ac_add_options --disable-debug-modules
198ac_add_options --disable-logging
199ac_add_options --enable-optimize="%{rpmcflags} -Os"
200%endif
201ac_add_options --disable-strip
202ac_add_options --disable-strip-libs
203%if %{with tests}
204ac_add_options --enable-tests
205%else
206ac_add_options --disable-tests
207%endif
208%if %{with gnomeui}
209ac_add_options --enable-gnomeui
210%else
211ac_add_options --disable-gnomeui
212%endif
213%if %{with gnomevfs}
214ac_add_options --enable-gnomevfs
215%else
216ac_add_options --disable-gnomevfs
217%endif
218ac_add_options --disable-crashreporter
219ac_add_options --disable-installer
220ac_add_options --disable-javaxpcom
221ac_add_options --disable-updater
222ac_add_options --disable-xprint
223ac_add_options --enable-canvas
224ac_add_options --enable-libxul
225ac_add_options --enable-pango
226ac_add_options --enable-startup-notification
227ac_add_options --enable-svg
228ac_add_options --enable-system-cairo
229ac_add_options --enable-system-hunspell
230ac_add_options --enable-system-sqlite
231ac_add_options --enable-xinerama
232ac_add_options --with-distribution-id=org.pld-linux
233%if %{with xulrunner}
234ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
235%endif
236ac_add_options --with-pthreads
237ac_add_options --with-system-bz2
238ac_add_options --with-system-jpeg
239ac_add_options --with-system-nspr
240ac_add_options --with-system-nss
241ac_add_options --with-system-png
242ac_add_options --with-system-zlib
243ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
244EOF
245
246%{__make} -j1 -f client.mk build \
247 STRIP="/bin/true" \
248 CC="%{__cc}" \
249 CXX="%{__cxx}"
250
251%install
252rm -rf $RPM_BUILD_ROOT
253cd mozilla
254install -d \
255 $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
256 $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
257 $RPM_BUILD_ROOT%{_datadir}/%{name}
258
259%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
260
261%{__make} -C obj-%{_target_cpu}/browser/installer stage-package \
262 DESTDIR=$RPM_BUILD_ROOT \
263 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
264 PKG_SKIP_STRIP=1
265
266install -d \
267 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
268
269# move arch independant ones to datadir
270mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
271mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
272mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
273mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
274mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
275mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
276mv $RPM_BUILD_ROOT%{_libdir}/%{name}/browserconfig.properties $RPM_BUILD_ROOT%{_datadir}/%{name}
277%if %{without xulrunner}
278mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
279mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
280%endif
281
282ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
283ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
284ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
285ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
286ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
287ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
288ln -s ../../share/%{name}/browserconfig.properties $RPM_BUILD_ROOT%{_libdir}/%{name}
289%if %{without xulrunner}
290ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
291ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
292%endif
293
294%if %{without xulrunner}
295%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
296ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
297%endif
298
299sed 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
300chmod 755 $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
301ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
302
303cp -a browser/branding/unofficial/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
304cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
305
306# files created by firefox -register
307touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
308touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
309
310%if %{with xulrunner}
311%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/run-mozilla.sh
312%endif
313%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/LICENSE
314%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
315%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
316
317cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
318#!/bin/sh
319umask 022
320rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
321
322# it attempts to touch files in $HOME/.mozilla
323# beware if you run this with sudo!!!
324export HOME=$(mktemp -d)
325# also TMPDIR could be pointing to sudo user's homedir
326unset TMPDIR TMP || :
327
328%{_libdir}/%{name}/firefox -register
329
330rm -rf $HOME
331EOF
332chmod 755 $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
333
334%clean
335rm -rf $RPM_BUILD_ROOT
336
337%pretrans
338if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
339 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
340fi
341for d in chrome defaults extensions greprefs icons res searchplugins; do
342 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
343 install -d %{_datadir}/%{name}
344 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
345 fi
346done
347exit 0
348
349%post
350%{_sbindir}/%{name}-chrome+xpcom-generate
351%update_browser_plugins
352
353%postun
354if [ "$1" = 0 ]; then
355 %update_browser_plugins
356fi
357
358%files
359%defattr(644,root,root,755)
360%attr(755,root,root) %{_bindir}/%{name}
361%attr(755,root,root) %{_bindir}/firefox
362%attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
363
364# browser plugins v2
365%{_browserpluginsconfdir}/browsers.d/%{name}.*
366%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
367
368%dir %{_libdir}/%{name}
369%if %{without xulrunner}
370%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
371%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
372%attr(755,root,root) %{_libdir}/%{name}/libxul.so
373%endif
374%{_libdir}/%{name}/blocklist.xml
375
376%if %{with crashreporter}
377%{_libdir}/%{name}/crashreporter
378%{_libdir}/%{name}/crashreporter-override.ini
379%{_libdir}/%{name}/crashreporter.ini
380%{_libdir}/%{name}/Throbber-small.gif
381%endif
382
383# config?
384%{_libdir}/%{name}/.autoreg
385%{_libdir}/%{name}/application.ini
386
387%dir %{_libdir}/%{name}/components
388
389%{_libdir}/%{name}/components/FeedConverter.js
390%{_libdir}/%{name}/components/FeedWriter.js
391%{_libdir}/%{name}/components/WebContentConverter.js
392%{_libdir}/%{name}/components/browser.xpt
393%{_libdir}/%{name}/components/fuelApplication.js
394%{_libdir}/%{name}/components/nsBrowserContentHandler.js
395%{_libdir}/%{name}/components/nsBrowserGlue.js
396%{_libdir}/%{name}/components/nsMicrosummaryService.js
397%{_libdir}/%{name}/components/nsPlacesTransactionsService.js
398%{_libdir}/%{name}/components/nsPrivateBrowsingService.js
399%{_libdir}/%{name}/components/nsSafebrowsingApplication.js
400%{_libdir}/%{name}/components/nsSessionStartup.js
401%{_libdir}/%{name}/components/nsSessionStore.js
402%{_libdir}/%{name}/components/nsSetDefaultBrowser.js
403%{_libdir}/%{name}/components/nsSidebar.js
404%if %{without xulrunner}
405%{_libdir}/%{name}/platform.ini
406%{_libdir}/%{name}/components/FeedProcessor.js
407%{_libdir}/%{name}/components/GPSDGeolocationProvider.js
408%{_libdir}/%{name}/components/NetworkGeolocationProvider.js
409%{_libdir}/%{name}/components/jsconsole-clhandler.js
410%{_libdir}/%{name}/components/nsAddonRepository.js
411%{_libdir}/%{name}/components/nsBadCertHandler.js
412%{_libdir}/%{name}/components/nsBlocklistService.js
413%{_libdir}/%{name}/components/nsContentDispatchChooser.js
414%{_libdir}/%{name}/components/nsContentPrefService.js
415%{_libdir}/%{name}/components/nsDefaultCLH.js
416%{_libdir}/%{name}/components/nsDownloadManagerUI.js
417%{_libdir}/%{name}/components/nsExtensionManager.js
418%{_libdir}/%{name}/components/nsFilePicker.js
419%{_libdir}/%{name}/components/nsFormAutoComplete.js
420%{_libdir}/%{name}/components/nsHandlerService.js
421%{_libdir}/%{name}/components/nsHelperAppDlg.js
422%{_libdir}/%{name}/components/nsINIProcessor.js
423%{_libdir}/%{name}/components/nsLivemarkService.js
424%{_libdir}/%{name}/components/nsLoginInfo.js
425%{_libdir}/%{name}/components/nsLoginManager.js
426%{_libdir}/%{name}/components/nsLoginManagerPrompter.js
427%{_libdir}/%{name}/components/nsPlacesAutoComplete.js
428%{_libdir}/%{name}/components/nsPlacesDBFlush.js
429%{_libdir}/%{name}/components/nsProxyAutoConfig.js
430%{_libdir}/%{name}/components/nsSearchService.js
431%{_libdir}/%{name}/components/nsSearchSuggestions.js
432%{_libdir}/%{name}/components/nsTaggingService.js
433%{_libdir}/%{name}/components/nsTryToClose.js
434%{_libdir}/%{name}/components/nsURLFormatter.js
435%{_libdir}/%{name}/components/nsUpdateTimerManager.js
436%{_libdir}/%{name}/components/nsUrlClassifierLib.js
437%{_libdir}/%{name}/components/nsUrlClassifierListManager.js
438%{_libdir}/%{name}/components/nsWebHandlerApp.js
439%{_libdir}/%{name}/components/pluginGlue.js
440%{_libdir}/%{name}/components/storage-Legacy.js
441%{_libdir}/%{name}/components/storage-mozStorage.js
442%{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
443%endif
444
445%attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
446%attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
447%if %{without xulrunner}
448%attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
449%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so
450%endif
451
452%if %{with gnomevfs} && %{without xulrunner}
453%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
454%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so
455%endif
456
457%attr(755,root,root) %{_libdir}/%{name}/firefox
458%dir %{_libdir}/%{name}/plugins
459%if %{without xulrunner}
460%attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
461%attr(755,root,root) %{_libdir}/%{name}/firefox-bin
462%attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
463%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
464%attr(755,root,root) %{_libdir}/%{name}/plugin-container
465%endif
466%{_pixmapsdir}/mozilla-firefox.png
467%{_desktopdir}/mozilla-firefox.desktop
468
469# symlinks
470%{_libdir}/%{name}/chrome
471%{_libdir}/%{name}/defaults
472%{_libdir}/%{name}/extensions
473%{_libdir}/%{name}/icons
474%{_libdir}/%{name}/modules
475%{_libdir}/%{name}/searchplugins
476%{_libdir}/%{name}/browserconfig.properties
477%if %{without xulrunner}
478%{_libdir}/%{name}/dictionaries
479%{_libdir}/%{name}/greprefs
480%{_libdir}/%{name}/res
481%endif
482
483%dir %{_datadir}/%{name}
484%{_datadir}/%{name}/chrome
485%{_datadir}/%{name}/defaults
486%{_datadir}/%{name}/icons
487%{_datadir}/%{name}/modules
488%{_datadir}/%{name}/searchplugins
489%{_datadir}/%{name}/browserconfig.properties
490%if %{without xulrunner}
491%{_datadir}/%{name}/greprefs
492%{_datadir}/%{name}/res
493%endif
494
495%dir %{_datadir}/%{name}/extensions
496# -dom-inspector subpackage?
497#%{_datadir}/%{name}/extensions/inspector@mozilla.org
498# the signature of the default theme
499%{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
500
501# files created by firefox -register
502%ghost %{_libdir}/%{name}/components/compreg.dat
503%ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.036815 seconds and 4 git commands to generate.