]> git.pld-linux.org Git - packages/firefox.git/blame_incremental - mozilla-firefox.spec
- MOZILLA_FIVE_HOME is compiled in
[packages/firefox.git] / mozilla-firefox.spec
... / ...
CommitLineData
1# TODO:
2# - handle locales differently (runtime, since it's possible to do)
3# - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
4# for hints how to make locales
5# - make it more pld-like (bookmarks, default page etc..)
6#
7# Conditional build:
8%bcond_with tests # enable tests (whatever they check)
9%bcond_without gnomeui # disable gnomeui support
10%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
11%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
12%bcond_with tidy # htmlvalidator extension (tidy)
13#
14%if %{without gnome}
15%undefine with_gnomeui
16%undefine with_gnomevfs
17%endif
18%define tidy_ver 0.8.4.1
19%define firefox_ver 2.0.0.8
20#
21Summary: Firefox Community Edition web browser
22Summary(pl.UTF-8): Firefox Community Edition - przeglądarka WWW
23Name: mozilla-firefox
24Version: %{firefox_ver}
25Release: 2
26License: MPL 1.1 or GPL v2+ or LGPL v2.1+
27Group: X11/Applications/Networking
28Source0: ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
29# Source0-md5: f4ffac67751bc3e556c4926da2e0b65a
30Source1: http://users.skynet.be/mgueury/mozilla/tidy_08x_source.zip
31# Source1-md5: 2cab81118267fc87c9ebbfa6fb44b113
32Source2: %{name}.desktop
33Source3: %{name}.sh
34Patch0: mozilla-install.patch
35Patch1: %{name}-lib_path.patch
36Patch2: %{name}-addon-tidy.patch
37Patch3: %{name}-fonts.patch
38Patch4: %{name}-agent.patch
39Patch5: %{name}-myspell.patch
40# if ac rebuild is needed...
41#PatchX: %{name}-ac.patch
42URL: http://www.mozilla.org/projects/firefox/
43%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
44BuildRequires: automake
45BuildRequires: cairo-devel >= 1.0.0
46%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
47BuildRequires: gtk+2-devel >= 1:2.0.0
48BuildRequires: krb5-devel
49BuildRequires: libIDL-devel >= 0.8.0
50%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
51%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
52BuildRequires: libjpeg-devel >= 6b
53BuildRequires: libpng-devel >= 1.2.7
54BuildRequires: libstdc++-devel
55BuildRequires: myspell-devel
56BuildRequires: nspr-devel >= 1:4.6.3
57BuildRequires: nss-devel >= 1:3.11.3-3
58%{?with_tidy:BuildRequires: opensp-devel >= 2:1.5.2-4}
59BuildRequires: pango-devel >= 1:1.6.0
60BuildRequires: perl-modules >= 5.004
61BuildRequires: pkgconfig
62BuildRequires: rpmbuild(macros) >= 1.356
63BuildRequires: xorg-lib-libXext-devel
64BuildRequires: xorg-lib-libXft-devel >= 2.1
65BuildRequires: xorg-lib-libXinerama-devel
66BuildRequires: xorg-lib-libXp-devel
67BuildRequires: xorg-lib-libXt-devel
68BuildRequires: zip
69BuildRequires: zlib-devel >= 1.2.3
70Requires(post): mktemp >= 1.5-18
71Requires: %{name}-lang-resources = %{version}
72Requires: browser-plugins >= 2.0
73Requires: nspr >= 1:4.6.3
74Requires: nss >= 1:3.11.3
75Provides: wwwbrowser
76Obsoletes: mozilla-firebird
77Obsoletes: mozilla-firefox-libs
78BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80# firefox/thunderbird/seamonkey provide their own versions
81%define _noautoreqdep libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so
82%define _noautoprovfiles %{_libdir}/%{name}/components
83# we don't want these to satisfy xulrunner-devel
84%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
85# and as we don't provide them, don't require either
86%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
87
88%define specflags -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
89
90%description
91Firefox Community Edition is an open-source web browser, designed for
92standards compliance, performance and portability.
93
94%description -l pl.UTF-8
95Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
96zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
97o zgodności ze standardami, wydajnością i przenośnością.
98
99%package addon-tidy
100Summary: HTML Validator for Firefox
101Summary(pl.UTF-8): Narzędzie do sprawdzania poprawności HTML-a dla Firefoksa
102Version: %{tidy_ver}
103License: GPL
104Group: X11/Applications/Networking
105URL: http://users.skynet.be/mgueury/mozilla/
106Requires: %{name} = %{firefox_ver}-%{release}
107
108%description addon-tidy
109HTML Validator is a Mozilla extension that adds HTML validation inside
110Firefox. The number of errors of a HTML page is seen on the form of an
111icon in the status bar when browsing.
112
113%description addon-tidy -l pl.UTF-8
114HTML Validator to rozszerzenie Mozilli dodające sprawdzanie
115poprawności HTML-a w Firefoksie. Liczbę błędów na przeglądanej stronie
116HTML można zobaczyć w postaci ikony na pasku stanu.
117
118%package lang-en
119Summary: English resources for Firefox Community Edition
120Summary(pl.UTF-8): Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition
121Version: %{firefox_ver}
122Group: X11/Applications/Networking
123Requires: %{name} = %{firefox_ver}-%{release}
124Provides: %{name}-lang-resources = %{firefox_ver}-%{release}
125
126%description lang-en
127English resources for Firefox Community Edition.
128
129%description lang-en -l pl.UTF-8
130Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition.
131
132%prep
133%setup -qc %{?with_tidy:-a1}
134%if %{with tidy}
135mv mozilla_tidy_source/mozilla/extensions/tidy mozilla/extensions/tidy
136mv mozilla_tidy_source/tidy_extension .
137rm -rf mozilla/extensions/tidy/opensp
138%endif
139cd mozilla
140%patch0 -p1
141%patch1 -p1
142%{?with_tidy:%patch2 -p1}
143%patch3 -p1
144%patch4 -p1
145%patch5 -p1
146
147# use system
148#rm -rf mozilla/nsprpub mozilla/security/nss
149
150%build
151cd mozilla
152export CFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
153export CXXFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
154
155cp -f %{_datadir}/automake/config.* build/autoconf
156cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
157cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
158
159cat << 'EOF' > .mozconfig
160. $topsrcdir/browser/config/mozconfig
161
162# Options for 'configure' (same as command-line options).
163ac_add_options --prefix=%{_prefix}
164ac_add_options --exec-prefix=%{_exec_prefix}
165ac_add_options --bindir=%{_bindir}
166ac_add_options --sbindir=%{_sbindir}
167ac_add_options --sysconfdir=%{_sysconfdir}
168ac_add_options --datadir=%{_datadir}
169ac_add_options --includedir=%{_includedir}
170ac_add_options --libdir=%{_libdir}
171ac_add_options --libexecdir=%{_libexecdir}
172ac_add_options --localstatedir=%{_localstatedir}
173ac_add_options --sharedstatedir=%{_sharedstatedir}
174ac_add_options --mandir=%{_mandir}
175ac_add_options --infodir=%{_infodir}
176%if %{?debug:1}0
177ac_add_options --disable-optimize
178ac_add_options --enable-debug
179ac_add_options --enable-debug-modules
180ac_add_options --enable-debugger-info-modules
181ac_add_options --enable-crash-on-assert
182%else
183ac_add_options --disable-debug
184ac_add_options --disable-logging
185ac_add_options --enable-optimize="%{rpmcflags}"
186%endif
187%if %{with tests}
188ac_add_options --enable-tests
189%else
190ac_add_options --disable-tests
191%endif
192%if %{with gnomeui}
193ac_add_options --enable-gnomeui
194%else
195ac_add_options --disable-gnomeui
196%endif
197%if %{with gnomevfs}
198ac_add_options --enable-gnomevfs
199%else
200ac_add_options --disable-gnomevfs
201%endif
202ac_add_options --disable-freetype2
203ac_add_options --disable-installer
204ac_add_options --disable-javaxpcom
205ac_add_options --disable-updater
206ac_add_options --enable-default-toolkit=gtk2
207ac_add_options --enable-svg
208ac_add_options --enable-system-cairo
209ac_add_options --enable-system-myspell
210ac_add_options --enable-xft
211ac_add_options --with-distribution-id=org.pld-linux
212ac_add_options --with-system-nspr
213ac_add_options --with-system-nss
214ac_add_options --with-system-zlib
215ac_add_options --with-system-jpeg
216ac_add_options --with-system-png
217ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
218ac_cv_visibility_pragma=no
219EOF
220
221%{__make} -j1 -f client.mk build \
222 CC="%{__cc}" \
223 CXX="%{__cxx}"
224
225%install
226rm -rf $RPM_BUILD_ROOT
227cd mozilla
228install -d \
229 $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
230 $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
231 $RPM_BUILD_ROOT%{_datadir}/%{name}
232
233%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
234
235%{__make} -C xpinstall/packager stage-package \
236 DESTDIR=$RPM_BUILD_ROOT \
237 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
238 PKG_SKIP_STRIP=1
239
240# move arch independant ones to datadir
241mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
242mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
243mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
244mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
245mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
246mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
247mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
248mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
249ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
250ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
251ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
252ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
253ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
254ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
255ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
256ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
257
258rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
259ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
260
261sed 's,@LIBDIR@,%{_libdir},' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
262ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
263
264install browser/base/branding/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
265
266install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
267
268# header/development files
269rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpidl
270rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_dump
271rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_link
272
273# files created by regxpcom and firefox -register
274touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
275touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
276
277# what's this? it's content is invalid anyway.
278rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
279rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
280
281cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
282#!/bin/sh
283umask 022
284rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
285
286# it attempts to touch files in $HOME/.mozilla
287# beware if you run this with sudo!!!
288export HOME=$(mktemp -d)
289# also TMPDIR could be pointing to sudo user's homedir
290unset TMPDIR TMP || :
291
292LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
293%{_libdir}/%{name}/firefox -register
294
295rm -rf $HOME
296EOF
297
298%clean
299rm -rf $RPM_BUILD_ROOT
300
301%pretrans
302if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
303 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
304fi
305for d in chrome defaults extensions greprefs icons init.d res searchplugins; do
306 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
307 install -d %{_datadir}/%{name}
308 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
309 fi
310done
311exit 0
312
313%post
314%{_sbindir}/%{name}-chrome+xpcom-generate
315%update_browser_plugins
316
317%postun
318if [ "$1" = 0 ]; then
319 %update_browser_plugins
320fi
321
322%files
323%defattr(644,root,root,755)
324%attr(755,root,root) %{_bindir}/%{name}
325%attr(755,root,root) %{_bindir}/firefox
326%attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
327
328# browser plugins v2
329%{_browserpluginsconfdir}/browsers.d/%{name}.*
330%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
331
332%dir %{_libdir}/%{name}
333%attr(755,root,root) %{_libdir}/%{name}/*.so
334
335%dir %{_libdir}/%{name}/components
336%attr(755,root,root) %{_libdir}/%{name}/components/libaccessibility.so
337%attr(755,root,root) %{_libdir}/%{name}/components/libappcomps.so
338%attr(755,root,root) %{_libdir}/%{name}/components/libauth.so
339%attr(755,root,root) %{_libdir}/%{name}/components/libautoconfig.so
340%attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
341%attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
342%attr(755,root,root) %{_libdir}/%{name}/components/libcaps.so
343%attr(755,root,root) %{_libdir}/%{name}/components/libchrome.so
344%attr(755,root,root) %{_libdir}/%{name}/components/libcommandlines.so
345%attr(755,root,root) %{_libdir}/%{name}/components/libcomposer.so
346%attr(755,root,root) %{_libdir}/%{name}/components/libcookie.so
347%attr(755,root,root) %{_libdir}/%{name}/components/libdocshell.so
348%attr(755,root,root) %{_libdir}/%{name}/components/libeditor.so
349%attr(755,root,root) %{_libdir}/%{name}/components/libembedcomponents.so
350%attr(755,root,root) %{_libdir}/%{name}/components/libfileview.so
351%attr(755,root,root) %{_libdir}/%{name}/components/libgfx_gtk.so
352%attr(755,root,root) %{_libdir}/%{name}/components/libgfxps.so
353%attr(755,root,root) %{_libdir}/%{name}/components/libgklayout.so
354%attr(755,root,root) %{_libdir}/%{name}/components/libgkplugin.so
355%attr(755,root,root) %{_libdir}/%{name}/components/libhtmlpars.so
356%attr(755,root,root) %{_libdir}/%{name}/components/libi18n.so
357%{?with_gnomeui:%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so}
358%attr(755,root,root) %{_libdir}/%{name}/components/libimglib2.so
359%attr(755,root,root) %{_libdir}/%{name}/components/libjar50.so
360%attr(755,root,root) %{_libdir}/%{name}/components/libjsd.so
361%attr(755,root,root) %{_libdir}/%{name}/components/libmork.so
362%attr(755,root,root) %{_libdir}/%{name}/components/libmozfind.so
363%{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so}
364%attr(755,root,root) %{_libdir}/%{name}/components/libmyspell.so
365%attr(755,root,root) %{_libdir}/%{name}/components/libnecko2.so
366%attr(755,root,root) %{_libdir}/%{name}/components/libnecko.so
367%{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so}
368%attr(755,root,root) %{_libdir}/%{name}/components/libnsappshell.so
369%attr(755,root,root) %{_libdir}/%{name}/components/liboji.so
370%attr(755,root,root) %{_libdir}/%{name}/components/libpermissions.so
371%attr(755,root,root) %{_libdir}/%{name}/components/libpipboot.so
372%attr(755,root,root) %{_libdir}/%{name}/components/libpipnss.so
373%attr(755,root,root) %{_libdir}/%{name}/components/libpippki.so
374%attr(755,root,root) %{_libdir}/%{name}/components/libpref.so
375%attr(755,root,root) %{_libdir}/%{name}/components/librdf.so
376%attr(755,root,root) %{_libdir}/%{name}/components/libremoteservice.so
377%attr(755,root,root) %{_libdir}/%{name}/components/libsearchservice.so
378%attr(755,root,root) %{_libdir}/%{name}/components/libspellchecker.so
379%attr(755,root,root) %{_libdir}/%{name}/components/libstoragecomps.so
380%attr(755,root,root) %{_libdir}/%{name}/components/libsystem-pref.so
381%attr(755,root,root) %{_libdir}/%{name}/components/libtoolkitcomps.so
382%attr(755,root,root) %{_libdir}/%{name}/components/libtransformiix.so
383%attr(755,root,root) %{_libdir}/%{name}/components/libtxmgr.so
384%attr(755,root,root) %{_libdir}/%{name}/components/libuconv.so
385%attr(755,root,root) %{_libdir}/%{name}/components/libucvmath.so
386%attr(755,root,root) %{_libdir}/%{name}/components/libuniversalchardet.so
387%attr(755,root,root) %{_libdir}/%{name}/components/libwebbrwsr.so
388%attr(755,root,root) %{_libdir}/%{name}/components/libwebsrvcs.so
389%attr(755,root,root) %{_libdir}/%{name}/components/libwidget_gtk2.so
390%attr(755,root,root) %{_libdir}/%{name}/components/libxmlextras.so
391%attr(755,root,root) %{_libdir}/%{name}/components/libxpcom_compat_c.so
392%attr(755,root,root) %{_libdir}/%{name}/components/libxpconnect.so
393%attr(755,root,root) %{_libdir}/%{name}/components/libxpinstall.so
394%{_libdir}/%{name}/components/accessibility-atk.xpt
395%{_libdir}/%{name}/components/accessibility.xpt
396%{_libdir}/%{name}/components/alerts.xpt
397%{_libdir}/%{name}/components/appshell.xpt
398%{_libdir}/%{name}/components/appstartup.xpt
399%{_libdir}/%{name}/components/autocomplete.xpt
400%{_libdir}/%{name}/components/autoconfig.xpt
401%{_libdir}/%{name}/components/bookmarks.xpt
402%{_libdir}/%{name}/components/browsercompsbase.xpt
403%{_libdir}/%{name}/components/browser-feeds.xpt
404%{_libdir}/%{name}/components/browsersearch.xpt
405%{_libdir}/%{name}/components/caps.xpt
406%{_libdir}/%{name}/components/chardet.xpt
407%{_libdir}/%{name}/components/chrome.xpt
408%{_libdir}/%{name}/components/commandhandler.xpt
409%{_libdir}/%{name}/components/commandlines.xpt
410%{_libdir}/%{name}/components/composer.xpt
411%{_libdir}/%{name}/components/content_base.xpt
412%{_libdir}/%{name}/components/content_htmldoc.xpt
413%{_libdir}/%{name}/components/content_html.xpt
414%{_libdir}/%{name}/components/content_xmldoc.xpt
415%{_libdir}/%{name}/components/content_xslt.xpt
416%{_libdir}/%{name}/components/content_xtf.xpt
417%{_libdir}/%{name}/components/cookie.xpt
418%{_libdir}/%{name}/components/directory.xpt
419%{_libdir}/%{name}/components/docshell.xpt
420%{_libdir}/%{name}/components/dom_base.xpt
421%{_libdir}/%{name}/components/dom_canvas.xpt
422%{_libdir}/%{name}/components/dom_core.xpt
423%{_libdir}/%{name}/components/dom_css.xpt
424%{_libdir}/%{name}/components/dom_events.xpt
425%{_libdir}/%{name}/components/dom_html.xpt
426%{_libdir}/%{name}/components/dom_loadsave.xpt
427%{_libdir}/%{name}/components/dom_range.xpt
428%{_libdir}/%{name}/components/dom_sidebar.xpt
429%{_libdir}/%{name}/components/dom_storage.xpt
430%{_libdir}/%{name}/components/dom_stylesheets.xpt
431%{_libdir}/%{name}/components/dom_svg.xpt
432%{_libdir}/%{name}/components/dom_traversal.xpt
433%{_libdir}/%{name}/components/dom_views.xpt
434%{_libdir}/%{name}/components/dom_xbl.xpt
435%{_libdir}/%{name}/components/dom_xpath.xpt
436%{_libdir}/%{name}/components/dom.xpt
437%{_libdir}/%{name}/components/dom_xul.xpt
438%{_libdir}/%{name}/components/downloads.xpt
439%{_libdir}/%{name}/components/editor.xpt
440%{_libdir}/%{name}/components/embed_base.xpt
441%{_libdir}/%{name}/components/extensions.xpt
442%{_libdir}/%{name}/components/exthandler.xpt
443%{_libdir}/%{name}/components/fastfind.xpt
444%{_libdir}/%{name}/components/FeedConverter.js
445%{_libdir}/%{name}/components/FeedProcessor.js
446%{_libdir}/%{name}/components/feeds.xpt
447%{_libdir}/%{name}/components/FeedWriter.js
448%{_libdir}/%{name}/components/filepicker.xpt
449%{_libdir}/%{name}/components/find.xpt
450%{_libdir}/%{name}/components/gfx.xpt
451%{_libdir}/%{name}/components/gksvgrenderer.xpt
452%{_libdir}/%{name}/components/history.xpt
453%{_libdir}/%{name}/components/htmlparser.xpt
454%{?with_gnomeui:%{_libdir}/%{name}/components/imgicon.xpt}
455%{_libdir}/%{name}/components/imglib2.xpt
456%{_libdir}/%{name}/components/inspector.xpt
457%{_libdir}/%{name}/components/intl.xpt
458%{_libdir}/%{name}/components/jar.xpt
459%{_libdir}/%{name}/components/jsconsole-clhandler.js
460%{_libdir}/%{name}/components/jsconsole.xpt
461%{_libdir}/%{name}/components/jsdservice.xpt
462%{_libdir}/%{name}/components/layout_base.xpt
463%{_libdir}/%{name}/components/layout_printing.xpt
464%{_libdir}/%{name}/components/layout_xul_tree.xpt
465%{_libdir}/%{name}/components/layout_xul.xpt
466%{_libdir}/%{name}/components/locale.xpt
467%{_libdir}/%{name}/components/lwbrk.xpt
468%{_libdir}/%{name}/components/microsummaries.xpt
469%{_libdir}/%{name}/components/migration.xpt
470%{_libdir}/%{name}/components/mimetype.xpt
471%{_libdir}/%{name}/components/mozbrwsr.xpt
472%{_libdir}/%{name}/components/mozfind.xpt
473%{_libdir}/%{name}/components/mozgnome.xpt
474%{_libdir}/%{name}/components/necko_about.xpt
475%{_libdir}/%{name}/components/necko_cache.xpt
476%{_libdir}/%{name}/components/necko_cookie.xpt
477%{_libdir}/%{name}/components/necko_data.xpt
478%{_libdir}/%{name}/components/necko_dns.xpt
479%{_libdir}/%{name}/components/necko_file.xpt
480%{_libdir}/%{name}/components/necko_ftp.xpt
481%{_libdir}/%{name}/components/necko_http.xpt
482%{_libdir}/%{name}/components/necko_res.xpt
483%{_libdir}/%{name}/components/necko_socket.xpt
484%{_libdir}/%{name}/components/necko_strconv.xpt
485%{_libdir}/%{name}/components/necko_viewsource.xpt
486%{_libdir}/%{name}/components/necko.xpt
487%{_libdir}/%{name}/components/nsBookmarkTransactionManager.js
488%{_libdir}/%{name}/components/nsBrowserContentHandler.js
489%{_libdir}/%{name}/components/nsBrowserGlue.js
490%{_libdir}/%{name}/components/nsCloseAllWindows.js
491%{_libdir}/%{name}/components/nsDefaultCLH.js
492%{_libdir}/%{name}/components/nsDictionary.js
493%{_libdir}/%{name}/components/nsExtensionManager.js
494%{_libdir}/%{name}/components/nsFilePicker.js
495%{_libdir}/%{name}/components/nsHelperAppDlg.js
496%{_libdir}/%{name}/components/nsInterfaceInfoToIDL.js
497%{_libdir}/%{name}/components/nsKillAll.js
498%{_libdir}/%{name}/components/nsMicrosummaryService.js
499%{_libdir}/%{name}/components/nsProgressDialog.js
500%{_libdir}/%{name}/components/nsProxyAutoConfig.js
501%{_libdir}/%{name}/components/nsResetPref.js
502%{_libdir}/%{name}/components/nsSafebrowsingApplication.js
503%{_libdir}/%{name}/components/nsSearchService.js
504%{_libdir}/%{name}/components/nsSearchSuggestions.js
505%{_libdir}/%{name}/components/nsSessionStartup.js
506%{_libdir}/%{name}/components/nsSessionStore.js
507%{_libdir}/%{name}/components/nsSetDefaultBrowser.js
508%{_libdir}/%{name}/components/nsSidebar.js
509%{_libdir}/%{name}/components/nsUpdateService.js
510%{_libdir}/%{name}/components/nsUrlClassifierLib.js
511%{_libdir}/%{name}/components/nsUrlClassifierListManager.js
512%{_libdir}/%{name}/components/nsUrlClassifierTable.js
513%{_libdir}/%{name}/components/nsURLFormatter.js
514%{_libdir}/%{name}/components/nsXmlRpcClient.js
515%{_libdir}/%{name}/components/oji.xpt
516%{_libdir}/%{name}/components/passwordmgr.xpt
517%{_libdir}/%{name}/components/pipboot.xpt
518%{_libdir}/%{name}/components/pipnss.xpt
519%{_libdir}/%{name}/components/pippki.xpt
520%{_libdir}/%{name}/components/plugin.xpt
521%{_libdir}/%{name}/components/prefetch.xpt
522%{_libdir}/%{name}/components/pref.xpt
523%{_libdir}/%{name}/components/profile.xpt
524%{_libdir}/%{name}/components/progressDlg.xpt
525%{_libdir}/%{name}/components/proxyObjInst.xpt
526%{_libdir}/%{name}/components/rdf.xpt
527%{_libdir}/%{name}/components/safebrowsing.xpt
528%{_libdir}/%{name}/components/satchel.xpt
529%{_libdir}/%{name}/components/saxparser.xpt
530%{_libdir}/%{name}/components/search.xpt
531%{_libdir}/%{name}/components/sessionstore.xpt
532%{_libdir}/%{name}/components/shellservice.xpt
533%{_libdir}/%{name}/components/shistory.xpt
534%{_libdir}/%{name}/components/spellchecker.xpt
535%{_libdir}/%{name}/components/storage.xpt
536%{_libdir}/%{name}/components/toolkitprofile.xpt
537%{_libdir}/%{name}/components/toolkitremote.xpt
538%{_libdir}/%{name}/components/txmgr.xpt
539%{_libdir}/%{name}/components/txtsvc.xpt
540%{_libdir}/%{name}/components/uconv.xpt
541%{_libdir}/%{name}/components/unicharutil.xpt
542%{_libdir}/%{name}/components/update.xpt
543%{_libdir}/%{name}/components/uriloader.xpt
544%{_libdir}/%{name}/components/url-classifier.xpt
545%{_libdir}/%{name}/components/urlformatter.xpt
546%{_libdir}/%{name}/components/webBrowser_core.xpt
547%{_libdir}/%{name}/components/webbrowserpersist.xpt
548%{_libdir}/%{name}/components/WebContentConverter.js
549%{_libdir}/%{name}/components/webshell_idls.xpt
550%{_libdir}/%{name}/components/websrvcs.xpt
551%{_libdir}/%{name}/components/widget.xpt
552%{_libdir}/%{name}/components/windowds.xpt
553%{_libdir}/%{name}/components/windowwatcher.xpt
554%{_libdir}/%{name}/components/xml-rpc.xpt
555%{_libdir}/%{name}/components/xpcom_base.xpt
556%{_libdir}/%{name}/components/xpcom_components.xpt
557%{_libdir}/%{name}/components/xpcom_ds.xpt
558%{_libdir}/%{name}/components/xpcom_io.xpt
559%{_libdir}/%{name}/components/xpcom_obsolete.xpt
560%{_libdir}/%{name}/components/xpcom_threads.xpt
561%{_libdir}/%{name}/components/xpcom_xpti.xpt
562%{_libdir}/%{name}/components/xpconnect.xpt
563%{_libdir}/%{name}/components/xpinstall.xpt
564%{_libdir}/%{name}/components/xulapp.xpt
565%{_libdir}/%{name}/components/xuldoc.xpt
566%{_libdir}/%{name}/components/xultmpl.xpt
567%dir %{_libdir}/%{name}/plugins
568%attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
569%attr(755,root,root) %{_libdir}/%{name}/*.sh
570%attr(755,root,root) %{_libdir}/%{name}/m*
571%attr(755,root,root) %{_libdir}/%{name}/f*
572%attr(755,root,root) %{_libdir}/%{name}/regxpcom
573%attr(755,root,root) %{_libdir}/%{name}/xpcshell
574%attr(755,root,root) %{_libdir}/%{name}/xpicleanup
575%{_pixmapsdir}/mozilla-firefox.png
576%{_desktopdir}/mozilla-firefox.desktop
577
578# symlinks
579%{_libdir}/%{name}/chrome
580%{_libdir}/%{name}/defaults
581%{_libdir}/%{name}/dictionaries
582%{_libdir}/%{name}/extensions
583%{_libdir}/%{name}/greprefs
584%{_libdir}/%{name}/icons
585%{_libdir}/%{name}/init.d
586%{_libdir}/%{name}/res
587%{_libdir}/%{name}/searchplugins
588
589# browserconfig
590%{_libdir}/%{name}/browserconfig.properties
591
592%{_libdir}/%{name}/LICENSE
593%{_libdir}/%{name}/README.txt
594
595%dir %{_datadir}/%{name}
596%{_datadir}/%{name}/chrome
597%{_datadir}/%{name}/defaults
598%{_datadir}/%{name}/greprefs
599%{_datadir}/%{name}/icons
600%{_datadir}/%{name}/init.d
601%{_datadir}/%{name}/res
602%{_datadir}/%{name}/searchplugins
603
604%dir %{_datadir}/%{name}/extensions
605# -dom-inspector subpackage?
606%{_datadir}/%{name}/extensions/inspector@mozilla.org
607# the signature of the default theme
608%{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
609
610# files created by regxpcom and firefox -register
611%ghost %{_libdir}/%{name}/components/compreg.dat
612%ghost %{_libdir}/%{name}/components/xpti.dat
613
614%files lang-en
615%defattr(644,root,root,755)
616%{_datadir}/%{name}/chrome/en-US.jar
617%{_datadir}/%{name}/chrome/en-US.manifest
618
619%if %{with tidy}
620%files addon-tidy
621%defattr(644,root,root,755)
622%attr(755,root,root) %{_libdir}/%{name}/components/libnstidy.so
623%{_libdir}/%{name}/components/nstidy.xpt
624%endif
This page took 0.066341 seconds and 4 git commands to generate.