]> git.pld-linux.org Git - packages/firefox.git/blame_incremental - mozilla-firefox.spec
- updated to 11.0
[packages/firefox.git] / mozilla-firefox.spec
... / ...
CommitLineData
1# NOTE: PLD distributes iceweasel instead
2#
3# TODO:
4# - (12:22:58) patrys: can you also move _libdir/mozilla-firefox to just _libdir/firefox?
5# (12:23:25) patrys: it's not like we ship official firefox
6# - fix wrapper script to allow playing with profiles (must not use -remote)
7#
8# Conditional build:
9%bcond_with tests # enable tests (whatever they check)
10%bcond_without gnomeui # disable gnomeui support
11%bcond_without gnome # synonym for gnomeui (gconf, libnotify and gio are still enabled)
12%bcond_without kerberos # disable krb5 support
13%bcond_without xulrunner # system xulrunner
14
15%if %{without gnome}
16%undefine with_gnomeui
17%endif
18
19%if %{without xulrunner}
20# The actual sqlite version (see RHBZ#480989):
21%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
22%endif
23
24Summary: Firefox Community Edition web browser
25Summary(pl.UTF-8): Firefox Community Edition - przeglądarka WWW
26Name: mozilla-firefox
27Version: 11.0
28Release: 1
29License: MPL 1.1 or GPL v2+ or LGPL v2.1+
30Group: X11/Applications/Networking
31Source0: http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.bz2
32# Source0-md5: 4b07acf47857aff72776d805409cdd1b
33Source1: %{name}.desktop
34Source2: %{name}.sh
35Patch0: %{name}-install.patch
36Patch1: %{name}-gcc3.patch
37Patch2: %{name}-agent.patch
38Patch3: %{name}-agent-ac.patch
39Patch4: %{name}-ti-agent.patch
40Patch5: %{name}-branding.patch
41Patch6: %{name}-prefs.patch
42Patch7: %{name}-nss_cflags.patch
43Patch8: %{name}-no-subshell.patch
44URL: http://www.mozilla.org/projects/firefox/
45BuildRequires: GConf2-devel >= 1.2.1
46BuildRequires: OpenGL-devel
47BuildRequires: alsa-lib-devel
48BuildRequires: automake
49BuildRequires: bzip2-devel
50BuildRequires: cairo-devel >= 1.10.2-5
51BuildRequires: dbus-glib-devel >= 0.60
52BuildRequires: glib2-devel >= 1:2.18
53BuildRequires: gtk+2-devel >= 2:2.14
54%{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
55BuildRequires: hunspell-devel
56BuildRequires: libIDL-devel >= 0.8.0
57BuildRequires: libdnet-devel
58BuildRequires: libevent-devel >= 1.4.7
59# standalone libffi 3.0.9 or gcc's from 4.5(?)+
60BuildRequires: libffi-devel >= 6:3.0.9
61%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
62BuildRequires: libiw-devel
63BuildRequires: libjpeg-devel >= 6b
64BuildRequires: libnotify-devel >= 0.4
65BuildRequires: libpng(APNG)-devel >= 0.10
66BuildRequires: libpng-devel >= 1.4.1
67BuildRequires: libstdc++-devel
68BuildRequires: libvpx-devel >= 1.0.0
69BuildRequires: nspr-devel >= 1:4.9
70BuildRequires: nss-devel >= 1:3.13.3
71BuildRequires: pango-devel >= 1:1.14.0
72BuildRequires: perl-modules >= 5.004
73BuildRequires: pkgconfig
74BuildRequires: pkgconfig(libffi) >= 3.0.9
75BuildRequires: python-modules
76BuildRequires: rpm >= 4.4.9-56
77BuildRequires: rpmbuild(macros) >= 1.601
78BuildRequires: sqlite3-devel >= 3.7.7.1
79BuildRequires: startup-notification-devel >= 0.8
80BuildRequires: xorg-lib-libXScrnSaver-devel
81BuildRequires: xorg-lib-libXext-devel
82BuildRequires: xorg-lib-libXinerama-devel
83BuildRequires: xorg-lib-libXt-devel
84%if %{with xulrunner}
85BuildRequires: xulrunner-devel >= 2:%{version}
86%endif
87BuildRequires: zip
88BuildRequires: zlib-devel >= 1.2.3
89Requires(post): mktemp >= 1.5-18
90%if %{with xulrunner}
91%requires_eq_to xulrunner xulrunner-devel
92%else
93Requires: browser-plugins >= 2.0
94Requires: cairo >= 1.10.2-5
95Requires: dbus-glib >= 0.60
96Requires: glib2 >= 1:2.18
97Requires: gtk+2 >= 2:2.14
98Requires: libpng >= 1.4.1
99Requires: libpng(APNG) >= 0.10
100Requires: myspell-common
101Requires: nspr >= 1:4.8.9
102Requires: nss >= 1:3.13.1
103Requires: pango >= 1:1.14.0
104Requires: sqlite3 >= %{sqlite_build_version}
105Requires: startup-notification >= 0.8
106%endif
107Provides: wwwbrowser
108Obsoletes: mozilla-firebird
109Obsoletes: mozilla-firefox-lang-en < 2.0.0.8-3
110Obsoletes: mozilla-firefox-libs
111Conflicts: mozilla-firefox-lang-resources < %{version}
112BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114# don't satisfy other packages (don't use %{name} here)
115%define _noautoprovfiles %{_libdir}/mozilla-firefox
116# and as we don't provide them, don't require either
117%define _noautoreq libmozjs.so libxpcom.so libxul.so %{!?with_xulrunner:libmozalloc.so}
118
119%if "%{cc_version}" >= "3.4"
120%define specflags -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
121%else
122%define specflags -fno-strict-aliasing
123%endif
124
125%description
126Firefox Community Edition is an open-source web browser, designed for
127standards compliance, performance and portability.
128
129%description -l pl.UTF-8
130Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
131zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
132o zgodności ze standardami, wydajnością i przenośnością.
133
134%prep
135%setup -qc
136mv -f mozilla-release mozilla
137cd mozilla
138
139# libvpx fix
140grep -q VPX_CODEC_USE_INPUT_PARTITION configure.in && sed -i 's#VPX_CODEC_USE_INPUT_PARTITION#VPX_CODEC_USE_INPUT_FRAGMENTS#' configure || exit 1
141
142%patch0 -p1
143
144%if "%{cc_version}" < "3.4"
145%patch1 -p2
146%endif
147
148%if "%{pld_release}" == "th"
149%patch2 -p1
150%endif
151
152%if "%{pld_release}" == "ac"
153%patch3 -p1
154%endif
155
156%if "%{pld_release}" == "ti"
157%patch4 -p1
158%endif
159
160%patch5 -p1
161%patch6 -p1
162%patch7 -p1
163%patch8 -p2
164
165# config/rules.mk is patched by us and js/src/config/rules.mk
166# is supposed to be exact copy
167cp -a config/rules.mk js/src/config/rules.mk
168
169%build
170cd mozilla
171cp -f %{_datadir}/automake/config.* build/autoconf
172
173cat << EOF > .mozconfig
174. \$topsrcdir/browser/config/mozconfig
175
176mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
177
178# Options for 'configure' (same as command-line options).
179ac_add_options --prefix=%{_prefix}
180ac_add_options --exec-prefix=%{_exec_prefix}
181ac_add_options --bindir=%{_bindir}
182ac_add_options --sbindir=%{_sbindir}
183ac_add_options --sysconfdir=%{_sysconfdir}
184ac_add_options --datadir=%{_datadir}
185ac_add_options --includedir=%{_includedir}
186ac_add_options --libdir=%{_libdir}
187ac_add_options --libexecdir=%{_libexecdir}
188ac_add_options --localstatedir=%{_localstatedir}
189ac_add_options --sharedstatedir=%{_sharedstatedir}
190ac_add_options --mandir=%{_mandir}
191ac_add_options --infodir=%{_infodir}
192ac_add_options --disable-elf-hack
193%if %{?debug:1}0
194ac_add_options --disable-optimize
195ac_add_options --enable-debug
196ac_add_options --enable-debug-modules
197ac_add_options --enable-debugger-info-modules
198ac_add_options --enable-crash-on-assert
199%else
200ac_add_options --disable-debug
201ac_add_options --disable-debug-modules
202ac_add_options --disable-logging
203ac_add_options --enable-optimize="%{rpmcflags} -Os"
204%endif
205ac_add_options --disable-strip
206ac_add_options --disable-strip-libs
207%if %{with tests}
208ac_add_options --enable-tests
209%else
210ac_add_options --disable-tests
211%endif
212%if %{with gnomeui}
213ac_add_options --enable-gnomeui
214%else
215ac_add_options --disable-gnomeui
216%endif
217ac_add_options --disable-gnomevfs
218ac_add_options --disable-crashreporter
219ac_add_options --disable-installer
220ac_add_options --disable-javaxpcom
221ac_add_options --disable-updater
222ac_add_options --enable-gio
223ac_add_options --enable-libxul
224ac_add_options --enable-pango
225ac_add_options --enable-shared-js
226ac_add_options --enable-startup-notification
227ac_add_options --enable-system-cairo
228ac_add_options --enable-system-hunspell
229ac_add_options --enable-system-sqlite
230ac_add_options --with-distribution-id=org.pld-linux
231%if %{with xulrunner}
232ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
233%endif
234ac_add_options --with-pthreads
235ac_add_options --with-system-bz2
236ac_add_options --with-system-ffi
237ac_add_options --with-system-jpeg
238ac_add_options --with-system-libevent
239ac_add_options --with-system-libvpx
240ac_add_options --with-system-nspr
241ac_add_options --with-system-nss
242ac_add_options --with-system-png
243ac_add_options --with-system-zlib
244ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
245EOF
246
247%{__make} -f client.mk build \
248 STRIP="/bin/true" \
249 CC="%{__cc}" \
250 CXX="%{__cxx}"
251
252%install
253rm -rf $RPM_BUILD_ROOT
254cd mozilla
255install -d \
256 $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
257 $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
258 $RPM_BUILD_ROOT%{_datadir}/%{name}
259
260%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
261
262%{__make} -C obj-%{_target_cpu}/browser/installer stage-package \
263 DESTDIR=$RPM_BUILD_ROOT \
264 MOZ_PKG_DIR=%{_libdir}/%{name} \
265 PKG_SKIP_STRIP=1
266
267install -d \
268 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
269
270%if %{with xulrunner}
271# >= 5.0 seems to require this
272ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
273%endif
274
275# move arch independant ones to datadir
276mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
277mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
278mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
279mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
280mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
281mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
282%if %{without xulrunner}
283mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
284mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
285%endif
286
287ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
288ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
289ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
290ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
291ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
292ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
293%if %{without xulrunner}
294ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
295ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
296%endif
297
298%if %{without xulrunner}
299%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
300ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
301%endif
302
303sed 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
304chmod 755 $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
305ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
306
307cp -a browser/branding/unofficial/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
308cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
309
310# files created by firefox -register
311touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
312touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
313
314%if %{with xulrunner}
315%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/run-mozilla.sh
316%endif
317
318cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
319#!/bin/sh
320umask 022
321rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
322
323# it attempts to touch files in $HOME/.mozilla
324# beware if you run this with sudo!!!
325export HOME=$(mktemp -d)
326# also TMPDIR could be pointing to sudo user's homedir
327unset TMPDIR TMP || :
328
329%{_libdir}/%{name}/firefox -register
330
331rm -rf $HOME
332EOF
333chmod 755 $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
334
335%clean
336rm -rf $RPM_BUILD_ROOT
337
338%pretrans
339if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
340 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
341fi
342for d in chrome defaults extensions greprefs.js icons res searchplugins; do
343 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
344 install -d %{_datadir}/%{name}
345 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
346 fi
347done
348exit 0
349
350%post
351%{_sbindir}/%{name}-chrome+xpcom-generate
352%update_browser_plugins
353
354%postun
355if [ "$1" = 0 ]; then
356 %update_browser_plugins
357fi
358
359%files
360%defattr(644,root,root,755)
361%attr(755,root,root) %{_bindir}/%{name}
362%attr(755,root,root) %{_bindir}/firefox
363%attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
364
365# browser plugins v2
366%{_browserpluginsconfdir}/browsers.d/%{name}.*
367%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
368
369%dir %{_libdir}/%{name}
370%if %{without xulrunner}
371%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
372%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
373%attr(755,root,root) %{_libdir}/%{name}/libxul.so
374%endif
375%{_libdir}/%{name}/blocklist.xml
376
377%if %{with crashreporter}
378%{_libdir}/%{name}/crashreporter
379%{_libdir}/%{name}/crashreporter-override.ini
380%{_libdir}/%{name}/crashreporter.ini
381%{_libdir}/%{name}/Throbber-small.gif
382%endif
383
384# config?
385%{_libdir}/%{name}/application.ini
386%{_libdir}/%{name}/chrome.manifest
387
388%dir %{_libdir}/%{name}/components
389
390%{_libdir}/%{name}/components/ChromeProfileMigrator.js
391%{_libdir}/%{name}/components/FeedConverter.js
392%{_libdir}/%{name}/components/FeedWriter.js
393%{_libdir}/%{name}/components/PlacesProtocolHandler.js
394%{_libdir}/%{name}/components/Weave.js
395%{_libdir}/%{name}/components/WebContentConverter.js
396%{_libdir}/%{name}/components/browser.xpt
397%{_libdir}/%{name}/components/fuelApplication.js
398%{_libdir}/%{name}/components/nsBrowserContentHandler.js
399%{_libdir}/%{name}/components/nsBrowserGlue.js
400%{_libdir}/%{name}/components/nsPrivateBrowsingService.js
401%{_libdir}/%{name}/components/nsSafebrowsingApplication.js
402%{_libdir}/%{name}/components/nsSessionStartup.js
403%{_libdir}/%{name}/components/nsSessionStore.js
404%{_libdir}/%{name}/components/nsSetDefaultBrowser.js
405%{_libdir}/%{name}/components/nsSidebar.js
406
407%{_libdir}/%{name}/components/components.manifest
408%{_libdir}/%{name}/components/interfaces.manifest
409
410%if %{without xulrunner}
411%{_libdir}/%{name}/platform.ini
412%{_libdir}/%{name}/components/ConsoleAPI.js
413%{_libdir}/%{name}/components/FeedProcessor.js
414%{_libdir}/%{name}/components/GPSDGeolocationProvider.js
415%{_libdir}/%{name}/components/NetworkGeolocationProvider.js
416%{_libdir}/%{name}/components/PlacesCategoriesStarter.js
417%{_libdir}/%{name}/components/TelemetryPing.js
418%{_libdir}/%{name}/components/addonManager.js
419%{_libdir}/%{name}/components/amContentHandler.js
420%{_libdir}/%{name}/components/amWebInstallListener.js
421%{_libdir}/%{name}/components/contentAreaDropListener.js
422%{_libdir}/%{name}/components/contentSecurityPolicy.js
423%{_libdir}/%{name}/components/crypto-SDR.js
424%{_libdir}/%{name}/components/jsconsole-clhandler.js
425%{_libdir}/%{name}/components/nsBadCertHandler.js
426%{_libdir}/%{name}/components/nsBlocklistService.js
427%{_libdir}/%{name}/components/nsContentDispatchChooser.js
428%{_libdir}/%{name}/components/nsContentPrefService.js
429%{_libdir}/%{name}/components/nsDefaultCLH.js
430%{_libdir}/%{name}/components/nsDownloadManagerUI.js
431%{_libdir}/%{name}/components/nsFilePicker.js
432%{_libdir}/%{name}/components/nsFormAutoComplete.js
433%{_libdir}/%{name}/components/nsFormHistory.js
434%{_libdir}/%{name}/components/nsHandlerService.js
435%{_libdir}/%{name}/components/nsHelperAppDlg.js
436%{_libdir}/%{name}/components/nsINIProcessor.js
437%{_libdir}/%{name}/components/nsInputListAutoComplete.js
438%{_libdir}/%{name}/components/nsLivemarkService.js
439%{_libdir}/%{name}/components/nsLoginInfo.js
440%{_libdir}/%{name}/components/nsLoginManager.js
441%{_libdir}/%{name}/components/nsLoginManagerPrompter.js
442%{_libdir}/%{name}/components/nsPlacesAutoComplete.js
443%{_libdir}/%{name}/components/nsPlacesExpiration.js
444%{_libdir}/%{name}/components/nsPrompter.js
445%{_libdir}/%{name}/components/nsProxyAutoConfig.js
446%{_libdir}/%{name}/components/nsSearchService.js
447%{_libdir}/%{name}/components/nsSearchSuggestions.js
448%{_libdir}/%{name}/components/nsTaggingService.js
449%{_libdir}/%{name}/components/nsTryToClose.js
450%{_libdir}/%{name}/components/nsURLFormatter.js
451%{_libdir}/%{name}/components/nsUpdateTimerManager.js
452%{_libdir}/%{name}/components/nsUrlClassifierHashCompleter.js
453%{_libdir}/%{name}/components/nsUrlClassifierLib.js
454%{_libdir}/%{name}/components/nsUrlClassifierListManager.js
455%{_libdir}/%{name}/components/nsWebHandlerApp.js
456%{_libdir}/%{name}/components/storage-Legacy.js
457%{_libdir}/%{name}/components/storage-mozStorage.js
458%{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
459%endif
460
461%attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
462%if %{without xulrunner}
463%attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
464%endif
465
466%if %{without xulrunner}
467%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
468%endif
469
470%attr(755,root,root) %{_libdir}/%{name}/firefox
471%dir %{_libdir}/%{name}/plugins
472%if %{without xulrunner}
473%attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
474%attr(755,root,root) %{_libdir}/%{name}/firefox-bin
475%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
476%attr(755,root,root) %{_libdir}/%{name}/plugin-container
477%endif
478
479%{_pixmapsdir}/mozilla-firefox.png
480%{_desktopdir}/mozilla-firefox.desktop
481
482# symlinks
483%{_libdir}/%{name}/chrome
484%{_libdir}/%{name}/defaults
485%{_libdir}/%{name}/extensions
486%{_libdir}/%{name}/icons
487%{_libdir}/%{name}/modules
488%{_libdir}/%{name}/searchplugins
489%if %{with xulrunner}
490%{_libdir}/%{name}/xulrunner
491%else
492%{_libdir}/%{name}/dictionaries
493%{_libdir}/%{name}/greprefs.js
494%{_libdir}/%{name}/res
495%endif
496
497%dir %{_datadir}/%{name}
498%{_datadir}/%{name}/chrome
499%{_datadir}/%{name}/defaults
500%{_datadir}/%{name}/icons
501%{_datadir}/%{name}/modules
502%{_datadir}/%{name}/searchplugins
503%if %{without xulrunner}
504%{_datadir}/%{name}/greprefs.js
505%{_datadir}/%{name}/res
506%endif
507
508%dir %{_datadir}/%{name}/extensions
509# the signature of the default theme
510%{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
511
512# files created by firefox -register
513%ghost %{_libdir}/%{name}/components/compreg.dat
514%ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.037194 seconds and 4 git commands to generate.