]> git.pld-linux.org Git - packages/firefox.git/blame_incremental - mozilla-firefox.spec
- rel 5
[packages/firefox.git] / mozilla-firefox.spec
... / ...
CommitLineData
1# TODO:
2# - handle locales differently (runtime, since it's possible to do)
3# - see ftp://ftp.debian.org/debian/pool/main/m/mozilla-firefox/*diff*
4# for hints how to make locales
5# - make it more pld-like (bookmarks, default page etc..)
6#
7# Conditional build:
8%bcond_with tests # enable tests (whatever they check)
9%bcond_without gnomeui # disable gnomeui support
10%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
11%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
12%bcond_without tidy # htmlvalidator extension (tidy)
13#
14%if %{without gnome}
15%undefine with_gnomeui
16%undefine with_gnomevfs
17%endif
18%define tidy_ver 0.8.4.1
19%define firefox_ver 2.0.0.6
20#
21Summary: Firefox Community Edition web browser
22Summary(pl.UTF-8): Firefox Community Edition - przeglądarka WWW
23Name: mozilla-firefox
24Version: %{firefox_ver}
25Release: 5
26License: MPL 1.1 or GPL v2+ or LGPL v2.1+
27Group: X11/Applications/Networking
28Source0: ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}-source.tar.bz2
29# Source0-md5: 16fb252fb7b0371894f7101b88fd9076
30Source1: http://users.skynet.be/mgueury/mozilla/tidy_08x_source.zip
31# Source1-md5: 2cab81118267fc87c9ebbfa6fb44b113
32Source2: %{name}.desktop
33Source3: %{name}.sh
34Patch0: mozilla-install.patch
35Patch1: %{name}-lib_path.patch
36Patch2: %{name}-addon-tidy.patch
37Patch3: %{name}-nopangoxft.patch
38Patch5: %{name}-fonts.patch
39Patch6: %{name}-agent.patch
40Patch7: %{name}-myspell.patch
41# if ac rebuild is needed...
42#PatchX: %{name}-ac.patch
43URL: http://www.mozilla.org/projects/firefox/
44%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
45BuildRequires: automake
46BuildRequires: cairo-devel >= 1.0.0
47%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
48BuildRequires: gtk+2-devel >= 1:2.0.0
49BuildRequires: krb5-devel
50BuildRequires: libIDL-devel >= 0.8.0
51%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
52%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
53BuildRequires: libjpeg-devel >= 6b
54BuildRequires: libpng-devel >= 1.2.7
55BuildRequires: libstdc++-devel
56BuildRequires: myspell-devel
57BuildRequires: nspr-devel >= 1:4.6.3
58BuildRequires: nss-devel >= 1:3.11.3-3
59%{?with_tidy:BuildRequires: opensp-devel >= 2:1.5.2-4}
60BuildRequires: pango-devel >= 1:1.6.0
61BuildRequires: perl-modules >= 5.004
62BuildRequires: pkgconfig
63BuildRequires: rpmbuild(macros) >= 1.356
64BuildRequires: xorg-lib-libXext-devel
65BuildRequires: xorg-lib-libXft-devel >= 2.1
66BuildRequires: xorg-lib-libXinerama-devel
67BuildRequires: xorg-lib-libXp-devel
68BuildRequires: xorg-lib-libXt-devel
69BuildRequires: zip
70BuildRequires: zlib-devel >= 1.2.3
71Requires(post): mktemp >= 1.5-18
72Requires: %{name}-lang-resources = %{version}
73Requires: %{name}-libs = %{epoch}:%{version}-%{release}
74Requires: browser-plugins >= 2.0
75Requires: nspr >= 1:4.6.3
76Requires: nss >= 1:3.11.3
77Provides: wwwbrowser
78Obsoletes: mozilla-firebird
79BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81# firefox/thunderbird/seamonkey provide their own versions
82%define _noautoreqdep libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so
83%define _noautoprovfiles %{_libdir}/%{name}/components
84# we don't want these to satisfy xulrunner-devel
85%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
86# and as we don't provide them, don't require either
87%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
88
89%define specflags -fno-strict-aliasing -fno-tree-vrp -fno-stack-protector
90
91%description
92Firefox Community Edition is an open-source web browser, designed for
93standards compliance, performance and portability.
94
95%description -l pl.UTF-8
96Firefox Community Edition jest przeglądarką WWW rozpowszechnianą
97zgodnie z ideami ruchu otwartego oprogramowania oraz tworzoną z myślą
98o zgodności ze standardami, wydajnością i przenośnością.
99
100%package libs
101Summary: Firefox Community Edition shared libraries
102Summary(pl.UTF-8): Biblioteki współdzielone przeglądarki Firefox Community Edition
103Group: Libraries
104Conflicts: mozilla-firefox < 2.0-1.4
105
106%description libs
107Firefox Community Edition shared libraries.
108
109%description libs -l pl.UTF-8
110Biblioteki współdzielone przeglądarki Firefox Community Edition.
111
112%package addon-tidy
113Summary: HTML Validator for Firefox
114Summary(pl.UTF-8): Narzędzie do sprawdzania poprawności HTML-a dla Firefoksa
115Version: %{tidy_ver}
116License: GPL
117Group: X11/Applications/Networking
118URL: http://users.skynet.be/mgueury/mozilla/
119Requires: %{name} = %{firefox_ver}-%{release}
120
121%description addon-tidy
122HTML Validator is a Mozilla extension that adds HTML validation inside
123Firefox. The number of errors of a HTML page is seen on the form of an
124icon in the status bar when browsing.
125
126%description addon-tidy -l pl.UTF-8
127HTML Validator to rozszerzenie Mozilli dodające sprawdzanie
128poprawności HTML-a w Firefoksie. Liczbę błędów na przeglądanej stronie
129HTML można zobaczyć w postaci ikony na pasku stanu.
130
131%package lang-en
132Summary: English resources for Firefox Community Edition
133Summary(pl.UTF-8): Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition
134Version: %{firefox_ver}
135Group: X11/Applications/Networking
136Requires: %{name} = %{firefox_ver}-%{release}
137Provides: %{name}-lang-resources = %{firefox_ver}-%{release}
138
139%description lang-en
140English resources for Firefox Community Edition.
141
142%description lang-en -l pl.UTF-8
143Anglojęzyczne zasoby dla przeglądarki Firefox Community Edition.
144
145%prep
146%setup -qc %{?with_tidy:-a1}
147%if %{with tidy}
148mv mozilla_tidy_source/mozilla/extensions/tidy mozilla/extensions/tidy
149mv mozilla_tidy_source/tidy_extension .
150rm -rf mozilla/extensions/tidy/opensp
151%endif
152cd mozilla
153%patch0 -p1
154%patch1 -p1
155%{?with_tidy:%patch2 -p1}
156%patch3 -p1
157%patch5 -p1
158%patch6 -p1
159%patch7 -p1
160
161# use system
162#rm -rf mozilla/nsprpub mozilla/security/nss
163
164%build
165cd mozilla
166export CFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
167export CXXFLAGS="%{rpmcflags} $(%{_bindir}/pkg-config mozilla-nspr --cflags-only-I)"
168
169cp -f %{_datadir}/automake/config.* build/autoconf
170cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
171cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
172
173cat << 'EOF' > .mozconfig
174. $topsrcdir/browser/config/mozconfig
175
176# Options for 'configure' (same as command-line options).
177ac_add_options --prefix=%{_prefix}
178ac_add_options --exec-prefix=%{_exec_prefix}
179ac_add_options --bindir=%{_bindir}
180ac_add_options --sbindir=%{_sbindir}
181ac_add_options --sysconfdir=%{_sysconfdir}
182ac_add_options --datadir=%{_datadir}
183ac_add_options --includedir=%{_includedir}
184ac_add_options --libdir=%{_libdir}
185ac_add_options --libexecdir=%{_libexecdir}
186ac_add_options --localstatedir=%{_localstatedir}
187ac_add_options --sharedstatedir=%{_sharedstatedir}
188ac_add_options --mandir=%{_mandir}
189ac_add_options --infodir=%{_infodir}
190%if %{?debug:1}0
191ac_add_options --disable-optimize
192ac_add_options --enable-debug
193ac_add_options --enable-debug-modules
194ac_add_options --enable-debugger-info-modules
195ac_add_options --enable-crash-on-assert
196%else
197ac_add_options --disable-debug
198ac_add_options --disable-logging
199ac_add_options --enable-optimize="%{rpmcflags}"
200%endif
201%if %{with tests}
202ac_add_options --enable-tests
203%else
204ac_add_options --disable-tests
205%endif
206%if %{with gnomeui}
207ac_add_options --enable-gnomeui
208%else
209ac_add_options --disable-gnomeui
210%endif
211%if %{with gnomevfs}
212ac_add_options --enable-gnomevfs
213%else
214ac_add_options --disable-gnomevfs
215%endif
216ac_add_options --disable-freetype2
217ac_add_options --disable-installer
218ac_add_options --disable-javaxpcom
219ac_add_options --disable-updater
220ac_add_options --enable-default-toolkit=gtk2
221ac_add_options --enable-svg
222ac_add_options --enable-system-cairo
223ac_add_options --enable-system-myspell
224ac_add_options --enable-xft
225ac_add_options --with-distribution-id=org.pld-linux
226ac_add_options --with-system-nspr
227ac_add_options --with-system-nss
228ac_add_options --with-system-zlib
229ac_add_options --with-system-jpeg
230ac_add_options --with-system-png
231ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
232ac_cv_visibility_pragma=no
233EOF
234
235%{__make} -j1 -f client.mk build \
236 CC="%{__cc}" \
237 CXX="%{__cxx}"
238
239%install
240rm -rf $RPM_BUILD_ROOT
241cd mozilla
242install -d \
243 $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
244 $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}} \
245 $RPM_BUILD_ROOT%{_datadir}/%{name}
246
247%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
248
249%{__make} -C xpinstall/packager stage-package \
250 DESTDIR=$RPM_BUILD_ROOT \
251 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
252 PKG_SKIP_STRIP=1
253
254# move arch independant ones to datadir
255mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
256mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
257mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
258mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
259mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
260mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
261mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
262mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
263ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
264ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
265ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
266ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
267ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
268ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
269ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
270ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
271
272rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
273ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
274
275sed 's,@LIBDIR@,%{_libdir},' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
276ln -s mozilla-firefox $RPM_BUILD_ROOT%{_bindir}/firefox
277
278install browser/base/branding/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/mozilla-firefox.png
279
280install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
281
282# header/development files
283rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpidl
284rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_dump
285rm $RPM_BUILD_ROOT%{_libdir}/%{name}/xpt_link
286
287# files created by regxpcom and firefox -register
288touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
289touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
290
291# what's this? it's content is invalid anyway.
292rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
293rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/old-homepage-default.properties
294
295cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
296#!/bin/sh
297umask 022
298rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
299
300# it attempts to touch files in $HOME/.mozilla
301# beware if you run this with sudo!!!
302export HOME=$(mktemp -d)
303# also TMPDIR could be pointing to sudo user's homedir
304unset TMPDIR TMP || :
305
306LD_LIBRARY_PATH=%{_libdir}/%{name}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} %{_libdir}/%{name}/regxpcom
307%{_libdir}/%{name}/firefox -register
308
309rm -rf $HOME
310EOF
311
312%clean
313rm -rf $RPM_BUILD_ROOT
314
315%pretrans
316if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
317 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
318fi
319for d in chrome defaults extensions greprefs icons init.d res searchplugins; do
320 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
321 install -d %{_datadir}/%{name}
322 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
323 fi
324done
325exit 0
326
327%post
328%{_sbindir}/%{name}-chrome+xpcom-generate
329%update_browser_plugins
330
331%postun
332if [ "$1" = 0 ]; then
333 %update_browser_plugins
334fi
335
336%files
337%defattr(644,root,root,755)
338%attr(755,root,root) %{_bindir}/%{name}
339%attr(755,root,root) %{_bindir}/firefox
340%attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
341
342# browser plugins v2
343%{_browserpluginsconfdir}/browsers.d/%{name}.*
344%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
345
346%dir %{_libdir}/%{name}/components
347%attr(755,root,root) %{_libdir}/%{name}/components/libaccessibility.so
348%attr(755,root,root) %{_libdir}/%{name}/components/libappcomps.so
349%attr(755,root,root) %{_libdir}/%{name}/components/libauth.so
350%attr(755,root,root) %{_libdir}/%{name}/components/libautoconfig.so
351%attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
352%attr(755,root,root) %{_libdir}/%{name}/components/libbrowserdirprovider.so
353%attr(755,root,root) %{_libdir}/%{name}/components/libcaps.so
354%attr(755,root,root) %{_libdir}/%{name}/components/libchrome.so
355%attr(755,root,root) %{_libdir}/%{name}/components/libcommandlines.so
356%attr(755,root,root) %{_libdir}/%{name}/components/libcomposer.so
357%attr(755,root,root) %{_libdir}/%{name}/components/libcookie.so
358%attr(755,root,root) %{_libdir}/%{name}/components/libdocshell.so
359%attr(755,root,root) %{_libdir}/%{name}/components/libeditor.so
360%attr(755,root,root) %{_libdir}/%{name}/components/libembedcomponents.so
361%attr(755,root,root) %{_libdir}/%{name}/components/libfileview.so
362%attr(755,root,root) %{_libdir}/%{name}/components/libgfx_gtk.so
363%attr(755,root,root) %{_libdir}/%{name}/components/libgfxps.so
364%attr(755,root,root) %{_libdir}/%{name}/components/libgklayout.so
365%attr(755,root,root) %{_libdir}/%{name}/components/libgkplugin.so
366%attr(755,root,root) %{_libdir}/%{name}/components/libhtmlpars.so
367%attr(755,root,root) %{_libdir}/%{name}/components/libi18n.so
368%{?with_gnomeui:%attr(755,root,root) %{_libdir}/%{name}/components/libimgicon.so}
369%attr(755,root,root) %{_libdir}/%{name}/components/libimglib2.so
370%attr(755,root,root) %{_libdir}/%{name}/components/libjar50.so
371%attr(755,root,root) %{_libdir}/%{name}/components/libjsd.so
372%attr(755,root,root) %{_libdir}/%{name}/components/libmork.so
373%attr(755,root,root) %{_libdir}/%{name}/components/libmozfind.so
374%{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so}
375%attr(755,root,root) %{_libdir}/%{name}/components/libmyspell.so
376%attr(755,root,root) %{_libdir}/%{name}/components/libnecko2.so
377%attr(755,root,root) %{_libdir}/%{name}/components/libnecko.so
378%{?with_gnomevfs:%attr(755,root,root) %{_libdir}/%{name}/components/libnkgnomevfs.so}
379%attr(755,root,root) %{_libdir}/%{name}/components/libnsappshell.so
380%attr(755,root,root) %{_libdir}/%{name}/components/liboji.so
381%attr(755,root,root) %{_libdir}/%{name}/components/libpermissions.so
382%attr(755,root,root) %{_libdir}/%{name}/components/libpipboot.so
383%attr(755,root,root) %{_libdir}/%{name}/components/libpipnss.so
384%attr(755,root,root) %{_libdir}/%{name}/components/libpippki.so
385%attr(755,root,root) %{_libdir}/%{name}/components/libpref.so
386%attr(755,root,root) %{_libdir}/%{name}/components/librdf.so
387%attr(755,root,root) %{_libdir}/%{name}/components/libremoteservice.so
388%attr(755,root,root) %{_libdir}/%{name}/components/libsearchservice.so
389%attr(755,root,root) %{_libdir}/%{name}/components/libspellchecker.so
390%attr(755,root,root) %{_libdir}/%{name}/components/libstoragecomps.so
391%attr(755,root,root) %{_libdir}/%{name}/components/libsystem-pref.so
392%attr(755,root,root) %{_libdir}/%{name}/components/libtoolkitcomps.so
393%attr(755,root,root) %{_libdir}/%{name}/components/libtransformiix.so
394%attr(755,root,root) %{_libdir}/%{name}/components/libtxmgr.so
395%attr(755,root,root) %{_libdir}/%{name}/components/libuconv.so
396%attr(755,root,root) %{_libdir}/%{name}/components/libucvmath.so
397%attr(755,root,root) %{_libdir}/%{name}/components/libuniversalchardet.so
398%attr(755,root,root) %{_libdir}/%{name}/components/libwebbrwsr.so
399%attr(755,root,root) %{_libdir}/%{name}/components/libwebsrvcs.so
400%attr(755,root,root) %{_libdir}/%{name}/components/libwidget_gtk2.so
401%attr(755,root,root) %{_libdir}/%{name}/components/libxmlextras.so
402%attr(755,root,root) %{_libdir}/%{name}/components/libxpcom_compat_c.so
403%attr(755,root,root) %{_libdir}/%{name}/components/libxpconnect.so
404%attr(755,root,root) %{_libdir}/%{name}/components/libxpinstall.so
405%{_libdir}/%{name}/components/accessibility-atk.xpt
406%{_libdir}/%{name}/components/accessibility.xpt
407%{_libdir}/%{name}/components/alerts.xpt
408%{_libdir}/%{name}/components/appshell.xpt
409%{_libdir}/%{name}/components/appstartup.xpt
410%{_libdir}/%{name}/components/autocomplete.xpt
411%{_libdir}/%{name}/components/autoconfig.xpt
412%{_libdir}/%{name}/components/bookmarks.xpt
413%{_libdir}/%{name}/components/browsercompsbase.xpt
414%{_libdir}/%{name}/components/browser-feeds.xpt
415%{_libdir}/%{name}/components/browsersearch.xpt
416%{_libdir}/%{name}/components/caps.xpt
417%{_libdir}/%{name}/components/chardet.xpt
418%{_libdir}/%{name}/components/chrome.xpt
419%{_libdir}/%{name}/components/commandhandler.xpt
420%{_libdir}/%{name}/components/commandlines.xpt
421%{_libdir}/%{name}/components/composer.xpt
422%{_libdir}/%{name}/components/content_base.xpt
423%{_libdir}/%{name}/components/content_htmldoc.xpt
424%{_libdir}/%{name}/components/content_html.xpt
425%{_libdir}/%{name}/components/content_xmldoc.xpt
426%{_libdir}/%{name}/components/content_xslt.xpt
427%{_libdir}/%{name}/components/content_xtf.xpt
428%{_libdir}/%{name}/components/cookie.xpt
429%{_libdir}/%{name}/components/directory.xpt
430%{_libdir}/%{name}/components/docshell.xpt
431%{_libdir}/%{name}/components/dom_base.xpt
432%{_libdir}/%{name}/components/dom_canvas.xpt
433%{_libdir}/%{name}/components/dom_core.xpt
434%{_libdir}/%{name}/components/dom_css.xpt
435%{_libdir}/%{name}/components/dom_events.xpt
436%{_libdir}/%{name}/components/dom_html.xpt
437%{_libdir}/%{name}/components/dom_loadsave.xpt
438%{_libdir}/%{name}/components/dom_range.xpt
439%{_libdir}/%{name}/components/dom_sidebar.xpt
440%{_libdir}/%{name}/components/dom_storage.xpt
441%{_libdir}/%{name}/components/dom_stylesheets.xpt
442%{_libdir}/%{name}/components/dom_svg.xpt
443%{_libdir}/%{name}/components/dom_traversal.xpt
444%{_libdir}/%{name}/components/dom_views.xpt
445%{_libdir}/%{name}/components/dom_xbl.xpt
446%{_libdir}/%{name}/components/dom_xpath.xpt
447%{_libdir}/%{name}/components/dom.xpt
448%{_libdir}/%{name}/components/dom_xul.xpt
449%{_libdir}/%{name}/components/downloads.xpt
450%{_libdir}/%{name}/components/editor.xpt
451%{_libdir}/%{name}/components/embed_base.xpt
452%{_libdir}/%{name}/components/extensions.xpt
453%{_libdir}/%{name}/components/exthandler.xpt
454%{_libdir}/%{name}/components/fastfind.xpt
455%{_libdir}/%{name}/components/FeedConverter.js
456%{_libdir}/%{name}/components/FeedProcessor.js
457%{_libdir}/%{name}/components/feeds.xpt
458%{_libdir}/%{name}/components/FeedWriter.js
459%{_libdir}/%{name}/components/filepicker.xpt
460%{_libdir}/%{name}/components/find.xpt
461%{_libdir}/%{name}/components/gfx.xpt
462%{_libdir}/%{name}/components/gksvgrenderer.xpt
463%{_libdir}/%{name}/components/history.xpt
464%{_libdir}/%{name}/components/htmlparser.xpt
465%{?with_gnomeui:%{_libdir}/%{name}/components/imgicon.xpt}
466%{_libdir}/%{name}/components/imglib2.xpt
467%{_libdir}/%{name}/components/inspector.xpt
468%{_libdir}/%{name}/components/intl.xpt
469%{_libdir}/%{name}/components/jar.xpt
470%{_libdir}/%{name}/components/jsconsole-clhandler.js
471%{_libdir}/%{name}/components/jsconsole.xpt
472%{_libdir}/%{name}/components/jsdservice.xpt
473%{_libdir}/%{name}/components/layout_base.xpt
474%{_libdir}/%{name}/components/layout_printing.xpt
475%{_libdir}/%{name}/components/layout_xul_tree.xpt
476%{_libdir}/%{name}/components/layout_xul.xpt
477%{_libdir}/%{name}/components/locale.xpt
478%{_libdir}/%{name}/components/lwbrk.xpt
479%{_libdir}/%{name}/components/microsummaries.xpt
480%{_libdir}/%{name}/components/migration.xpt
481%{_libdir}/%{name}/components/mimetype.xpt
482%{_libdir}/%{name}/components/mozbrwsr.xpt
483%{_libdir}/%{name}/components/mozfind.xpt
484%{_libdir}/%{name}/components/mozgnome.xpt
485%{_libdir}/%{name}/components/necko_about.xpt
486%{_libdir}/%{name}/components/necko_cache.xpt
487%{_libdir}/%{name}/components/necko_cookie.xpt
488%{_libdir}/%{name}/components/necko_data.xpt
489%{_libdir}/%{name}/components/necko_dns.xpt
490%{_libdir}/%{name}/components/necko_file.xpt
491%{_libdir}/%{name}/components/necko_ftp.xpt
492%{_libdir}/%{name}/components/necko_http.xpt
493%{_libdir}/%{name}/components/necko_res.xpt
494%{_libdir}/%{name}/components/necko_socket.xpt
495%{_libdir}/%{name}/components/necko_strconv.xpt
496%{_libdir}/%{name}/components/necko_viewsource.xpt
497%{_libdir}/%{name}/components/necko.xpt
498%{_libdir}/%{name}/components/nsBookmarkTransactionManager.js
499%{_libdir}/%{name}/components/nsBrowserContentHandler.js
500%{_libdir}/%{name}/components/nsBrowserGlue.js
501%{_libdir}/%{name}/components/nsCloseAllWindows.js
502%{_libdir}/%{name}/components/nsDefaultCLH.js
503%{_libdir}/%{name}/components/nsDictionary.js
504%{_libdir}/%{name}/components/nsExtensionManager.js
505%{_libdir}/%{name}/components/nsFilePicker.js
506%{_libdir}/%{name}/components/nsHelperAppDlg.js
507%{_libdir}/%{name}/components/nsInterfaceInfoToIDL.js
508%{_libdir}/%{name}/components/nsKillAll.js
509%{_libdir}/%{name}/components/nsMicrosummaryService.js
510%{_libdir}/%{name}/components/nsProgressDialog.js
511%{_libdir}/%{name}/components/nsProxyAutoConfig.js
512%{_libdir}/%{name}/components/nsResetPref.js
513%{_libdir}/%{name}/components/nsSafebrowsingApplication.js
514%{_libdir}/%{name}/components/nsSearchService.js
515%{_libdir}/%{name}/components/nsSearchSuggestions.js
516%{_libdir}/%{name}/components/nsSessionStartup.js
517%{_libdir}/%{name}/components/nsSessionStore.js
518%{_libdir}/%{name}/components/nsSetDefaultBrowser.js
519%{_libdir}/%{name}/components/nsSidebar.js
520%{_libdir}/%{name}/components/nsUpdateService.js
521%{_libdir}/%{name}/components/nsUrlClassifierLib.js
522%{_libdir}/%{name}/components/nsUrlClassifierListManager.js
523%{_libdir}/%{name}/components/nsUrlClassifierTable.js
524%{_libdir}/%{name}/components/nsURLFormatter.js
525%{_libdir}/%{name}/components/nsXmlRpcClient.js
526%{_libdir}/%{name}/components/oji.xpt
527%{_libdir}/%{name}/components/passwordmgr.xpt
528%{_libdir}/%{name}/components/pipboot.xpt
529%{_libdir}/%{name}/components/pipnss.xpt
530%{_libdir}/%{name}/components/pippki.xpt
531%{_libdir}/%{name}/components/plugin.xpt
532%{_libdir}/%{name}/components/prefetch.xpt
533%{_libdir}/%{name}/components/pref.xpt
534%{_libdir}/%{name}/components/profile.xpt
535%{_libdir}/%{name}/components/progressDlg.xpt
536%{_libdir}/%{name}/components/proxyObjInst.xpt
537%{_libdir}/%{name}/components/rdf.xpt
538%{_libdir}/%{name}/components/safebrowsing.xpt
539%{_libdir}/%{name}/components/satchel.xpt
540%{_libdir}/%{name}/components/saxparser.xpt
541%{_libdir}/%{name}/components/search.xpt
542%{_libdir}/%{name}/components/sessionstore.xpt
543%{_libdir}/%{name}/components/shellservice.xpt
544%{_libdir}/%{name}/components/shistory.xpt
545%{_libdir}/%{name}/components/spellchecker.xpt
546%{_libdir}/%{name}/components/storage.xpt
547%{_libdir}/%{name}/components/toolkitprofile.xpt
548%{_libdir}/%{name}/components/toolkitremote.xpt
549%{_libdir}/%{name}/components/txmgr.xpt
550%{_libdir}/%{name}/components/txtsvc.xpt
551%{_libdir}/%{name}/components/uconv.xpt
552%{_libdir}/%{name}/components/unicharutil.xpt
553%{_libdir}/%{name}/components/update.xpt
554%{_libdir}/%{name}/components/uriloader.xpt
555%{_libdir}/%{name}/components/url-classifier.xpt
556%{_libdir}/%{name}/components/urlformatter.xpt
557%{_libdir}/%{name}/components/webBrowser_core.xpt
558%{_libdir}/%{name}/components/webbrowserpersist.xpt
559%{_libdir}/%{name}/components/WebContentConverter.js
560%{_libdir}/%{name}/components/webshell_idls.xpt
561%{_libdir}/%{name}/components/websrvcs.xpt
562%{_libdir}/%{name}/components/widget.xpt
563%{_libdir}/%{name}/components/windowds.xpt
564%{_libdir}/%{name}/components/windowwatcher.xpt
565%{_libdir}/%{name}/components/xml-rpc.xpt
566%{_libdir}/%{name}/components/xpcom_base.xpt
567%{_libdir}/%{name}/components/xpcom_components.xpt
568%{_libdir}/%{name}/components/xpcom_ds.xpt
569%{_libdir}/%{name}/components/xpcom_io.xpt
570%{_libdir}/%{name}/components/xpcom_obsolete.xpt
571%{_libdir}/%{name}/components/xpcom_threads.xpt
572%{_libdir}/%{name}/components/xpcom_xpti.xpt
573%{_libdir}/%{name}/components/xpconnect.xpt
574%{_libdir}/%{name}/components/xpinstall.xpt
575%{_libdir}/%{name}/components/xulapp.xpt
576%{_libdir}/%{name}/components/xuldoc.xpt
577%{_libdir}/%{name}/components/xultmpl.xpt
578%dir %{_libdir}/%{name}/plugins
579%attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
580%attr(755,root,root) %{_libdir}/%{name}/*.sh
581%attr(755,root,root) %{_libdir}/%{name}/m*
582%attr(755,root,root) %{_libdir}/%{name}/f*
583%attr(755,root,root) %{_libdir}/%{name}/regxpcom
584%attr(755,root,root) %{_libdir}/%{name}/xpcshell
585%attr(755,root,root) %{_libdir}/%{name}/xpicleanup
586%{_pixmapsdir}/mozilla-firefox.png
587%{_desktopdir}/mozilla-firefox.desktop
588
589# symlinks
590%{_libdir}/%{name}/chrome
591%{_libdir}/%{name}/defaults
592%{_libdir}/%{name}/dictionaries
593%{_libdir}/%{name}/extensions
594%{_libdir}/%{name}/greprefs
595%{_libdir}/%{name}/icons
596%{_libdir}/%{name}/init.d
597%{_libdir}/%{name}/res
598%{_libdir}/%{name}/searchplugins
599
600# browserconfig
601%{_libdir}/%{name}/browserconfig.properties
602
603%{_libdir}/%{name}/LICENSE
604%{_libdir}/%{name}/README.txt
605
606%dir %{_datadir}/%{name}
607%{_datadir}/%{name}/chrome
608%{_datadir}/%{name}/defaults
609%{_datadir}/%{name}/greprefs
610%{_datadir}/%{name}/icons
611%{_datadir}/%{name}/init.d
612%{_datadir}/%{name}/res
613%{_datadir}/%{name}/searchplugins
614
615%dir %{_datadir}/%{name}/extensions
616# -dom-inspector subpackage?
617%{_datadir}/%{name}/extensions/inspector@mozilla.org
618# the signature of the default theme
619%{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
620
621# files created by regxpcom and firefox -register
622%ghost %{_libdir}/%{name}/components/compreg.dat
623%ghost %{_libdir}/%{name}/components/xpti.dat
624
625%files libs
626%defattr(644,root,root,755)
627%dir %{_libdir}/%{name}
628%attr(755,root,root) %{_libdir}/%{name}/*.so
629
630%files lang-en
631%defattr(644,root,root,755)
632%{_datadir}/%{name}/chrome/en-US.jar
633%{_datadir}/%{name}/chrome/en-US.manifest
634
635%if %{with tidy}
636%files addon-tidy
637%defattr(644,root,root,755)
638%attr(755,root,root) %{_libdir}/%{name}/components/libnstidy.so
639%{_libdir}/%{name}/components/nstidy.xpt
640%endif
This page took 0.081789 seconds and 4 git commands to generate.